Author Topic: LXqt  (Read 8911 times)

0 Members and 1 Guest are viewing this topic.

Offline sdch

  • Sr. Mitglied
  • ****
  • Posts: 277
  • Branch: Stable
  • Desktop: KDE
  • GPU Card: nvidia
  • GPU driver: nvidia
  • Kernel: 3.12 LTS x86_64
  • Skill: Novice
LXqt
« on: 04. November 2013, 07:27:46 »

Offline Rob

  • Core Team
  • *****
  • Posts: 5390
  • Alias: Korrode
  • Branch: Unstable
  • Desktop: Xfce+Compiz
  • GPU Card: nVidia GTX560Ti
  • GPU driver: non-free
  • Kernel: linux314 x64
  • Skill: Advanced
Re: LXqt
« Reply #1 on: 04. November 2013, 07:33:12 »
I'm busy the next couple of days, but after that i'll be testing this fo shiz.

Offline john29

  • Sr. Mitglied
  • ****
  • Posts: 495
  • Branch: Manjaro unstable
  • Desktop: Arch + Manjaro CINNAMON
  • GPU Card: ATi HD 7850 pcs +
  • GPU driver: open-source drivers
  • Kernel: manjaro + Arch Kernel 4.3-ck 4.2 x86-x64
  • Skill: Intermediate
Re: LXqt
« Reply #2 on: 04. November 2013, 08:29:09 »
I had part lxde-qt install 3or4 week ago now I get

Packages (1): libqtxdg-git-139.eede4b9-1

Total Installed Size:   0.51 MiB

:: Proceed with installation? [Y/n] y
(1/1) checking keys in keyring                                                                               [################################################################] 100%
(1/1) checking package integrity                                                                             [################################################################] 100%
(1/1) loading package files                                                                                  [################################################################] 100%
(1/1) checking for file conflicts                                                                            [################################################################] 100%
error: failed to commit transaction (conflicting files)
libqtxdg-git: /usr/include/qtxdg/xdgaction.h exists in filesystem
libqtxdg-git: /usr/include/qtxdg/xdgautostart.h exists in filesystem
libqtxdg-git: /usr/include/qtxdg/xdgdesktopfile.h exists in filesystem
libqtxdg-git: /usr/include/qtxdg/xdgdirs.h exists in filesystem
libqtxdg-git: /usr/include/qtxdg/xdgicon.h exists in filesystem
libqtxdg-git: /usr/include/qtxdg/xdgmenu.h exists in filesystem
libqtxdg-git: /usr/include/qtxdg/xdgmenuwidget.h exists in filesystem
libqtxdg-git: /usr/include/qtxdg/xdgmime.h exists in filesystem
libqtxdg-git: /usr/include/qtxdg/xmlhelper.h exists in filesystem
libqtxdg-git: /usr/lib/libqtxdg.so exists in filesystem
libqtxdg-git: /usr/lib/libqtxdg.so.0 exists in filesystem
libqtxdg-git: /usr/lib/pkgconfig/qtxdg.pc exists in filesystem
Errors occurred, no packages were upgraded.
==> WARNING: Your packages are saved in /tmp/yaourt-tmp-root
[root@johnpc john]#

Offline Rob

  • Core Team
  • *****
  • Posts: 5390
  • Alias: Korrode
  • Branch: Unstable
  • Desktop: Xfce+Compiz
  • GPU Card: nVidia GTX560Ti
  • GPU driver: non-free
  • Kernel: linux314 x64
  • Skill: Advanced
Re: LXqt
« Reply #3 on: 04. November 2013, 08:44:15 »
See what package owns those files with pacman -Qo
Example:
Code: [Select]
pacman -Qo /usr/include/qtxdg/xdgaction.h
pacman -Qo /usr/lib/libqtxdg.so
pacman -Qo /usr/lib/pkgconfig/qtxdg.pc

Offline mips

  • Held Mitglied
  • *****
  • Posts: 2892
  • Valkyrja
  • Branch: Testing
  • Desktop: XFCE
  • GPU Card: GTX 960
  • GPU driver: video-nvidia
  • Kernel: 3.16
  • Skill: Intermediate
Re: LXqt
« Reply #4 on: 04. November 2013, 10:04:58 »
The instructions in the original post in that list are incomplete.


First do,
Code: [Select]
yaourt -S sddm-git
yaourt -S vala
yaourt -S libfm-git


Then,

Code: [Select]
yaourt -S libqtxdg-git liblxqt-git liblxqt-mount-git libsysstat-git lxsession-git pcmanfm-qt-git lxqt-common-git lxqt-panel-git lxinput-qt-git lxqt-about-git lxqt-config-git lxqt-globalkeys-git lxqt-notificationd-git lxqt-openssh-askpass-git lxqt-policykit-git lxqt-power-git lxqt-runner-git

and remember to enable sddm.

Offline Verändert2.0

  • Held Mitglied
  • *****
  • Posts: 1890
  • Ni Dieu ni maître
  • Skill: Novice
Re: LXqt
« Reply #5 on: 04. November 2013, 11:17:27 »
And if it's moaning about missing dependencies, edit PKBUILD to use the -git packages.

Offline Esclapion

  • Support Team
  • ****
  • Posts: 5523
    • manjaro
  • Branch: stable
  • Desktop: Lxqt
  • GPU Card: GTX 970
  • GPU driver: nonfree
  • Kernel: 4.4.6
  • Skill: Advanced
Re: LXqt
« Reply #6 on: 04. November 2013, 12:28:47 »
Very interesting, thanks.  :)

I will probably try at the end of this week.
Venez nous rejoindre sur l'IRC francophone
Patrice - Violence is the last refuge of the incompetent (Asimov)

Offline Verändert2.0

  • Held Mitglied
  • *****
  • Posts: 1890
  • Ni Dieu ni maître
  • Skill: Novice
Re: LXqt
« Reply #7 on: 04. November 2013, 12:35:16 »
Doesn't work for me- it shows the desktop but nothing else.

Offline mips

  • Held Mitglied
  • *****
  • Posts: 2892
  • Valkyrja
  • Branch: Testing
  • Desktop: XFCE
  • GPU Card: GTX 960
  • GPU driver: video-nvidia
  • Kernel: 3.16
  • Skill: Intermediate
Re: LXqt
« Reply #8 on: 04. November 2013, 12:44:25 »
Doesn't work for me- it shows the desktop but nothing else.


I don't get a menu either.

Offline Verändert2.0

  • Held Mitglied
  • *****
  • Posts: 1890
  • Ni Dieu ni maître
  • Skill: Novice
Re: LXqt
« Reply #9 on: 04. November 2013, 13:16:16 »
Did you install it on top of Xfce, too ? I figured that might be the problem and were thinking about a net-install.

Offline john29

  • Sr. Mitglied
  • ****
  • Posts: 495
  • Branch: Manjaro unstable
  • Desktop: Arch + Manjaro CINNAMON
  • GPU Card: ATi HD 7850 pcs +
  • GPU driver: open-source drivers
  • Kernel: manjaro + Arch Kernel 4.3-ck 4.2 x86-x64
  • Skill: Intermediate
Re: LXqt
« Reply #10 on: 04. November 2013, 13:50:21 »
 Korrode

Thier all own by razor-qt 5.2-1

Offline Rob

  • Core Team
  • *****
  • Posts: 5390
  • Alias: Korrode
  • Branch: Unstable
  • Desktop: Xfce+Compiz
  • GPU Card: nVidia GTX560Ti
  • GPU driver: non-free
  • Kernel: linux314 x64
  • Skill: Advanced
Re: LXqt
« Reply #11 on: 04. November 2013, 14:14:27 »
Korrode

Thier all own by razor-qt 5.2-1

Then you need to remove razor-qt before trying LXqt, which is unsurprising... and the LXqt PKGBUILD's conflicts array needs updating by the maintainer(s).

Offline Verändert2.0

  • Held Mitglied
  • *****
  • Posts: 1890
  • Ni Dieu ni maître
  • Skill: Novice
Re: LXqt
« Reply #12 on: 04. November 2013, 14:24:50 »
It is probably safe to say that LXqt is stil in a rather early state of development...

Offline mips

  • Held Mitglied
  • *****
  • Posts: 2892
  • Valkyrja
  • Branch: Testing
  • Desktop: XFCE
  • GPU Card: GTX 960
  • GPU driver: video-nvidia
  • Kernel: 3.16
  • Skill: Intermediate
Re: LXqt
« Reply #13 on: 04. November 2013, 14:34:01 »
Did you install it on top of Xfce, too ? I figured that might be the problem and were thinking about a net-install.


On top of openbox.

Offline john29

  • Sr. Mitglied
  • ****
  • Posts: 495
  • Branch: Manjaro unstable
  • Desktop: Arch + Manjaro CINNAMON
  • GPU Card: ATi HD 7850 pcs +
  • GPU driver: open-source drivers
  • Kernel: manjaro + Arch Kernel 4.3-ck 4.2 x86-x64
  • Skill: Intermediate
Re: LXqt
« Reply #14 on: 05. November 2013, 11:20:47 »
install it from a manjaro net change lxsession-qt-git lxsession  & oxygen-icons

I will change openbox to kwin standalone WM
but all work good