Author Topic: [COMPILATION] How to get Xbox 360 Controllers Working with Steam in Manjaro  (Read 8101 times)

0 Members and 1 Guest are viewing this topic.

Offline dlambert

  • Vollwertiges Mitglied
  • ***
  • Posts: 177
  • I'm 20, love Linux, computers, and gaming!
  • Branch: Stable
  • Desktop: GNOME
  • GPU Card: GTX 980 | GT 610 | Intel 5500
  • GPU driver: Non-Free
  • Kernel: Latest Stable
  • Skill: Intermediate
Hello,
Having just spent a ton of time trying to get my beloved xbox 360 controller working with steam under manjaro, I've decided to compile all the steps I had to take in order for the controller to finally work.

Having said that, this guide might help you if:


  • By default when you sync your controller the mouse moves to the uppermost of the screen and refuses to stay down.
  • You just want your Xbox 360 controller to work with steam. *Haven't tested with non-steam games.

Note: One of the more common "solutions" is to install xboxdrv (an alternate to xpad), DON'T.

Xboxdrv is a handy tool (in some cases), but it requires a lot of configuration in order for it to be useable (in my experience).





How To:

First, if you have the mouse movement issue, do as forum member handy discovered and set your joystick config to disable controlling of the mouse.

Noob disclaimer: In the following code the $ is used in place of "sudo," thus meaning you have to have root access in order for the following code to work.

To do this:

Code: [Select]
$ gedit /etc/X11/xorg.conf.d/50-joystick.conf
Then if the file is blank (like mine was) enter:

If the file is not empty, just be sure to add or modify the two lines handy references.


Code: [Select]
Section "InputClass"
Identifier "joystick catchall"
      MatchIsJoystick "on"
      MatchDevicePath "/dev/input/event*"
      Driver "joystick"
      Option "StartKeysEnabled" "False"     # These two lines
      Option "StartMouseEnabled" "False"    # here
EndSection

Then save the file and exit.

That should be it! Go play some games!




If That didn't Work:

Some people have said that removing the package xf86-input-joystick will also fix this issue, so if the above problem doesn't work, you could remove that file by*:

Code: [Select]
$ pacman -R xf86-input-joystick
*Before I saw handy's solution, I removed the xf86-input-joystick package and still had the issue, but upon setting up handy's solution everything worked great. I have no way of knowing if the two are connected.

I take no credit for this, I just wanted to create a guide for the noobies (like me) that was really straight forward. If this could be improved in anyway, feel free to let me know.

Thank you handy!

Sources:
« Last Edit: 31. October 2013, 02:07:58 by dlambert »
"If you do what you love, you never work a day in your life" -Confucius

Offline dlambert

  • Vollwertiges Mitglied
  • ***
  • Posts: 177
  • I'm 20, love Linux, computers, and gaming!
  • Branch: Stable
  • Desktop: GNOME
  • GPU Card: GTX 980 | GT 610 | Intel 5500
  • GPU driver: Non-Free
  • Kernel: Latest Stable
  • Skill: Intermediate
Can this maybe get stickied in gaming?
« Last Edit: 01. November 2013, 22:52:10 by dlambert »
"If you do what you love, you never work a day in your life" -Confucius

Offline Ludowicus

  • Neuling
  • *
  • Posts: 17
  • Branch: testing
  • Desktop: Cinnamon
  • GPU Card: nVidia GTX 660
  • GPU driver: non-free
  • Kernel: linux314-x64
  • Skill: Novice
Thank you for this tutorial :D

Offline dlambert

  • Vollwertiges Mitglied
  • ***
  • Posts: 177
  • I'm 20, love Linux, computers, and gaming!
  • Branch: Stable
  • Desktop: GNOME
  • GPU Card: GTX 980 | GT 610 | Intel 5500
  • GPU driver: Non-Free
  • Kernel: Latest Stable
  • Skill: Intermediate
Thank you for this tutorial :D

No problem!
"If you do what you love, you never work a day in your life" -Confucius

Offline spider623

  • Vollwertiges Mitglied
  • ***
  • Posts: 125
  • Branch: unstable
  • Desktop: xfce, gnome
  • GPU Card: nVidia GTX970[ZOTAC GeForce GTX 970 AMP! Omega Edition]
  • GPU driver: video-nvidia from mhwd
  • Kernel: x86_64 Linux 4.4.0-1-MANJARO
  • Skill: Intermediate
this breaks the usb a4tech keyboards on 3.14, xboxdrv has the profiles of the controllers prebuild
CPU: Intel Core i7-6700K CPU @ 4.2GHz
GPU: GeForce GTX 970
RAM: 0MiB / 15979MiB

Offline xDShot

  • Neuling
  • *
  • Posts: 2
  • Desktop: Xfce
  • GPU Card: Intel HD Graphics + AMD Radeon HD 8750M
  • GPU driver: open-source
  • Skill: Intermediate
I suggest installing xpad module from SteamOS project as it fixes some issues for xbox 360 controller (especially for wireless variant) like LED not showing for which player the gamepad is assigned to, and it probably fixes vibration. More info here:
https://wiki.archlinux.org/index.php/Gamepad#SteamOS_xpad

Offline eduardo

  • Sr. Mitglied
  • ****
  • Posts: 316
  • Branch: testing
  • Desktop: KDE plasma 5
  • GPU Card: Intel HDGraphics 4400 / Nvidia Geforce 960M
  • GPU driver: non-free on nvidia
  • Kernel: linux44, linux45_RC
  • Skill: Novice
This works to stop using the controller as a mouse, thanks for that, I dont even understand why it comes like that by default, it doesnt make any sense. But still I have tried my xbox 360 controller on 2 different laptops and it only works on some games (like on battleblock theater, postal o postal 2), but it does not on others SDL2 games like adventures of shuggy, retro city rampage dx, overgrowth, super meat boy, all of them works with the controller on windows, so I assume this is an issue of the manjaro distro since the controller works properly for most of the people.
Now I even tried using the steamos xpad, but it didnt change anything. Is there something I can do to make this thing work?