Author Topic: User Guides for Beginners  (Read 40852 times)

0 Members and 1 Guest are viewing this topic.

Offline ariane_c

  • Neuling
  • *
  • Posts: 24
Re: User Guides for Beginners
« Reply #15 on: 23. February 2013, 21:03:16 »
Yes it is quite helpful!  Great resources!

ariane_c,
Please be sure to frequently visit Carl's fantabulous Manjaro wiki and read through more than just the beginner's guide to installation. There is a lot more in the wiki that will be well worth the time you spend there!

Offline awesomesauce

  • Neuling
  • *
  • Posts: 3
Re: User Guides for Beginners
« Reply #16 on: 03. May 2013, 01:51:28 »
Hey hi hello!
Am downloading the ISO right now, no different versions for 32/64 bit?  ???

A bit confuzzled here

Offline eskaini

  • Security Team
  • *****
  • Posts: 10842
  • I eat deleted accounts
  • Skill: Novice
Re: User Guides for Beginners
« Reply #17 on: 03. May 2013, 02:15:32 »
Quote from: awesomesauce
Am downloading the ISO right now...

There are 2 official release flavours, 5 community maintained releases, so that's 7 in total...
Quote
Overview

32 and 64 bit versions of Manjaro are available for download as ISO files. An ISO file is itself a literal copy of a disc image, although not in the same sense as a copy and paste duplication. Rather it is a copy of the raw machine code that makes up the files and folders of that disc. This is why just copying an ISO file to a disc (or USB flashdrive) to begin installing it won't work; you'll need to use a disc burning application to translate that raw data into the files and folders. Instructions to do so for both Linux and Windows operating systems are provided below.

Note: There is an exception to this rule. If you intend on installing Manjaro in a virtual machine environment using Oracle's Virtualbox, then there will be no need to burn the image as Virtualbox will be able to read from the ISO file directly as a virtual disc.

ISO images available for 32 bit systems will end in i686.iso, while images for 64 bit systems will end in x86_64.iso. Please try to ensure that you download the appropriate ISO image for your system as:

    a 64 bit ISO won't run on a 32 bit system, and
    a 32 bit ISO will not be able use the full power or resources of a 64 bit system.

From the wiki page

Offline awesomesauce

  • Neuling
  • *
  • Posts: 3
Re: User Guides for Beginners
« Reply #18 on: 03. May 2013, 03:31:31 »
Thank you, Stupely, but this isn't the first Linux I've ever installed. When you download from the download section here you only get one flavor, no choice. AS it tuned out it was in fact a 32bit system.  :( Also I ended up with just a command line instead of a GUI.  :'(
So I'll try it again now with the community downloads. I hope that will work better.
 

Offline awesomesauce

  • Neuling
  • *
  • Posts: 3
Re: User Guides for Beginners
« Reply #19 on: 03. May 2013, 03:56:14 »
Also when I try to download the XFCE version from community I'm redirected to this one: xcfe 0.8.5.1-i686.iso

And since i686 are 32bit versions I slowly doubt there is a 64bit version available. WTF?  ::)

Offline Attila1964

  • Neuling
  • *
  • Posts: 35
  • Branch: unstable
  • Desktop: Xfce
  • GPU driver: free
  • Kernel: linux4.4.6-1_x86_64
  • Skill: Intermediate

Offline graphixtux

  • Neuling
  • *
  • Posts: 22
  • Manjaro Linux as in mount Killimanjaro....
  • Branch: Stable
  • Desktop: Xfce
  • GPU Card: nVidia Quadro FX 3500
  • GPU driver: Free driver
  • Kernel: 3.16.7.10-1-MANJARO
  • Skill: Novice
Re: User Guides for Beginners
« Reply #21 on: 13. May 2013, 23:19:19 »
User guides for beginners are up on our wiki. They will:

  • Give an overview of the key points about using Manjaro
  • Explain how to use package browser to find software, and
  • Explain how to use the pacman-gui to update your system, install and remove software
Start here: http://wiki.manjaro.org/index.php/Using_Manjaro_for_Beginners

Your feedback is also important. If there is anything you feel would improve these guides, or anything that needs to be added, then please let us know. You can post here, or send me a PM  :)

Hi Im running Manjaro Linux 64bit excelent experience so far, my last sys upgrade was abaut 7 months ago, now im back on my manjaro kernel multi-boot but i cant upgrade the system it reports some lib dependency missing and pacman has to be upgraded first... this is my command as root:

Code: [Select]
# pacman -SyuResults...
Code: [Select]
:: Synchronizing package databases...
 basis is up to date
 platform is up to date
 addon is up to date
 extra is up to date
 community is up to date
 basis-multilib is up to date
 multilib is up to date
 basis-testing is up to date
error: failed retrieving file 'platform-testing.db' from mirror.dacentec.com : The requested URL returned error: 404 Not Found
error: failed to update platform-testing (download library error)
error: failed retrieving file 'addon-testing.db' from mirror.dacentec.com : The requested URL returned error: 404 Not Found
error: failed to update addon-testing (download library error)
error: failed retrieving file 'extra-testing.db' from mirror.dacentec.com : The requested URL returned error: 404 Not Found
error: failed to update extra-testing (download library error)
error: failed retrieving file 'community-testing.db' from mirror.dacentec.com : The requested URL returned error: 404 Not Found
error: failed to update community-testing (download library error)
error: failed retrieving file 'basis-multilib-testing.db' from mirror.dacentec.com : The requested URL returned error: 404 Not Found
error: failed to update basis-multilib-testing (download library error)
error: failed retrieving file 'multilib-testing.db' from mirror.dacentec.com : The requested URL returned error: 404 Not Found
error: failed to update multilib-testing (download library error)
:: The following packages should be upgraded first :
    manjaro-system  pacman
:: Do you want to cancel the current operation
:: and upgrade these packages now? [Y/n]

resolving dependencies...
warning: cannot resolve "linux-api-headers>=3.7", a dependency of "glibc"
warning: cannot resolve "linux-api-headers>=3.7", a dependency of "glibc"
:: The following packages cannot be upgraded due to unresolvable dependencies:
      manjaro-system  pacman

Do you want to skip the above packages for this upgrade? [y/N]
warning: cannot resolve "linux-api-headers>=3.7", a dependency of "glibc"
:: The following packages cannot be upgraded due to unresolvable dependencies:
      manjaro-system  pacman
error: failed to prepare transaction (unexpected error)

And I realy want to upgrade pacman,  :P

Offline handy

  • Global Moderator
  • *****
  • Posts: 5738
  • Desktop: Openbox 3.6.1-3 & Worker :)
  • GPU Card: intel...
  • GPU driver: open-source
  • Kernel: OpenBSD
  • Skill: Intermediate
Re: User Guides for Beginners
« Reply #22 on: 14. May 2013, 00:12:41 »
Have a read of this:

http://forum.manjaro.org/index.php?topic=3732.msg32643#msg32643

There was dramatic repo system changes recently.

It is always a good idea to upgrade rolling release systems fairly often, you strike less problems that way. That wouldn't have saved you from this one though, just saying... ;)
The ultimate tyranny in a society is not control
by martial law. It is control by the psychological
manipulation of consciousness, through which reality
is defined so that those who exist within do not even
realize that they are in prison.
  —  Barbara Marciniak

Offline graphixtux

  • Neuling
  • *
  • Posts: 22
  • Manjaro Linux as in mount Killimanjaro....
  • Branch: Stable
  • Desktop: Xfce
  • GPU Card: nVidia Quadro FX 3500
  • GPU driver: Free driver
  • Kernel: 3.16.7.10-1-MANJARO
  • Skill: Novice
Re: User Guides for Beginners
« Reply #23 on: 14. May 2013, 04:08:46 »
Ok, so i got the new pacman.conf file:

Code: [Select]
#
# /etc/pacman.conf
#
# See the pacman.conf(5) manpage for option and repository directives

#
# GENERAL OPTIONS
#
[options]
# The following paths are commented out with their default values listed.
# If you wish to use different paths, uncomment and update the paths.
#RootDir     = /
#DBPath      = /var/lib/pacman/
#CacheDir    = /var/cache/pacman/pkg/
#LogFile     = /var/log/pacman.log
#GPGDir      = /etc/pacman.d/gnupg/
HoldPkg     = pacman glibc manjaro-system
# If upgrades are available for these packages they will be asked for first
SyncFirst   = manjaro-system pacman
#XferCommand = /usr/bin/curl -C - -f %u > %o
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
#CleanMethod = KeepInstalled
#UseDelta    = 0.7
Architecture = auto

# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
#IgnorePkg   =
#IgnoreGroup =

#NoUpgrade   =
#NoExtract   =

# Misc options
#UseSyslog
#Color
#TotalDownload
CheckSpace
#VerbosePkgLists

# By default, pacman accepts packages signed by keys that its local keyring
# trusts (see pacman-key and its man page), as well as unsigned packages.
SigLevel = Required DatabaseOptional
LocalFileSigLevel = Required
#RemoteFileSigLevel = Required

# NOTE: You must run `pacman-key --init` before first using pacman; the local
# keyring can then be populated with the keys of all official Arch Linux
# packagers with `pacman-key --populate archlinux`.

#
# REPOSITORIES
#   - can be defined here or included from another file
#   - pacman will search repositories in the order defined here
#   - local/custom mirrors can be added here or in separate files
#   - repositories listed first will take precedence when packages
#     have identical names, regardless of version number
#   - URLs will have $repo replaced by the name of the current repo
#   - URLs will have $arch replaced by the name of the architecture
#
# Repository entries are of the format:
#       [repo-name]
#       Server = ServerName
#       Include = IncludePath
#
# The header [repo-name] is crucial - it must be present and
# uncommented to enable the repo.
#

[core]
SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

[extra]
SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

[community]
SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

# If you want to run 32 bit applications on your x86_64 system,
# enable the multilib repositories as required here.

[multilib]
SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

# An example of a custom package repository.  See the pacman manpage for
# tips on creating your own repositories.
#[custom]
#SigLevel = Optional TrustAll
#Server = file:///home/custompkgs

Provided by Roland the Admin, hes very busi. Ok this is a cat of my mirrorlist:

Code: [Select]
$ cat /etc/pacman.d/mirrorlist
##
## Manjaro Linux repository mirrorlist
## Generated on 2012-11-08
##

## Brasil
# Server = http://manjaro.fis.unb.br/$repo/$arch

## France
# Server = http://manjarolinux.polymorf.fr/$repo/$arch

## Germany
# Server = http://mirrors.mycraft.eu/manjaro/$repo/$arch
# Server = http://ftp.halifax.rwth-aachen.de/manjaro/$repo/$arch
# Server = http://mirror.vinzv.de/manjaro/repo/$repo/$arch


## Greece
# Server = http://ftp.cc.uoc.gr/mirrors/linux/manjaro/$repo/$arch


## United Kingdom
#Server = http://repo.manjaro.org.uk/$repo/$arch


## United States
 Server = http://mirror.dacentec.com/manjaro/$repo/$arch
#Server = http://mirror.dacentec.com/manjaro/$repo/$arch
 Server = http://ftp.halifax.rwth-aachen.de/manjaro/$repo/$arch
 Server = http://mirrors.mycraft.eu/manjaro/$repo/$arch
 Server = http://manjarolinux.polymorf.fr/$repo/$arch
 Server = http://repo.manjaro.org.uk/$repo/$arch

And when I try to refresh my repos with the command:

Code: [Select]
Sudo pacman -Syy
I get this:

Code: [Select]
warning: config file /etc/pacman.conf, line 43: directive 'LocalFileSigLevel' in section 'options' not recognized.
warning: database file for 'core' does not exist
:: Synchronizing package databases...
error: failed retrieving file 'core.db' from mirror.dacentec.com : The requested URL returned error: 404 Not Found
error: failed retrieving file 'core.db' from ftp.halifax.rwth-aachen.de : The requested URL returned error: 404 Not Found
error: failed retrieving file 'core.db' from mirrors.mycraft.eu : The requested URL returned error: 404 Not Found
error: failed retrieving file 'core.db' from manjarolinux.polymorf.fr : The requested URL returned error: 404 Not Found
error: failed retrieving file 'core.db' from repo.manjaro.org.uk : The requested URL returned error: 404 Not Found
error: failed to update core (download library error)
 extra                     45.0   B  13.7K/s 00:00 [######################] 100%
 community                 45.0   B  1046K/s 00:00 [######################] 100%
 multilib                  45.0   B  1418K/s 00:00 [######################] 100%

Im lost and cant find my way. I'll keep digging araund but im tired and have to sleep, Goodbye.  :)

Offline handy

  • Global Moderator
  • *****
  • Posts: 5738
  • Desktop: Openbox 3.6.1-3 & Worker :)
  • GPU Card: intel...
  • GPU driver: open-source
  • Kernel: OpenBSD
  • Skill: Intermediate
Re: User Guides for Beginners
« Reply #24 on: 14. May 2013, 05:17:19 »
Try the following commands one after the other:

Code: [Select]
sudo pacman-mirrors -g

pacman -Syy

pacman -Syu
« Last Edit: 14. May 2013, 05:19:03 by handy »
The ultimate tyranny in a society is not control
by martial law. It is control by the psychological
manipulation of consciousness, through which reality
is defined so that those who exist within do not even
realize that they are in prison.
  —  Barbara Marciniak

Offline graphixtux

  • Neuling
  • *
  • Posts: 22
  • Manjaro Linux as in mount Killimanjaro....
  • Branch: Stable
  • Desktop: Xfce
  • GPU Card: nVidia Quadro FX 3500
  • GPU driver: Free driver
  • Kernel: 3.16.7.10-1-MANJARO
  • Skill: Novice
Re: User Guides for Beginners
« Reply #25 on: 17. May 2013, 13:12:16 »
Ok this are the results

Code: [Select]
sudo pacman-mirrors -g
[sudo] password for graphixtux:
sudo: pacman-mirrors: command not found

I searched for that file and its missing. the /etc/pacman.mirrors.conf

next -

Code: [Select]
sudo pacman -Syy
[sudo] password for graphixtux:
warning: config file /etc/pacman.conf, line 43: directive 'LocalFileSigLevel' in section 'options' not recognized.
warning: database file for 'core' does not exist
:: Synchronizing package databases...
error: failed retrieving file 'core.db' from mirror.dacentec.com : The requested URL returned error: 404 Not Found
error: failed retrieving file 'core.db' from ftp.halifax.rwth-aachen.de : The requested URL returned error: 404 Not Found
error: failed retrieving file 'core.db' from mirrors.mycraft.eu : The requested URL returned error: 404 Not Found
error: failed retrieving file 'core.db' from manjarolinux.polymorf.fr : The requested URL returned error: 404 Not Found
error: failed retrieving file 'core.db' from repo.manjaro.org.uk : The requested URL returned error: 404 Not Found
error: failed to update core (download library error)
 extra                     45.0   B  13.7K/s 00:00 [######################] 100%
 community            45.0   B  1911K/s 00:00 [######################] 100%
 multilib                  45.0   B  1127K/s 00:00 [######################] 100%

last one was to upgrade

Code: [Select]
sudo pacman -Syu
warning: config file /etc/pacman.conf, line 43: directive 'LocalFileSigLevel' in section 'options' not recognized.
warning: database file for 'core' does not exist
:: Synchronizing package databases...
error: failed retrieving file 'core.db' from mirror.dacentec.com : The requested URL returned error: 404 Not Found
error: failed retrieving file 'core.db' from ftp.halifax.rwth-aachen.de : The requested URL returned error: 404 Not Found
error: failed retrieving file 'core.db' from mirrors.mycraft.eu : The requested URL returned error: 404 Not Found
error: failed retrieving file 'core.db' from manjarolinux.polymorf.fr : The requested URL returned error: 404 Not Found
error: failed retrieving file 'core.db' from repo.manjaro.org.uk : The requested URL returned error: 404 Not Found
error: failed to update core (download library error)
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
 there is nothing to do

 :-\ I searched for that file and its gone, /etc/pacman-mirrors.conf

Code: [Select]
cat /etc/pacman-mirrors.conf
cat: /etc/pacman-mirrors.conf: No such file or directory

Its just gone. Im out of words. I didnt saw that one coming.

Offline dante

  • Vollwertiges Mitglied
  • ***
  • Posts: 218
  • Branch: testing
  • Desktop: KDE
  • GPU Card: GeForce GTX 275
  • GPU driver: non-free
  • Kernel: Kernel39 SMP x64
  • Skill: Intermediate
Re: User Guides for Beginners
« Reply #26 on: 18. May 2013, 00:52:15 »
grep mine
Code: [Select]

##
## /etc/pacman-mirrors.conf
##


## Branch Pacman should use (stable, testing, unstable)
Branch=testing


## Generation method
## 1) rank   - rank mirrors depending on their access time
## 2) random - randomly generate the output mirrorlist
Method=rank


## Specify to use only mirrors from a specific country
## Disabled by default
# OnlyCountry=Germany


## Input mirrorlist directory
MirrorlistsDir="/etc/pacman.d/mirrors"


## Output mirrorlist
OutputMirrorlist="/etc/pacman.d/mirrorlist"


Only change testing to stable if you use this branch.

Offline graphixtux

  • Neuling
  • *
  • Posts: 22
  • Manjaro Linux as in mount Killimanjaro....
  • Branch: Stable
  • Desktop: Xfce
  • GPU Card: nVidia Quadro FX 3500
  • GPU driver: Free driver
  • Kernel: 3.16.7.10-1-MANJARO
  • Skill: Novice
Re: User Guides for Beginners
« Reply #27 on: 18. May 2013, 03:22:19 »
How do i grep it?

Offline dante

  • Vollwertiges Mitglied
  • ***
  • Posts: 218
  • Branch: testing
  • Desktop: KDE
  • GPU Card: GeForce GTX 275
  • GPU driver: non-free
  • Kernel: Kernel39 SMP x64
  • Skill: Intermediate
Re: User Guides for Beginners
« Reply #28 on: 18. May 2013, 03:45:51 »
Oh I see above you haven't pacman-mirrors try first
Code: [Select]
sudo pacman -S manjaro-system

copy the commandline above into your terminal and hit enter

Offline graphixtux

  • Neuling
  • *
  • Posts: 22
  • Manjaro Linux as in mount Killimanjaro....
  • Branch: Stable
  • Desktop: Xfce
  • GPU Card: nVidia Quadro FX 3500
  • GPU driver: Free driver
  • Kernel: 3.16.7.10-1-MANJARO
  • Skill: Novice
Re: User Guides for Beginners
« Reply #29 on: 18. May 2013, 04:14:35 »
I just run the command:

Code: [Select]
sudo pacman -S manjaro-system
Results:

Code: [Select]
  sudo pacman -S manjaro-system   
warning: config file /etc/pacman.conf, line 43: directive 'LocalFileSigLevel' in section 'options' not recognized.
resolving dependencies...
looking for inter-conflicts...

Targets (7): haveged-1.7.a-2  keyboardctl-0.1.5-2  mkinitcpio-0.14.0-1
             pacman-init-4.1.1-1  pcmciautils-018-7  util-linux-2.23-2
             manjaro-system-20130511-1

Total Download Size:    1.77 MiB
Total Installed Size:   9.62 MiB
Net Upgrade Size:       0.34 MiB

Proceed with installation? [Y/n]
:: Retrieving packages from core...
 util-linux-2.23-2-x...  1694.3 KiB  84.3K/s 00:20 [######################] 100%
 mkinitcpio-0.14.0-1-any   33.8 KiB   123K/s 00:00 [######################] 100%
 pcmciautils-018-7-x...    19.7 KiB   141K/s 00:00 [######################] 100%
 keyboardctl-0.1.5-2-any   26.7 KiB  98.6K/s 00:00 [######################] 100%
 pacman-init-4.1.1-1-any 2012.0   B  5.76M/s 00:00 [######################] 100%
 manjaro-system-2013...     2.2 KiB  2.56M/s 00:00 [######################] 100%
:: Retrieving packages from community...
 haveged-1.7.a-2-x86_64    37.4 KiB  68.7K/s 00:01 [######################] 100%
(7/7) checking package integrity                   [######################] 100%
(7/7) loading package files                        [######################] 100%
(7/7) checking for file conflicts                  [######################] 100%
(7/7) checking available disk space                [######################] 100%
(1/7) upgrading util-linux                         [######################] 100%
(2/7) upgrading mkinitcpio                         [######################] 100%
==> The "block" hook has replaced several hooks:
       fw, sata, pata, scsi, virtio, mmc, usb
    Replace any and all of these in /etc/mkinitcpio.conf with a single
    instance of the "block" hook
(3/7) upgrading pcmciautils                        [######################] 100%
(4/7) installing keyboardctl                       [######################] 100%
(5/7) installing haveged                           [######################] 100%
(6/7) installing pacman-init                       [######################] 100%
==> Initialize a new random GnuPG key for pacman
gpg: /etc/pacman.d/gnupg/trustdb.gpg: trustdb created
gpg: no ultimately trusted keys found
gpg: Generating pacman keychain master key...
gpg: key B3C67F87 marked as ultimately trusted
gpg: Done
==> Updating trust database...
gpg: 3 marginal(s) needed, 1 complete(s) needed, PGP trust model
gpg: depth: 0  valid:   1  signed:   0  trust: 0-, 0q, 0n, 0m, 0f, 1u
==> Importing trusted keys
==> Appending keys from archlinux.gpg...
gpg: key FFF979E7: public key "Allan McRae (Arch Linux Master Key) <allan@master-key.archlinux.org>" imported
gpg: key CDFD6BB0: public key "Dan McGee (Arch Linux Master Key) <dan@master-key.archlinux.org>" imported
gpg: key 4C7EA887: public key "Ionut Biru (Arch Linux Master Key) <ionut@master-key.archlinux.org>" imported
gpg: key 6AC6A4C2: public key "Pierre Schmitz (Arch Linux Master Key) <pierre@master-key.archlinux.org>" imported
gpg: key 824B18E8: public key "Thomas Bächler (Arch Linux Master Key) <thomas@master-key.archlinux.org>" imported
gpg: key 31496106: public key "Andrzej Giniewicz (giniu) <gginiu@gmail.com>" imported
gpg: key EAE999BD: public key "Allan McRae <me@allanmcrae.com>" imported
gpg: key D30DB0AD: public key "Andrea Scarpino (Arch Linux) <andrea@archlinux.org>" imported
gpg: key 0F2A092B: public key "Andreas Radke <andyrtr@archlinux.org>" imported
gpg: key EC133BAD: public key "Angel Velásquez <angvp@archlinux.org>" imported
gpg: key 5CF9C8D4: public key "Alexander Rødseth <rodseth@gmail.com>" imported
gpg: key 0901C163: public key "Balló György <ballogyor@gmail.com>" imported
gpg: key 00F0D0F0: public key "Gaetan Bisson <gaetan.bisson@normalesup.org>" imported
gpg: key 4CE1C13E: public key "Florian Pritz <bluewind@xinu.at>" imported
gpg: key 487328A9: public key "Bartlomiej Piotrowski <b@bpiotrowski.pl>" imported
gpg: key B47A0DAB: public key "Connor Behan <connor.behan@gmail.com>" imported
gpg: key 6521E06D: public key "Christopher Brannon <chris@the-brannons.com>" imported
gpg: key 99AD6E84: public key "Gavin Marciniak-Bisesi <Daenyth@gmail.com>" imported
gpg: key F53A76ED: public key "Dan McGee <dpmcgee@gmail.com>" imported
gpg: key B4440678: public key "Daniel Isenmann <daniel@archlinux.org>" imported
gpg: key 1985A992: public key "Dieter Plaetinck <dieter@plaetinck.be>" imported
gpg: key 5BD5C938: public key "Gerardo Exequiel Pozzi <vmlinuz386@yahoo.com.ar>" imported
gpg: key F56C0C53: public key "Dave Reisner <d@falconindy.com>" imported
gpg: key 4F010D48: public key "Daniel Wallace <danielwallace@gtmanfred.com>" imported
gpg: key 9205AC90: public key "Eric Belanger <eric@archlinux.org>" imported
gpg: key A9999C34: public key "Evangelos Foutras <evangelos@foutrelis.com>" imported
gpg: key 30D7CB92: public key "Felix Yan <felixonmars@gmail.com>" imported
gpg: key F04569AE: public key "Giovanni Scafora <giovanni@archlinux.org>" imported
gpg: key 215B37AD: public key "Guillaume ALAUX <guillaume@archlinux.org>" imported
gpg: key 4FA415FA: public key "Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>" imported
gpg: key 615137BC: public key "Ionut Biru <ibiru@archlinux.org>" imported
gpg: key 796CA067: public key "Ike Devolder <ike.devolder@gmail.com>" imported
gpg: key 3CFD4BB6: public key "Jonathan Conder <jonno.conder@gmail.com>" imported
gpg: key 7C50773E: public key "Jelle van der Waa <jelle@vdwaa.nl>" imported
gpg: key 3B94FA10: public key "Jan de Groot <jgc@archlinux.org>" imported
gpg: key 013C2580: public key "Jaroslav Lichtblau (trusted user) <dragonlord@aur.archlinux.org>" imported
gpg: key F40D2072: public key "Jonathan Steel <mail@jsteel.org>" imported
gpg: key 589874AB: public key "Jürgen Hötzel <juergen@hoetzel.info>" imported
gpg: key 983D4366: public key "Justin Davis (juster) <jrcd83@gmail.com>" imported
gpg: key D21E1A55: public key "Kaiting Chen <kaitocracy@gmail.com>" imported
gpg: key BAB142C1: public key "Kyle Keen <keenerd@gmail.com>" imported
gpg: key D1CEDDAC: public key "Laurent Carlier <lordheavym@gmail.com>" imported
gpg: key 9326B440: public key "Lukas Fleischer <info@cryptocrack.de>" imported
gpg: key DA2EE423: public key "Massimiliano Torromeo (Personal non-work identity) <massimiliano.torromeo@gmail.com>" imported
gpg: key 9741E8AC: public key "Pierre Schmitz <pierre@archlinux.de>" imported
gpg: key E19DAA50: public key "Peter Richard Lewis <pete@muddygoat.org>" imported
gpg: key 2D1493D2: public key "Rémy Oudompheng <remy@archlinux.org>" imported
gpg: key 70E80477: public key "Роман Кирилич (Roman Kyrylych) <roman@archlinux.org>" imported
gpg: key 8406FFF3: public key "Ronald van Haren <ronald@archlinux.org>" imported
gpg: key C0711BF1: public key "Rashif Rahman (Ray) <schiv@archlinux.org>" imported
gpg: key 91B842AE: public key "Jakob Gruber <jakob.gruber@gmail.com>" imported
gpg: key 2072D77A: public key "Seblu <seblu@seblu.net>" imported
gpg: key F27FB7DA: public key "speps <speps@aur.archlinux.org>" imported
gpg: key EA433FC7: public key "Sergej Pupykin <arch@sergej.pp.ru>" imported
gpg: key F1D357C1: public key "Lukas Jirkovsky <l.jirkovsky@gmail.com>" imported
gpg: key AB441196: public key "Stéphane Gaudreault <stephane@archlinux.org>" imported
gpg: key E62EB915: public key "Sven-Hendrik Haase <sh@lutzhaase.com>" imported
gpg: key 0C84C0A5: public key "Thomas Dziedzic <gostrc@gmail.com>" imported
gpg: key 8E4B1A25: public key "Thomas Bächler <thomas@archlinux.org>" imported
gpg: key 06361833: public key "Tom Gundersen <teg@jklm.no>" imported
gpg: key 7EDF681F: public key "Tobias Powalowski <tobias.powalowski@googlemail.com>" imported
gpg: key 3C4F88BC: public key "Timothy Redaelli <tredaelli@archlinux.info>" imported
gpg: key 295AFBF4: public key "Thorsten Töpper <atsutane@freethoughts.de>" imported
gpg: key 437520BD: public key "Vesa Kaihlavirta <vegai@iki.fi>" imported
gpg: key C2E5C0D2: public key "Xyne. <xyne@archlinux.ca>" imported
gpg: Total number processed: 65
gpg:               imported: 65  (RSA: 58)
gpg: 3 marginal(s) needed, 1 complete(s) needed, PGP trust model
gpg: depth: 0  valid:   1  signed:   0  trust: 0-, 0q, 0n, 0m, 0f, 1u
==> Appending keys from manjaro.gpg...
gpg: key 247B52CC: public key "Guillaume Benoit (Guinux) <guillaume@manjaro.org>" imported
gpg: key 11C7F07E: public key "Philip Müller (Called Little) <philm@manjaro.org>" imported
gpg: key 59152F77: public key "Roland Singer (Manjaro Linux) <roland@manjaro.org>" imported
gpg: Total number processed: 3
gpg:               imported: 3  (RSA: 3)
==> Locally signing trusted keys in keyring...
  -> Locally signing key 0E8B644079F599DFC1DDC3973348882F6AC6A4C2...

pub  3072R/6AC6A4C2  created: 2011-11-18  expires: never       usage: SC 
                     trust: unknown       validity: unknown
sub  1024R/86872C2F  created: 2011-11-18  expires: never       usage: E   
sub  3072R/1B516B59  created: 2011-11-18  expires: never       usage: A   
[ unknown] (1). Pierre Schmitz (Arch Linux Master Key) <pierre@master-key.archlinux.org>


pub  3072R/6AC6A4C2  created: 2011-11-18  expires: never       usage: SC 
                     trust: unknown       validity: unknown
 Primary key fingerprint: 0E8B 6440 79F5 99DF C1DD  C397 3348 882F 6AC6 A4C2

     Pierre Schmitz (Arch Linux Master Key) <pierre@master-key.archlinux.org>

Are you sure that you want to sign this key with your
key "Pacman Keychain Master Key <pacman@localhost>" (B3C67F87)

The signature will be marked as non-exportable.


  -> Locally signing key B4663188A692DB1E45A98EE95BD96CC4247B52CC...

gpg: checking the trustdb
gpg: 3 marginal(s) needed, 1 complete(s) needed, PGP trust model
gpg: depth: 0  valid:   1  signed:   1  trust: 0-, 0q, 0n, 0m, 0f, 1u
gpg: depth: 1  valid:   1  signed:  59  trust: 1-, 0q, 0n, 0m, 0f, 0u
pub  2048R/247B52CC  created: 2012-05-04  expires: 2022-05-02  usage: SC 
                     trust: unknown       validity: unknown
sub  2048R/72CD35DE  created: 2012-05-04  expires: 2022-05-02  usage: E   
[ unknown] (1). Guillaume Benoit (Guinux) <guillaume@manjaro.org>


pub  2048R/247B52CC  created: 2012-05-04  expires: 2022-05-02  usage: SC 
                     trust: unknown       validity: unknown
 Primary key fingerprint: B466 3188 A692 DB1E 45A9  8EE9 5BD9 6CC4 247B 52CC

     Guillaume Benoit (Guinux) <guillaume@manjaro.org>

This key is due to expire on 2022-05-02.
Are you sure that you want to sign this key with your
key "Pacman Keychain Master Key <pacman@localhost>" (B3C67F87)

The signature will be marked as non-exportable.


  -> Locally signing key 684148BB25B49E986A4944C55184252D824B18E8...

gpg: checking the trustdb
gpg: 3 marginal(s) needed, 1 complete(s) needed, PGP trust model
gpg: depth: 0  valid:   1  signed:   2  trust: 0-, 0q, 0n, 0m, 0f, 1u
gpg: depth: 1  valid:   2  signed:  59  trust: 2-, 0q, 0n, 0m, 0f, 0u
gpg: next trustdb check due at 2022-05-02
pub  3072R/824B18E8  created: 2011-11-19  expires: never       usage: SC 
                     trust: unknown       validity: unknown
The following key was revoked on 2011-11-19 by RSA key 824B18E8 Thomas Bächler (Arch Linux Master Key) <thomas@master-key.archlinux.org>
sub  1024R/AAE53976  created: 2011-11-19  revoked: 2011-11-19  usage: E   
The following key was revoked on 2011-11-19 by RSA key 824B18E8 Thomas Bächler (Arch Linux Master Key) <thomas@master-key.archlinux.org>
sub  2048R/96A8F3F2  created: 2011-11-19  revoked: 2011-11-19  usage: A   
[ unknown] (1). Thomas Bächler (Arch Linux Master Key) <thomas@master-key.archlinux.org>


pub  3072R/824B18E8  created: 2011-11-19  expires: never       usage: SC 
                     trust: unknown       validity: unknown
 Primary key fingerprint: 6841 48BB 25B4 9E98 6A49  44C5 5184 252D 824B 18E8

     Thomas Bächler (Arch Linux Master Key) <thomas@master-key.archlinux.org>

Are you sure that you want to sign this key with your
key "Pacman Keychain Master Key <pacman@localhost>" (B3C67F87)

The signature will be marked as non-exportable.


  -> Locally signing key 1E7908935AAB9A00D6B47503363DFFFD59152F77...

gpg: checking the trustdb
gpg: 3 marginal(s) needed, 1 complete(s) needed, PGP trust model
gpg: depth: 0  valid:   1  signed:   3  trust: 0-, 0q, 0n, 0m, 0f, 1u
gpg: depth: 1  valid:   3  signed:  59  trust: 3-, 0q, 0n, 0m, 0f, 0u
gpg: next trustdb check due at 2022-05-02
pub  4096R/59152F77  created: 2012-05-09  expires: never       usage: SC 
                     trust: unknown       validity: unknown
sub  4096R/67F91B40  created: 2012-05-09  expires: never       usage: E   
[ unknown] (1). Roland Singer (Manjaro Linux) <roland@manjaro.org>


pub  4096R/59152F77  created: 2012-05-09  expires: never       usage: SC 
                     trust: unknown       validity: unknown
 Primary key fingerprint: 1E79 0893 5AAB 9A00 D6B4  7503 363D FFFD 5915 2F77

     Roland Singer (Manjaro Linux) <roland@manjaro.org>

Are you sure that you want to sign this key with your
key "Pacman Keychain Master Key <pacman@localhost>" (B3C67F87)

The signature will be marked as non-exportable.


  -> Locally signing key 44D4A033AC140143927397D47EFD567D4C7EA887...

gpg: checking the trustdb
gpg: 3 marginal(s) needed, 1 complete(s) needed, PGP trust model
gpg: depth: 0  valid:   1  signed:   4  trust: 0-, 0q, 0n, 0m, 0f, 1u
gpg: depth: 1  valid:   4  signed:  59  trust: 4-, 0q, 0n, 0m, 0f, 0u
gpg: next trustdb check due at 2022-05-02
pub  3072R/4C7EA887  created: 2011-11-25  expires: never       usage: SC 
                     trust: unknown       validity: unknown
The following key was revoked on 2011-11-25 by RSA key 4C7EA887 Ionut Biru (Arch Linux Master Key) <ionut@master-key.archlinux.org>
sub  1024R/93F91AC3  created: 2011-11-25  revoked: 2011-11-25  usage: E   
The following key was revoked on 2011-11-25 by RSA key 4C7EA887 Ionut Biru (Arch Linux Master Key) <ionut@master-key.archlinux.org>
sub  3072R/B20030F3  created: 2011-11-25  revoked: 2011-11-25  usage: A   
[ unknown] (1). Ionut Biru (Arch Linux Master Key) <ionut@master-key.archlinux.org>


pub  3072R/4C7EA887  created: 2011-11-25  expires: never       usage: SC 
                     trust: unknown       validity: unknown
 Primary key fingerprint: 44D4 A033 AC14 0143 9273  97D4 7EFD 567D 4C7E A887

     Ionut Biru (Arch Linux Master Key) <ionut@master-key.archlinux.org>

Are you sure that you want to sign this key with your
key "Pacman Keychain Master Key <pacman@localhost>" (B3C67F87)

The signature will be marked as non-exportable.


  -> Locally signing key 27FFC4769E19F096D41D9265A04F9397CDFD6BB0...

gpg: checking the trustdb
gpg: 3 marginal(s) needed, 1 complete(s) needed, PGP trust model
gpg: depth: 0  valid:   1  signed:   5  trust: 0-, 0q, 0n, 0m, 0f, 1u
gpg: depth: 1  valid:   5  signed:  59  trust: 5-, 0q, 0n, 0m, 0f, 0u
gpg: next trustdb check due at 2022-05-02
pub  3072R/CDFD6BB0  created: 2011-11-29  expires: never       usage: SC 
                     trust: unknown       validity: unknown
sub  3072R/87E611F8  created: 2011-11-29  expires: never       usage: E   
[ unknown] (1). Dan McGee (Arch Linux Master Key) <dan@master-key.archlinux.org>


pub  3072R/CDFD6BB0  created: 2011-11-29  expires: never       usage: SC 
                     trust: unknown       validity: unknown
 Primary key fingerprint: 27FF C476 9E19 F096 D41D  9265 A04F 9397 CDFD 6BB0

     Dan McGee (Arch Linux Master Key) <dan@master-key.archlinux.org>

Are you sure that you want to sign this key with your
key "Pacman Keychain Master Key <pacman@localhost>" (B3C67F87)

The signature will be marked as non-exportable.


  -> Locally signing key E4CDFE50A2DA85D58C8A8C70CAA6A59611C7F07E...

gpg: checking the trustdb
gpg: 3 marginal(s) needed, 1 complete(s) needed, PGP trust model
gpg: depth: 0  valid:   1  signed:   6  trust: 0-, 0q, 0n, 0m, 0f, 1u
gpg: depth: 1  valid:   6  signed:  59  trust: 6-, 0q, 0n, 0m, 0f, 0u
gpg: next trustdb check due at 2022-05-02
pub  2048R/11C7F07E  created: 2012-05-05  expires: never       usage: SC 
                     trust: unknown       validity: unknown
sub  2048R/0576724A  created: 2012-05-05  expires: never       usage: E   
[ unknown] (1). Philip Müller (Called Little) <philm@manjaro.org>


pub  2048R/11C7F07E  created: 2012-05-05  expires: never       usage: SC 
                     trust: unknown       validity: unknown
 Primary key fingerprint: E4CD FE50 A2DA 85D5 8C8A  8C70 CAA6 A596 11C7 F07E

     Philip Müller (Called Little) <philm@manjaro.org>

Are you sure that you want to sign this key with your
key "Pacman Keychain Master Key <pacman@localhost>" (B3C67F87)

The signature will be marked as non-exportable.


  -> Locally signing key AB19265E5D7D20687D303246BA1DFB64FFF979E7...

gpg: checking the trustdb
gpg: 3 marginal(s) needed, 1 complete(s) needed, PGP trust model
gpg: depth: 0  valid:   1  signed:   7  trust: 0-, 0q, 0n, 0m, 0f, 1u
gpg: depth: 1  valid:   7  signed:  59  trust: 7-, 0q, 0n, 0m, 0f, 0u
gpg: next trustdb check due at 2022-05-02
pub  4096R/FFF979E7  created: 2011-11-29  expires: never       usage: SC 
                     trust: unknown       validity: unknown
[ unknown] (1). Allan McRae (Arch Linux Master Key) <allan@master-key.archlinux.org>


pub  4096R/FFF979E7  created: 2011-11-29  expires: never       usage: SC 
                     trust: unknown       validity: unknown
 Primary key fingerprint: AB19 265E 5D7D 2068 7D30  3246 BA1D FB64 FFF9 79E7

     Allan McRae (Arch Linux Master Key) <allan@master-key.archlinux.org>

Are you sure that you want to sign this key with your
key "Pacman Keychain Master Key <pacman@localhost>" (B3C67F87)

The signature will be marked as non-exportable.


==> Importing owner trust values...
gpg: inserting ownertrust of 4
gpg: setting ownertrust to 4
gpg: setting ownertrust to 4
gpg: setting ownertrust to 4
gpg: setting ownertrust to 4
gpg: setting ownertrust to 4
gpg: setting ownertrust to 4
gpg: setting ownertrust to 4
==> Updating trust database...
gpg: 3 marginal(s) needed, 1 complete(s) needed, PGP trust model
gpg: depth: 0  valid:   1  signed:   8  trust: 0-, 0q, 0n, 0m, 0f, 1u
gpg: depth: 1  valid:   8  signed:  59  trust: 0-, 0q, 0n, 8m, 0f, 0u
gpg: depth: 2  valid:  59  signed:   1  trust: 59-, 0q, 0n, 0m, 0f, 0u
gpg: next trustdb check due at 2022-05-02
==> Generation complete.
(7/7) upgrading manjaro-system                     [######################] 100%
warning: config file /etc/pacman.conf, line 43: directive 'LocalFileSigLevel' in section 'options' not recognized.
warning: config file /etc/pacman.conf, line 43: directive 'LocalFileSigLevel' in section 'options' not recognized.
warning: config file /etc/pacman.conf, line 43: directive 'LocalFileSigLevel' in section 'options' not recognized.
==> Installing missing systemd-sysvcompat ...
warning: config file /etc/pacman.conf, line 43: directive 'LocalFileSigLevel' in section 'options' not recognized.
:: The following packages should be upgraded first :
    pacman
:: Do you want to cancel the current operation
:: and upgrade these packages now? [Y/n]

resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: kalu: requires pacman<4.1
warning: config file /etc/pacman.conf, line 43: directive 'LocalFileSigLevel' in section 'options' not recognized.
==> Fixing turbojpeg ...
rm: cannot remove ‘/var/lib/pacman/db.lck’: No such file or directory
warning: config file /etc/pacman.conf, line 43: directive 'LocalFileSigLevel' in section 'options' not recognized.
:: The following packages should be upgraded first :
    pacman
:: Do you want to cancel the current operation
:: and upgrade these packages now? [Y/n]

resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: kalu: requires pacman<4.1
warning: config file /etc/pacman.conf, line 43: directive 'LocalFileSigLevel' in section 'options' not recognized.
==> Fixing lib32-turbojpeg ...
rm: cannot remove ‘/var/lib/pacman/db.lck’: No such file or directory
warning: config file /etc/pacman.conf, line 43: directive 'LocalFileSigLevel' in section 'options' not recognized.
:: The following packages should be upgraded first :
    pacman
:: Do you want to cancel the current operation
:: and upgrade these packages now? [Y/n]

resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: kalu: requires pacman<4.1
warning: config file /etc/pacman.conf, line 43: directive 'LocalFileSigLevel' in section 'options' not recognized.
warning: config file /etc/pacman.conf, line 43: directive 'LocalFileSigLevel' in section 'options' not recognized.
==> Fixing manjaro-hotfixes ...
warning: config file /etc/pacman.conf, line 43: directive 'LocalFileSigLevel' in section 'options' not recognized.
warning: config file /etc/pacman.conf, line 43: directive 'LocalFileSigLevel' in section 'options' not recognized.
warning: config file /etc/pacman.conf, line 43: directive 'LocalFileSigLevel' in section 'options' not recognized.
warning: config file /etc/pacman.conf, line 43: directive 'LocalFileSigLevel' in section 'options' not recognized.
warning: config file /etc/pacman.conf, line 43: directive 'LocalFileSigLevel' in section 'options' not recognized.
warning: config file /etc/pacman.conf, line 43: directive 'LocalFileSigLevel' in section 'options' not recognized.
warning: config file /etc/pacman.conf, line 43: directive 'LocalFileSigLevel' in section 'options' not recognized.
warning: config file /etc/pacman.conf, line 43: directive 'LocalFileSigLevel' in section 'options' not recognized.
warning: config file /etc/pacman.conf, line 43: directive 'LocalFileSigLevel' in section 'options' not recognized.
warning: config file /etc/pacman.conf, line 43: directive 'LocalFileSigLevel' in section 'options' not recognized.
warning: config file /etc/pacman.conf, line 43: directive 'LocalFileSigLevel' in section 'options' not recognized.
warning: config file /etc/pacman.conf, line 43: directive 'LocalFileSigLevel' in section 'options' not recognized.
warning: config file /etc/pacman.conf, line 43: directive 'LocalFileSigLevel' in section 'options' not recognized.
warning: config file /etc/pacman.conf, line 43: directive 'LocalFileSigLevel' in section 'options' not recognized.
warning: config file /etc/pacman.conf, line 43: directive 'LocalFileSigLevel' in section 'options' not recognized.
warning: config file /etc/pacman.conf, line 43: directive 'LocalFileSigLevel' in section 'options' not recognized.
warning: config file /etc/pacman.conf, line 43: directive 'LocalFileSigLevel' in section 'options' not recognized.
warning: config file /etc/pacman.conf, line 43: directive 'LocalFileSigLevel' in section 'options' not recognized.
warning: config file /etc/pacman.conf, line 43: directive 'LocalFileSigLevel' in section 'options' not recognized.
warning: config file /etc/pacman.conf, line 43: directive 'LocalFileSigLevel' in section 'options' not recognized.
==> Removing linux-meta pkgs ...
rm: cannot remove ‘/var/lib/pacman/db.lck’: No such file or directory
warning: config file /etc/pacman.conf, line 43: directive 'LocalFileSigLevel' in section 'options' not recognized.

Targets (1): linux-2012.11-1

Total Removed Size:     0.01 MiB

Do you want to remove these packages? [Y/n]
removing linux...
==> Removing linux-meta pkgs - done
warning: config file /etc/pacman.conf, line 43: directive 'LocalFileSigLevel' in section 'options' not recognized.
warning: config file /etc/pacman.conf, line 43: directive 'LocalFileSigLevel' in section 'options' not recognized.

I still got some errors but i was able to sync with:

Code: [Select]
sudo pacman -Syy
warning: config file /etc/pacman.conf, line 43: directive 'LocalFileSigLevel' in section 'options' not recognized.
warning: database file for 'core' does not exist
:: Synchronizing package databases...
 core                     112.2 KiB   256K/s 00:00 [######################] 100%
 extra                   1470.4 KiB  69.9K/s 00:21 [######################] 100%
 community               1927.3 KiB  85.1K/s 00:23 [######################] 100%

Also should update pacman, because when i installed Geany it ask me to, i answered no.

Code: [Select]
sudo pacman -S geany
warning: config file /etc/pacman.conf, line 43: directive 'LocalFileSigLevel' in section 'options' not recognized.
:: The following packages should be upgraded first :
    manjaro-system  pacman
:: Do you want to cancel the current operation
:: and upgrade these packages now? [Y/n] n

resolving dependencies...
looking for inter-conflicts...

Targets (1): geany-1.23-1

Total Download Size:    2.54 MiB
Total Installed Size:   10.47 MiB

Proceed with installation? [Y/n]
:: Retrieving packages from community...
 geany-1.23-1-x86_64        2.5 MiB  72.6K/s 00:36 [######################] 100%
(1/1) checking package integrity                   [######################] 100%
(1/1) loading package files                        [######################] 100%
(1/1) checking for file conflicts                  [######################] 100%
(1/1) checking available disk space                [######################] 100%
(1/1) installing geany                             [######################] 100%
Optional dependencies for geany
    vte: for terminal support
    geany-plugins: various extra features
    python2

It installed and runs but its bugging me te fact to upgrade the whole system, i want to run this command:

Code: [Select]
sudo pacman -Syu
[sudo] password for yonnlopez:
warning: config file /etc/pacman.conf, line 43: directive 'LocalFileSigLevel' in section 'options' not recognized.
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: The following packages should be upgraded first :
    pacman
:: Do you want to cancel the current operation
:: and upgrade these packages now? [Y/n]

Should i upgrade pacman first???