Author Topic: Disable screen dimming when video is playing  (Read 14351 times)

0 Members and 1 Guest are viewing this topic.

Offline mattarse

  • Vollwertiges Mitglied
  • ***
  • Posts: 183
    • Matt's Respite
  • Branch: Stable
  • Desktop: XFCE
  • Kernel: 3.13
  • Skill: Novice
Disable screen dimming when video is playing
« on: 29. September 2013, 00:57:06 »
Hopefully someone can help me - but I can't seem to figure out how to stop XFCE from dimming the screen when on battery and I have VLC running a full screen video.
I'd like to leave the setting to dim the screen running at other times to save battery.

Any ideas?

Offline tmallafre

  • Jr. Mitglied
  • **
  • Posts: 59
    • Blog personal del Tomàs Mallafré
  • Branch: stable
  • Desktop: Xfce
  • GPU Card: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display
  • Kernel: 4.4.5-1 x86_64 GNU/Linux
  • Skill: Intermediate
Re: Disable screen dimming when video is playing
« Reply #1 on: 29. September 2013, 01:41:36 »
I'm at phone right now, but there is an applet that you can add to the panel for toggle between normal and presentation modes

Offline handy

  • Global Moderator
  • *****
  • Posts: 5738
  • Desktop: Openbox 3.6.1-3 & Worker :)
  • GPU Card: intel...
  • GPU driver: open-source
  • Kernel: OpenBSD
  • Skill: Intermediate
Re: Disable screen dimming when video is playing
« Reply #2 on: 29. September 2013, 03:56:01 »
If you go into VLC's Preferences > Video, then choose the Show Settings > All option (situated in the bottom left hand corner of the window), you will then see an option displayed in the settings area of the window that says > Inhibit the power management daemon during playback. Select that & see how you go.
The ultimate tyranny in a society is not control
by martial law. It is control by the psychological
manipulation of consciousness, through which reality
is defined so that those who exist within do not even
realize that they are in prison.
  —  Barbara Marciniak

Offline FadeMind

  • Support Team
  • ****
  • Posts: 2331
    • gravatar
  • Branch: Arch x86_64
  • Desktop: Plasma 5
  • GPU Card: Intel + NVIDIA
  • GPU driver: Intel + NVIDIA
  • Kernel: linux
  • Skill: Intermediate

Offline mattarse

  • Vollwertiges Mitglied
  • ***
  • Posts: 183
    • Matt's Respite
  • Branch: Stable
  • Desktop: XFCE
  • Kernel: 3.13
  • Skill: Novice
Re: Disable screen dimming when video is playing
« Reply #4 on: 29. September 2013, 23:31:00 »
@Handy - I checked that setting and it was already checked.


But - I watched a show last night and didn't realize until after that it didn't dim on me. Yesterday I had went thru all the screensaver settings, power settings etc. I'm not sure what changed and won't be able to test to confirm that it's not dimming on me until tonight but I think it may be fixed.

Kind of irritating that vlc has a setting to block the screensaver and the power mgmt settings that aren't together unless you choose advanced :) I hadn't seen this setting at all. 

@tmallafre - that may be a workaround, but I'd much rather automate these things.

Offline jonathon

  • Core Team
  • *****
  • Posts: 2104
  • Technologist - Teacher - Tea drinker
  • Branch: Unstable
  • Desktop: MATE 1.14
  • GPU Card: Nvidia GTX680M
  • GPU driver: Bumblebee nvidia+intel
  • Kernel: 4.6.0-*-MANJARO x86_64
  • Skill: Advanced
Re: Disable screen dimming when video is playing
« Reply #5 on: 30. September 2013, 21:49:14 »
Caffeine will do (mostly automatic) screensaver/display power management inhibition. It's in AUR (aur/caffeine-bzr 2.4.1.485.6433545-1).
--
MSI GT70: Core i7-3630QM, 16GB, Nvidia GTX680M, Intel 2230, Manjaro-MATE-amd64-EFI
Lenovo X230: Core i5-3320M, 4GB, Intel HD4000, Intel 6205, Manjaro-MATE-amd64
Dell Studio 1749: Core i5 540, 8GB, ATi HD5650, Intel WLAN, Manjaro-Xfce-amd64
Let's go in the garden; you'll find something waiting.

Offline coloxim

  • Vollwertiges Mitglied
  • ***
  • Posts: 141
  • Branch: stable
  • Desktop: xffce
  • GPU Card: Card: [AMD/ATI] Bonaire XT [Radeon HD 7790/8770]
  • GPU driver: nonfree
  • Kernel: linux 312
  • Skill: Novice
Re: Disable screen dimming when video is playing
« Reply #6 on: 13. February 2014, 17:14:10 »
this work with xbmc?
i've the same problem with xbmc...
when i'm using it the screen saver starts anyway...
Card: [AMD/ATI] Bonaire XT [Radeon HD 7790/8770]
CPU:       Quad core AMD Phenom II X4 945

4 gb ram

Offline mattarse

  • Vollwertiges Mitglied
  • ***
  • Posts: 183
    • Matt's Respite
  • Branch: Stable
  • Desktop: XFCE
  • Kernel: 3.13
  • Skill: Novice
Re: Disable screen dimming when video is playing
« Reply #7 on: 30. April 2014, 17:41:01 »
I had forgotten this thread was here - and since it's been stickied I just wanted to add that at some point the VLC settings stopped working to stop the screen blanking. 

Turning off DPMS as posted  does work however -
http://forum.manjaro.org/index.php?topic=6904.0

This command will do it, but the other post has a script to automate it.

Code: [Select]
xset -dpms && xset s off

Offline Uncle Spellbinder

  • Vollwertiges Mitglied
  • ***
  • Posts: 123
  • IPA!
    • Hallucination Layer
  • Branch: Testing
  • Desktop: KDE
  • GPU Card: AMD Kaveri Quad-Core A10-7800 Radeon R7 Series
  • GPU driver: Non-Free
  • Kernel: x86_64 Linux 4.1.19-1-MANJARO
  • Skill: Intermediate
Re: Disable screen dimming when video is playing
« Reply #8 on: 21. May 2014, 04:23:36 »
I just added xset s off to my startup and all is great.
“Without deviation from the norm, progress is not possible.” -  Frank Zappa

Offline petrea

  • Vollwertiges Mitglied
  • ***
  • Posts: 246
  • Branch: stable
  • Desktop: lxqt
  • GPU Card: Intel HD 4400
  • GPU driver: non-free
  • Kernel: 3.14-x64
  • Skill: Novice
Re: Disable screen dimming when video is playing
« Reply #9 on: 21. May 2014, 11:31:29 »
Caffeine doesn't work with flash.  screen dimming ONLY  when ANY kind of video plays in fullscreen is a MUST HAVE  for each distro. But no one can do this. A piece of sh*t like windows has this "feature".
« Last Edit: 21. May 2014, 11:33:41 by petrea »
Acer Aspire V7 582P i5 256 SSD

Offline oo7vin

  • Neuling
  • *
  • Posts: 2
  • Skill: Novice
Re: Disable screen dimming when video is playing
« Reply #10 on: 23. May 2014, 01:46:25 »
Go to setting manager and click on screensaver and disable it and then
click on power manager and click on on ac then monitor and slide all
to the left.

Offline mattarse

  • Vollwertiges Mitglied
  • ***
  • Posts: 183
    • Matt's Respite
  • Branch: Stable
  • Desktop: XFCE
  • Kernel: 3.13
  • Skill: Novice
Re: Disable screen dimming when video is playing
« Reply #11 on: 24. May 2014, 06:40:09 »
Go to setting manager and click on screensaver and disable it and then
click on power manager and click on on ac then monitor and slide all
to the left.

None of the normal settings were working for me - the DPMS settings seems to override anything else.

Offline gazulon

  • Neuling
  • *
  • Posts: 2
  • Desktop: XFCE
  • GPU Card: Intel Media Graphic Accelerator 3150
  • Skill: Novice
Re: Disable screen dimming when video is playing
« Reply #12 on: 19. October 2015, 19:40:26 »
Hi, there is an app called "Caffeine" - you can find it with Octopi or yaourt (cli) - it will allow programs like vlc to run without being interrupted by the screensaver  :)

Gazulon.

 

Offline c00ter

  • Held Mitglied
  • *****
  • Posts: 1534
  • Towelie's cupcake
  • Branch: ☮Olive☮
  • Desktop: Depends©
  • GPU Card: Intel HD4400M CPU: Core i7-4510U
  • GPU driver: Intel/Free
  • Kernel: 4.4-lts & 4.5
  • Skill: Novice
Re: Disable screen dimming when video is playing
« Reply #13 on: 20. October 2015, 00:40:00 »
The EASIEST way I know of is the Xfce panel power applet set to Presentation. It was specifically designed to permit uninterrupted video presentations. Tada!  8)
“What, me worry?” ― Alfred E. Newman

Manjaro Wiki: https://wiki.manjaro.org/
Arch Wiki: https://wiki.archlinux.org/
Pacman Rosetta: https://wiki.archlinux.org/index.php/Pacman/Rosetta

Offline sjohri

  • Neuling
  • *
  • Posts: 12
  • Skill: Novice
Re: Disable screen dimming when video is playing
« Reply #14 on: 27. October 2015, 09:53:02 »
The EASIEST way I know of is the Xfce panel power applet set to Presentation. It was specifically designed to permit uninterrupted video presentations. Tada!  8)

Just to reiterate what c00ter said, I have successfully used this presentation mode setting to ensure the screen doesn't dim or other power manager settings (sleep / hibernate) don't kick in when needed e.g. watching a movie.  I've added the 'power manager' plugin to my panel which gives me quick access to this setting.
Thx.