Author Topic: Sound Problems  (Read 22502 times)

0 Members and 1 Guest are viewing this topic.

Offline schpankme

  • Held Mitglied
  • *****
  • Posts: 1600
  • High Carb / Low Fat / Vegan
  • Branch: Stable
  • Desktop: Qt..i3..OpenRC..Eudev
  • GPU Card: GTX 780 Ti
  • GPU driver: video-nouveau
  • Kernel: 4.4.45-1 x64
  • Skill: Advanced
Re: Sound Problems
« Reply #30 on: 29. August 2014, 19:47:32 »

Offline kmcclry1

  • Neuling
  • *
  • Posts: 8
  • Branch: Stable
  • Desktop: Gnome, XFCE
  • GPU Card: Laptop: GTX 540M
  • GPU driver: non-free
  • Kernel: 316
  • Skill: Intermediate
Re: Sound Problems
« Reply #31 on: 30. August 2014, 00:12:24 »
I was so close to saying that you just solved my issues, and then I waited a couple minutes...

That seemed to help. I got audio out of my speakers for 2.5 minutes instead of seconds, but it still ended up muting (or whatever the hell its doing). It may have happened when I clicked on a new tab in firefox. (I'm going to try to recreate it and then add an edit to this post when I get through that again.)

So that's the right track? What more could I do? One thing to ask is do I need to drop into root to make changes like that persistent across reboots? I know that some things involving ALSA configs require root to make persistent changes, would this be one of them?

Offline schpankme

  • Held Mitglied
  • *****
  • Posts: 1600
  • High Carb / Low Fat / Vegan
  • Branch: Stable
  • Desktop: Qt..i3..OpenRC..Eudev
  • GPU Card: GTX 780 Ti
  • GPU driver: video-nouveau
  • Kernel: 4.4.45-1 x64
  • Skill: Advanced
Re: Sound Problems
« Reply #32 on: 30. August 2014, 00:31:20 »
You can try sudo.

You may need to add the Sound Configuration File
Code: [Select]
sudo mousepad /etc/asound.conf
Cut & Paste into /etc/asound.conf
Code: [Select]
pcm.pulse {
   type pulse
}
ctl.pulse {
   type pulse
}
pcm.!default {
   type pulse
}
ctl.!default {
   type pulse
}

reboot


1) You may need to re-install "jack"
Code: [Select]
sudo pacman -S jack
2) IF - resetting PulseAudio corrects the issue temporarliy, you 'could' remove PulseAudio and use only Alsa.
Code: [Select]
sudo rm -rf /tmp/pulse* ~/.pulse* ~/.config/pulse
pulseaudio -k
pulseaudio --start

3) Remove PulseAudio
Code: [Select]
sudo pacman -R pavucontrol pulseaudio pulseaudio-alsa

Offline kmcclry1

  • Neuling
  • *
  • Posts: 8
  • Branch: Stable
  • Desktop: Gnome, XFCE
  • GPU Card: Laptop: GTX 540M
  • GPU driver: non-free
  • Kernel: 316
  • Skill: Intermediate
Re: Sound Problems
« Reply #33 on: 30. August 2014, 03:42:58 »
I followed the "no sound" bit that you posted and then killed pulseaudio and removed it so that I would hopefully be starting with a fresh alsa interface without pulse stuff. I also reinstalled jack.

No dice. I still have it cutting out audio. I'm going to reboot and check alsamixer before I start another audio test but this is getting really weird. I can't understand what kind of problem this is. Unless there is a conf file somewhere that has something messed up that's causing this. The part that is really throwing me off is that this happens if I start up the computer and immediately go to say a video on youtube, I get about 20 seconds of audio and then is stops. I'll check the dmesg's as well to see if something is starting or stopping at that time after boot.

Offline schpankme

  • Held Mitglied
  • *****
  • Posts: 1600
  • High Carb / Low Fat / Vegan
  • Branch: Stable
  • Desktop: Qt..i3..OpenRC..Eudev
  • GPU Card: GTX 780 Ti
  • GPU driver: video-nouveau
  • Kernel: 4.4.45-1 x64
  • Skill: Advanced
Re: Sound Problems
« Reply #34 on: 30. August 2014, 03:53:38 »
You may want to change to the Testing Repo's to see if that eliminates the problem, there may be a bad file some-where. You can test this my using the LiveISO and check for sound.

Code: [Select]
sudo mousepad /etc/pacman-mirrors.conf     Branch=testing

Code: [Select]
sudo pacman-mirrors -g -b testing
sudo pacman -Syuu
yaourt -Syuua
reboot
...

suggestion:
We can always completely remove the sound system (alsa and jack) and start over as well.
« Last Edit: 30. August 2014, 03:56:53 by schpankme »

Offline kmcclry1

  • Neuling
  • *
  • Posts: 8
  • Branch: Stable
  • Desktop: Gnome, XFCE
  • GPU Card: Laptop: GTX 540M
  • GPU driver: non-free
  • Kernel: 316
  • Skill: Intermediate
Re: Sound Problems
« Reply #35 on: 30. August 2014, 04:23:46 »
I don't have a USB drive available that would have enough space to take all the updates necessary when doing a pacman -Syuu so I moved my install to testing, still have the audio issues. It didn't look like there were many packages that changed from stable to testing (maybe 10) and none of them had anything to do with audio.

One thing to note, without pulseaudio alsamixer labels my soundcard as "Intel CougarPoint HDMI." My headphones still work when I unmute them with the mixer but that naming almost makes me think it isn't recognizing outputs correctly.

Since ALSA is compiled in the kernel how would you remove it and reinstall it?

Offline schpankme

  • Held Mitglied
  • *****
  • Posts: 1600
  • High Carb / Low Fat / Vegan
  • Branch: Stable
  • Desktop: Qt..i3..OpenRC..Eudev
  • GPU Card: GTX 780 Ti
  • GPU driver: video-nouveau
  • Kernel: 4.4.45-1 x64
  • Skill: Advanced
Re: Sound Problems
« Reply #36 on: 30. August 2014, 04:36:07 »
I meant that you can use the LiveISO to test to see if Sound works?

As for removing Alsa, that would be everything shown installed (alsa*) within your Package Handler (pamac/octopi).
« Last Edit: 30. August 2014, 04:38:47 by schpankme »

Offline kmcclry1

  • Neuling
  • *
  • Posts: 8
  • Branch: Stable
  • Desktop: Gnome, XFCE
  • GPU Card: Laptop: GTX 540M
  • GPU driver: non-free
  • Kernel: 316
  • Skill: Intermediate
Re: Sound Problems
« Reply #37 on: 30. August 2014, 22:09:20 »
Ah, well, no LiveISO I've tried has worked. I've tried two different versions of Manjaro (Xfce and Gnome), Antergos (to see if it was a Manjaro and not arch problem), Fedora (to see if my previous distribution would work), and Ubuntu 14.04 (to see if older software would work and maybe it was a bleeding edge problem). The stranger part of this is that my Windows install has pretty much the same issue except that sound comes back if I move a youtube player around to another buffered area of the video, instead of being permanently muted. That's why I was wondering if this was somehow a hardware issue and not a config file issue earlier, its persistent across distributions and OSes. Could Grub be causing it? That's the only thing I can think of that ultimately effects both OSes.

I'll try removing all alsa and jack files and then rebooting and installing them. I'll report back to see if that changes anything.

Thanks for all your help btw, its nice that there is someone else trying to help because this was driving me crazy when I was trying to figure it out by myself.

EDIT:
Also, I forgot to mention that when I try to remove the state-daemon.conf part it says that there isn't a file of that type. How important is that file and should I have it in the first place?
« Last Edit: 30. August 2014, 22:24:45 by kmcclry1 »

Offline schpankme

  • Held Mitglied
  • *****
  • Posts: 1600
  • High Carb / Low Fat / Vegan
  • Branch: Stable
  • Desktop: Qt..i3..OpenRC..Eudev
  • GPU Card: GTX 780 Ti
  • GPU driver: video-nouveau
  • Kernel: 4.4.45-1 x64
  • Skill: Advanced
Re: Sound Problems
« Reply #38 on: 30. August 2014, 22:18:08 »
If this issue happens with Multiple OS's, then it's probably a Hardware Issue; cable, port or card.

Offline kmcclry1

  • Neuling
  • *
  • Posts: 8
  • Branch: Stable
  • Desktop: Gnome, XFCE
  • GPU Card: Laptop: GTX 540M
  • GPU driver: non-free
  • Kernel: 316
  • Skill: Intermediate
Re: Sound Problems
« Reply #39 on: 30. August 2014, 22:26:30 »
See that's what I thought it might be, but its odd that it happened for both I and a previous poster in this thread. We have the same soundcard and we both have this issue. I think that's a little too coincidental to not be something that we have in common. *shrug* I guess I'll just deal with it or get another laptop at some point.

Offline kmcclry1

  • Neuling
  • *
  • Posts: 8
  • Branch: Stable
  • Desktop: Gnome, XFCE
  • GPU Card: Laptop: GTX 540M
  • GPU driver: non-free
  • Kernel: 316
  • Skill: Intermediate
Re: Sound Problems
« Reply #40 on: 12. September 2014, 06:03:14 »
Update:
Not sure what happened, but my sound is working now. I reinstalled a little while back and had the same issues. I then updated to 316 again and had to save my install because grub screwed up. I chrooted in and fixed the laptop and apparently the sound. I have no idea if grub was screwing something up, or what the deal was, but either way sound is working now.

I wish I could be more helpful for whoever may come here looking for a solution, but I literally have no idea what happened...

Offline mxx

  • Sr. Mitglied
  • ****
  • Posts: 420
  • Branch: stable
  • Desktop: Openbox/i3wm
  • Kernel: linux4
  • Skill: Intermediate
Re: Sound Problems!
« Reply #41 on: 11. November 2014, 12:29:54 »
i had same problem [amixer set Master toggle] code dont do the trick on me... :D may be my bad... for now i'm unmuting the laptop by reinserting earphone jack..only after the unplug the earphone jack laptop speaker came to alive.... i'm searching for better solution...finger crossed. :-\
Tick off PulseAudio Sound System under Session and Startup --> Application Autostart. Leave the PulseAudio applet ticked on. See, if it works.

Offline lightbeam

  • Sr. Mitglied
  • ****
  • Posts: 286
  • Branch: Stable as in: "Whoa, Nelly!"
  • Desktop: Wide Openbox
  • GPU Card: AMD Radeon Xpress 200 Series - Methuselah Edition
  • GPU driver: Free as in Lunch
  • Kernel: Linux44, i686
  • Skill: Intermediate
Re: Sound Problems
« Reply #42 on: 06. August 2015, 13:32:25 »
duplicate
« Last Edit: 06. August 2015, 14:08:36 by lightbeam »
---------------------------------------------------
I make you look good. 8)

Offline lightbeam

  • Sr. Mitglied
  • ****
  • Posts: 286
  • Branch: Stable as in: "Whoa, Nelly!"
  • Desktop: Wide Openbox
  • GPU Card: AMD Radeon Xpress 200 Series - Methuselah Edition
  • GPU driver: Free as in Lunch
  • Kernel: Linux44, i686
  • Skill: Intermediate
Re: Sound Problems
« Reply #43 on: 06. August 2015, 14:10:04 »
...but there is one problem: in certain cases alsa will only play the sound from one application at a time, so sometimes there is no alert or notification sound. Usually it is ok with panel notifications but mozilla firefox and thunderbird will not play nicely at all. Does anyone have any ideas or information about this?

Do you still have this problem?  If so, you might need to tell the kernel to load the snd-aloop module at boot:

Code: [Select]
sudo nano /etc/modules-load.d/modules.conf
So that your modules.conf looks like this:

Code: [Select]
# List of modules to load at boot
snd-aloop

Sound from all of your applications should now be routed to your sound mixer after doing that. If not, you will have to check your sound preferences and see if there and option to create a bridge between ALSA and the snd-aloop daemon, then enable it.  I'm not familiar with QasMixer but maybe it has an option to do this.

Hope this helps!  Somebody, at least.
---------------------------------------------------
I make you look good. 8)

Offline vnvman

  • Neuling
  • *
  • Posts: 28
  • Branch: stable
  • Desktop: Xfce 4.12.3 (Gtk 2.24.28)
  • GPU Card: AMD A4-1200 APU with Radeon HD 8180 Graphics
  • GPU driver: free
  • Kernel: 4.4.6-1.1-MANJAROx86_64
  • Skill: Novice
Re: Sound Problems
« Reply #44 on: 12. April 2016, 08:31:36 »
I have already created a topic at the xfce section because I didn't  notice that this discussion was up before, but probably this was the right topic I should have looked at in the first place but...thing is I have no sound output on HDMI, on other distros simply playing this sound check:
Code: [Select]
speaker-test -c 2 -r 48000 -D hw:0,3used to fix the issue. Right now  tho if I do that I can hear the sound test through the TV so both the hardware and the sowftware are definitely fine, but still when I'm trying to output media it doesn't work and the sound keeps playing through netbook speakers. Any workaround?
Update: all good. The "issue" was that I didn't change the per app setongs.
« Last Edit: 12. April 2016, 15:47:05 by vnvman »