Author Topic: Usb drives not auto mounting  (Read 4370 times)

0 Members and 1 Guest are viewing this topic.

Offline LizziAS

  • Vollwertiges Mitglied
  • ***
  • Posts: 134
  • Branch: Hyssop
  • Desktop: OB-OpenRC
  • GPU Card: 6520G
  • GPU driver: Catalyst
  • Kernel: Zen
  • Skill: Intermediate
Re: Usb drives not auto mounting
« Reply #15 on: 05. May 2016, 21:04:00 »
following this thread    https://forum.manjaro.org/index.php?topic=32877.0

i was able to get it to work.  I had to edit options in thunar -> edit -> prefences -> advanced and click the boxes to auto mount usbdrives and such

then after rebooting it worked but with the caveat that i had to eject them from thunar before removing them from the computer, otherwise when i inserted  a new usb drive my desktop would lock up and require a hardboot.

I'm marking this as solved then.

What say you Eugen-b?

Offline LizziAS

  • Vollwertiges Mitglied
  • ***
  • Posts: 134
  • Branch: Hyssop
  • Desktop: OB-OpenRC
  • GPU Card: 6520G
  • GPU driver: Catalyst
  • Kernel: Zen
  • Skill: Intermediate
Re: Usb drives not auto mounting
« Reply #16 on: 05. May 2016, 21:11:32 »
Thunar works pretty good in openbox but sometime i like to use pcmanfm too so i usually have them both installed.

Offline eugen-b

  • Support Team
  • ****
  • Posts: 3191
  • Branch: testing
  • Desktop: LXDE, Fluxbox, JWM, LXQt, bspwm
  • GPU Card: Intel 82945G/GZ
  • GPU driver: free
  • Kernel: 4.5, 4.6
  • Skill: Intermediate
Re: Usb drives not auto mounting
« Reply #17 on: 05. May 2016, 22:33:05 »
No it doesn't work for me.
Installed and added to rc fuse and autofs, edited /etc/xdg/openbox/autostart, enable Thunar volume management, checked .xinitrc to have ck-session, but still no removable media are shown in Thunar.
MSI Wind Nettop, Intel Atom 230 1.6GHz (64bit), 2GB RAM
DEs: NET-minimal + (LXDE / Fluxbox / JWM); LXQt OpenRC
how to install on btrfs subvolumes
http://manjaro.github.io/donate/

Offline eugen-b

  • Support Team
  • ****
  • Posts: 3191
  • Branch: testing
  • Desktop: LXDE, Fluxbox, JWM, LXQt, bspwm
  • GPU Card: Intel 82945G/GZ
  • GPU driver: free
  • Kernel: 4.5, 4.6
  • Skill: Intermediate
Re: Usb drives not auto mounting
« Reply #18 on: 05. May 2016, 22:46:59 »
I installed pcmanfm - same behaviour as Thunar.
MSI Wind Nettop, Intel Atom 230 1.6GHz (64bit), 2GB RAM
DEs: NET-minimal + (LXDE / Fluxbox / JWM); LXQt OpenRC
how to install on btrfs subvolumes
http://manjaro.github.io/donate/

Offline LizziAS

  • Vollwertiges Mitglied
  • ***
  • Posts: 134
  • Branch: Hyssop
  • Desktop: OB-OpenRC
  • GPU Card: 6520G
  • GPU driver: Catalyst
  • Kernel: Zen
  • Skill: Intermediate
Re: Usb drives not auto mounting
« Reply #19 on: 05. May 2016, 22:51:33 »
i didn't enable ck-session in the .init file thingy

Offline LizziAS

  • Vollwertiges Mitglied
  • ***
  • Posts: 134
  • Branch: Hyssop
  • Desktop: OB-OpenRC
  • GPU Card: 6520G
  • GPU driver: Catalyst
  • Kernel: Zen
  • Skill: Intermediate
Re: Usb drives not auto mounting
« Reply #20 on: 05. May 2016, 22:57:21 »
 in /etc/xdg/openbox/autostart did you add a command for pcmanfm same as thunat one?  Eugen-b?

Offline eugen-b

  • Support Team
  • ****
  • Posts: 3191
  • Branch: testing
  • Desktop: LXDE, Fluxbox, JWM, LXQt, bspwm
  • GPU Card: Intel 82945G/GZ
  • GPU driver: free
  • Kernel: 4.5, 4.6
  • Skill: Intermediate
Re: Usb drives not auto mounting
« Reply #21 on: 05. May 2016, 23:10:27 »
in /etc/xdg/openbox/autostart did you add a command for pcmanfm same as thunat one?  Eugen-b?
No, forgot it first, but now I did it following your advice and the SD card shows up in pcmanfm, but not in Thunar.
The command was dbus-launch pcmanfm --daemon-mode &
What do you have in .xinitrc?
« Last Edit: 05. May 2016, 23:19:55 by eugen-b »
MSI Wind Nettop, Intel Atom 230 1.6GHz (64bit), 2GB RAM
DEs: NET-minimal + (LXDE / Fluxbox / JWM); LXQt OpenRC
how to install on btrfs subvolumes
http://manjaro.github.io/donate/

Offline LizziAS

  • Vollwertiges Mitglied
  • ***
  • Posts: 134
  • Branch: Hyssop
  • Desktop: OB-OpenRC
  • GPU Card: 6520G
  • GPU driver: Catalyst
  • Kernel: Zen
  • Skill: Intermediate
Re: Usb drives not auto mounting
« Reply #22 on: 06. May 2016, 03:05:56 »
Code: [Select]
#!/bin/sh

#
# ~/.xinitrc
#
# Executed by startx
#

export GTK2_RC_FILES="$HOME/.gtkrc-2.0"

DEFAULT_SESSION=openbox-session
case $1 in
  openbox) exec ck-launch-session openbox-session ;;
  *) exec ck-launch-session $DEFAULT_SESSION ;;
esac


Offline LizziAS

  • Vollwertiges Mitglied
  • ***
  • Posts: 134
  • Branch: Hyssop
  • Desktop: OB-OpenRC
  • GPU Card: 6520G
  • GPU driver: Catalyst
  • Kernel: Zen
  • Skill: Intermediate
Re: Usb drives not auto mounting
« Reply #23 on: 06. May 2016, 03:06:56 »
That was there for me i didn't put it there

Offline LizziAS

  • Vollwertiges Mitglied
  • ***
  • Posts: 134
  • Branch: Hyssop
  • Desktop: OB-OpenRC
  • GPU Card: 6520G
  • GPU driver: Catalyst
  • Kernel: Zen
  • Skill: Intermediate
Re: Usb drives not auto mounting
« Reply #24 on: 06. May 2016, 03:14:23 »
but i also ran this command in terminal:

yaourt -S sysvinit openrc eudev udev-openrc eudev-systemdcompat dbus-openrc procps-ng-nosystemd syslog-ng-nosystemd udisks2-nosystemd consolekit polkit-consolekit upower-pm-utils udisks2-nosystemd desktop-privileges xorg-xwrapper acpid-openrc alsa-utils-openrc autofs-openrc consolekit consolekit-openrc cronie-openrc dbus-openrc cups-openrc displaymanager-openrc fuse-openrc haveged-openrc hdparm-openrc openssh-openrc samba-openrc syslog-ng-openrc avahi-openrc

adapted from this page:

http://systemd-free.org/install.php

Offline viordiasko

  • Neuling
  • *
  • Posts: 19
  • So far, impressed.
  • Branch: Stable
  • Desktop: XFCE/Openbox
  • GPU Card: nVidia GTX760
  • GPU driver: non-free
  • Kernel: 4.1.23-1-MANJARO x86_64
  • Skill: Intermediate
Re: Usb drives not auto mounting
« Reply #25 on: 06. May 2016, 03:45:24 »
I had no removeable drives visible in thunar in Openbox. I solved it by running from a terminal / changing menu entries to:
Code: [Select]
dbus-launch thunar
No "--daemon" option. Now I can see all the removable drives & mount, eject them  :D (and I've rebooted since).

Also
I've just used thunar-volman-settings to automount removeable drives / media when hotplugged / inserted & it works. I haven't rebooted for this yet.

Offline suska

  • Neuling
  • *
  • Posts: 14
  • I'm new. Be nice!
  • Branch: testing
  • Desktop: xfce-openbox-openrc
  • GPU Card: GM45
  • GPU driver: free
  • Kernel: 4.6
  • Skill: Novice
Re: Usb drives not auto mounting
« Reply #26 on: 06. May 2016, 09:55:44 »
I had no removeable drives visible in thunar in Openbox. I solved it by running from a terminal / changing menu entries to:
Code: [Select]
dbus-launch thunar
No "--daemon" option. Now I can see all the removable drives & mount, eject them  :D (and I've rebooted since).

Got this issue 2 weeks ago. That´s what i did and was the only way for me to get it working.

Offline eugen-b

  • Support Team
  • ****
  • Posts: 3191
  • Branch: testing
  • Desktop: LXDE, Fluxbox, JWM, LXQt, bspwm
  • GPU Card: Intel 82945G/GZ
  • GPU driver: free
  • Kernel: 4.5, 4.6
  • Skill: Intermediate
Re: Usb drives not auto mounting
« Reply #27 on: 06. May 2016, 14:21:19 »
That was there for me i didn't put it there
Same with my, but I checked that it was there, that's what I meant.

@viordiasko, I haven't tried your method yet, looking forward to trying it, thanks!
EDIT: I can now confirm that it works. It opens a Thunar window at start but that's a minor annoyance, could be mitigated with wmctrl -c thunar & added to startup file.
« Last Edit: 06. May 2016, 15:02:48 by eugen-b »
MSI Wind Nettop, Intel Atom 230 1.6GHz (64bit), 2GB RAM
DEs: NET-minimal + (LXDE / Fluxbox / JWM); LXQt OpenRC
how to install on btrfs subvolumes
http://manjaro.github.io/donate/

Offline viordiasko

  • Neuling
  • *
  • Posts: 19
  • So far, impressed.
  • Branch: Stable
  • Desktop: XFCE/Openbox
  • GPU Card: nVidia GTX760
  • GPU driver: non-free
  • Kernel: 4.1.23-1-MANJARO x86_64
  • Skill: Intermediate
Re: Usb drives not auto mounting
« Reply #28 on: 07. May 2016, 00:10:39 »
@eugen-b You're welcome.

To be clear: I didn't add it to auto start. I changed the top level menu entry for thunar in my pipe menu
(~/.config/obmenu-generator/schema.pl).
Code: [Select]
    {item => ['dbus-launch thunar',        'File Manager',      'file-manager']},
 :) BONUS: I also noticed that using dbus-launch tomboy stops tomboy crashing on launch complaining like this:
Code: [Select]
Unhandled Exception:
System.NullReferenceException: Object reference not set to an instance of an object
  at DBus.BusG.Init (DBus.Connection conn, DBus.GLib.IOFunc dispatchHandler) <0x41116ab0 + 0x0001e> in <filename unknown>:0  etc. etc.

Now I have to work out how to change the menu entry for tomboy. It seems to be auto generated as part of the 'Accesories' category of apps in schema.pl .  Possibly changing the 'Exec=tomboy --search' line in the .desktop file in /usr/share/application. ???

Offline eugen-b

  • Support Team
  • ****
  • Posts: 3191
  • Branch: testing
  • Desktop: LXDE, Fluxbox, JWM, LXQt, bspwm
  • GPU Card: Intel 82945G/GZ
  • GPU driver: free
  • Kernel: 4.5, 4.6
  • Skill: Intermediate
Re: Usb drives not auto mounting
« Reply #29 on: 07. May 2016, 01:20:17 »
@viordiasko, I've just found it out myself that I can edit the thunar.desktop file to Exec=dbus-launch thunar %F
This way obmenu-generator will create the entries with this command. Only the top menu entry needs to be edited in schema.pl, as you wrote.
aaditya will be happy about the solution.
MSI Wind Nettop, Intel Atom 230 1.6GHz (64bit), 2GB RAM
DEs: NET-minimal + (LXDE / Fluxbox / JWM); LXQt OpenRC
how to install on btrfs subvolumes
http://manjaro.github.io/donate/