Author Topic: Usb drives not auto mounting  (Read 4384 times)

0 Members and 1 Guest are viewing this topic.

Offline LizziAS

  • Vollwertiges Mitglied
  • ***
  • Posts: 134
  • Branch: Hyssop
  • Desktop: OB-OpenRC
  • GPU Card: 6520G
  • GPU driver: Catalyst
  • Kernel: Zen
  • Skill: Intermediate
Usb drives not auto mounting
« on: 04. May 2016, 21:36:44 »
i have the openbox openrc installed.  I stripped out xfce and installed some things that are needed for openbox to run properly and it all does except that i can't get usb drives to automount.  i have udisks and udisks2-nosystemd installed.  What else needs be done?  (Yes i have rebooted).
« Last Edit: 05. May 2016, 03:34:10 by LizziAS »

Offline eugen-b

  • Support Team
  • ****
  • Posts: 3191
  • Branch: testing
  • Desktop: LXDE, Fluxbox, JWM, LXQt, bspwm
  • GPU Card: Intel 82945G/GZ
  • GPU driver: free
  • Kernel: 4.5, 4.6
  • Skill: Intermediate
Re: Usb drives not auto mounting
« Reply #1 on: 04. May 2016, 21:45:01 »
maybe some gvfs stuff
MSI Wind Nettop, Intel Atom 230 1.6GHz (64bit), 2GB RAM
DEs: NET-minimal + (LXDE / Fluxbox / JWM); LXQt OpenRC
how to install on btrfs subvolumes
http://manjaro.github.io/donate/

Offline LizziAS

  • Vollwertiges Mitglied
  • ***
  • Posts: 134
  • Branch: Hyssop
  • Desktop: OB-OpenRC
  • GPU Card: 6520G
  • GPU driver: Catalyst
  • Kernel: Zen
  • Skill: Intermediate
Re: Usb drives not auto mounting
« Reply #2 on: 05. May 2016, 03:35:32 »
Let me look into that.  I had installed some gifts stuffs to try to get my phone to mount but had no success.

Offline LizziAS

  • Vollwertiges Mitglied
  • ***
  • Posts: 134
  • Branch: Hyssop
  • Desktop: OB-OpenRC
  • GPU Card: 6520G
  • GPU driver: Catalyst
  • Kernel: Zen
  • Skill: Intermediate
Re: Usb drives not auto mounting
« Reply #3 on: 05. May 2016, 04:19:27 »
i looked into openrc on the wiki and started following the commands to convert a system to openrc and found this command:

Code: [Select]
for daemon in acpid alsasound autofs dbus consolekit cronie cupsd xdm fuse haveged hdparm smb sshd atd; do rc-update add $daemon default; done
which gave me this output:
Code: [Select]
* rc-update: acpid already installed in runlevel `default'; skipping
 * rc-update: alsasound already installed in runlevel `default'; skipping
 * rc-update: service `autofs' does not exist
 * rc-update: dbus already installed in runlevel `default'; skipping
 * rc-update: consolekit already installed in runlevel `default'; skipping
 * rc-update: cronie already installed in runlevel `default'; skipping
 * rc-update: cupsd already installed in runlevel `default'; skipping
 * rc-update: xdm already installed in runlevel `default'; skipping
 * rc-update: service `fuse' does not exist
 * rc-update: failed to add service `haveged' to runlevel `default': Permission denied
 * rc-update: failed to add service `hdparm' to runlevel `default': Permission denied
 * rc-update: service `smb' does not exist
 * rc-update: failed to add service `sshd' to runlevel `default': Permission denied
 * rc-update: service `atd' does not exist

Offline LizziAS

  • Vollwertiges Mitglied
  • ***
  • Posts: 134
  • Branch: Hyssop
  • Desktop: OB-OpenRC
  • GPU Card: 6520G
  • GPU driver: Catalyst
  • Kernel: Zen
  • Skill: Intermediate
Re: Usb drives not auto mounting
« Reply #4 on: 05. May 2016, 04:23:04 »
and so i searched pamac-manager for autofs and found autofs-openrc which i then installed and it gave me an exit command to run:

rc-update add autofs default

which i then ran as root and now i am rebooting

Offline LizziAS

  • Vollwertiges Mitglied
  • ***
  • Posts: 134
  • Branch: Hyssop
  • Desktop: OB-OpenRC
  • GPU Card: 6520G
  • GPU driver: Catalyst
  • Kernel: Zen
  • Skill: Intermediate
Re: Usb drives not auto mounting
« Reply #5 on: 05. May 2016, 04:26:26 »
but not before installing fuse-openrc  and adding:

rc-update add fuse default

as root

Offline LizziAS

  • Vollwertiges Mitglied
  • ***
  • Posts: 134
  • Branch: Hyssop
  • Desktop: OB-OpenRC
  • GPU Card: 6520G
  • GPU driver: Catalyst
  • Kernel: Zen
  • Skill: Intermediate
Re: Usb drives not auto mounting
« Reply #6 on: 05. May 2016, 04:50:05 »


http://systemd-free.org/install.php



while the above instructions provided some insight into things i might be missing, i still can not auto mount an usb drives that are formatted and working.  The mount in my arch install and my other manjaro (E20) install that uses systemd...

Any other ideas?

Offline dbVU

  • Jr. Mitglied
  • **
  • Posts: 52
  • Branch: stable
  • Desktop: XFCE openrc
  • GPU Card: Nvidia 7800GS
  • GPU driver: free
  • Kernel: 4.4.6-1-MANJARO i686
  • Skill: Novice
Re: Usb drives not auto mounting
« Reply #7 on: 05. May 2016, 13:27:26 »
I checked and I have this problem too. But I use Xfce which works perfectly. Please take a look at this thread :https://forum.manjaro.org/index.php?topic=32877.0
maybe something there.

db

Offline eugen-b

  • Support Team
  • ****
  • Posts: 3191
  • Branch: testing
  • Desktop: LXDE, Fluxbox, JWM, LXQt, bspwm
  • GPU Card: Intel 82945G/GZ
  • GPU driver: free
  • Kernel: 4.5, 4.6
  • Skill: Intermediate
Re: Usb drives not auto mounting
« Reply #8 on: 05. May 2016, 16:53:04 »
I checked and I have this problem too. But I use Xfce which works perfectly. Please take a look at this thread :https://forum.manjaro.org/index.php?topic=32877.0
maybe something there.
I can confirm this behaviour, on Xfce OpenRC session I see all partitions and devices in Thunar, but on Openbox session not.
I remember on Fluxbox OpenRC it worked OOTB with removable devices with PCManFM, it also works on LXQt with PCManFM-Qt. I will see what the difference is between these installs.
MSI Wind Nettop, Intel Atom 230 1.6GHz (64bit), 2GB RAM
DEs: NET-minimal + (LXDE / Fluxbox / JWM); LXQt OpenRC
how to install on btrfs subvolumes
http://manjaro.github.io/donate/

Offline LizziAS

  • Vollwertiges Mitglied
  • ***
  • Posts: 134
  • Branch: Hyssop
  • Desktop: OB-OpenRC
  • GPU Card: 6520G
  • GPU driver: Catalyst
  • Kernel: Zen
  • Skill: Intermediate
Re: Usb drives not auto mounting
« Reply #9 on: 05. May 2016, 17:59:02 »
Thanks!  I won't give up on it as i like my Openbox only OpenRC.  Appreciate the help.

Offline eugen-b

  • Support Team
  • ****
  • Posts: 3191
  • Branch: testing
  • Desktop: LXDE, Fluxbox, JWM, LXQt, bspwm
  • GPU Card: Intel 82945G/GZ
  • GPU driver: free
  • Kernel: 4.5, 4.6
  • Skill: Intermediate
Re: Usb drives not auto mounting
« Reply #10 on: 05. May 2016, 18:06:40 »
Install PCManFM (if you are not a hardcore Thunar devotee;)) and see if it behaves differently.
MSI Wind Nettop, Intel Atom 230 1.6GHz (64bit), 2GB RAM
DEs: NET-minimal + (LXDE / Fluxbox / JWM); LXQt OpenRC
how to install on btrfs subvolumes
http://manjaro.github.io/donate/

Offline glock172

  • Vollwertiges Mitglied
  • ***
  • Posts: 124
  • Branch: openrc, unstable
  • Desktop: MATE,Xfce
  • GPU Card: GT 210
  • GPU driver: free
  • Kernel: 4.4
  • Skill: Novice
Re: Usb drives not auto mounting
« Reply #11 on: 05. May 2016, 18:26:13 »
The last time I used openbox (before month) I get it working with Thunar by adding
Code: [Select]
dbus-launch thunar --daemon &in /etc/xdg/openbox/autostart
It was taking around 4 seconds until the usb drive was mounted.
If it ain't broke, don't fix it

Offline dbVU

  • Jr. Mitglied
  • **
  • Posts: 52
  • Branch: stable
  • Desktop: XFCE openrc
  • GPU Card: Nvidia 7800GS
  • GPU driver: free
  • Kernel: 4.4.6-1-MANJARO i686
  • Skill: Novice
Re: Usb drives not auto mounting
« Reply #12 on: 05. May 2016, 19:13:24 »
I can confirm that glock172's solution works! I can now automount usb stick in Openbox.

Thanks,

db

Offline LizziAS

  • Vollwertiges Mitglied
  • ***
  • Posts: 134
  • Branch: Hyssop
  • Desktop: OB-OpenRC
  • GPU Card: 6520G
  • GPU driver: Catalyst
  • Kernel: Zen
  • Skill: Intermediate
Re: Usb drives not auto mounting
« Reply #13 on: 05. May 2016, 20:39:16 »
The last time I used openbox (before month) I get it working with Thunar by adding
Code: [Select]
dbus-launch thunar --daemon &in /etc/xdg/openbox/autostart
It was taking around 4 seconds until the usb drive was mounted.

Here is my autostart file:

Code: [Select]
#
# These things are run when an Openbox X Session is started.
# You may place a similar script in $HOME/.config/openbox/autostart
# to run user-specific things.
#

# If you want to use GNOME config tools...
#
#if test -x /usr/lib/openbox/gnome-settings-daemon >/dev/null; then
#  /usr/lib/openbox/gnome-settings-daemon &
#elif which gnome-settings-daemon >/dev/null 2>&1; then
#  gnome-settings-daemon &
#fi

# If you want to use XFCE config tools...
#
#xfce-mcs-manager &
dbus-launch thunar --daemon &


it still does not work

Offline eugen-b

  • Support Team
  • ****
  • Posts: 3191
  • Branch: testing
  • Desktop: LXDE, Fluxbox, JWM, LXQt, bspwm
  • GPU Card: Intel 82945G/GZ
  • GPU driver: free
  • Kernel: 4.5, 4.6
  • Skill: Intermediate
Re: Usb drives not auto mounting
« Reply #14 on: 05. May 2016, 20:46:47 »
My /etc/xdg/openbox/autostart is exactly as Lizzy's and I just checked, it doesn't work for me either.
MSI Wind Nettop, Intel Atom 230 1.6GHz (64bit), 2GB RAM
DEs: NET-minimal + (LXDE / Fluxbox / JWM); LXQt OpenRC
how to install on btrfs subvolumes
http://manjaro.github.io/donate/