Author Topic: PulseAudio dummy output and no sound issue after update  (Read 2347 times)

0 Members and 1 Guest are viewing this topic.

Offline Mr Pedrito

  • Neuling
  • *
  • Posts: 4
  • I'm new. Be nice!
  • Skill: Novice
Hi y'all!

After the big update I've lost sound function and pulse only displays dummy as an output option. I have had pulse issues in the past but have usually been able to find a work around somewhere online. Unfortunately this time I'm struggling.

Here's hoping someone has an idea of what to do. Sorry in advance as I am little more than a seasoned novice.

Cheers,

Pete


Offline linuxtopia

  • Neuling
  • *
  • Posts: 7
  • I'm new. Be nice!
  • Branch: stable
  • Desktop: xfce
  • Skill: Novice
Re: PulseAudio dummy output and no sound issue after update
« Reply #1 on: 07. May 2016, 15:16:56 »
Same problem occurred for me after update on my lenovo s100 netbook. tried something just like reinstalling pulseaudio but not solved the problem.

searched the forum for any advice and tried them also (by the way ı'm very novice) but still continue :(

could anyone help us please? I really really love manjaro xfce and don't want to fresh install or change my OS to other distro.

Offline Heart Of A Lion

  • Sr. Mitglied
  • ****
  • Posts: 313
  • I'm new. Be nice!
  • Branch: Stable
  • Desktop: Xfce, Enlightenment
  • GPU Card: ATi 7770 . . . . . . . CPU: AMD octacore 4GHz
  • GPU driver: Free (video-ATI)
  • Kernel: 4.6 (x64)
  • Skill: Intermediate
Re: PulseAudio dummy output and no sound issue after update
« Reply #2 on: 07. May 2016, 22:37:37 »
I had the same problem, but I fixed it.

I uninstalled and then reinstalled both Pulse and Fluidsynth. And then I ran the following command and rebooted my system:

Code: [Select]
mv ~/.config/pulse ~/.config/pulse.old
It renames and backs up the config file directory of Pulse and allows Pulse to automatically generate a new one. Your current Pulse config files are potentially broken, because for some reason PulseAudio's user configuration files can become corrupted in some way - and deleting them (and forcing fresh ones to be generated) can fix a no sound condition.

Don't forget to reboot your system after running the command.

After that I was able to select my headphones as an output device again in Pulse and sound worked again.

Let me know if that worked for either of you as well.
« Last Edit: 08. May 2016, 01:03:38 by Heart Of A Lion »

Offline Heart Of A Lion

  • Sr. Mitglied
  • ****
  • Posts: 313
  • I'm new. Be nice!
  • Branch: Stable
  • Desktop: Xfce, Enlightenment
  • GPU Card: ATi 7770 . . . . . . . CPU: AMD octacore 4GHz
  • GPU driver: Free (video-ATI)
  • Kernel: 4.6 (x64)
  • Skill: Intermediate
Re: PulseAudio dummy output and no sound issue after update
« Reply #3 on: 07. May 2016, 22:42:26 »
- double post -
« Last Edit: 07. May 2016, 22:51:30 by Heart Of A Lion »

Offline linuxtopia

  • Neuling
  • *
  • Posts: 7
  • I'm new. Be nice!
  • Branch: stable
  • Desktop: xfce
  • Skill: Novice
Re: PulseAudio dummy output and no sound issue after update
« Reply #4 on: 07. May 2016, 23:02:57 »
I have tried your advice that command produced another pulse file in .config. Then reboot the system and no sound still :(

Offline Heart Of A Lion

  • Sr. Mitglied
  • ****
  • Posts: 313
  • I'm new. Be nice!
  • Branch: Stable
  • Desktop: Xfce, Enlightenment
  • GPU Card: ATi 7770 . . . . . . . CPU: AMD octacore 4GHz
  • GPU driver: Free (video-ATI)
  • Kernel: 4.6 (x64)
  • Skill: Intermediate
Re: PulseAudio dummy output and no sound issue after update
« Reply #5 on: 07. May 2016, 23:25:02 »
I have tried your advice that command produced another pulse file in .config. Then reboot the system and no sound still :(

Have you tried to reinstall Pulse and Fluidsynth as well? (and then rebooted)

Also check if you don't have anything muted with the mute buttons in Pulse and in the Audio Mixer. And if you have volume of everything at 100%, both in Pulse and in your Audio Mixer.
« Last Edit: 07. May 2016, 23:27:08 by Heart Of A Lion »

Offline linuxtopia

  • Neuling
  • *
  • Posts: 7
  • I'm new. Be nice!
  • Branch: stable
  • Desktop: xfce
  • Skill: Novice
Re: PulseAudio dummy output and no sound issue after update
« Reply #6 on: 07. May 2016, 23:48:02 »
I have done step by step that you mentioned however still no sound

Offline Heart Of A Lion

  • Sr. Mitglied
  • ****
  • Posts: 313
  • I'm new. Be nice!
  • Branch: Stable
  • Desktop: Xfce, Enlightenment
  • GPU Card: ATi 7770 . . . . . . . CPU: AMD octacore 4GHz
  • GPU driver: Free (video-ATI)
  • Kernel: 4.6 (x64)
  • Skill: Intermediate
Re: PulseAudio dummy output and no sound issue after update
« Reply #7 on: 08. May 2016, 00:15:55 »
These are also some commands that I tried, however I'm not sure if they will help:

Code: [Select]
systemctl daemon-reload
Code: [Select]
systemctl restart fluidsynth
Code: [Select]
pulseaudio -k
Then reboot.

Offline Holmes

  • Mirror Support Team
  • ***
  • Posts: 2039
  • Brazilian and Hispanic Support Team
    • Manjaro Brasil
  • Branch: Stable
  • Desktop: Manjaro XFCE
  • GPU Card: Mobile Intel (R) 945
  • GPU driver: Non-free
  • Kernel: kernellinux
  • Skill: Novice
Re: PulseAudio dummy output and no sound issue after update
« Reply #8 on: 08. May 2016, 00:21:43 »
hello @Heart Of A Lion,
which packages have been removed? fluidsynth and pulseaudio (?)
i am also with this problem!
thaks...

vlw fwi, Holmes :)


==> Manjaro Brasil I Manjaro Hispano
==> IRC Manjaro Brasil: #manjaro-br I IRC Manjaro Hispano: #manjaro-es

Offline linuxtopia

  • Neuling
  • *
  • Posts: 7
  • I'm new. Be nice!
  • Branch: stable
  • Desktop: xfce
  • Skill: Novice
Re: PulseAudio dummy output and no sound issue after update
« Reply #9 on: 08. May 2016, 00:54:49 »
These are also some commands that I tried, however I'm not sure if they will help:

Code: [Select]
systemctl daemon-reload
Code: [Select]
systemctl restart fluidsynth
Code: [Select]
pulseaudio -k
Then reboot.

No sound still... Uppp manjaro is awesome but that issue is very very low side of it. couldnt find yet any solution although reading forums and wikis :(

Offline Heart Of A Lion

  • Sr. Mitglied
  • ****
  • Posts: 313
  • I'm new. Be nice!
  • Branch: Stable
  • Desktop: Xfce, Enlightenment
  • GPU Card: ATi 7770 . . . . . . . CPU: AMD octacore 4GHz
  • GPU driver: Free (video-ATI)
  • Kernel: 4.6 (x64)
  • Skill: Intermediate
Re: PulseAudio dummy output and no sound issue after update
« Reply #10 on: 08. May 2016, 01:01:49 »
hello @Heart Of A Lion,
which packages have been removed? fluidsynth and pulseaudio (?)

I uninstalled and re-installed both pulseaudio and fluidsynth. I restarted their process/service/deamon and I reset the config files of Pulse. Then I rebooted. For me, these things worked.

Also try to look very carefully if anything within PulseAudio or the Audio Mixer isn't muted and that volumes are at 100%. These things can be very sneeky, as they are easily overlooked.


Offline Heart Of A Lion

  • Sr. Mitglied
  • ****
  • Posts: 313
  • I'm new. Be nice!
  • Branch: Stable
  • Desktop: Xfce, Enlightenment
  • GPU Card: ATi 7770 . . . . . . . CPU: AMD octacore 4GHz
  • GPU driver: Free (video-ATI)
  • Kernel: 4.6 (x64)
  • Skill: Intermediate
Re: PulseAudio dummy output and no sound issue after update
« Reply #11 on: 08. May 2016, 01:12:36 »
By the way it's good to know that I wasn't the only person with this issue. It seems like a lot of people have had their sound broken after the update.

The fact that I was able to get sound back though makes it hopeful that you guys will be able to fix it as well, however we might need to get some advice about this from one of the maintainers, as it seems to be a widespread issue and the solution that worked for me didn't necessarily work for others.

This is also a reason why I always advocate to make a backup of your system before every update cycle.

However in this case I think it can be fixed.
« Last Edit: 08. May 2016, 01:16:47 by Heart Of A Lion »

Offline linuxtopia

  • Neuling
  • *
  • Posts: 7
  • I'm new. Be nice!
  • Branch: stable
  • Desktop: xfce
  • Skill: Novice
Re: PulseAudio dummy output and no sound issue after update
« Reply #12 on: 08. May 2016, 10:18:22 »
yep, thanks for all your help. I agree with you that other maintainers may advice us if they want to develop Manjaro community and user number of it.

Please help us hey you others whre are you? :D

Offline Rob

  • Core Team
  • *****
  • Posts: 5390
  • Alias: Korrode
  • Branch: Unstable
  • Desktop: Xfce+Compiz
  • GPU Card: nVidia GTX560Ti
  • GPU driver: non-free
  • Kernel: linux314 x64
  • Skill: Advanced
Re: PulseAudio dummy output and no sound issue after update
« Reply #13 on: 08. May 2016, 10:43:23 »
If you guys run alsamixer in a terminal, do the ALSA volume controls for your sound cards appear?

Also post output of
Code: [Select]
lsmod

Offline linuxtopia

  • Neuling
  • *
  • Posts: 7
  • I'm new. Be nice!
  • Branch: stable
  • Desktop: xfce
  • Skill: Novice
Re: PulseAudio dummy output and no sound issue after update
« Reply #14 on: 08. May 2016, 11:28:03 »
If you guys run alsamixer in a terminal, do the ALSA volume controls for your sound cards appear?

Also post output of
Code: [Select]
lsmod

after alsamixer command in terminal that gives this output (some words in Turkish roughly translate which means Invalid Argument)

Code: [Select]
alsamixer
ALSA lib conf.c:1697:(snd_config_load1) _toplevel_:20:0:Unexpected char
ALSA lib conf.c:3449:(config_file_open) /etc/asound.conf may be old or corrupted: consider to remove or fix it
ALSA lib conf.c:3371:(snd_config_hooks_call) function snd_config_hook_load returned error: Geçersiz argüman
ALSA lib conf.c:3820:(snd_config_update_r) hooks failed, removing configuration
cannot open mixer: Geçersiz argüman

theof
Code: [Select]
lsmod output result is :
Code: [Select]
Module                  Size  Used by
rfcomm                 53248  2
fuse                   86016  2
bnep                   20480  2
joydev                 20480  0
mousedev               20480  0
uvcvideo               77824  0
videobuf2_vmalloc      16384  1 uvcvideo
videobuf2_memops       16384  1 videobuf2_vmalloc
videobuf2_v4l2         24576  1 uvcvideo
videobuf2_core         32768  2 uvcvideo,videobuf2_v4l2
v4l2_common            16384  1 videobuf2_v4l2
videodev              131072  4 uvcvideo,v4l2_common,videobuf2_core,videobuf2_v4l2
media                  20480  2 uvcvideo,videodev
psmouse               126976  0
input_leds             16384  0
serio_raw              16384  0
fjes                   28672  0
thinkpad_acpi          65536  0
nvram                  16384  1 thinkpad_acpi
msr                    16384  0
iTCO_wdt               16384  0
iTCO_vendor_support    16384  1 iTCO_wdt
mac_hid                16384  0
evdev                  20480  15
coretemp               16384  0
btusb                  36864  0
btrtl                  16384  1 btusb
btbcm                  16384  1 btusb
btintel                16384  1 btusb
ideapad_laptop         24576  0
tg3                   155648  0
ptp                    20480  1 tg3
pps_core               20480  1 ptp
bluetooth             425984  29 bnep,btbcm,btrtl,btusb,rfcomm,btintel
sparse_keymap          16384  1 ideapad_laptop
wmi                    20480  1 ideapad_laptop
libphy                 28672  1 tg3
i2c_i801               20480  0
wl                   6094848  0
led_class              16384  2 thinkpad_acpi,input_leds
lpc_ich                20480  0
rng_core               16384  0
snd_hda_codec_realtek    61440  1
snd_hda_codec_generic    65536  1 snd_hda_codec_realtek
snd_hda_intel          32768  0
snd_hda_codec          94208  3 snd_hda_codec_realtek,snd_hda_codec_generic,snd_hda_intel
snd_hda_core           45056  4 snd_hda_codec_realtek,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel
snd_hwdep              16384  1 snd_hda_codec
snd_pcm                77824  3 snd_hda_codec,snd_hda_intel,snd_hda_core
snd_timer              28672  1 snd_pcm
snd                    57344  8 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_pcm,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel,thinkpad_acpi
soundcore              16384  1 snd
acpi_cpufreq           20480  1
tpm_tis                20480  0
tpm                    36864  1 tpm_tis
cfg80211              438272  1 wl
rfkill                 20480  7 cfg80211,ideapad_laptop,thinkpad_acpi,bluetooth
thermal                20480  0
i915                 1077248  8
battery                16384  0
button                 16384  1 i915
drm_kms_helper         98304  1 i915
drm                   245760  10 i915,drm_kms_helper
syscopyarea            16384  1 drm_kms_helper
sysfillrect            16384  1 drm_kms_helper
sysimgblt              16384  1 drm_kms_helper
fb_sys_fops            16384  1 drm_kms_helper
i2c_algo_bit           16384  1 i915
intel_agp              20480  0
intel_gtt              20480  3 i915,intel_agp
agpgart                32768  3 drm,intel_agp,intel_gtt
shpchp                 32768  0
video                  32768  3 i915,ideapad_laptop,thinkpad_acpi
ac                     16384  0
processor              32768  1 acpi_cpufreq
sch_fq_codel           20480  7
nfs                   188416  0
lockd                  73728  1 nfs
grace                  16384  1 lockd
sunrpc                241664  2 nfs,lockd
fscache                49152  1 nfs
ip_tables              20480  0
x_tables               20480  1 ip_tables
ext4                  487424  1
crc16                  16384  2 ext4,bluetooth
mbcache                20480  1 ext4
jbd2                   81920  1 ext4
ums_realtek            20480  0
uas                    20480  0
usb_storage            53248  2 uas,ums_realtek
sd_mod                 36864  3
ata_generic            16384  0
pata_acpi              16384  0
atkbd                  24576  0
libps2                 16384  2 atkbd,psmouse
ata_piix               32768  2
libata                184320  3 pata_acpi,ata_generic,ata_piix
scsi_mod              131072  4 uas,usb_storage,libata,sd_mod
ehci_pci               16384  0
uhci_hcd               40960  0
ehci_hcd               65536  1 ehci_pci
usbcore               172032  8 uas,btusb,uhci_hcd,uvcvideo,ums_realtek,usb_storage,ehci_hcd,ehci_pci
usb_common             16384  1 usbcore
i8042                  20480  2 libps2,ideapad_laptop
serio                  20480  6 serio_raw,atkbd,i8042,psmouse
« Last Edit: 08. May 2016, 13:56:31 by linuxtopia »