Author Topic: ISO problem (virtualbox maybe?)  (Read 1068 times)

0 Members and 1 Guest are viewing this topic.

Offline Strit

  • Maintainer
  • ***
  • Posts: 746
  • Manjaro Torrent Maintainer
    • Strits.dk
  • Branch: Stable
  • Desktop: XFCE
  • GPU Card: GTX 760 OC
  • GPU driver: Non-free nvidia 361
  • Kernel: 4.4.8-1-MANJARO
  • Skill: Intermediate
ISO problem (virtualbox maybe?)
« on: 29. April 2016, 22:15:05 »
Hi all.

When creating my ISO's it finishes without errors, but the resulting ISO will not boot into a GUI when in Virtualbox.
I get passed the isolinux screen, and it says it has started the mhwd live script. After that, it's just a black screen with a blinking cursor.

I've also tried burning the ISO to a DVD and testing it on real hardware. The ISO didn't really burn right, it was stuck in an eternal "loop" with creating checksum for the burned DVD. Tried it on the laptop any, but after the isolinux screen I get thrown into a rootfs prompt.

I'm using the current manjaro-tools from stable (0.11.5-2) and the iso profiles from github (with my own custom in it).

Any idea what I am doing wrong?
Desktop PC: Manjaro XFCE 15.12 (stable, kernel 4.4)
Private Laptop: Manjaro Strit 16.03 (unstable, kernel 4.6)
Work Laptop: Manjaro Strit 16.03 (stable, kernel 4.4)
Netbook: Arch Linux XFCE/LXqt (i686, kernel 4.0)

Offline Strit

  • Maintainer
  • ***
  • Posts: 746
  • Manjaro Torrent Maintainer
    • Strits.dk
  • Branch: Stable
  • Desktop: XFCE
  • GPU Card: GTX 760 OC
  • GPU driver: Non-free nvidia 361
  • Kernel: 4.4.8-1-MANJARO
  • Skill: Intermediate
Re: ISO problem (virtualbox maybe?)
« Reply #1 on: 30. April 2016, 08:18:12 »
Well. If I build the XFCE-Minimal it works.

Here's the output from buildiso -p strit-minimal -qv:
Code: [Select]
strit@strit-Manjaro:~$ buildiso -p strit-minimal -qv
[sudo] password for strit:
==> manjaro-tools
  -> version: 0.11.5
  -> manjaro_tools_conf: /etc/manjaro-tools/manjaro-tools.conf
==> PROFILE:
  -> sets_dir_iso: /etc/manjaro-tools/iso.d
  -> buildsets: community|default|minimal|official|sonar
  -> buildset_iso: strit-minimal
  -> is_buildset: false
  -> run_dir: /home/strit/git/manjaro-tools-iso-profiles
==> OPTIONS:
  -> arch: x86_64
  -> branch: stable
  -> chroots_iso: /home/strit/Manjaro-Strit/manjaro-tools/lib/buildiso
  -> initsys: systemd
  -> kernel: linux44
==> ARGS:
  -> clean_first: true
  -> images_only: false
  -> iso_only: false
  -> sign: false
  -> is_log: false
==> DIST SETTINGS:
  -> dist_name: Manjaro
  -> dist_release: 16.04
  -> dist_codename: Capella
==> ISO SETTINGS:
  -> iso_label: MJRO1604
  -> iso_publisher: Manjaro Linux <http://www.manjaro.org>
  -> iso_app_id: Manjaro Linux Live/Rescue CD
  -> iso_compression: xz
  -> iso_checksum: md5
  -> use_overlayfs: true
  -> iso_fs: overlayfs
==> BUILD QUEUE:
 --> Profile: [strit-minimal]
  -> work_dir: /home/strit/Manjaro-Strit/manjaro-tools/lib/buildiso/strit-minimal/x86_64
  -> iso_dir: /home/strit/Manjaro-Strit/manjaro-tools/cache/iso/minimal/strit-minimal/16.04/x86_64
  -> iso_file: manjaro-strit-minimal-16.04-x86_64.iso
  -> displaymanager: lightdm
  -> autologin: true
  -> nonfree_xorg: false
  -> pxe_boot: true
  -> plymouth_boot: false
  -> multilib: true
  -> efi_boot_loader: grub
  -> efi_part_size: 31M
  -> hostname: manjaro-strit
  -> username: manjaro-strit
  -> password: manjaro
  -> addgroups: video,audio,power,disk,storage,optical,network,lp,scanner,wheel
  -> start_systemd: avahi-daemon bluetooth cronie ModemManager NetworkManager org.cups.cupsd tlp tlp-sleep
  -> start_systemd_live: manjaro-live mhwd-live pacman-init
  -> disable_systemd: pacman-init
  -> is_custom_pac_conf: true
strit@strit-Manjaro:~$
Desktop PC: Manjaro XFCE 15.12 (stable, kernel 4.4)
Private Laptop: Manjaro Strit 16.03 (unstable, kernel 4.6)
Work Laptop: Manjaro Strit 16.03 (stable, kernel 4.4)
Netbook: Arch Linux XFCE/LXqt (i686, kernel 4.0)

Offline Chrysostomus

  • Maintainer
  • ***
  • Posts: 1634
  • Neckbeards are cool
    • Git
  • Branch: unstable
  • Desktop: Gnome, bspwm
  • GPU Card: Intel HD4000
  • GPU driver: free
  • Kernel: linux44-x64
  • Skill: Intermediate
Re: ISO problem (virtualbox maybe?)
« Reply #2 on: 30. April 2016, 08:27:14 »
Sounds like a issue with drivers or startx. Could you give details about your profile? Issue might be there since xfce-minimal works.

Offline Chrysostomus

  • Maintainer
  • ***
  • Posts: 1634
  • Neckbeards are cool
    • Git
  • Branch: unstable
  • Desktop: Gnome, bspwm
  • GPU Card: Intel HD4000
  • GPU driver: free
  • Kernel: linux44-x64
  • Skill: Intermediate
Re: ISO problem (virtualbox maybe?)
« Reply #3 on: 30. April 2016, 08:35:31 »
Just a poke in the dark, but you could check if you have all the necessary files and packages for lightdm. You could also try enabling non-free xorg.

Offline Strit

  • Maintainer
  • ***
  • Posts: 746
  • Manjaro Torrent Maintainer
    • Strits.dk
  • Branch: Stable
  • Desktop: XFCE
  • GPU Card: GTX 760 OC
  • GPU driver: Non-free nvidia 361
  • Kernel: 4.4.8-1-MANJARO
  • Skill: Intermediate
Re: ISO problem (virtualbox maybe?)
« Reply #4 on: 30. April 2016, 09:16:34 »
I have the same packages for lightdm that xfce-minimal has and my profile looks like this:

Code: [Select]
##########################################
###### use this file in the profile ######
##########################################

# use multilib packages; x86_64 only
# multilib="true"

displaymanager="lightdm"

# Set to false to disable autologin in the livecd
# autologin="true"

# nonfree xorg drivers
 nonfree_xorg="false"

# use plymouth; initcpio hook
 plymouth_boot="false"

# use pxe boot; initcpio hook
pxe_boot="true"

################ install ################

# unset defaults to given value
# efi_boot_loader="grub"

# set uefi partition size
# efi_part_size=32M

# unset defaults to given value
# plymouth_theme=manjaro-elegant

# unset defaults to given values
# names must match systemd service names
start_systemd=('avahi-daemon' 'bluetooth' 'cronie' 'ModemManager' 'NetworkManager' 'org.cups.cupsd' 'tlp' 'tlp-sleep')
disable_systemd=('pacman-init')

# unset defaults to given values,
# names must match openrc service names
# start_openrc=('acpid' 'bluetooth' 'cgmanager' 'consolekit' 'cronie' 'cupsd' 'dbus' 'syslog-ng' 'NetworkManager')
# disable_openrc=('pacman-init')

################# livecd #################

# unset defaults to given value
 hostname="manjaro-strit"

# unset defaults to given value
 username="manjaro-strit"

# unset defaults to given value
# password="manjaro"

# unset defaults to given values
# addgroups="video,audio,power,disk,storage,optical,network,lp,scanner,wheel"

# unset defaults to given values
# names must match systemd service names
# services in start_systemd array don't need to be listed here
# start_systemd_live=('manjaro-live' 'mhwd-live' 'pacman-init')

# unset defaults to given values,
# names must match openrc service names
# services in start_openrc array don't need to be listed here
# start_openrc_live=('manjaro-live' 'mhwd-live' 'pacman-init')

I've tried with non-free drivers true, plymouth boot true, pxe boot false, with all compinations it seems. None of them work.

I'm probably just missing 1 little detail.
Desktop PC: Manjaro XFCE 15.12 (stable, kernel 4.4)
Private Laptop: Manjaro Strit 16.03 (unstable, kernel 4.6)
Work Laptop: Manjaro Strit 16.03 (stable, kernel 4.4)
Netbook: Arch Linux XFCE/LXqt (i686, kernel 4.0)

Offline Strit

  • Maintainer
  • ***
  • Posts: 746
  • Manjaro Torrent Maintainer
    • Strits.dk
  • Branch: Stable
  • Desktop: XFCE
  • GPU Card: GTX 760 OC
  • GPU driver: Non-free nvidia 361
  • Kernel: 4.4.8-1-MANJARO
  • Skill: Intermediate
Re: ISO problem (virtualbox maybe?)
« Reply #5 on: 30. April 2016, 13:09:35 »
Hm. Seems I need to have plymouth activated before the ISO will boot. In my previous test with plymouth activated I just forgot to include a plymouth theme.

This time I activated plymouth and added a plymouth theme and it just worked. Any idea why plymouth would be needed?
Desktop PC: Manjaro XFCE 15.12 (stable, kernel 4.4)
Private Laptop: Manjaro Strit 16.03 (unstable, kernel 4.6)
Work Laptop: Manjaro Strit 16.03 (stable, kernel 4.4)
Netbook: Arch Linux XFCE/LXqt (i686, kernel 4.0)

Offline Esclapion

  • Support Team
  • ****
  • Posts: 5523
    • manjaro
  • Branch: stable
  • Desktop: Lxqt
  • GPU Card: GTX 970
  • GPU driver: nonfree
  • Kernel: 4.4.6
  • Skill: Advanced
Re: ISO problem (virtualbox maybe?)
« Reply #6 on: 30. April 2016, 13:22:58 »
I think it's because of lightdm-plymouth.service (in /usr/lib/systemd/system).

Else, you have an option to change that in profile.conf.
Venez nous rejoindre sur l'IRC francophone
Patrice - Violence is the last refuge of the incompetent (Asimov)

Offline scachemaille

  • Held Mitglied
  • *****
  • Posts: 528
  • I'm new. Be nice!
  • Branch: Unstable
  • Desktop: Plasma 5
  • GPU Card: nVidia GT 330M
  • GPU driver: Nouveau
  • Kernel: 4.8_x64
  • Skill: Intermediate
Re: ISO problem (virtualbox maybe?)
« Reply #7 on: 30. April 2016, 13:23:12 »
I don't know..  But yesterday I tried to remove the splash screen from grub to start the 3rd preview of xfce in a vm and it also refuse too boot to the login screen.
I couldn't investigate much as the key to switch to tty are interpreted by the host. With the splash screen there is no problem.
And it's not the ISO.  But installed system
« Last Edit: 30. April 2016, 13:25:29 by scachemaille »

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: ISO problem (virtualbox maybe?)
« Reply #8 on: 30. April 2016, 13:32:30 »
I couldn't investigate much as the key to switch to tty are interpreted by the host.
I think it was <hostkey>+F1,2,3 that works to switch ttys!
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline scachemaille

  • Held Mitglied
  • *****
  • Posts: 528
  • I'm new. Be nice!
  • Branch: Unstable
  • Desktop: Plasma 5
  • GPU Card: nVidia GT 330M
  • GPU driver: Nouveau
  • Kernel: 4.8_x64
  • Skill: Intermediate
Re: ISO problem (virtualbox maybe?)
« Reply #9 on: 30. April 2016, 13:54:44 »
I think it was <hostkey>+F1,2,3 that works to switch ttys!
Ooh thanks..  Never tried..  Good too know..