Author Topic: Audacity install broken  (Read 1080 times)

0 Members and 1 Guest are viewing this topic.

Offline wvi

  • Neuling
  • *
  • Posts: 6
    • Github
  • Desktop: Fluxbox
  • Skill: Intermediate
Audacity install broken
« on: 27. April 2016, 12:09:34 »
I have installed audacity but it didn't start because it couldn't find libSoundTouch, Installing soundtouch package solved it. Where should I check if there are correct dependencies? The upstream arch PKGBUILD is correct so I wonder if this is really a manjaro only issue or glitch in my system.

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: Audacity install broken
« Reply #1 on: 27. April 2016, 12:51:48 »
Arch upstream is the package Manjaro uses.
Somehow it doesn't seem possible that you had installed audacity without soundtouch! ???
Code: [Select]
$ pacman -Si audacity
Repository      : extra
Name            : audacity
Version         : 2.1.2-2
Description     : A program that lets you manipulate digital audio
                  waveforms
Architecture    : x86_64
URL             : http://audacityteam.org
Licenses        : GPL
Groups          : None
Provides        : None
Depends On      : libmad  libid3tag  wxgtk  lame  lilv  soundtouch
                  ffmpeg  vamp-plugin-sdk  sbsms  portsmf
                  desktop-file-utils
Optional Deps   : None
Conflicts With  : None
Replaces        : None
Download Size   : 4.37 MiB
Installed Size  : 19.20 MiB
Packager        : Maxime Gauduin <alucryd@archlinux.org>
Build Date      : Sat 16 Apr 2016 19:03:44 CEST
Validated By    : MD5 Sum  SHA-256 Sum  Signature
So I guess the question is: How did you install it in the first place? ;) ;D
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline badbodh

  • Held Mitglied
  • *****
  • Posts: 923
  • Windows assumes I'm stupid, Linux proves it.
  • Branch: Testing
  • Desktop: Xfce, i3
  • GPU Card: Intel Mobile 4 Series
  • Kernel: linux41 64-bit
  • Skill: Intermediate
Re: Audacity install broken
« Reply #2 on: 27. April 2016, 12:59:01 »
purge both audacity and soundtouch with -Rs.
Then do pacman -Sy audacity and paste the output here.
You can't feel the love till it hurts a little. Go rolling, go bleeding-edge !

Offline wvi

  • Neuling
  • *
  • Posts: 6
    • Github
  • Desktop: Fluxbox
  • Skill: Intermediate
Re: Audacity install broken
« Reply #3 on: 27. April 2016, 15:01:12 »
So it was a glitch on my system. I don't know how this happened, soundtouch was already installed because of gstreamer bad plugins package. Anyway I am glad to hear that it was just my local problem. I just installed it the regular way, see below.

Code: [Select]
$ sudo pacman -Sy audacity                                                     
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
resolving dependencies...
looking for conflicting packages...

Packages (13) blas-3.6.0-4  cblas-3.6.0-4  lapack-3.6.0-4  lilv-0.22.0-2
              lv2-1.12.0-1  portsmf-228-2  python2-numpy-1.11.0-1  sbsms-2.0.2-2
              serd-0.22.0-1  sord-0.14.0-1  sratom-0.4.6-1  vamp-plugin-sdk-2.6-1
              audacity-2.1.2-2

Total Installed Size:  44.47 MiB

:: Proceed with installation? [Y/n]
(13/13) checking keys in keyring                   [#########################] 100%
(13/13) checking package integrity                 [#########################] 100%
(13/13) loading package files                      [#########################] 100%
(13/13) checking for file conflicts                [#########################] 100%
(13/13) checking available disk space              [#########################] 100%
:: Processing package changes...
( 1/13) installing blas                            [#########################] 100%
( 2/13) installing lapack                          [#########################] 100%
( 3/13) installing cblas                           [#########################] 100%
( 4/13) installing python2-numpy                   [#########################] 100%
Optional dependencies for python2-numpy
    python2-nose: testsuite
    atlas-lapack: for improved performance of some linear algebra operations
( 5/13) installing lv2                             [#########################] 100%
Optional dependencies for lv2
    libsndfile: Example sampler [installed]
    gtk2: Example sampler [installed]
    python2: Scripts [installed]
( 6/13) installing serd                            [#########################] 100%
( 7/13) installing sord                            [#########################] 100%
( 8/13) installing sratom                          [#########################] 100%
( 9/13) installing lilv                            [#########################] 100%
Optional dependencies for lilv
    bash-completion
(10/13) installing vamp-plugin-sdk                 [#########################] 100%
(11/13) installing sbsms                           [#########################] 100%
(12/13) installing portsmf                         [#########################] 100%
(13/13) installing audacity                        [#########################] 100%
:: Running post-transaction hooks...
(1/1) Descriptions