Author Topic: setting the touchpad in 3.20.1  (Read 975 times)

0 Members and 1 Guest are viewing this topic.

Offline stevelorenz

  • Neuling
  • *
  • Posts: 4
  • Übung macht Meister!
    • my cookbook
  • Branch: stable
  • Desktop: Gnome 3.18.2
  • GPU Card: Intel Corporation Haswell-ULT Integrated Graphics
  • GPU driver: free
  • Kernel: linux44-x64
  • Skill: Intermediate
setting the touchpad in 3.20.1
« on: 26. April 2016, 23:26:11 »
Hello  ;D

I upgrade Gnome to 3.20.1 right now. Everything is OK. But the setting for touch pad is not right. I want to use two finger tap as right click, but it means now middle button. And in the settings menu, there is only option for primary button, speed and natural scrolling. How can i set the two finger tapping? Thanks so much for the help

Offline Maphardam

  • Neuling
  • *
  • Posts: 9
  • Branch: stable
  • Desktop: Gnome 3.20
  • Kernel: 4.4
  • Skill: Novice
Re: setting the touchpad in 3.20.1
« Reply #1 on: 27. April 2016, 12:50:21 »
Hey steve,

I guess that you're using Synaptics for your touchpad configuration. Gnome does not longer support synaptics.

Have a look here

However, I'm not sure if full functionality (e.g. two-finger-tap) is already implemented and configurable. I'm having troubles as well.

Cheers
Maphardam
« Last Edit: 27. April 2016, 12:53:41 by Maphardam »

Offline stevelorenz

  • Neuling
  • *
  • Posts: 4
  • Übung macht Meister!
    • my cookbook
  • Branch: stable
  • Desktop: Gnome 3.18.2
  • GPU Card: Intel Corporation Haswell-ULT Integrated Graphics
  • GPU driver: free
  • Kernel: linux44-x64
  • Skill: Intermediate
Re: setting the touchpad in 3.20.1
« Reply #2 on: 27. April 2016, 23:44:51 »
Hallo Maphardam,

Thanks so much for the help. The problem is exactly the synaptics. I have tried to uninstall the package xf86-input-synaptics and install libinput and xf86-input-libinput. And now the "two-finger-tap" means right click. But there is still no setting option in the menu to choose the function of multi touch. However now it works, thank u again.  ;D

Offline c00ter

  • Held Mitglied
  • *****
  • Posts: 1534
  • Towelie's cupcake
  • Branch: ☮Olive☮
  • Desktop: Depends©
  • GPU Card: Intel HD4400M CPU: Core i7-4510U
  • GPU driver: Intel/Free
  • Kernel: 4.4-lts & 4.5
  • Skill: Novice
Re: setting the touchpad in 3.20.1
« Reply #3 on: 28. April 2016, 00:10:22 »
Hallo Maphardam,

Thanks so much for the help. The problem is exactly the synaptics. I have tried to uninstall the package xf86-input-synaptics and install libinput and xf86-input-libinput. And now the "two-finger-tap" means right click. But there is still no setting option in the menu to choose the function of multi touch. However now it works, thank u again.  ;D

Even with the touchpad improvements in 3.20, it still lacks the ability to turn on/off when a mouse is "inserted" which is a very handy feature, IMHO. A snail would win in a race against GNOME developers...
“What, me worry?” ― Alfred E. Newman

Manjaro Wiki: https://wiki.manjaro.org/
Arch Wiki: https://wiki.archlinux.org/
Pacman Rosetta: https://wiki.archlinux.org/index.php/Pacman/Rosetta

Offline stevelorenz

  • Neuling
  • *
  • Posts: 4
  • Übung macht Meister!
    • my cookbook
  • Branch: stable
  • Desktop: Gnome 3.18.2
  • GPU Card: Intel Corporation Haswell-ULT Integrated Graphics
  • GPU driver: free
  • Kernel: linux44-x64
  • Skill: Intermediate
Re: setting the touchpad in 3.20.1
« Reply #4 on: 28. April 2016, 21:36:10 »
Even with the touchpad improvements in 3.20, it still lacks the ability to turn on/off when a mouse is "inserted" which is a very handy feature, IMHO. A snail would win in a race against GNOME developers...

I can't agree with you more  ;)

Offline drilow

  • Neuling
  • *
  • Posts: 42
  • Branch: Stable
  • Desktop: Gnome
  • GPU Card: Intel HD Graphics 4000 / Nvidia GeForce 740M
  • GPU driver: non-free
  • Kernel: 4.1 (x86_64)
  • Skill: Novice
Re: setting the touchpad in 3.20.1
« Reply #5 on: 30. April 2016, 20:48:41 »
Next time I have trouble with an update, I will first look for the answer here..
However, I was able to find the same answer here:
https://forum.antergos.com/topic/4271/gnome-3-20-natural-scrolling-only-working-in-wayland/10
I agree with the comments on that forum that the feel isn't quite the same at all. The touchpad is far less precise at small speeds, and something like the Acceleration Factor and MinSpeed of the synaptics driver would be very appreciated.
I hope upstream improves the driver to catch up with synaptics standards, or that GNOME supports synaptics again.