Author Topic: How to fix steam not running on Unstable Repository  (Read 1218 times)

0 Members and 1 Guest are viewing this topic.

Offline devhost97

  • Neuling
  • *
  • Posts: 13
  • Branch: Unstable
  • Desktop: Deepin & MATE
  • GPU Card: Intel HD Graphics (IvyBridge)
  • Kernel: 4.6.1-RC6
  • Skill: Intermediate
How to fix steam not running on Unstable Repository
« on: 23. April 2016, 20:31:03 »
If you get error in terminal when launch steam (or you steam not running) something like this :
Code: [Select]
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(1459463254)
libGL error: unable to load driver: i965_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: i965
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast

To fix this bug you need to write in console this command:
Code: [Select]
find ~/.steam/root/ -name "libgpg-error.so*" -print -delete
They going to Steam root folder and delete steam's own lib (modules).
After this on Intel HD Graphics Steam run. Its working on Manjaro and all Archlinux based OS. I tested in on Archlinux too.
These modules need to be removed because the system thinks that it initiated the graphics drivers even though they are.
« Last Edit: 04. May 2016, 12:12:51 by devhost97 »

Offline jonathon

  • Core Team
  • *****
  • Posts: 2104
  • Technologist - Teacher - Tea drinker
  • Branch: Unstable
  • Desktop: MATE 1.14
  • GPU Card: Nvidia GTX680M
  • GPU driver: Bumblebee nvidia+intel
  • Kernel: 4.6.0-*-MANJARO x86_64
  • Skill: Advanced
Re: How to fix steam not running on Unstable Repository
« Reply #1 on: 23. April 2016, 20:58:40 »
(Please note: this post is purposefully concise and so lacks usual pleasantries)

This does not meet the basic requirements for a Tutorial.

The single command which "worked for me" doesn't appear to bear any relationship to the issue. You have not specified why this fixes your issue.

There is zero reason to run `find` as sudo and this suggests a general lack of understanding of how things work. It also suggests you yourself have found this command elsewhere and applied it without knowing what effect it will have.

This is a dangerous thing to post in a Tutorials section where people will simple copy and paste, then have no idea what has changed or whether it will help them.

Please feel free to improve your post to make it into a true Tutorial.
--
MSI GT70: Core i7-3630QM, 16GB, Nvidia GTX680M, Intel 2230, Manjaro-MATE-amd64-EFI
Lenovo X230: Core i5-3320M, 4GB, Intel HD4000, Intel 6205, Manjaro-MATE-amd64
Dell Studio 1749: Core i5 540, 8GB, ATi HD5650, Intel WLAN, Manjaro-Xfce-amd64
Let's go in the garden; you'll find something waiting.

Offline devhost97

  • Neuling
  • *
  • Posts: 13
  • Branch: Unstable
  • Desktop: Deepin & MATE
  • GPU Card: Intel HD Graphics (IvyBridge)
  • Kernel: 4.6.1-RC6
  • Skill: Intermediate
Re: How to fix steam not running on Unstable Repository
« Reply #2 on: 23. April 2016, 22:16:09 »
Quote
The single command which "worked for me" doesn't appear to bear any relationship to the issue. You have not specified why this fixes your issue.

I'm sorry - actually my fault. I edited my post.

Offline Trinakrian

  • Vollwertiges Mitglied
  • ***
  • Posts: 108
  • Skill: Intermediate
Re: How to fix steam not running on Unstable Repository
« Reply #3 on: 25. April 2016, 15:41:05 »
Going to try this when I get home. Steam has been giving me grief starting lately and workarounds are getting old.

Offline emigrant

  • Neuling
  • *
  • Posts: 1
  • I'm new. Be nice!
  • Branch: stable
  • Desktop: KDE
  • GPU Card: nVidia x Intel - Optimus
  • GPU driver: non-free
  • Kernel: linux38-x64
  • Skill: Novice
Re: How to fix steam not running on Unstable Repository
« Reply #4 on: 10. May 2016, 19:58:08 »
Thank you! This fixed my own problem.  ;)