Author Topic: locale in Gnome  (Read 822 times)

0 Members and 1 Guest are viewing this topic.

Offline faber

  • Neuling
  • *
  • Posts: 18
  • I'm new. Be nice!
  • Desktop: Gnome
  • GPU driver: video-intel
  • Kernel: linux4
  • Skill: Novice
locale in Gnome
« on: 20. April 2016, 16:51:32 »
Hey All,
I seem to have a problem with locale setting which seems to be particular to Gnome and I'm hoping you can point me the way to the solution.

Specifically, my MATLAB crashed with the the message

Code: [Select]
locale::facet::_S_create_c_locale name not valid
this also happens while running MATLAB with sudo. This problem does not occur in awesome, xfce4, and i3wm.
I've followed guides for setting locale to en_US.UTF-8 but after setting it and running 'locale' I'm still left with the previous settings. I'm not sure the locale output should look like this:

Code: [Select]
ocale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_US.utf8
LC_CTYPE=en_US.utf8
LC_NUMERIC=paris
LC_TIME=paris
LC_COLLATE=en_US.utf8
LC_MONETARY=paris
LC_MESSAGES=en_US.utf8
LC_PAPER=paris
LC_NAME=en_US.utf8
LC_ADDRESS=en_US.utf8
LC_TELEPHONE=en_US.utf8
LC_MEASUREMENT=paris
LC_IDENTIFICATION=en_US.utf8
LC_ALL=

any ideas if this is right?
 
BTW, I'm not sure it is related but when running kde based application like kate from the terminal, I'm getting this warning message
Code: [Select]
Gtk-WARNING **: Locale not supported by C library.
Using the fallback 'C' locale.

Any diagnosis will be appreciated.
many thanks



Offline badbodh

  • Held Mitglied
  • *****
  • Posts: 923
  • Windows assumes I'm stupid, Linux proves it.
  • Branch: Testing
  • Desktop: Xfce, i3
  • GPU Card: Intel Mobile 4 Series
  • Kernel: linux41 64-bit
  • Skill: Intermediate
Re: locale in Gnome
« Reply #1 on: 20. April 2016, 17:56:23 »
always use manjaro-settings-manager to manage locales. Don;t use gnome's inbuilt language settings.
You can't feel the love till it hurts a little. Go rolling, go bleeding-edge !

Offline faber

  • Neuling
  • *
  • Posts: 18
  • I'm new. Be nice!
  • Desktop: Gnome
  • GPU driver: video-intel
  • Kernel: linux4
  • Skill: Novice
Re: locale in Gnome
« Reply #2 on: 20. April 2016, 18:48:04 »
Hey badbodh, thanks
using the manjaro-system-setting doesn't seem to resolve the issue. All fields of the detailed settings under Language seem to match the input language I chose but the output from locale remains different. This behavior is not seen in other DE so my guess is that settings get overridden somehow specifically in Gnome, but I'm clueless as to how.

As a comparison, when I'm logged in to a xfce session the output of locale is
Code: [Select]
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

which doesn't have the "paris" entries as with the Gnome output (in the first post).

thanks,




Offline faber

  • Neuling
  • *
  • Posts: 18
  • I'm new. Be nice!
  • Desktop: Gnome
  • GPU driver: video-intel
  • Kernel: linux4
  • Skill: Novice
Re: locale in Gnome
« Reply #3 on: 20. April 2016, 19:32:14 »
For those interested, to avoid MATLAB from crashing due to locale issues on Gnome, I've made a  (simply bad) workaround  by manually setting the environmental variables prior to any call to matlab, so essentially I'm running it using an sh file which I link and place on my desktop

Code: [Select]
LANG=en_US.UTF-8
LC_CTYPE=en_US.UTF-8
LC_NUMERIC=en_US.UTF-8
LC_TIME=en_US.UTF-8
LC_COLLATE=en_US.UTF-8
LC_MONETARY=en_US.UTF-8
LC_MESSAGES=en_US.UTF-8
LC_PAPER=en_US.UTF-8
LC_NAME=en_US.UTF-8
LC_ADDRESS=en_US.UTF-8
LC_TELEPHONE=en_US.UTF-8
LC_MEASUREMENT=en_US.UTF-8
LC_IDENTIFICATION=en_US.UTF-8

[path to matlab]/MATLAB2015/bin/matlab