Author Topic: Boot only in fallback mode  (Read 2418 times)

0 Members and 1 Guest are viewing this topic.

Offline dancaer69

  • Neuling
  • *
  • Posts: 36
  • I'm new. Be nice!
  • Skill: Intermediate
Boot only in fallback mode
« on: 16. April 2016, 11:08:55 »
Hello,
I updated cpu/mainboard/ram and now I cannot boot to manjaro in normal mode, I can only boot in fallback mode.
When I'm trying to boot in normal mode I get an error about cannot find device with UUID="63e8acbe-78c2-412b-a908-4a724dd5adae", drops me to a root shell and stack there(I cannot input any command). In fallback mode the system boots though.
Here is the blkid output:
Code: [Select]
/dev/sdb1: LABEL="windows" UUID="0127FC4141477878" TYPE="ntfs" PARTUUID="6b3bb6d9-01"
/dev/sdb3: LABEL="ChaletOs" UUID="ea6932a5-4423-4cac-8510-8e661f329c31" TYPE="ext4" PARTUUID="6b3bb6d9-03"
/dev/sdb4: LABEL="ubuntu" UUID="79f46549-b0ae-49b0-a038-0c120d24b42e" TYPE="ext4" PARTUUID="6b3bb6d9-04"
/dev/sdb5: LABEL="Series" UUID="3E783C41783BF66D" TYPE="ntfs" PARTUUID="6b3bb6d9-05"
/dev/sdb6: LABEL="Data" UUID="323CC4623CC422A9" TYPE="ntfs" PARTUUID="6b3bb6d9-06"
/dev/sdb7: LABEL="Manjaro" UUID="63e8acbe-78c2-412b-a908-4a724dd5adae" TYPE="ext4" PARTUUID="6b3bb6d9-07"
/dev/sdb8: LABEL="archbang" UUID="03223ead-36f6-48ac-b554-86f3530e837a" TYPE="ext4" PARTUUID="6b3bb6d9-08"
/dev/sdc2: LABEL="Downloads" UUID="430619557237FCFD" TYPE="ntfs" PARTUUID="aa6c801f-02"
/dev/sdc3: UUID="ea12c6f5-3a40-4aad-9b11-f0e9a258df94" TYPE="swap" PARTUUID="aa6c801f-03"
/dev/sdc5: UUID="1eab239f-a9ca-41f9-b334-fdfd375f5ee5" TYPE="ext4" PARTUUID="aa6c801f-05"
/dev/sda1: LABEL="datadisk" UUID="D47604D77604BC6C" TYPE="ntfs" PARTUUID="c5dc5197-01"
/dev/sr0: UUID="2016-03-19-21-33-19-00" LABEL=" 15.10 kfreebsd-amd64" TYPE="iso9660"
What can I do to fix this?

P.S:
What problem have the arch forum mods with Manjaro???
I'm using both distros and I, by mistake, created this thread in arch forum.
You know what the did? The banned me without any warning with the message:
"Manjaro is not arch"

Offline gohlip

  • Held Mitglied
  • *****
  • Posts: 1689
  • Desktop: OpenBox
  • GPU Card: nvidia
  • GPU driver: nonfree
  • Kernel: linux46 - x64
  • Skill: Intermediate
Re: Boot only in fallback mode
« Reply #1 on: 16. April 2016, 14:58:55 »
Provide the following.....
o cat /etc/fstab
o cat /etc/default/grub | grep GRUB_CMDLINE
o sudo blkid (provided in first post)
o First entry of /boot/grub/grub.cfg, just like this, the rest not necessary

Code: [Select]
menuentry 'Manjaro Linux' --class manjaro --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-5a4d7104-bf96-4bb7-9f38-d7f407a631fb' {
        savedefault
        load_video
        set gfxpayload=keep
        insmod gzio
        insmod part_msdos
        insmod ext2
        set root='hd0,msdos8'
        if [ x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos8 --hint-efi=hd0,msdos8 --hint-baremetal=ahci0,msdos8  5a4d7104-bf96-4bb7-9f38-d7f407a631fb
        else
          search --no-floppy --fs-uuid --set=root 5a4d7104-bf96-4bb7-9f38-d7f407a631fb
        fi
        echo    'Loading Linux manjaro ...'
        linux   /boot/vmlinuz-manjaro root=UUID=5a4d7104-bf96-4bb7-9f38-d7f407a631fb rw  quiet splash
        echo    'Loading initial ramdisk ...'
        initrd  /boot/intel-ucode.img /boot/initramfs-manjaro.img
}

Life is a sexually transmitted disease with a 100% mortality rate.

Offline dancaer69

  • Neuling
  • *
  • Posts: 36
  • I'm new. Be nice!
  • Skill: Intermediate
Re: Boot only in fallback mode
« Reply #2 on: 16. April 2016, 15:18:18 »
fstab:
Code: [Select]
# /etc/fstab: static file system information
#
# <file system> <dir> <type> <options> <dump> <pass>
# DEVICE DETAILS: /dev/sdc3 UUID=ea12c6f5-3a40-4aad-9b11-f0e9a258df94 LABEL=
# DEVICE DETAILS: /dev/sdc5 UUID=1eab239f-a9ca-41f9-b334-fdfd375f5ee5 LABEL=
# DEVICE DETAILS: /dev/sdb7 UUID=63e8acbe-78c2-412b-a908-4a724dd5adae LABEL=Manjaro
UUID=1eab239f-a9ca-41f9-b334-fdfd375f5ee5 /home x-systemd.automount,ext4 defaults 0 1
UUID=63e8acbe-78c2-412b-a908-4a724dd5adae / ext4 defaults 0 1
UUID=ea12c6f5-3a40-4aad-9b11-f0e9a258df94 swap swap defaults 0 0


#disk Series
UUID=3E783C41783BF66D /media/series ntfs-3g uid=1000,gid=1000,dmask=000,fmask=000,x-systemd.automount 00
#disk Datadisk
UUID=D47604D77604BC6C /media/Datadisk ntfs-3g uid=1000,gid=1000,dmask=000,fmask=000,x-systemd.automount 00
#disk Data
UUID=323CC4623CC422A9 /media/Data ntfs-3g uid=1000,gid=1000,dmask=000,fmask=000,x-systemd.automount 00
#disk Downloads
UUID=430619557237FCFD /media/Downloads ntfs-3g uid=1000,gid=1000,dmask=000,fmask=000,x-systemd.automount 0 0

grub cmdline:
Code: [Select]
GRUB_CMDLINE_LINUX_DEFAULT="rdblacklist=nouveau nouveau.modeset=0 rootflags=rw resume=UUID=ea12c6f5-3a40-4aad-9b11-f0e9a258df94"
GRUB_CMDLINE_LINUX=""

grub.cfg entry:
Code: [Select]
### BEGIN /etc/grub.d/10_linux ###
menuentry 'Manjaro Linux' --class manjaro --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-63e8acbe-78c2-412b-a908-4a724dd5adae' {
savedefault
load_video
set gfxpayload=keep
insmod gzio
insmod part_msdos
insmod ext2
set root='hd1,msdos7'
if [ x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root --hint-bios=hd1,msdos7 --hint-efi=hd1,msdos7 --hint-baremetal=ahci1,msdos7  63e8acbe-78c2-412b-a908-4a724dd5adae
else
  search --no-floppy --fs-uuid --set=root 63e8acbe-78c2-412b-a908-4a724dd5adae
fi
echo 'Loading Linux 4.4.6-1-MANJARO x64 ...'
linux /boot/vmlinuz-4.4-x86_64 root=UUID=63e8acbe-78c2-412b-a908-4a724dd5adae rw  rdblacklist=nouveau nouveau.modeset=0 rootflags=rw resume=UUID=ea12c6f5-3a40-4aad-9b11-f0e9a258df94
echo 'Loading initial ramdisk ...'
initrd /boot/intel-ucode.img /boot/initramfs-4.4-x86_64.img
}

Offline gohlip

  • Held Mitglied
  • *****
  • Posts: 1689
  • Desktop: OpenBox
  • GPU Card: nvidia
  • GPU driver: nonfree
  • Kernel: linux46 - x64
  • Skill: Intermediate
Re: Boot only in fallback mode
« Reply #3 on: 16. April 2016, 16:12:14 »
The output actually looks alright.
But can you try to boot by changing manually the linux line when grub menu  comes out?
When grub menu appears at the first entry, press 'e', then arrow down to the linux line and arrow right, backspace to remove as follows, change
Code: [Select]
linux /boot/vmlinuz-4.4-x86_64 root=UUID=63e8acbe-78c2-412b-a908-4a724dd5adae rw  rdblacklist=nouveau nouveau.modeset=0 rootflags=rw resume=UUID=ea12c6f5-3a40-4aad-9b11-f0e9a258df94 to just
Code: [Select]
linux /boot/vmlinuz-4.4-x86_64 root=UUID=63e8acbe-78c2-412b-a908-4a724dd5adae rw 
The rest of the other lines remain untouched.
'F10' (or 'ctrl' + 'x') to boot.

Life is a sexually transmitted disease with a 100% mortality rate.

Offline dancaer69

  • Neuling
  • *
  • Posts: 36
  • I'm new. Be nice!
  • Skill: Intermediate
Re: Boot only in fallback mode
« Reply #4 on: 16. April 2016, 16:37:14 »
No difference. I also change it to root=/dev/sdb7 which is the partition of manjaro.

Offline gohlip

  • Held Mitglied
  • *****
  • Posts: 1689
  • Desktop: OpenBox
  • GPU Card: nvidia
  • GPU driver: nonfree
  • Kernel: linux46 - x64
  • Skill: Intermediate
Re: Boot only in fallback mode
« Reply #5 on: 16. April 2016, 17:31:37 »
Ok. but recommend you use back uuid instead of sdb7.
Now, not sure if this will work but can you comment out all the ntfs partitions in /etc/fstab [1] and try to reboot, keeping the linux line in the simple format I recommend (without all that rdblacklist...etc).



[1] - you may have to do this through a livecd.
Life is a sexually transmitted disease with a 100% mortality rate.

Offline dancaer69

  • Neuling
  • *
  • Posts: 36
  • I'm new. Be nice!
  • Skill: Intermediate
Re: Boot only in fallback mode
« Reply #6 on: 16. April 2016, 17:58:50 »
Again nothing changed. The exact messages are:
Code: [Select]
running hook (udev)....
Triggering uevents...
running hook (keymap)
loading keymap....done
Waiting 10 seconds for device /dev/disk/by-uuid/63e8acbe-78c2-412b-a908-4a724dd5adae ...
ERROR: device 'UUID=63e8acbe-78c2-412b-a908-4a724dd5adae' not found. Skipping fsck.
ERROR: Unable to find root device 'UUID=63e8acbe-78c2-412b-a908-4a724dd5adae'
You are been dropped to a recovery shell
Type exit to try and continue booting
sh: can't access tty: job control turned off
[rootfs ]# _
and it freezes there.

Offline gohlip

  • Held Mitglied
  • *****
  • Posts: 1689
  • Desktop: OpenBox
  • GPU Card: nvidia
  • GPU driver: nonfree
  • Kernel: linux46 - x64
  • Skill: Intermediate
Re: Boot only in fallback mode
« Reply #7 on: 16. April 2016, 18:04:03 »
Okay, understand.
I need to logoff soon (but not now). Will be offline for at least 6 hours. If somebody else want to jump in, please do.

Now just checking just to be sure.
o you said you changed cpu, mainboard and ram
   you did not change graphic cards did you? nor architecture?  :)
o I assume packages are up to date. pacman -syyu ?

I now suggest a "slegehammer approach"
Boot using fallback
Code: [Select]
sudo pacman-mirrors -g
sudo pacman -Syy
sudo pacman -Suu
sudo mhwd -a pci nonfree 0300
sudo mkinitcpio -P
sudo grub-install /dev/sda
sudo update-grub

Good luck. Hope you don't have to reinstall.
Life is a sexually transmitted disease with a 100% mortality rate.

Offline dancaer69

  • Neuling
  • *
  • Posts: 36
  • I'm new. Be nice!
  • Skill: Intermediate
Re: Boot only in fallback mode
« Reply #8 on: 16. April 2016, 18:20:57 »
When I was waiting for your answer I searched a bit in google and I found this:
http://superuser.com/questions/769047/unable-to-find-root-device-on-a-fresh-archlinux-install
As suggested there I put the "block" before "autodetect in hooks, and I ran sudo mkinitcpio -p linux which failed. After I show your post and I did all that you sugested except the grub-install command, I skipped it and I ran the update-grub only.
Show I don't know if was your advice or both yours and that I found on superuser.com but it worked and I've managed to boot to Manjaro without problems.
Thanks a lot.

Offline gohlip

  • Held Mitglied
  • *****
  • Posts: 1689
  • Desktop: OpenBox
  • GPU Card: nvidia
  • GPU driver: nonfree
  • Kernel: linux46 - x64
  • Skill: Intermediate
Re: Boot only in fallback mode
« Reply #9 on: 16. April 2016, 18:38:37 »
Hey, great find.
Good to know you've fixed it (but wonder why is 'block' in wrong order anyway).

Cheers, take care.
Life is a sexually transmitted disease with a 100% mortality rate.