Author Topic: gdm failed to start if I removed plymouth  (Read 790 times)

0 Members and 1 Guest are viewing this topic.

Offline csj

  • Neuling
  • *
  • Posts: 7
  • I'm new. Be nice!
  • Skill: Novice
gdm failed to start if I removed plymouth
« on: 12. April 2016, 19:58:26 »
I removed plymouth and also that in `/etc/mkinitcpio.conf`.
rebuild initial ramdisk and reboot.
Then. gdm failed to start and I got tty1 login prompt.

I tried to debug, modified `/etc/gdm/custom.conf`, change [debug] section's Enabled to "true"
However, there is nothing in `/var/log/gdm/`

How to make gdm work without plymouth?  :-\
Thanks.

Offline badbodh

  • Held Mitglied
  • *****
  • Posts: 923
  • Windows assumes I'm stupid, Linux proves it.
  • Branch: Testing
  • Desktop: Xfce, i3
  • GPU Card: Intel Mobile 4 Series
  • Kernel: linux41 64-bit
  • Skill: Intermediate
Re: gdm failed to start if I removed plymouth
« Reply #1 on: 12. April 2016, 20:08:33 »
try
Code: [Select]
sudo systemctl disable gdm-plymouth
sudo systemctl enable gdm
You can't feel the love till it hurts a little. Go rolling, go bleeding-edge !

Offline csj

  • Neuling
  • *
  • Posts: 7
  • I'm new. Be nice!
  • Skill: Novice
Re: gdm failed to start if I removed plymouth
« Reply #2 on: 13. April 2016, 22:24:53 »
Cool, it solved my problem. and I see the content of /usr/lib/systemd/system/gdm.service
changed a lot aobut plymouth service.

Thanks a lot  ;D