Author Topic: conky-lua 1.10  (Read 2615 times)

0 Members and 1 Guest are viewing this topic.

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
conky-lua 1.10
« on: 17. March 2016, 12:03:14 »
conky-lua has been outdated for quite a while and is still using conky 1.9 including the old syntax for the config.
This was getting more and more a problem, especially because  conky-lua and the regular conky 1.10 conflict and you cannot have both installed.
I now found conky-lua-nv which is at version 1.10.1 and 'provides' conky, meaning: When you have installed conky-lua-nv you can run any (new syntax) conkyrc files.
If you would still like to hold on to your old config syntax conkyrc, in many cases it will be read correctly. Or you will just have to stick to conky-lua which is still available from the AUR.
conky-lua-nv is in our unstable repo already and will arrive in the other repos with the next update.
The -"nv" btw stands for nvidia-support! ;) 8)

I have updated lua-clock-manjaro and lua-clock-i3 with the new syntax now and have them depend on conky-lua-nv, and I have added a third 'solarized' version for both of them, too :)
« Last Edit: 17. March 2016, 12:07:06 by oberon »
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline eugen-b

  • Support Team
  • ****
  • Posts: 3191
  • Branch: testing
  • Desktop: LXDE, Fluxbox, JWM, LXQt, bspwm
  • GPU Card: Intel 82945G/GZ
  • GPU driver: free
  • Kernel: 4.5, 4.6
  • Skill: Intermediate
Re: conky-lua 1.10
« Reply #1 on: 17. March 2016, 12:08:27 »
If s.o. tested it, I would like to know if it uses more RAM than the regular conky.
MSI Wind Nettop, Intel Atom 230 1.6GHz (64bit), 2GB RAM
DEs: NET-minimal + (LXDE / Fluxbox / JWM); LXQt OpenRC
how to install on btrfs subvolumes
http://manjaro.github.io/donate/

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: conky-lua 1.10
« Reply #2 on: 17. March 2016, 12:32:14 »
You mean with the same config? It's identical.
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline nadal80

  • Neuling
  • *
  • Posts: 9
  • I'm new. Be nice!
  • Skill: Novice
Re: conky-lua 1.10
« Reply #3 on: 17. March 2016, 20:49:20 »
Great Oberon  ;)
I will be glad to try the new package, but I can't install it because pamac complain that manjaro-i3-setting require conky-i3 and conky-i3 conflicts with any other conky package...

Offline Strit

  • Maintainer
  • ***
  • Posts: 746
  • Manjaro Torrent Maintainer
    • Strits.dk
  • Branch: Stable
  • Desktop: XFCE
  • GPU Card: GTX 760 OC
  • GPU driver: Non-free nvidia 361
  • Kernel: 4.4.8-1-MANJARO
  • Skill: Intermediate
Re: conky-lua 1.10
« Reply #4 on: 21. March 2016, 11:10:30 »
Great Oberon  ;)
I will be glad to try the new package, but I can't install it because pamac complain that manjaro-i3-setting require conky-i3 and conky-i3 conflicts with any other conky package...

Ofcourse it does, as it's providing conky. So you should remove the other conky package(s) and the install conky-i3.
Desktop PC: Manjaro XFCE 15.12 (stable, kernel 4.4)
Private Laptop: Manjaro Strit 16.03 (unstable, kernel 4.6)
Work Laptop: Manjaro Strit 16.03 (stable, kernel 4.4)
Netbook: Arch Linux XFCE/LXqt (i686, kernel 4.0)

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: conky-lua 1.10
« Reply #5 on: 21. March 2016, 12:22:46 »
You need today's stable update first! Then install conky-lua-nv and you'll have a conky 1.10 provided :)
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline nadal80

  • Neuling
  • *
  • Posts: 9
  • I'm new. Be nice!
  • Skill: Novice
Re: conky-lua 1.10
« Reply #6 on: 23. March 2016, 10:28:19 »
Thank you Oberon, it works properly for me.  ;)
Now I have both the fluxbox and the i3 desktop and I can switch between using lightdm.
Unfortunately I have to rewrite my conky script since with 1.10 old configuration isn't fully supported  :-\
I just found the topic from you in the forum  O:-)

Offline flipper

  • Sr. Mitglied
  • ****
  • Posts: 486
  • spic-and-span
  • Branch: testing
  • Desktop: Netrunner KDE 4 -> 5
  • GPU Card: nVidia GT555M/ HD3000
  • GPU driver: non-free bumblebee
  • Kernel: x64 4.5 Manjaro
  • Skill: Novice
Re: conky-lua 1.10
« Reply #7 on: 23. March 2016, 19:27:45 »
Thanks Oberon, this package solved an old issue I had with the rss feed since plasma5
https://forum.manjaro.org/index.php?topic=23044.msg202814

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: conky-lua 1.10
« Reply #8 on: 23. March 2016, 20:15:47 »
Nice side-effect! ;D
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline lightbeam

  • Sr. Mitglied
  • ****
  • Posts: 286
  • Branch: Stable as in: "Whoa, Nelly!"
  • Desktop: Wide Openbox
  • GPU Card: AMD Radeon Xpress 200 Series - Methuselah Edition
  • GPU driver: Free as in Lunch
  • Kernel: Linux44, i686
  • Skill: Intermediate
Re: conky-lua 1.10
« Reply #9 on: 10. May 2016, 07:37:45 »
Glad this was here.  Solved my problem with the latest stable [Update] 2016-05-08.

Thanks, Oberon!  :)
---------------------------------------------------
I make you look good. 8)

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: conky-lua 1.10
« Reply #10 on: 10. May 2016, 09:39:37 »
 ^-^
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline lightbeam

  • Sr. Mitglied
  • ****
  • Posts: 286
  • Branch: Stable as in: "Whoa, Nelly!"
  • Desktop: Wide Openbox
  • GPU Card: AMD Radeon Xpress 200 Series - Methuselah Edition
  • GPU driver: Free as in Lunch
  • Kernel: Linux44, i686
  • Skill: Intermediate
Re: conky-lua 1.10
« Reply #11 on: 07. June 2016, 00:54:30 »
^-^

Too bad.  That was short-lived, conky no longer works for me after the latest stable release.  Conky-lua-nv was updated to 1.10.2-1 with the latest stable release.  Have a solution?  Thanks!
« Last Edit: 07. June 2016, 00:57:42 by lightbeam »
---------------------------------------------------
I make you look good. 8)

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: conky-lua 1.10
« Reply #12 on: 08. June 2016, 02:25:03 »
What exactly is not working for you, lightbeam?
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline Holmes

  • Mirror Support Team
  • ***
  • Posts: 2039
  • Brazilian and Hispanic Support Team
    • Manjaro Brasil
  • Branch: Stable
  • Desktop: Manjaro XFCE
  • GPU Card: Mobile Intel (R) 945
  • GPU driver: Non-free
  • Kernel: kernellinux
  • Skill: Novice
Re: conky-lua 1.10
« Reply #13 on: 09. June 2016, 06:15:01 »
also i'm in trouble.
it does not appear!



vlw fwi, Holmes :)


==> Manjaro Brasil I Manjaro Hispano
==> IRC Manjaro Brasil: #manjaro-br I IRC Manjaro Hispano: #manjaro-es

Offline lightbeam

  • Sr. Mitglied
  • ****
  • Posts: 286
  • Branch: Stable as in: "Whoa, Nelly!"
  • Desktop: Wide Openbox
  • GPU Card: AMD Radeon Xpress 200 Series - Methuselah Edition
  • GPU driver: Free as in Lunch
  • Kernel: Linux44, i686
  • Skill: Intermediate
Re: conky-lua 1.10
« Reply #14 on: 13. June 2016, 14:31:19 »
What exactly is not working for you, lightbeam?

Exactly, version 1.10.2-1 of Conky or Conky-lua-nv doesn't work on my machine.  It appears to be an issue that limited to single-core CPU machines.  But it's explained over at the new forum.  Thanks, Oberon!
---------------------------------------------------
I make you look good. 8)