Author Topic: [stable] Manjaro Lxqt 16.03 released !  (Read 10787 times)

0 Members and 1 Guest are viewing this topic.

Offline mikronimo

  • Neuling
  • *
  • Posts: 28
  • Branch: stable
  • Desktop: KDE Plasma 5.5.5
  • GPU Card: intel HD 4600 (integrated with Intel i3 4330 3.5 GHz Haswell)
  • GPU driver: open
  • Kernel: 4.1.19-1-MANJARO
  • Skill: Novice
Re: [stable] Manjaro Lxqt 16.03 released !
« Reply #30 on: 12. March 2016, 16:30:26 »
Is it possible to add lxqt to a Plasma install (5.5.5, with qt 5.5.1), due they are both based on qt? Is there a sort of wiki to do it?

Offline excalibur1234

  • Global Moderator
  • *****
  • Posts: 2508
  • Branch: unstable
  • Desktop: net-minimal + LXQt
  • GPU driver: video-nouveau
  • Kernel: 4.6
  • Skill: Intermediate
Re: [stable] Manjaro Lxqt 16.03 released !
« Reply #31 on: 12. March 2016, 17:10:13 »
this sounds interesting, indeed.

i have to remove gvfs and see. somehow, i always installed gvfs out of habit.
at the moment i have gvfs, gvfs-afc, and gvfs-smb installed.
i have to test, whether i can connect to a network share without gvfs-smb.
Need more information? Search here:   Manjaro Forum   |   Manjaro Wiki   |   Arch Wiki

Offline Esclapion

  • Support Team
  • ****
  • Posts: 5523
    • manjaro
  • Branch: stable
  • Desktop: Lxqt
  • GPU Card: GTX 970
  • GPU driver: nonfree
  • Kernel: 4.4.6
  • Skill: Advanced
Re: [stable] Manjaro Lxqt 16.03 released !
« Reply #32 on: 12. March 2016, 17:31:13 »
For me, install a heavy plasma on the light lxqt is to avoid. Why not use directly kde instead ?

So, it's possible, but...
Venez nous rejoindre sur l'IRC francophone
Patrice - Violence is the last refuge of the incompetent (Asimov)

Offline mikronimo

  • Neuling
  • *
  • Posts: 28
  • Branch: stable
  • Desktop: KDE Plasma 5.5.5
  • GPU Card: intel HD 4600 (integrated with Intel i3 4330 3.5 GHz Haswell)
  • GPU driver: open
  • Kernel: 4.1.19-1-MANJARO
  • Skill: Novice
Re: [stable] Manjaro Lxqt 16.03 released !
« Reply #33 on: 12. March 2016, 17:40:20 »
For me, install a heavy plasma on the light lxqt is to avoid. Why not use directly kde instead ?

So, it's possible, but...
I already run a plasma install on a intel i3 64 bit (as you can see under my avatar), and it works fine, so i would install lxqt alongside the plasma, ligth on heavy... change anything?

Offline excalibur1234

  • Global Moderator
  • *****
  • Posts: 2508
  • Branch: unstable
  • Desktop: net-minimal + LXQt
  • GPU driver: video-nouveau
  • Kernel: 4.6
  • Skill: Intermediate
Re: [stable] Manjaro Lxqt 16.03 released !
« Reply #34 on: 12. March 2016, 17:51:24 »
here are wiki links how to install lxqt:
https://wiki.manjaro.org/index.php?title=Install_Desktop_Environments#LXQt
https://wiki.manjaro.org/index.php?title=Minimal_LXQt_installation
i think this is enough for you. just test it!

i have tested lxqt with kwin (plasma's window manager) before. look here how to do it:
https://wiki.manjaro.org/index.php?title=LXQt_with_kwin
it works, but i still encountered the typical kde bugs (which i just hate). so, for the time being i am using lxqt with openbox, but i definitely would like to use lxqt with kwin in the long term.
« Last Edit: 12. March 2016, 17:56:56 by excalibur1234 »
Need more information? Search here:   Manjaro Forum   |   Manjaro Wiki   |   Arch Wiki

Offline mikronimo

  • Neuling
  • *
  • Posts: 28
  • Branch: stable
  • Desktop: KDE Plasma 5.5.5
  • GPU Card: intel HD 4600 (integrated with Intel i3 4330 3.5 GHz Haswell)
  • GPU driver: open
  • Kernel: 4.1.19-1-MANJARO
  • Skill: Novice
Re: [stable] Manjaro Lxqt 16.03 released !
« Reply #35 on: 12. March 2016, 17:57:33 »
here is are wiki links how to install lxqt:
https://wiki.manjaro.org/index.php?title=Install_Desktop_Environments#LXQt
https://wiki.manjaro.org/index.php?title=Minimal_LXQt_installation
i think this is enough for you. just test it!

i have tested lxqt with kwin (plasma's window manager) before. look here how to do it:
https://wiki.manjaro.org/index.php?title=LXQt_with_kwin
it works, but i still encountered the typical kde bugs (which i just hate). so, for the time being i am using lxqt with openbox, but i definitely would like to use lxqt with kwin in the long term.
Thanks a lot, in the next days i'll try out... about which kind of kde bugs are you talking about?

Offline AJSlye

  • Maintainer
  • ***
  • Posts: 4298
  • Netrunner Rolling Edition moderator / maintainer
  • Branch: Stable / Testing / Unstable
  • Desktop: Netrunner Rolling
  • GPU Card: Intel
  • GPU driver: Intel
  • Kernel: 4.4.1-1-MANJARO x86_64 (64 bit)
  • Skill: Guru
Re: [stable] Manjaro Lxqt 16.03 released !
« Reply #36 on: 12. March 2016, 18:11:41 »
@ Esclapion,

Here is the pcmanfm-qt dependency tree:

Pcmanfm-qt --> liblxqt libfm lxmenu-data
   libxqt --> kwindowsystem libqtxdg
      kwindowsystem --> qt5-x11extras libxfixes
          qt5-x11extras --> qt5-base
          libxfixes --> libx11 fixesproto>=5.0 (goes further but no more kde deps)
       libqtxdg --> libsm libxkbcommon-x11 qt5-base
   libfm --> dbus-glib libexif libfm-extra=1.2.4 menu-cache shared-mime-info
       dbus-glib --> dbus glib2 (goes further but no kde deps)
       libexif --> glibc
       menu-cache --> libfm-extra (redundant dep)
       shared-mime-info --> libxml2 glib2 (goes further but no kde deps)
   lxmenu-data --> (no more deps)
« Last Edit: 12. March 2016, 18:26:31 by AJSlye »

Offline excalibur1234

  • Global Moderator
  • *****
  • Posts: 2508
  • Branch: unstable
  • Desktop: net-minimal + LXQt
  • GPU driver: video-nouveau
  • Kernel: 4.6
  • Skill: Intermediate
Re: [stable] Manjaro Lxqt 16.03 released !
« Reply #37 on: 12. March 2016, 18:21:14 »
here is my dependency tree of pcmanfm-qt (built today from the aur):
Code: [Select]
~ » pactree pcmanfm-qt-git
pcmanfm-qt-git
├─liblxqt-git
│ ├─qt5-base
│ │ ├─libjpeg-turbo
│ │ ├─xcb-util-keysyms
│ │ │ └─libxcb
│ │ │   ├─xcb-proto
│ │ │   ├─libxdmcp
│ │ │   │ ├─xproto
│ │ │   │ └─glibc
│ │ │   │   ├─linux-api-headers
│ │ │   │   ├─tzdata
│ │ │   │   └─filesystem
│ │ │   │     └─iana-etc
│ │ │   └─libxau
│ │ │     ├─glibc
│ │ │     └─xproto
│ │ ├─mhwd provides libgl
│ │ │ ├─hwinfo
│ │ │ │ ├─libx86emu
│ │ │ │ │ └─glibc
│ │ │ │ ├─bash
│ │ │ │ │ ├─readline
│ │ │ │ │ │ ├─glibc
│ │ │ │ │ │ ├─ncurses
│ │ │ │ │ │ │ ├─glibc
│ │ │ │ │ │ │ └─gcc-libs
│ │ │ │ │ │ │   └─glibc
│ │ │ │ │ │ └─ncurses provides libncursesw.so
│ │ │ │ │ ├─glibc
│ │ │ │ │ ├─ncurses
│ │ │ │ │ └─ncurses provides libncursesw.so
│ │ │ │ └─perl
│ │ │ │   ├─gdbm
│ │ │ │   │ ├─glibc
│ │ │ │   │ └─bash provides sh
│ │ │ │   ├─db
│ │ │ │   │ ├─gcc-libs
│ │ │ │   │ └─bash provides sh
│ │ │ │   └─glibc
│ │ │ ├─mesa
│ │ │ │ ├─libdrm
│ │ │ │ │ ├─glibc
│ │ │ │ │ └─libpciaccess
│ │ │ │ │   └─glibc
│ │ │ │ ├─wayland
│ │ │ │ │ ├─glibc
│ │ │ │ │ ├─libffi
│ │ │ │ │ │ └─glibc
│ │ │ │ │ ├─expat
│ │ │ │ │ │ └─glibc
│ │ │ │ │ └─libxml2
│ │ │ │ │   ├─zlib
│ │ │ │ │   │ └─glibc
│ │ │ │ │   ├─readline
│ │ │ │ │   ├─ncurses
│ │ │ │ │   └─xz
│ │ │ │ │     └─bash provides sh
│ │ │ │ ├─libxxf86vm
│ │ │ │ │ ├─libxext
│ │ │ │ │ │ ├─libx11
│ │ │ │ │ │ │ ├─libxcb
│ │ │ │ │ │ │ ├─xproto
│ │ │ │ │ │ │ └─kbproto
│ │ │ │ │ │ └─xextproto
│ │ │ │ │ └─xf86vidmodeproto
│ │ │ │ ├─libxdamage
│ │ │ │ │ ├─libxfixes
│ │ │ │ │ │ ├─libx11
│ │ │ │ │ │ └─fixesproto
│ │ │ │ │ │   ├─xproto
│ │ │ │ │ │   └─xextproto
│ │ │ │ │ └─damageproto
│ │ │ │ │   ├─xproto
│ │ │ │ │   └─fixesproto
│ │ │ │ ├─libxshmfence
│ │ │ │ │ └─glibc
│ │ │ │ ├─systemd
│ │ │ │ │ ├─acl
│ │ │ │ │ │ └─attr
│ │ │ │ │ │   └─glibc
│ │ │ │ │ ├─bash
│ │ │ │ │ ├─dbus
│ │ │ │ │ │ ├─libdbus
│ │ │ │ │ │ │ └─libsystemd
│ │ │ │ │ │ │   ├─glibc
│ │ │ │ │ │ │   ├─libcap
│ │ │ │ │ │ │   │ ├─glibc
│ │ │ │ │ │ │   │ └─attr
│ │ │ │ │ │ │   ├─libgcrypt
│ │ │ │ │ │ │   │ └─libgpg-error
│ │ │ │ │ │ │   │   ├─glibc
│ │ │ │ │ │ │   │   └─bash provides sh
│ │ │ │ │ │ │   ├─lz4
│ │ │ │ │ │ │   │ └─glibc
│ │ │ │ │ │ │   └─xz
│ │ │ │ │ │ └─expat
│ │ │ │ │ ├─iptables
│ │ │ │ │ │ ├─glibc
│ │ │ │ │ │ └─bash
│ │ │ │ │ ├─kbd
│ │ │ │ │ │ ├─glibc
│ │ │ │ │ │ └─pam
│ │ │ │ │ │   ├─glibc
│ │ │ │ │ │   ├─cracklib
│ │ │ │ │ │   │ ├─glibc
│ │ │ │ │ │   │ └─zlib
│ │ │ │ │ │   ├─libtirpc
│ │ │ │ │ │   │ └─krb5
│ │ │ │ │ │   │   ├─e2fsprogs
│ │ │ │ │ │   │   │ ├─bash provides sh
│ │ │ │ │ │   │   │ └─libutil-linux
│ │ │ │ │ │   │   ├─libldap
│ │ │ │ │ │   │   │ ├─libsasl
│ │ │ │ │ │   │   │ │ └─openssl
│ │ │ │ │ │   │   │ │   └─perl
│ │ │ │ │ │   │   │ └─e2fsprogs
│ │ │ │ │ │   │   └─keyutils
│ │ │ │ │ │   │     ├─glibc
│ │ │ │ │ │   │     └─bash provides sh
│ │ │ │ │ │   └─pambase
│ │ │ │ │ ├─kmod
│ │ │ │ │ │ ├─glibc
│ │ │ │ │ │ ├─zlib
│ │ │ │ │ │ └─xz
│ │ │ │ │ ├─hwids
│ │ │ │ │ ├─libcap
│ │ │ │ │ ├─libgcrypt
│ │ │ │ │ ├─libsystemd
│ │ │ │ │ ├─libidn
│ │ │ │ │ │ ├─glibc
│ │ │ │ │ │ └─texinfo
│ │ │ │ │ │   ├─ncurses
│ │ │ │ │ │   ├─findutils
│ │ │ │ │ │   │ ├─glibc
│ │ │ │ │ │   │ └─bash provides sh
│ │ │ │ │ │   ├─gzip
│ │ │ │ │ │   │ ├─glibc
│ │ │ │ │ │   │ ├─bash
│ │ │ │ │ │   │ └─less
│ │ │ │ │ │   │   ├─glibc
│ │ │ │ │ │   │   ├─ncurses
│ │ │ │ │ │   │   └─pcre
│ │ │ │ │ │   │     ├─gcc-libs
│ │ │ │ │ │   │     ├─readline
│ │ │ │ │ │   │     ├─zlib
│ │ │ │ │ │   │     ├─bzip2
│ │ │ │ │ │   │     │ └─glibc
│ │ │ │ │ │   │     └─bash
│ │ │ │ │ │   ├─perl
│ │ │ │ │ │   └─bash provides sh
│ │ │ │ │ ├─lz4
│ │ │ │ │ ├─pam
│ │ │ │ │ ├─libelf
│ │ │ │ │ │ ├─gcc-libs
│ │ │ │ │ │ ├─zlib
│ │ │ │ │ │ ├─bzip2
│ │ │ │ │ │ └─xz
│ │ │ │ │ ├─libseccomp
│ │ │ │ │ │ └─glibc
│ │ │ │ │ ├─util-linux
│ │ │ │ │ │ ├─pam
│ │ │ │ │ │ ├─shadow
│ │ │ │ │ │ │ ├─bash
│ │ │ │ │ │ │ ├─pam
│ │ │ │ │ │ │ └─acl
│ │ │ │ │ │ ├─coreutils
│ │ │ │ │ │ │ ├─glibc
│ │ │ │ │ │ │ ├─acl
│ │ │ │ │ │ │ ├─attr
│ │ │ │ │ │ │ ├─gmp
│ │ │ │ │ │ │ │ ├─gcc-libs
│ │ │ │ │ │ │ │ └─bash provides sh
│ │ │ │ │ │ │ ├─libcap
│ │ │ │ │ │ │ └─openssl
│ │ │ │ │ │ ├─libsystemd
│ │ │ │ │ │ └─libutil-linux
│ │ │ │ │ └─xz
│ │ │ │ ├─elfutils
│ │ │ │ │ └─libelf
│ │ │ │ ├─libomxil-bellagio
│ │ │ │ │ └─glibc
│ │ │ │ ├─expat
│ │ │ │ ├─libgcrypt
│ │ │ │ ├─libtxc_dxtn
│ │ │ │ │ └─glibc
│ │ │ │ └─llvm-libs
│ │ │ │   ├─gcc-libs
│ │ │ │   ├─zlib
│ │ │ │   ├─libffi
│ │ │ │   ├─libedit
│ │ │ │   │ └─ncurses
│ │ │ │   └─ncurses
│ │ │ ├─mhwd-db
│ │ │ │ ├─mhwd-nvidia
│ │ │ │ ├─mhwd-nvidia-304xx
│ │ │ │ ├─mhwd-nvidia-340xx
│ │ │ │ ├─mhwd-catalyst
│ │ │ │ └─mhwd-amdgpu
│ │ │ ├─v86d
│ │ │ │ └─glibc
│ │ │ └─pacman
│ │ │   ├─bash
│ │ │   ├─glibc
│ │ │   ├─libarchive
│ │ │   │ ├─acl
│ │ │   │ ├─attr
│ │ │   │ ├─bzip2
│ │ │   │ ├─expat
│ │ │   │ ├─lzo
│ │ │   │ │ └─glibc
│ │ │   │ ├─openssl
│ │ │   │ ├─xz
│ │ │   │ └─zlib
│ │ │   ├─curl
│ │ │   │ ├─ca-certificates
│ │ │   │ │ ├─ca-certificates-mozilla
│ │ │   │ │ │ └─ca-certificates-utils
│ │ │   │ │ │   ├─bash
│ │ │   │ │ │   ├─coreutils
│ │ │   │ │ │   ├─findutils
│ │ │   │ │ │   └─p11-kit
│ │ │   │ │ │     ├─glibc
│ │ │   │ │ │     ├─libtasn1
│ │ │   │ │ │     │ ├─glibc
│ │ │   │ │ │     │ └─texinfo
│ │ │   │ │ │     └─libffi
│ │ │   │ │ └─ca-certificates-cacert
│ │ │   │ │   └─ca-certificates-utils
│ │ │   │ ├─krb5
│ │ │   │ ├─libidn
│ │ │   │ ├─libssh2
│ │ │   │ │ └─openssl
│ │ │   │ ├─openssl
│ │ │   │ └─zlib
│ │ │   ├─gpgme
│ │ │   │ ├─libgpg-error
│ │ │   │ └─gnupg
│ │ │   │   ├─npth
│ │ │   │   ├─libgpg-error
│ │ │   │   ├─libgcrypt
│ │ │   │   ├─libksba
│ │ │   │   │ ├─bash
│ │ │   │   │ ├─libgpg-error
│ │ │   │   │ └─glibc
│ │ │   │   ├─libassuan
│ │ │   │   │ └─libgpg-error
│ │ │   │   ├─pinentry
│ │ │   │   │ ├─ncurses
│ │ │   │   │ ├─libcap
│ │ │   │   │ └─libassuan
│ │ │   │   ├─bzip2
│ │ │   │   ├─readline
│ │ │   │   ├─gnutls
│ │ │   │   │ ├─gcc-libs
│ │ │   │   │ ├─libtasn1
│ │ │   │   │ ├─readline
│ │ │   │   │ ├─zlib
│ │ │   │   │ ├─nettle
│ │ │   │   │ │ └─gmp
│ │ │   │   │ └─p11-kit
│ │ │   │   └─sqlite
│ │ │   │     └─readline
│ │ │   ├─pacman-mirrorlist
│ │ │   │ └─python
│ │ │   │   ├─expat
│ │ │   │   ├─bzip2
│ │ │   │   ├─gdbm
│ │ │   │   ├─openssl
│ │ │   │   ├─libffi
│ │ │   │   └─zlib
│ │ │   ├─archlinux-keyring
│ │ │   └─manjaro-keyring
│ │ ├─dbus
│ │ ├─fontconfig-infinality-ultimate provides fontconfig
│ │ │ ├─expat
│ │ │ └─freetype2-infinality-ultimate
│ │ │   ├─zlib
│ │ │   ├─bzip2
│ │ │   ├─bash provides sh
│ │ │   ├─xorg-xrdb
│ │ │   │ ├─libx11
│ │ │   │ └─libxmu
│ │ │   │   ├─libxext
│ │ │   │   └─libxt
│ │ │   │     ├─libsm
│ │ │   │     │ ├─libice
│ │ │   │     │ │ ├─glibc
│ │ │   │     │ │ └─xproto
│ │ │   │     │ └─util-linux
│ │ │   │     └─libx11
│ │ │   ├─libpng
│ │ │   │ ├─zlib
│ │ │   │ └─bash provides sh
│ │ │   └─harfbuzz
│ │ │     ├─glib2
│ │ │     │ ├─pcre
│ │ │     │ └─libffi
│ │ │     ├─freetype2-infinality-ultimate provides freetype2
│ │ │     └─graphite
│ │ │       └─gcc-libs
│ │ ├─systemd
│ │ ├─xcb-util-wm
│ │ │ └─libxcb
│ │ ├─libxrender
│ │ │ ├─libx11
│ │ │ └─renderproto
│ │ ├─libxi
│ │ │ ├─libxext
│ │ │ └─inputproto
│ │ ├─sqlite
│ │ ├─xcb-util-image
│ │ │ ├─libxcb
│ │ │ └─xcb-util
│ │ │   └─libxcb
│ │ ├─icu
│ │ │ ├─gcc-libs
│ │ │ └─bash provides sh
│ │ ├─qtchooser
│ │ │ └─gcc-libs
│ │ ├─libinput
│ │ │ ├─mtdev
│ │ │ │ └─glibc
│ │ │ ├─systemd
│ │ │ ├─libevdev
│ │ │ │ └─glibc
│ │ │ └─libwacom
│ │ │   ├─glib2
│ │ │   ├─systemd
│ │ │   └─libgudev
│ │ │     └─libsystemd
│ │ ├─libsm
│ │ └─libxkbcommon-x11
│ │   ├─libxkbcommon
│ │   │ ├─xkeyboard-config
│ │   │ └─glibc
│ │   └─libxcb
│ ├─qt5-x11extras
│ │ └─qt5-base
│ ├─kwindowsystem
│ │ ├─qt5-x11extras
│ │ └─libxfixes
│ └─libqtxdg-git
│   └─qt5-base
├─libfm
│ ├─dbus-glib
│ │ ├─dbus
│ │ └─glib2
│ ├─libexif
│ │ └─glibc
│ ├─libfm-extra
│ │ └─glib2
│ ├─menu-cache
│ │ └─libfm-extra
│ └─shared-mime-info
│   ├─libxml2
│   └─glib2
├─lxmenu-data
└─qt5-x11extras


i have just tested to run pcmanfm-qt without gvfs:
- i removed gvfs and installed solid-git and recompiled pcmanfm-qt-git from the aur. rebooted. result: usb sticks are no longer recognized and i cannot connect to samba shares.
- i reset my system (with pcmanfm-qt and gvfs-afc, gvfs-smb) and removed gtk3, but not gcr. i have still gtk2 installed. result: i count mount usb drives and connect to samba shares, but whenever i unmounted a drive pcmanfm-qt crashed. i think this behavior is acceptable to me.

as you can see, gtk3 is only dependent on these 2 packages on my system:
Code: [Select]
~ » pactree -r gtk3
gtk3
└─gcr
  └─gvfs
    ├─gvfs-afc
    └─gvfs-smb
so, i can afford to uninstall gtk3. let's see how the next update goes...
Need more information? Search here:   Manjaro Forum   |   Manjaro Wiki   |   Arch Wiki

Offline AJSlye

  • Maintainer
  • ***
  • Posts: 4298
  • Netrunner Rolling Edition moderator / maintainer
  • Branch: Stable / Testing / Unstable
  • Desktop: Netrunner Rolling
  • GPU Card: Intel
  • GPU driver: Intel
  • Kernel: 4.4.1-1-MANJARO x86_64 (64 bit)
  • Skill: Guru
Re: [stable] Manjaro Lxqt 16.03 released !
« Reply #38 on: 12. March 2016, 18:27:17 »
lxqt-panel pulls in solid, so no need for git. ;)

Offline Esclapion

  • Support Team
  • ****
  • Posts: 5523
    • manjaro
  • Branch: stable
  • Desktop: Lxqt
  • GPU Card: GTX 970
  • GPU driver: nonfree
  • Kernel: 4.4.6
  • Skill: Advanced
Re: [stable] Manjaro Lxqt 16.03 released !
« Reply #39 on: 12. March 2016, 18:28:35 »
@ Esclapion,

Here is the pcmanfm-qt dependency tree:

Pcmanfm-qt --> liblxqt libfm lxmenu-data
   libxqt --> kwindowsystem libqtxdg
      kwindowsystem --> qt5-x11extras libxfixes
          qt5-x11extras --> qt5-base
          libxfixes --> libx11 fixesproto>=5.0 (goes further but no more kde deps)
       libqtxdg --> libsm libxkbcommon-x11 qt5-base
   libfm --> dbus-glib libexif libfm-extra=1.2.4 menu-cache shared-mime-info
       dbus-glib --> dbus glib2 (goes further but no kde deps)
       libexif --> glibc
       menu-cache --> libfm-extra (redundant dep)
       shared-mime-info --> libxml2 glib2 (goes further but no kde deps)
   lxmenu-data --> (no more deps)

I have solid installed from extra due to depency of calamares and kio. I will ask for that on the lx(de,qt) irc.

(edit)
We posted at the same time.  ;)
« Last Edit: 12. March 2016, 18:31:04 by Esclapion »
Venez nous rejoindre sur l'IRC francophone
Patrice - Violence is the last refuge of the incompetent (Asimov)

Offline AJSlye

  • Maintainer
  • ***
  • Posts: 4298
  • Netrunner Rolling Edition moderator / maintainer
  • Branch: Stable / Testing / Unstable
  • Desktop: Netrunner Rolling
  • GPU Card: Intel
  • GPU driver: Intel
  • Kernel: 4.4.1-1-MANJARO x86_64 (64 bit)
  • Skill: Guru
Re: [stable] Manjaro Lxqt 16.03 released !
« Reply #40 on: 12. March 2016, 18:48:19 »
@ excalibur1234
I just mounted my 1tb WD passport USB external drive without gvfs.

When you removed gvfs and gvfs-afc you didn't remove usbmuxd or any other dependencies with it by accident, AKA use octopi or pamac to remove them?

You might also need kio installed to get this to work, I'm not sure since I use kmymoney which installed kio on my system.

Compiling from the latest code on git can be buggy.
« Last Edit: 12. March 2016, 18:59:46 by AJSlye »

Offline AJSlye

  • Maintainer
  • ***
  • Posts: 4298
  • Netrunner Rolling Edition moderator / maintainer
  • Branch: Stable / Testing / Unstable
  • Desktop: Netrunner Rolling
  • GPU Card: Intel
  • GPU driver: Intel
  • Kernel: 4.4.1-1-MANJARO x86_64 (64 bit)
  • Skill: Guru
Re: [stable] Manjaro Lxqt 16.03 released !
« Reply #41 on: 12. March 2016, 18:59:32 »
UPDATE: Nope, scratch that, I just looked and there is no gvfs, gvfs-afc or kio installed on my system.
Pcmanfm-qt still mounts all of my usb drives just fine, they even pop up in the removable media applet.

I can confirm however, that clicking on computer or network does complain about gvfsd-computer and gvfsd-network, but this could just be an issue with the .desktop file these use. These are after all specific function of gvfs and could be replaced with the kio alternatives. SMBclient wasn't even installed smbclient-stub was, before messing up my system I need to look into what this package is and what it does. I have no windows machines so samba support is not a necessity for me anyway.

I'm looking into this one it now.
« Last Edit: 12. March 2016, 19:20:21 by AJSlye »

Offline excalibur1234

  • Global Moderator
  • *****
  • Posts: 2508
  • Branch: unstable
  • Desktop: net-minimal + LXQt
  • GPU driver: video-nouveau
  • Kernel: 4.6
  • Skill: Intermediate
Re: [stable] Manjaro Lxqt 16.03 released !
« Reply #42 on: 12. March 2016, 19:24:17 »
When you removed gvfs and gvfs-afc you didn't remove usbmuxd or any other dependencies with it by accident, AKA use octopi or pamac to remove them?
yes, i did remove all dependencies with them. i will test this shortly again.


i looked at pcmanfm-qt-git before i did that, but it did not require any optional dependencies: there are none. imho, this would be a great way to tell users about hidden functionality.


i know that compiling from git can be buggy, but sometimes it gives you extra features (and because i am using pcmanfm-qt-git i also wanted to use solid-git).
Need more information? Search here:   Manjaro Forum   |   Manjaro Wiki   |   Arch Wiki

Offline AJSlye

  • Maintainer
  • ***
  • Posts: 4298
  • Netrunner Rolling Edition moderator / maintainer
  • Branch: Stable / Testing / Unstable
  • Desktop: Netrunner Rolling
  • GPU Card: Intel
  • GPU driver: Intel
  • Kernel: 4.4.1-1-MANJARO x86_64 (64 bit)
  • Skill: Guru
Re: [stable] Manjaro Lxqt 16.03 released !
« Reply #43 on: 12. March 2016, 20:33:32 »
Well, after rebooting my machine I noticed my usb devices not comming up or mounting anymore.
I went ahead and reinstalled gvfs then logout out and back in, low and behold my USB devices started mounting again.
I'll be the first to admit it when I was wrong, and I was wrong, gvfs is indeed needed.
I do sincerely apologize.

Offline growlinwolf

  • Jr. Mitglied
  • **
  • Posts: 75
  • I'm new. Be nice!
  • Branch: LTS
  • Desktop: Openbox
  • GPU Card: nvidia GTX 760
  • GPU driver: 355.11-Linux_x86_x64
  • Kernel: 4.1.9-1-MANJARO x64
  • Skill: Intermediate
Re: [stable] Manjaro Lxqt 16.03 released !
« Reply #44 on: 12. March 2016, 21:29:44 »
Tulliana  has also done one HERE.



Awesome a lot cleaner and better. What did he use to clean it up really awesome job  8)