Author Topic: compton users - please post your config file here!  (Read 7220 times)

0 Members and 1 Guest are viewing this topic.

Offline torvic9

  • Sr. Mitglied
  • ****
  • Posts: 253
  • Hello world!
  • Branch: stable
  • Skill: Intermediate
compton users - please post your config file here!
« on: 29. February 2016, 21:35:29 »
Title says it all.
This thread  https://forum.manjaro.org/index.php?topic=31407.0  made me think about finding optimal compton settings for a specific set of hardware, so I thought it might be good idea to collect info from compton users.

Could you please also post info about your graphics card, graphics drivers and monitor(s), and window manager / desktop environment?

Edit: attached my compton.conf
« Last Edit: 29. February 2016, 21:45:25 by torvic9 »
i3: i7-5820K | 32 GB | GeForce GTX 960, nvidia | linux44-custom
KDE: i7-920 | 12 GB | GeForce GTS 450, nouveau | linux44
Gnome: Thinkpad X200s | linux41

Offline eugen-b

  • Support Team
  • ****
  • Posts: 3191
  • Branch: testing
  • Desktop: LXDE, Fluxbox, JWM, LXQt, bspwm
  • GPU Card: Intel 82945G/GZ
  • GPU driver: free
  • Kernel: 4.5, 4.6
  • Skill: Intermediate
Re: compton users - please post your config file here!
« Reply #1 on: 29. February 2016, 21:42:29 »
Mine is a bit messy, the special thing about it is that the shadow offset goes to the left. The file is attached.
Code: [Select]
inxi -G
Graphics:  Card: Intel 82945G/GZ Integrated Graphics Controller
           Display Server: X.Org 1.17.4 driver: intel
           Resolution: 1366x768@59.79hz
           GLX Renderer: Mesa DRI Intel 945G GLX Version: 2.1 Mesa 11.1.2
« Last Edit: 29. February 2016, 21:44:41 by eugen-b »
MSI Wind Nettop, Intel Atom 230 1.6GHz (64bit), 2GB RAM
DEs: NET-minimal + (LXDE / Fluxbox / JWM); LXQt OpenRC
how to install on btrfs subvolumes
http://manjaro.github.io/donate/

Offline badbodh

  • Held Mitglied
  • *****
  • Posts: 923
  • Windows assumes I'm stupid, Linux proves it.
  • Branch: Testing
  • Desktop: Xfce, i3
  • GPU Card: Intel Mobile 4 Series
  • Kernel: linux41 64-bit
  • Skill: Intermediate
Re: compton users - please post your config file here!
« Reply #2 on: 01. March 2016, 03:07:38 »
one compton to rule them all: marco, xfwm4, i3
Code: [Select]
Graphics:  Card: Intel Mobile 4 Series Integrated Graphics Controller
           Display Server: X.Org 1.17.4 driver: intel Resolution: 1366x768@60.00hz
           GLX Renderer: Mesa DRI Mobile Intel GM45 Express GLX Version: 2.1 Mesa 11.1.2
You can't feel the love till it hurts a little. Go rolling, go bleeding-edge !

Offline Enindu

  • Sr. Mitglied
  • ****
  • Posts: 380
  • Keep it simple stupid..!
  • Desktop: Xfce
  • GPU driver: Free
  • Kernel: Linux 4.5.1-1-ARCH
  • Skill: Novice
Re: compton users - please post your config file here!
« Reply #3 on: 01. March 2016, 03:19:30 »
Here's mine. Using on Xfce and i3.

Graphic card
Code: [Select]
Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller
Compton config
Code: [Select]
# Shadow
shadow = false;
no-dnd-shadow = true;
no-dock-shadow = true;
clear-shadow = true;
shadow-radius = 7;
shadow-offset-x = -7;
shadow-offset-y = -7;
# shadow-opacity = 0.7;
# shadow-red = 0.0;
# shadow-green = 0.0;
# shadow-blue = 0.0;
shadow-exclude = [
    "name = 'Notification'",
    "class_g = 'Conky'",
    "class_g ?= 'Notify-osd'",
    "class_g = 'Cairo-clock'",
    "_GTK_FRAME_EXTENTS@:c"
];
# shadow-exclude = "n:e:Notification";
# shadow-exclude-reg = "x10+0+0";
# xinerama-shadow-crop = true;

# Opacity
menu-opacity = 1.0;
inactive-opacity = 1.0;
# active-opacity = 0.8;
# frame-opacity = 0.7;
inactive-opacity-override = false;
alpha-step = 0.06;
# inactive-dim = 0.2;
# inactive-dim-fixed = true;
# blur-background = true;
# blur-background-frame = true;
blur-kern = "3x3box"
# blur-kern = "5,5,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1"
# blur-background-fixed = true;
blur-background-exclude = [
    "window_type = 'dock'",
    "window_type = 'desktop'",
    "_GTK_FRAME_EXTENTS@:c"
];
# opacity-rule = [ "80:class_g = 'URxvt'" ];

# Fading
fading = true;
# fade-delta = 30;
fade-in-step = 0.05;
fade-out-step = 0.05;
# no-fading-openclose = true;
fade-exclude = [ ];

# Other
backend = "xrender"
mark-wmwin-focused = true;
mark-ovredir-focused = true;
# use-ewmh-active-win = true;
detect-rounded-corners = true;
detect-client-opacity = true;
refresh-rate = 0;
vsync = "none";
dbe = false;
paint-on-overlay = true;
# sw-opti = true;
# unredir-if-possible = true;
# unredir-if-possible-delay = 5000;
# unredir-if-possible-exclude = [ ];
focus-exclude = [ "class_g = 'Cairo-clock'" ];
detect-transient = true;
detect-client-leader = true;
invert-color-include = [ ];
# resize-damage = 1;

# GLX backend
# glx-no-stencil = true;
glx-copy-from-front = false;
# glx-use-copysubbuffermesa = true;
# glx-no-rebind-pixmap = true;
glx-swap-method = "undefined";
# glx-use-gpushader4 = true;
# xrender-sync = true;
# xrender-sync-fence = true;

# Window type settings
wintypes:
{
  tooltip = { fade = true; shadow = false; opacity = 0.75; focus = true; };
};

Offline badbodh

  • Held Mitglied
  • *****
  • Posts: 923
  • Windows assumes I'm stupid, Linux proves it.
  • Branch: Testing
  • Desktop: Xfce, i3
  • GPU Card: Intel Mobile 4 Series
  • Kernel: linux41 64-bit
  • Skill: Intermediate
Re: compton users - please post your config file here!
« Reply #4 on: 01. March 2016, 03:55:38 »
if your backend is xrender, why bother with glx options anyway? # them out.
You can't feel the love till it hurts a little. Go rolling, go bleeding-edge !

Offline Enindu

  • Sr. Mitglied
  • ****
  • Posts: 380
  • Keep it simple stupid..!
  • Desktop: Xfce
  • GPU driver: Free
  • Kernel: Linux 4.5.1-1-ARCH
  • Skill: Novice
Re: compton users - please post your config file here!
« Reply #5 on: 01. March 2016, 04:08:46 »
It's just a complete copy of this;D

Offline torvic9

  • Sr. Mitglied
  • ****
  • Posts: 253
  • Hello world!
  • Branch: stable
  • Skill: Intermediate
Re: compton users - please post your config file here!
« Reply #6 on: 01. March 2016, 16:12:48 »
My first impression is that the glx backend seems to work best with vsync set to "none", leaving vsync to the graphics drivers.
It's not easy to understand all the different glx options, I read through the readme but it seems that these options are mostly trial and error.
i3: i7-5820K | 32 GB | GeForce GTX 960, nvidia | linux44-custom
KDE: i7-920 | 12 GB | GeForce GTS 450, nouveau | linux44
Gnome: Thinkpad X200s | linux41

Offline mbb

  • Neuling
  • *
  • Posts: 11
  • This text is ... personal!
  • Branch: Stable
  • Desktop: i3
  • GPU Card: Mobility Radeon 9200
  • GPU driver: video-ati (free)
  • Kernel: linux314-x86
  • Skill: Novice
Re: compton users - please post your config file here!
« Reply #7 on: 31. March 2016, 13:29:46 »
Graphics:
Code: [Select]
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RV250/M9 GL [Mobility FireGL 9000/Radeon 9000]
           Display Server: X.Org 1.17.4 driver: radeon Resolution: 1280x800@59.91hz
           GLX Renderer: Mesa DRI R200 (RV250 4C66) x86/MMX/SSE2 DRI2 GLX Version: 1.3 Mesa 11.1.2

The file is attached. Most of it wasn't changed, except for some options related with the rendering engine, VSync, painting mode, overlay, fading and opacity. I'm still not fully happy with this configuration, but I haven't had the time needed to experiment a bit more. "VSync:drm" achieves better performance but results in a memory leak.

Congrats!

Update: just noticed that "glx-no-rebind-pixmap = true" also leads to a memory leak, so I changed it to "false".
« Last Edit: 31. March 2016, 17:54:26 by mbb »

Offline badbodh

  • Held Mitglied
  • *****
  • Posts: 923
  • Windows assumes I'm stupid, Linux proves it.
  • Branch: Testing
  • Desktop: Xfce, i3
  • GPU Card: Intel Mobile 4 Series
  • Kernel: linux41 64-bit
  • Skill: Intermediate
Re: compton users - please post your config file here!
« Reply #8 on: 31. March 2016, 21:28:40 »
Update: just noticed that "glx-no-rebind-pixmap = true" also leads to a memory leak, so I changed it to "false".
rtfm  :P :P
Code: [Select]
...but is known to break things on some drivers...
You can't feel the love till it hurts a little. Go rolling, go bleeding-edge !

Offline mbb

  • Neuling
  • *
  • Posts: 11
  • This text is ... personal!
  • Branch: Stable
  • Desktop: i3
  • GPU Card: Mobility Radeon 9200
  • GPU driver: video-ati (free)
  • Kernel: linux314-x86
  • Skill: Novice
Re: compton users - please post your config file here!
« Reply #9 on: 31. March 2016, 23:02:46 »
rtfm  :P :P
Code: [Select]
...but is known to break things on some drivers...

Well, it doesn't hurt to try... whenever you don't know which drivers get broken. By the way, found the time to try some more options and, on my system, almost every option related with reusing buffers lead to a memory leak. Then, not being resigned with the bad results, I tried to turn on all the ones getting me better performance and, for now, my memory isn't filling up with no reason... !!

So, changes from the file I posted:
Code: [Select]
vsync = "drm";
# glx-copy-from-front = true;
# glx-swap-method = "exchange";
glx-use-copysubbuffermesa = true;
glx-no-rebind-pixmap = true;
xrender-sync = true;

I'm not overly excited though... expecting for a memory leak at any moment... it would be nice if it worked like this because it makes a huge difference on this poor system.

Offline Fatboy

  • Sr. Mitglied
  • ****
  • Posts: 323
  • "Spiral out. Keep going..."
  • Branch: stable
  • Desktop: Xfce, KDE plasma 5
  • GPU Card: nVidia GeForce 210
  • GPU driver: 340.xx
  • Kernel: Manjaro Kernel 4.4 LTS
  • Skill: Intermediate
Re: compton users - please post your config file here!
« Reply #10 on: 03. April 2016, 21:28:05 »
I use XFCE DE, intel gfx as well as Nvidia geforce 210.
I love my compton setup, makes it snappy and slightly elegant with fast fade in/outs

Code: [Select]
backend = "glx";
paint-on-overlay = true;
glx-no-stencil = true;
vsync = "opengl-swc";

# Shadow
shadow = true; # Enabled client-side shadows on windows.
no-dock-shadow = true; # Avoid drawing shadows on dock/panel windows.
no-dnd-shadow = true; # Don't draw shadows on DND windows.
clear-shadow = true; # Zero the part of the shadow's mask behind the window (experimental).
shadow-radius = 7; # The blur radius for shadows. (default 12)
shadow-offset-x = -7; # The left offset for shadows. (default -15)
shadow-offset-y = -7; # The top offset for shadows. (default -15)
shadow-exclude = [
 "n:e:Notification",
 "n:e:Docky",
 "g:e:Synapse",
 "g:e:Conky",
 "n:w:*Firefox*",
 "n:w:*Chromium*",
 "n:w:*dockbarx*",
 "class_g ?= 'Cairo-dock'",
 "class_g ?= 'Xfce4-notifyd'",
 "class_g ?= 'Xfce4-power-manager'",
 "class_g ?= 'Notify-osd'",
 "_GTK_FRAME_EXTENTS@:c"
];

# Opacity
detect-client-opacity = true;
# Menu and Inactice Opacity
menu-opacity = 0.9;
inactive-opacity = 1.0;

# Fading
fading = true;
fade-delta = 4;
fade-in-step = 0.03;
fade-out-step = 0.05;
# no-fading-openclose = true;
# no-fading-destroyed-argb = true;
fade-exclude = [ ];

# Window type settings
wintypes:
{
 tooltip = { shadow = false; };
};
"I'm reaching for the random or whatever will bewilder me. Whatever will bewilder me."

Offline torvic9

  • Sr. Mitglied
  • ****
  • Posts: 253
  • Hello world!
  • Branch: stable
  • Skill: Intermediate
Re: compton users - please post your config file here!
« Reply #11 on: 05. April 2016, 20:13:53 »
I (finally?) settled for this:
Code: [Select]
backend = "glx";
mark-wmwin-focused = true;
mark-ovredir-focused = true;
detect-client-opacity = true;
unredir-if-possible = true;
refresh-rate = 0;
vsync = "none";
#dbe = false;
paint-on-overlay = true;
focus-exclude = [ "class_g = 'Cairo-clock'" ];
detect-transient = true;
detect-client-leader = true;
invert-color-include = [ ];
glx-copy-from-front = false;
glx-swap-method = "buffer-age";
glx-no-stencil = true;
#glx-no-rebind-pixmap = true;
xrender-sync-fence = true;
with __GL_SYNC_TO_VBLANK=1.

In use now for about a month, not really had problems.
Very rare to no tearing and does not interfere with games or other full-screen applications.
Works on dual monitor, but seems to need a little more CPU, nothing to worry about.
Also seems to be a nvidia specific config from what I've read here.
« Last Edit: 05. April 2016, 20:17:01 by torvic9 »
i3: i7-5820K | 32 GB | GeForce GTX 960, nvidia | linux44-custom
KDE: i7-920 | 12 GB | GeForce GTS 450, nouveau | linux44
Gnome: Thinkpad X200s | linux41

Offline badbodh

  • Held Mitglied
  • *****
  • Posts: 923
  • Windows assumes I'm stupid, Linux proves it.
  • Branch: Testing
  • Desktop: Xfce, i3
  • GPU Card: Intel Mobile 4 Series
  • Kernel: linux41 64-bit
  • Skill: Intermediate
Re: compton users - please post your config file here!
« Reply #12 on: 05. April 2016, 20:38:24 »
I (finally?) settled for this

No you didn't. Lemme start the stopwatch. You still haven't played with transparency, blur, shadows.
https://gist.github.com/120f6d3b089e32ebc671ab8a3933956c
« Last Edit: 05. April 2016, 20:40:14 by badbodh »
You can't feel the love till it hurts a little. Go rolling, go bleeding-edge !

Offline torvic9

  • Sr. Mitglied
  • ****
  • Posts: 253
  • Hello world!
  • Branch: stable
  • Skill: Intermediate
Re: compton users - please post your config file here!
« Reply #13 on: 06. April 2016, 13:26:48 »
No you didn't. Lemme start the stopwatch. You still haven't played with transparency, blur, shadows.
https://gist.github.com/120f6d3b089e32ebc671ab8a3933956c

:)

I've already set up transparency, blur and shadows. That's not really important for me.

However, you're right in that your config is very interesting. So I might be tempted to tinker once again with mine... :)
i3: i7-5820K | 32 GB | GeForce GTX 960, nvidia | linux44-custom
KDE: i7-920 | 12 GB | GeForce GTS 450, nouveau | linux44
Gnome: Thinkpad X200s | linux41

Offline eugen-b

  • Support Team
  • ****
  • Posts: 3191
  • Branch: testing
  • Desktop: LXDE, Fluxbox, JWM, LXQt, bspwm
  • GPU Card: Intel 82945G/GZ
  • GPU driver: free
  • Kernel: 4.5, 4.6
  • Skill: Intermediate
Re: compton users - please post your config file here!
« Reply #14 on: 06. May 2016, 14:37:16 »
I need to revice the thread, because I managed to improbe my compton.conf at least for my machine:
Code: [Select]
# Shadow
shadow = true;
no-dnd-shadow = true;
no-dock-shadow = true;
clear-shadow = true;
shadow-radius = 7;
shadow-offset-x = -7;
shadow-offset-y = -7;
# shadow-opacity = 0.7;
# shadow-red = 0.0;
# shadow-green = 0.0;
# shadow-blue = 0.0;
shadow-exclude = [ "name = 'Notification'", "class_g = 'Conky'", "class_g ?= 'Notify-osd'", "class_g = 'Cairo-clock'" ];
shadow-ignore-shaped = false;
# shadow-exclude-reg = "x10+0+0";
# xinerama-shadow-crop = true;

# Opacity
menu-opacity = 0.97;
inactive-opacity = 1.0;
active-opacity = 1.0;
frame-opacity = 0.7;
inactive-opacity-override = false;
#alpha-step = 0.05;
# inactive-dim = 0.2;
# inactive-dim-fixed = true;
blur-background = false;
# blur-background-frame = true;
#blur-kern = "3x3box";
#blur-kern = "5,5,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1";
#blur-background-fixed = true;
#blur-background-exclude = [ "window_type = 'dock'", "window_type = 'desktop'" ];

# Fading
fading = false;
# fade-delta = 30;
#fade-in-step = 0.03;
#fade-out-step = 0.03;
# no-fading-openclose = true;
#fade-exclude = [ ];

# Other
backend = "glx";
mark-wmwin-focused = false;
mark-ovredir-focused = false;
# use-ewmh-active-win = true;
detect-rounded-corners = false;
detect-client-opacity = false;
refresh-rate = "59.79";
vsync = "opengl-swc";
dbe = false;
paint-on-overlay = true;
# sw-opti = true;
# unredir-if-possible = true;
# unredir-if-possible-delay = 5000;
# unredir-if-possible-exclude = [ ];
#focus-exclude = [ "class_g = 'Cairo-clock'" ];
detect-transient = false;
detect-client-leader = false;
#invert-color-include = [ ];
# resize-damage = 1;

# GLX backend
glx-no-stencil = true;
glx-copy-from-front = true;
glx-use-copysubbuffermesa = true;
glx-no-rebind-pixmap = true;
glx-swap-method = "copy";
glx-use-gpushader4 = false;
xrender-sync = false;
xrender-sync-fence = false;

opacity-rule = [ "99:name *?= 'Screenshot'",
#"99:class_g = 'Firefox'",
"99:name *?= 'Pale Moon'",
#"99:name *?= 'QupZilla'",
"99:name *?= 'Write'",
#"99:name *?= 'VirtualBox'",
"90:name *?= 'Conky'",
"90:name *?= 'Panel'",
"90:name *?= 'Restart'",
"90:name *?= 'Page Info'",
"99:name *?= 'Image'",
"95:class_g = 'kwrite'",
"95:name *?= 'medit'",
"95:name *?= 'leafpad'",
"95:name *?= 'mousepad'"];

# Window type settings
wintypes:
{
  tooltip = { fade = true; shadow = false; opacity = 0.75; focus = true; };
};
I tried to include all options I found and set them to false rather than commenting them out if I don't need them.
The most important line for me was glx-use-copysubbuffermesa = true; because with all the other settings but without this one I got all windows flickering on and off in sub-second frequency.
MSI Wind Nettop, Intel Atom 230 1.6GHz (64bit), 2GB RAM
DEs: NET-minimal + (LXDE / Fluxbox / JWM); LXQt OpenRC
how to install on btrfs subvolumes
http://manjaro.github.io/donate/