Author Topic: DVD playback  (Read 474 times)

0 Members and 1 Guest are viewing this topic.

Offline Gumby

  • Jr. Mitglied
  • **
  • Posts: 52
  • Branch: stable
  • Desktop: KDE Plasma 5.5.5
  • GPU Card: nVidia GTX 780
  • GPU driver: non-free 352.79
  • Kernel: 4.4.5-1-MANJARO
  • Skill: Novice
DVD playback
« on: 14. March 2016, 04:48:29 »
I have very choppy DVD playback on VLC:  every 5-10 seconds the video will freeze and the sound will go out momentarily.  On the other hand, VLC has no problem playing high resolution media files such as mkv, etc.

But no problem with the optical drive as I am able to play DVDs and Blu-Rays in Windows without issue.

The problem is with all DVDs whether commercial with copy protection or home-made with no protection.

I have an Nvidia GTX 780 and am using the proprietary driver 352.79.  I also have the vdpau libraries installed.

Then I tried installing the mpv media player, and it plays DVD just fine!  I am fine with using mpv for all my media needs instead of VLC.  But I'm just wondering if this is a known issue with VLC, and if there is a fix.  I tried enabling hardware acceleration in VLC, etc. and it all made no difference in the choppy DVD playback.

Thanks!

Offline MadmanRB

  • Sr. Mitglied
  • ****
  • Posts: 333
  • Always thinking, always crazy
  • Branch: Stable
  • Desktop: Cinnamon 2.8.5
  • GPU Card: Intel HD Graphics 4600
  • GPU driver: Free and proprietary, depending on need
  • Kernel: 4.1.13
  • Skill: Intermediate
Re: DVD playback
« Reply #1 on: 14. March 2016, 04:57:28 »
Interesting, for me VLC works just fine in both linux and windows.
It could be a config issue of some kind, how fresh is your install of manjaro?
Insanity is only a state of mind

Offline inkrypted

  • Held Mitglied
  • *****
  • Posts: 548
  • Branch: Stable
  • Desktop: Cinnamon
  • GPU Card: Nvidia GTX 980
  • GPU driver: Latest Non Free
  • Kernel: The latest unless I need to fallback.
  • Skill: Intermediate
Re: DVD playback
« Reply #2 on: 14. March 2016, 06:22:46 »
I am using an EVGA GeForce GTX 980 Ti 06G-P4-4992-KR 6GB in my main machine and I have that issue with VLC both in Fedora and Manjaro. Since I am Using Gnome in Fedora and Cinnamon in Manjaro I switched to Gnome Videos (Formerly Totem) and it works alot better.
Inkrypted

Offline c00ter

  • Held Mitglied
  • *****
  • Posts: 1534
  • Towelie's cupcake
  • Branch: ☮Olive☮
  • Desktop: Depends©
  • GPU Card: Intel HD4400M CPU: Core i7-4510U
  • GPU driver: Intel/Free
  • Kernel: 4.4-lts & 4.5
  • Skill: Novice
Re: DVD playback
« Reply #3 on: 14. March 2016, 13:29:05 »
A lot of the time this can be an X11 issue, and changing 'sna' to 'uxa'--or the reverse--will help. TearFree is another option, but can impact framerates in games, for example. Also, if using  Xfce, then switching compositors will also help. Finally, OP, please take the time to complete your forum profile, at least fleshing out your hardware info, and please state what version and DE/WM version of Manjaro you are using. It just makes life a lot easier for all concerned. :D

Regards.
“What, me worry?” ― Alfred E. Newman

Manjaro Wiki: https://wiki.manjaro.org/
Arch Wiki: https://wiki.archlinux.org/
Pacman Rosetta: https://wiki.archlinux.org/index.php/Pacman/Rosetta

Offline beardedragon

  • Held Mitglied
  • *****
  • Posts: 500
  • Branch: Stable OpenRC & Testing Systemd
  • Desktop: Xfce 4.12.3 (Gtk 2.24.28)
  • GPU Card: NVIDIA GK208 [GeForce GT 720/PCIe/SSE2]
  • GPU driver: 4.5.0 NVIDIA 361.42(non-free)
  • Kernel: 4.4-6 & 4.6-rc5-MANJARO-x86_64
  • Skill: Advanced
Re: DVD playback
« Reply #4 on: 14. March 2016, 14:05:04 »
I changes to SMplayer and have never looked back for this very reason.  Tired many "Fixes" to no avail.
Robert Collard Madison, WI
Lenova K450e  8GB RAM
ManjaroLinux 15.12 Capella

Offline Gumby

  • Jr. Mitglied
  • **
  • Posts: 52
  • Branch: stable
  • Desktop: KDE Plasma 5.5.5
  • GPU Card: nVidia GTX 780
  • GPU driver: non-free 352.79
  • Kernel: 4.4.5-1-MANJARO
  • Skill: Novice
Re: DVD playback
« Reply #5 on: 14. March 2016, 18:21:53 »
Thanks for the replies.

I have a fresh install as of 2 weeks ago, and updated in the meantime.

I'm glad to know that I'm not the only one experiencing these issues with VLC.  It seems it may dependent on hardware and configuration.  I tried tweaking settings per advice found online, but to no avail...  I'm just happy I found a media player that will work for DVDs for me.  I uninstalled VLC since I generally don't like having redundant apps.

Where are the 'sna' and 'uxa' settings?  That is something I don't think I tried.

I have also fleshed out my profile a bit.

Thanks again.

Offline Shryp

  • Neuling
  • *
  • Posts: 10
  • I'm new. Be nice!
  • Branch: Stable
  • Desktop: XFCE
  • GPU Card: AMD A8-4500M - Radeon HD 7640G
  • GPU driver: Open Source
  • Kernel: 4.4.8-1 Manjaro
  • Skill: Intermediate
Re: DVD playback
« Reply #6 on: 14. March 2016, 19:35:12 »
Another option you have is to rip all of your DVDs to a hard drive / NAS and then use something like Kodi to play them.

Offline mandog

  • Held Mitglied
  • *****
  • Posts: 1921
  • Architect Forum And G+ Forum Owner With Daniel S
  • Branch: All
  • Desktop: Gnome, Mate, E19, Openbox,FLuxbox,Budgie, XFCE openRC,
  • GPU Card: nvidia
  • GPU driver: Non Free
  • Kernel: latest
  • Skill: Advanced
Re: DVD playback
« Reply #7 on: 14. March 2016, 19:54:03 »
Very strange Never had a problem with VLC all the others have never been any good including Mplayer that used to work well but not any more
A ENGLISHMAN IN PERU
I'm dyslexic Please do not complain about punctuation or spelling,
FANBOY,Taken from the urban dictionary
 A pathetic insult often used by fanboys themselves to try and put down people who don't like whatever it is they like.

Offline stevedude

  • Neuling
  • *
  • Posts: 41
  • I'm new. Be nice!
  • Branch: Stable
  • Desktop: Deepin
  • GPU Card: NVidia GTS 450
  • GPU driver: Non-Free
  • Kernel: linux41-x64
  • Skill: Novice
Re: DVD playback
« Reply #8 on: 15. March 2016, 18:40:30 »
VLC has always worked for me, however, here are some resources to try:

http://blog.riswan.com/2012/05/how-to-fix-slow-choppy-video-playback.html

https://wiki.videolan.org/VSG:Video:Choppy/

Also Try PREFERENCES > SHOW ALL > VIDEO CODECS> FFmpeg > Check "Allow Speed Tricks" and select "Skip the Loop Filter For All H.264 Decoding" to ALL