Poll

Did you experience any issue with this update?

No issues, everything went smoothly.
138 (73%)
Yes there was an issue. I was able to resolve it myself. (Please post your solution)
11 (5.8%)
Yes I am currently experiencing an issue due to the update. (Please post about it)
40 (21.2%)

Total Members Voted: 189

Author Topic: [Update] 2016-02-21 - Kernels, KDE, Pamac, Firefox, Thunderbird, Lumina, Intel  (Read 23474 times)

0 Members and 1 Guest are viewing this topic.

Offline philm

  • Core Team
  • *****
  • Posts: 10671
    • Manjaro Linux
  • Branch: Unstable
  • Desktop: XFCE
  • GPU Card: Geforce GTX 650
  • GPU driver: non-free
  • Kernel: Maintainer - so all ;)
  • Skill: Guru
More background about the cryptsetup issue. And yes, the story is still ongoing at upstream ...

Offline jonathon

  • Core Team
  • *****
  • Posts: 2104
  • Technologist - Teacher - Tea drinker
  • Branch: Unstable
  • Desktop: MATE 1.14
  • GPU Card: Nvidia GTX680M
  • GPU driver: Bumblebee nvidia+intel
  • Kernel: 4.6.0-*-MANJARO x86_64
  • Skill: Advanced
Some users might not realise how amazing it is to get a fix for an upstream issue so quickly. Instead of making Manjaro seem unprofessional it should reinforce the exact opposite view (e.g. Phil spending all day Sunday to fix an issue the same day it comes to light?).

We're also lucky to benefit from the excellent work Arch do - as a distro they are again incredibly responsive.

Not to pick on other OS, but, you may recall reported issues that some users had with a number of Window 10 updates bricking their PCs. The resolution took weeks (and I think some are still ongoing). That's Microsoft - a huge multinational corporation which has direct collaboration with hardware manufacturers.

Other users won't realise that there are have been vulnerable packages available to Ubuntu LTS users for _years_ - for example the Wordpress package in universe. Yeah, they don't guarantee security fixes to universe, but again, that's a large multinational company that should benefit from upstream work.

I'll come back to the points I made earlier: if you are reliant on a feature you need to have a recovery strategy in case is breaks (e.g. noone relies on only Firefox, they will have an alternate available), and if you are running multiple PCs you need to help test.
--
MSI GT70: Core i7-3630QM, 16GB, Nvidia GTX680M, Intel 2230, Manjaro-MATE-amd64-EFI
Lenovo X230: Core i5-3320M, 4GB, Intel HD4000, Intel 6205, Manjaro-MATE-amd64
Dell Studio 1749: Core i5 540, 8GB, ATi HD5650, Intel WLAN, Manjaro-Xfce-amd64
Let's go in the garden; you'll find something waiting.

Offline Foxwater

  • Neuling
  • *
  • Posts: 36
  • I'm new. Be nice!
  • Branch: Stable
  • Desktop: Xfce, KDE
  • GPU Card: ATi 7950
  • GPU driver: Free
  • Kernel: 4.1-x64
  • Skill: Novice
Smooth update on both KDE & Xfce.  Thank you
There is only one corner of the universe you can be certain of improving, and that's your own self.

Aldous Huxley

Offline maz5

  • Neuling
  • *
  • Posts: 42
  • Branch: stable
  • Desktop: Xfce
  • Kernel: 4.4
  • Skill: Intermediate
Good update without any problems, thank you very much team!!!

Offline rjonasz

  • Neuling
  • *
  • Posts: 25
  • I'm new. Be nice!
  • Branch: stable
  • Desktop: KDE 5 Plasma
  • GPU Card: nVidia GTX 980M
  • GPU driver: non-free
  • Kernel: 4.4.0-4-MANJARO
  • Skill: Intermediate
are the spl-utils and zfs-utils also installed?

Here's a little more info about my zfs set up:
Code: [Select]

    └─[$]> pacman -Ss zfs
    extra/linux310-zfs 0.6.5.4-2 (linux310-extramodules)
        Kernel modules for the Zettabyte File System.
    extra/linux312-zfs 0.6.5.4-1 (linux312-extramodules)
        Kernel modules for the Zettabyte File System.
    extra/linux313-zfs 0.6.5.4-2 (linux313-extramodules)
        Kernel modules for the Zettabyte File System.
    extra/linux314-zfs 0.6.5.4-2 (linux314-extramodules)
        Kernel modules for the Zettabyte File System.
    extra/linux316-zfs 0.6.5.4-2 (linux316-extramodules)
        Kernel modules for the Zettabyte File System.
    extra/linux318-zfs 0.6.5.4-2 (linux318-extramodules)
        Kernel modules for the Zettabyte File System.
    extra/linux319-zfs 0.6.5.4-3 (linux319-extramodules)
        Kernel modules for the Zettabyte File System.
    extra/linux41-zfs 0.6.5.4-3 (linux41-extramodules) [installed: 0.6.5.4-1]
        Kernel modules for the Zettabyte File System.
    extra/linux42-zfs 0.6.5.4-3 (linux42-extramodules)
        Kernel modules for the Zettabyte File System.
    extra/linux43-zfs 0.6.5.4-3 (linux43-extramodules)
        Kernel modules for the Zettabyte File System.
    extra/linux44-zfs 0.6.5.4-3 (linux44-extramodules) [installed: 0.6.5.4-1]
        Kernel modules for the Zettabyte File System.
    extra/linux45-zfs 0.6.5.4-0.3 (linux45-extramodules)
        Kernel modules for the Zettabyte File System.
    extra/spl-dkms 0.6.5.4-1 (manjarozfs)
        Solaris Porting Layer kernel modules.
    extra/spl-utils 0.6.5.4-1 (manjarozfs) [installed]
        Solaris Porting Layer User-Mode utils
    extra/zfs-dkms 0.6.5.4-1 (manjarozfs)
        Kernel modules for the Zettabyte File System.
    extra/zfs-utils 0.6.5.4-1 (manjarozfs) [installed]
        User-Mode utils for the Zettabyte File System.
    community/zfs-openrc 20151014-1 (openrc-misc)
        OpenRC zfs init script

Version 0.6.5.4-1 works.  Versions 0.6.5.4-2 and 0.6.5.4-3 of zfs do not.  The encryption problem has been resolved for me.

Offline pianoplayer

  • Neuling
  • *
  • Posts: 21
  • I'm new. Be nice!
  • Skill: Novice
After this last upgrade, the only issue I have is that when trying to reboot/shutdown, the system hangs with an error message (see attachment) for a while (maybe 30 seconds, I'm not exactly sure).

This happens with the 4.4.2 kernel, but not with 4.1.18.

I am having a very similar issue after the latest update (see attachment).  The system hangs with kernel 4.4.2 and 4.1.18. I havent had this error before.

Offline heyne001

  • Neuling
  • *
  • Posts: 10
  • I'm new. Be nice!
  • Skill: Novice
Kudos! Three absolutely marvelous post! Thank you, heyne001!

Maybe just one addition:
Code: [Select]
# cp /etc/resolv.conf etc/resolv.confbefore running chroot command.

Thanks man!

Just trying to help other newbies like me as I learn myself.

Also, 4.1.18 kernel works for me now as well. Maybe it's because I reinstalled it earlier or did something else - can't really remember, as I messed around quite a bit.

Anyway, thanx to the Manjaro support crew for the instructions/updates and keeping its users informed. I have to say I've really learned a lot because of this little hiccup. Before that I didn't know how to chroot into my system like that. Now I know.

Offline eugen-b

  • Support Team
  • ****
  • Posts: 3191
  • Branch: testing
  • Desktop: LXDE, Fluxbox, JWM, LXQt, bspwm
  • GPU Card: Intel 82945G/GZ
  • GPU driver: free
  • Kernel: 4.5, 4.6
  • Skill: Intermediate
I am having a very similar issue after the latest update (see attachment).  The system hangs with kernel 4.4.2 and 4.1.18. I havent had this error before.
I've done a web search for "boot error ata1.00: exception Emask 0x40 SAct 0x0 SErr 0xc0800 action 0x6" since this is a line you both have in your pictures. There are some hits, seem to be an issue with Western Digital HDD under heavy load [added text in italics] in some of them, but needs more reading to have a more complete picture.
Edit: Try adding 'acpi=off noapic' to the kernel parameters. Source (but a bit old): https://bugzilla.redhat.com/show_bug.cgi?id=462425#c80
Edit2: Could be also a bad or badly connected SATA cable, but unlikely in two cases.
Edit3: you could try running sudo fsck -a /dev/sdX with X being a or b, the name of your drive.
Edit4: Could be a dead SATA port - change the cable to the other port.

@heyne001, kernel 4.1.18 works for you now because you updated cryptsetup, I guess.
« Last Edit: 23. February 2016, 00:15:46 by eugen-b »
MSI Wind Nettop, Intel Atom 230 1.6GHz (64bit), 2GB RAM
DEs: NET-minimal + (LXDE / Fluxbox / JWM); LXQt OpenRC
how to install on btrfs subvolumes
http://manjaro.github.io/donate/

Offline Shadow Warrior

  • Mirror Support Team
  • ***
  • Posts: 671
  • Branch: Testing
  • Desktop: openbox from first ever version
  • GPU Card: Advanced Micro Devices [AMD/ATI] Wrestler [Radeon HD 6250]
  • GPU driver: non free
  • Kernel: Linux manjaro 4.4.8-1-MANJARO i686
  • Skill: Novice
I had an Issue ...

after downloading for one rather long time ...and the following install ..(have almost dial up type speeds atm..so not impressed seeing such a big update.
I ended up with a warning about a corrupted package or PGP signature from Thorsten Topper ( regional extras on letters unavailable)

I believe the package was called "Confuse"   
it asked if id like to delete which i did ..but that then said nothing had been updated... 

I have a problem from a previous update with Tint2 crashing...so i cant open browser / terminall etc  without it all crashing (segfault) (hence unable to post actual wording)..which is supposedly corrected with todays update ..now i dont have it ..and may have to go through hours of downloading and get another failed update..

can you reply re when the packages is no longer corrupted or signature is fixed

Offline AJSlye

  • Maintainer
  • ***
  • Posts: 4298
  • Netrunner Rolling Edition moderator / maintainer
  • Branch: Stable / Testing / Unstable
  • Desktop: Netrunner Rolling
  • GPU Card: Intel
  • GPU driver: Intel
  • Kernel: 4.4.1-1-MANJARO x86_64 (64 bit)
  • Skill: Guru
I had an Issue ...

after downloading for one rather long time ...and the following install ..(have almost dial up type speeds atm..so not impressed seeing such a big update.
I ended up with a warning about a corrupted package or PGP signature from Thorsten Topper ( regional extras on letters unavailable)

I believe the package was called "Confuse"   
it asked if id like to delete which i did ..but that then said nothing had been updated... 

I have a problem from a previous update with Tint2 crashing...so i cant open browser / terminall etc  without it all crashing (segfault) (hence unable to post actual wording)..which is supposedly corrected with todays update ..now i dont have it ..and may have to go through hours of downloading and get another failed update..

can you reply re when the packages is no longer corrupted or signature is fixed


No it will only re-download that package as long as you don't clear the cache.
try this:
Code: [Select]
sudo pacman -S arch-keyring manjaro-keyring
sudo pacman -Syu

Offline Shadow Warrior

  • Mirror Support Team
  • ***
  • Posts: 671
  • Branch: Testing
  • Desktop: openbox from first ever version
  • GPU Card: Advanced Micro Devices [AMD/ATI] Wrestler [Radeon HD 6250]
  • GPU driver: non free
  • Kernel: Linux manjaro 4.4.8-1-MANJARO i686
  • Skill: Novice
Ok Thanks a lot  I will try again when i have a better connection...can't cope with all that again in the same day..

Have tried again same result
Code: [Select]
:: Proceed with installation? [Y/n] y
:: Retrieving packages ...
 confuse-2.8-2-i686        34.7 KiB   104K/s 00:00 [######################] 100%
(166/166) checking keys in keyring                 [######################] 100%
(166/166) checking package integrity               [######################] 100%
error: confuse: signature from "Thorsten Töpper <atsutane@freethoughts.de>" is unknown trust
:: File /var/cache/pacman/pkg/confuse-2.8-2-i686.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.

this is what it is
Quote
confuse
C-library for parsing configuration files


URL
https://github.com/martinh/libconfuse
Version
2.8-2 (outdated installed version is 2.7-3)
Licenses
LGPL
Depends On
glibc
Download Size
34.74 KiB
Installed Size
115.00 KiB
Packager
Thorsten Töpper <atsutane@freethoughts.de>
Architecture
i686
Build Date
Mon - 25/01/2016 05:02:04
« Last Edit: 23. February 2016, 07:03:56 by Shadow Warrior »

Offline cb474

  • Vollwertiges Mitglied
  • ***
  • Posts: 169
I normally run the 4.4 kernel, but also keep 4.1 (or whatever is LTS at the time) on my system as a backup. I did the upgrade today, so the latest version of cryptsetup that fixes the encryption bug was already in the stable repo. So I have cryptsetup 1.7.0-1.1 on my system.

Rebooting into the 4.4 kernel worked fine. But if I try to boot into 4.1 I get the notorious error, "Check that kernel supports aes-xts-plain64 cipher (check syslog for more info)."

Isn't cryptsetup 1.7.0-1.1 supposed to fix this? Shouldn't I be able to boot into 4.1 also?

Offline jonathon

  • Core Team
  • *****
  • Posts: 2104
  • Technologist - Teacher - Tea drinker
  • Branch: Unstable
  • Desktop: MATE 1.14
  • GPU Card: Nvidia GTX680M
  • GPU driver: Bumblebee nvidia+intel
  • Kernel: 4.6.0-*-MANJARO x86_64
  • Skill: Advanced
So I have cryptsetup 1.7.0-1.1 on my system.

I believe the current (working) version is 1.7.0-2.
--
MSI GT70: Core i7-3630QM, 16GB, Nvidia GTX680M, Intel 2230, Manjaro-MATE-amd64-EFI
Lenovo X230: Core i5-3320M, 4GB, Intel HD4000, Intel 6205, Manjaro-MATE-amd64
Dell Studio 1749: Core i5 540, 8GB, ATi HD5650, Intel WLAN, Manjaro-Xfce-amd64
Let's go in the garden; you'll find something waiting.

Offline gadgetboi

  • Neuling
  • *
  • Posts: 24
  • I'm new. Be nice!
    • da gadgetboi's blog
  • Branch: stable
  • Desktop: KDE, Deepin, Cinnamon
  • Skill: Novice
I have problem with my KDE. I tried to update my system (which have 248 pakages to update) today but seem that there's error and it say
"error: failed to commit transaction (conflicting files)
manjaro-base-skel: /etc/skel/.dir_colors exists in filesystem
Errors occurred, no packages were upgraded."

I check and there's still 248 pakages ... i tried to sync and re-update but it's no good and still there ... i've tried 3 times with no luck.

Anyone had experience as I do? please share

Offline jonathon

  • Core Team
  • *****
  • Posts: 2104
  • Technologist - Teacher - Tea drinker
  • Branch: Unstable
  • Desktop: MATE 1.14
  • GPU Card: Nvidia GTX680M
  • GPU driver: Bumblebee nvidia+intel
  • Kernel: 4.6.0-*-MANJARO x86_64
  • Skill: Advanced
That was covered earlier in the thread. If you still need help after reading back, start a new thread.
--
MSI GT70: Core i7-3630QM, 16GB, Nvidia GTX680M, Intel 2230, Manjaro-MATE-amd64-EFI
Lenovo X230: Core i5-3320M, 4GB, Intel HD4000, Intel 6205, Manjaro-MATE-amd64
Dell Studio 1749: Core i5 540, 8GB, ATi HD5650, Intel WLAN, Manjaro-Xfce-amd64
Let's go in the garden; you'll find something waiting.