Author Topic: Switching Flavors  (Read 1281 times)

0 Members and 1 Guest are viewing this topic.

Offline rhg135

  • Neuling
  • *
  • Posts: 7
  • computers are supposed to make life easier...
    • tehblog
  • Branch: stable
  • Desktop: i3
  • GPU Card: A10-4600M APU
  • GPU driver: free
  • Kernel: linux314-x64
  • Skill: Intermediate
Switching Flavors
« on: 15. February 2016, 03:57:21 »
Hello manjaro people. I am currently running a manjaro plasma build; then later I saw the light of i3 and excised plasma from it.
One day (today) I saw this on the manjaro homepage and thought it looked cool, and thus I fired up virtualbox, and I liked it.
This leads me to ask, how to move to this config while keeping my home?

Fortunately when I installed I had enough foresight to keep /home/rhg135 on a seperate partition. Reinstalling and removing some config files on ~ beforehand may be the way to go,
but I could not figure out which.
I cannot always be at a computer, thus replies may be delayed if they require being at one.

Offline Chrysostomus

  • Maintainer
  • ***
  • Posts: 1634
  • Neckbeards are cool
    • Git
  • Branch: unstable
  • Desktop: Gnome, bspwm
  • GPU Card: Intel HD4000
  • GPU driver: free
  • Kernel: linux44-x64
  • Skill: Intermediate
Re: Switching Flavors
« Reply #1 on: 15. February 2016, 11:56:08 »
1. Install these packages: https://github.com/manjaro/manjaro-tools-iso-profiles/blob/master/community/bspwm/Packages-Bspwm
You may need
Code: [Select]
sudo pacman -fWith manjaro-bspwm-settings, but that is the important one.

2) in your file manager, copy contents of /etc/skel/ to your $HOME. Overwrite any files you have not edited yourself.

2b) alternative: create new user and copy your data to that users $HOME. New users get their defaults from /etc/skel

Offline rhg135

  • Neuling
  • *
  • Posts: 7
  • computers are supposed to make life easier...
    • tehblog
  • Branch: stable
  • Desktop: i3
  • GPU Card: A10-4600M APU
  • GPU driver: free
  • Kernel: linux314-x64
  • Skill: Intermediate
Re: Switching Flavors
« Reply #2 on: 15. February 2016, 21:02:17 »
Ah! That is very helpful. Thanks for everything so far.

May I ask how updates to config files are managed. I understand normally pacman just places .pac* files along side if they are changed; so does that mean the new files can be found in /etc/skel?

EDIT: manjaro-bspwm-settings and bspwm-manjaro both have the skeleton files for bspwm and sxhkd. I kept the ones from the latter if it matters.
« Last Edit: 15. February 2016, 21:35:56 by rhg135 »
I cannot always be at a computer, thus replies may be delayed if they require being at one.

Offline Chrysostomus

  • Maintainer
  • ***
  • Posts: 1634
  • Neckbeards are cool
    • Git
  • Branch: unstable
  • Desktop: Gnome, bspwm
  • GPU Card: Intel HD4000
  • GPU driver: free
  • Kernel: linux44-x64
  • Skill: Intermediate
Re: Switching Flavors
« Reply #3 on: 16. February 2016, 02:10:36 »
Yeah the latter ones are more up to date, the former should not even have those anymore.

Offline rhg135

  • Neuling
  • *
  • Posts: 7
  • computers are supposed to make life easier...
    • tehblog
  • Branch: stable
  • Desktop: i3
  • GPU Card: A10-4600M APU
  • GPU driver: free
  • Kernel: linux314-x64
  • Skill: Intermediate
Re: Switching Flavors
« Reply #4 on: 20. February 2016, 22:56:36 »
I got it running and have some issues that I'm certain are due to user error, but I don't see it.
  1. I installed the packages, keeping the bspwm-manjaro .configs.
  2. I set copied everything in /etc/skel with `rsync -RP /etc/skel/ ~rhg135/`
  3. I logged in and there
    a) was no panel, which strangely works if I manually start `lemonpanel`
    b) there is a noticable lag when switching workspaces with the keyboard as opposed to the bar
    c) the default terminal is bound to urxvtc, but urxvtd is not started
    d) I reverted back to my previus zsh files, I'm still unsure if anything important is missing, this was after the above was tested
    e) compton tends to black out some unfocused windows
    f) roxterm now lauches midori by default and I can't find a way to change it.

Fortunately dmenu worked flawlessly and was able to launch any app I wanted. And I'm writing this from firefox within bspwm.
I cannot always be at a computer, thus replies may be delayed if they require being at one.

Offline Chrysostomus

  • Maintainer
  • ***
  • Posts: 1634
  • Neckbeards are cool
    • Git
  • Branch: unstable
  • Desktop: Gnome, bspwm
  • GPU Card: Intel HD4000
  • GPU driver: free
  • Kernel: linux44-x64
  • Skill: Intermediate
Re: Switching Flavors
« Reply #5 on: 21. February 2016, 10:22:20 »
Can you post your .xinitrc? does it run
Code: [Select]
bspwm or
Code: [Select]
bspwm-session?

Offline Chrysostomus

  • Maintainer
  • ***
  • Posts: 1634
  • Neckbeards are cool
    • Git
  • Branch: unstable
  • Desktop: Gnome, bspwm
  • GPU Card: Intel HD4000
  • GPU driver: free
  • Kernel: linux44-x64
  • Skill: Intermediate
Re: Switching Flavors
« Reply #6 on: 21. February 2016, 10:24:21 »
Default terminal should be "terminal", which starts urxvtd if it is not running.

For midori thing, check your $BROWSER variable. Probably in ~/.profile.

Offline Chrysostomus

  • Maintainer
  • ***
  • Posts: 1634
  • Neckbeards are cool
    • Git
  • Branch: unstable
  • Desktop: Gnome, bspwm
  • GPU Card: Intel HD4000
  • GPU driver: free
  • Kernel: linux44-x64
  • Skill: Intermediate
Re: Switching Flavors
« Reply #7 on: 21. February 2016, 10:31:11 »
In roxterm, right click terminal. From menu choose Preferences-> Edit current profile -> Net urls. you can choose browser there.

Offline rhg135

  • Neuling
  • *
  • Posts: 7
  • computers are supposed to make life easier...
    • tehblog
  • Branch: stable
  • Desktop: i3
  • GPU Card: A10-4600M APU
  • GPU driver: free
  • Kernel: linux314-x64
  • Skill: Intermediate
Re: Switching Flavors
« Reply #8 on: 21. February 2016, 21:47:08 »
I had forgotten zsh sourced .profile and was confused where some variables came from.

Indeed BROWSER is set to midori here, although I had not noticed due to the fact that
it's set to xdg-open later by .zshenv. As for the terminal, the sxhkd config actually
calls $TERMINAL which can't be set to terminal as it does work when launched via
dmenu. So if I set it to roxterm in .zshenv I think I'll be good. I have attached an
xz compressed xinitrc, but I did check and it calls bspwm-session.
I cannot always be at a computer, thus replies may be delayed if they require being at one.

Offline Chrysostomus

  • Maintainer
  • ***
  • Posts: 1634
  • Neckbeards are cool
    • Git
  • Branch: unstable
  • Desktop: Gnome, bspwm
  • GPU Card: Intel HD4000
  • GPU driver: free
  • Kernel: linux44-x64
  • Skill: Intermediate
Re: Switching Flavors
« Reply #9 on: 22. February 2016, 01:34:09 »
dmenu sources .dmenurc and takes its terminal from there