Author Topic: padding settings bug  (Read 1065 times)

0 Members and 1 Guest are viewing this topic.

Offline TenShiN

  • Jr. Mitglied
  • **
  • Posts: 66
  • I like potatoes.
  • Branch: stable
  • Desktop: bspwm+xfce4-panel
  • Skill: Intermediate
padding settings bug
« on: 10. February 2016, 08:24:06 »
for some reason after update on testing branch today bspwm doesn't respect my padding rules. whatever I set, it gets override I think, but I can't even understand where else padding rules can be set besides bspwmrc. if I change settings with a terminal after, everything works fine.
« Last Edit: 10. February 2016, 09:35:26 by TenShiN »

Offline Chrysostomus

  • Maintainer
  • ***
  • Posts: 1634
  • Neckbeards are cool
    • Git
  • Branch: unstable
  • Desktop: Gnome, bspwm
  • GPU Card: Intel HD4000
  • GPU driver: free
  • Kernel: linux44-x64
  • Skill: Intermediate
Re: padding settings bug
« Reply #1 on: 10. February 2016, 10:42:13 »
Post your bspwmrc and autostart filre, I'll take a look.

Offline TenShiN

  • Jr. Mitglied
  • **
  • Posts: 66
  • I like potatoes.
  • Branch: stable
  • Desktop: bspwm+xfce4-panel
  • Skill: Intermediate
Re: padding settings bug
« Reply #2 on: 10. February 2016, 11:15:23 »
thx for the quick response

Code: [Select]
#! /bin/sh
export BSPWM_SCRIPTS_DIR="$HOME/scripts"
gap=30
PANEL_HEIGHT=40
export gap
export PANEL_HEIGHT

bspc config window_gap $gap
bspc config bottom_padding 40
bspc config gapless_monocle true
bspc config borderless_monocle true
bspc config single_monocle true
bspc config adaptative_raise true
bspc config apply_floating_atom true
bspc config history_aware_focus true
bspc config remove_disabled_monitors true
bspc config remove_unplugged_monitors true
bspc config normal_frame_opacity 1.0
bspc config focused_frame_opacity 1.0
bspc config focused_border_color "#5294E2"
bspc config normal_border_color "#2B2E39"
bspc config presel_feedback_color "#5294E2"
bspc config border_width 5
bspc config auto_alternate true
bspc config auto_cancel true
bspc config split_ratio 0.50
bspc monitor -d Deadbeef Main Reserve Reserve_2

bspc rule -a gcolor2 state=floating center=true
bspc rule -a lxappearance state=floating center=true
bspc rule -a gmrun state=floating center=true
bspc rule -a lxterminal state=floating center=true sticky=true
bspc rule -a file-roller state=floating center=true
bspc rule -a Firefox desktop=^2
bspc rule -a Wrapper-1.0 state=floating center=false border=false
bspc rule -a Screenruler border=off
bspc rule -a Xfce4-taskmanager state=floating center=true
#bspc rule -a Xfce4-panel -o manage=true border=false
bspc rule -a PyPanel manage=true border=false

#autogap &
bspc config external_rules_command /usr/bin/pseudo_automatic_mode

Code: [Select]
pulseaudio --start &
xsetroot -cursor_name left_ptr &
export GTK2_RC_FILES="$HOME/.gtkrc-2.0" &
xrdb merge .Xresources &
nitrogen --restore &
#pypanel &
xfce4-panel -d &
compton &
xset +fp /usr/share/fonts/local &
xset +fp /usr/share/fonts/misc &
xset +fp ~/.fonts &
xset fp rehash &
fc-cache -fv &
devmon &
xset s off &
xset s noblank &
xset s noexpose &
xset c on &
xset -dpms &
xbacklight -set 15 &
setxkbmap -model pc104 -layout us,ru -variant us -option grp:alt_shift_toggle &
/usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1 &
deadbeef &
firefox-aurora &
pamac-tray &

I also tried to set number for bottom_padding manually, still didn't worked.
« Last Edit: 10. February 2016, 11:21:19 by TenShiN »

Offline Chrysostomus

  • Maintainer
  • ***
  • Posts: 1634
  • Neckbeards are cool
    • Git
  • Branch: unstable
  • Desktop: Gnome, bspwm
  • GPU Card: Intel HD4000
  • GPU driver: free
  • Kernel: linux44-x64
  • Skill: Intermediate
Re: padding settings bug
« Reply #3 on: 10. February 2016, 12:23:42 »
Hmm...
Often this kind of thing is caused by creating workspaces before setting padding (padding applies only to desktop created after setting it). But that is not your case.

Try putting something like this at the end of your bspwmrc:
Code: [Select]
for monitor in $(bspc query -M); do
bspc config -m $monitor bottom_padding 40; done

Offline TenShiN

  • Jr. Mitglied
  • **
  • Posts: 66
  • I like potatoes.
  • Branch: stable
  • Desktop: bspwm+xfce4-panel
  • Skill: Intermediate
Re: padding settings bug
« Reply #4 on: 10. February 2016, 15:05:08 »
I found and fixed an issue. sry, it seems I edited my bspwmrc after I gave up fixing it, commenting autogap because I didn't liked it. didn't thought it can be an issue, when I rebooted everything worked, I checked again by uncommenting it and yep, it seems if padding is set before autogap it bugs. thx for the help anyway and sorry for taken time.

Offline Chrysostomus

  • Maintainer
  • ***
  • Posts: 1634
  • Neckbeards are cool
    • Git
  • Branch: unstable
  • Desktop: Gnome, bspwm
  • GPU Card: Intel HD4000
  • GPU driver: free
  • Kernel: linux44-x64
  • Skill: Intermediate
Re: padding settings bug
« Reply #5 on: 11. February 2016, 02:44:56 »
No problem!
Yes, autogap resets padding to get rid of negative padding that is default for the edition.