Poll

Did you experience any issue with this update?

No issues, everything went smoothly.
111 (84.1%)
Yes there was an issue. I was able to resolve it myself. (Please post your solution)
10 (7.6%)
Yes I am currently experiencing an issue due to the update. (Please post about it)
11 (8.3%)

Total Members Voted: 132

Author Topic: [Update] 2016-01-13 - Kernels, Plasma 5.5.3, Firefox 43.0.4, Manjaro-Tools 0.10  (Read 8226 times)

0 Members and 1 Guest are viewing this topic.

Offline epidenimus

  • Neuling
  • *
  • Posts: 4
  • Branch: Stable
  • Desktop: Cinnamon and KDE
  • Skill: Intermediate
Updated my Cinnamon laptop.  All went smoothly, but had to manually force install the new DE-specific settings package via:
Code: [Select]
pacman -S --force manjaro-cinnamon-settings
This fixed a couple of little things, most immediately noticeable is that my correct profile avatar now appears on the LightDM login screen.  Yay!

It might be nice to include, with each stable update, lists of any packages to manually add/remove for those who have existing installs, rather than making us guess at the names of those packages.  ;-)  This one was pretty easy though.

Offline Ars Technis

  • Neuling
  • *
  • Posts: 17
  • Linux gamer - OBS French translator
  • Branch: Stable
  • Desktop: KDE Plasma 5.6
  • GPU Card: Intel HD4600 / nVidia GTX 860M
  • GPU driver: Hybrid Non-free
  • Kernel: 4.4 (x64)
  • Skill: Intermediate
Re: Screen flickering in KDE with intel graphic card
« Reply #16 on: 13. January 2016, 16:58:32 »
Hi!

Everything went smooth with the upgrade of the KDE edition except 1 thing: terrible screen flickering occurs. My system uses bumblebee, but I assume that this problem might occur for anyone using Intel graphics.

So for everyone running into this issue: use DRI3, and the problem vanishes.

To enable DRI3 edit the file /etc/X11/mhwd.d/intel.conf,

in the 'Device' section, replace the line:
Option      "DRI"    "true"
by
Option      "DRI"    "3"

Had the same problem (flickering screen on SDDM login & Bumblebee here too) but this solution works for me ! Thanks ! :D

Offline neil1969

  • Neuling
  • *
  • Posts: 40
  • Branch: All
  • Desktop: XFCE 4.12
  • GPU Card: Intel Ivybridge Mobile / AMD R7 250X
  • GPU driver: Free / Non-Free
  • Kernel: Linux44-x64 / Linux 44-x64
  • Skill: Intermediate
Had the same problem many others did, with the Intel Graphics.  Changed DRI from true to 3 in intel.conf and it got rid of the flickering issues.  Moved up to kernel 4.4.0-1 also no issues.  Things seem like they are getting more stable, and my boot time continues to drop.  Very pleased.  Thanks for all the hard work.

Offline JairoAV25

  • Neuling
  • *
  • Posts: 9
  • Branch: Stable
  • Desktop: KDE
  • GPU Card: GTX 660
  • GPU driver: non-free
  • Kernel: 4.4.0-1-MANJARO-X64
  • Skill: Intermediate
updated one optimus machine, I had the same problem expressed here by Cubanpit
https://forum.manjaro.org/index.php?topic=30068.0

solved with Cubanpit suggestion
Code: [Select]
Section "Device"
Identifier  "Device0"
Driver      "intel"
BusID       "PCI:0:2:0"
Option      "AccelMethod" "sna"
Option      "DRI"    "3"

I dunno if I've to add "TearFree" option too...

Can confirm this too. Asus Laptop with Intel & Gerforce 820M Using Bumblebee, Flickering Issue...
Just ArchLinux User. . .

Offline schnelle

  • Jr. Mitglied
  • **
  • Posts: 73
  • Branch: stable/testing
  • Desktop: Plasma 5
  • GPU Card: intel
  • GPU driver: free
  • Skill: Intermediate
Flickering issue is introduced by qt5-base update. Downgrading qt5-base fixes the flickering problem.

So if one updates qt5-base, screen flickers under plasma 5 with intel gpu. Fixes/workarounds:
1) with updated qt5-base you have to set DRI to "3" or
2) downgrade qt5-base (works without screen flickering with default DRI2).

Tested both workarounds myself.

Offline beardedragon

  • Held Mitglied
  • *****
  • Posts: 500
  • Branch: Stable OpenRC & Testing Systemd
  • Desktop: Xfce 4.12.3 (Gtk 2.24.28)
  • GPU Card: NVIDIA GK208 [GeForce GT 720/PCIe/SSE2]
  • GPU driver: 4.5.0 NVIDIA 361.42(non-free)
  • Kernel: 4.4-6 & 4.6-rc5-MANJARO-x86_64
  • Skill: Advanced
Well done, stable update without problems, Thanks Team.
Robert Collard Madison, WI
Lenova K450e  8GB RAM
ManjaroLinux 15.12 Capella

Offline Nergal

  • Neuling
  • *
  • Posts: 44
  • Branch: Stable
  • Desktop: KDE Plasma 5
  • GPU Card: Intel / nVidia GTX 970M
  • GPU driver: non-free
  • Kernel: 4.4.3-1
  • Skill: Novice
A smooth update as always!!

I do not have any screen flickering with Bumblebee either.
___________________________________
MSI GS60 Ghost Pro 3K- i7-4710HQ - 16GB

Offline KabirGandhiok

  • Jr. Mitglied
  • **
  • Posts: 70
  • Branch: Stable
  • Desktop: Gnome / Xfce
  • GPU driver: Free
  • Kernel: 41 / 44
  • Skill: Novice
Another smooth update, besides the flickering issue, which I fixed by setting DRI to 3, as described by other users, thanks! And big thanks to the manjaro team too for putting together such an amazing dirsto, absolutely love it! :-D Linux44 works flawlessly.

By the way, wasn't linux44 supposed to be LTS, I'm just wondering because in the settings manager it doesn't show as LTS.

Offline israuor

  • Neuling
  • *
  • Posts: 11
  • Branch: stable
  • Desktop: Gnome 3.18
  • GPU Card: Card-1: Intel 4th Gen Core Processor Integrated Graphics Controller Card-2: NVIDIA GK107M [GeForce GT 755M]
  • GPU driver: nonfree bumblebee drivers
  • Kernel: linux44
  • Skill: Advanced
got following error:

Code: [Select]
error: failed to commit transaction (conflicting files)
lib32-libgnutls28: /usr/lib32/libgnutls.so.28 exists in filesystem
Errors occurred, no packages were upgraded.
yaourt -Syua  24.97s user 6.70s system 1% cpu 51:45.36 total

what to do?   

removed the file... and works ;)
« Last Edit: 13. January 2016, 20:37:39 by israuor »

Offline schnelle

  • Jr. Mitglied
  • **
  • Posts: 73
  • Branch: stable/testing
  • Desktop: Plasma 5
  • GPU Card: intel
  • GPU driver: free
  • Skill: Intermediate

Offline Foxwater

  • Neuling
  • *
  • Posts: 36
  • I'm new. Be nice!
  • Branch: Stable
  • Desktop: Xfce, KDE
  • GPU Card: ATi 7950
  • GPU driver: Free
  • Kernel: 4.1-x64
  • Skill: Novice
Smooth update both KDE & Xfce.  Thank you!
There is only one corner of the universe you can be certain of improving, and that's your own self.

Aldous Huxley

Offline Maycne Sonahoz

  • Neuling
  • *
  • Posts: 22
  • Branch: stable
  • Desktop: xfce
  • GPU Card: MSI GTX 660Ti
  • GPU driver: non-free (video-nvidia)
  • Kernel: linux 44-x64
  • Skill: Intermediate
Libtorrent updated, Deluge keeps working, i'm happy.
Thanks!  ;D

Offline lexuvar

  • Neuling
  • *
  • Posts: 11
  • I'm new. Be nice!
  • Branch: stable
  • Desktop: Gnome
  • GPU Card: Nvidia GTX 550 Ti
  • GPU driver: non-free
  • Kernel: linux41-x64
  • Skill: Intermediate
Well done! But the problem with Budgie Desktop (10.2.2-2): keyboard layout switching (Settings->Keyboard->Key's combinations tab->Modificator key->Ctrl-Shift -- doesn't work!) and still no keyboard layout and language indicator -- still doesn't work. It's critical. In full Gnome desktop that works.
« Last Edit: 13. January 2016, 22:14:58 by lexuvar »

Offline joshuadunamis

  • Vollwertiges Mitglied
  • ***
  • Posts: 119
  • Finally on the Arch Linux world with Manjaro KDE
  • Branch: stable
  • Desktop: Plasma 5.6.3
  • GPU Card: Intel HD Graphics 4000
  • GPU driver: free
  • Kernel: Kernel: 4.4.8-1-MANJARO x86_64
  • Skill: Intermediate
Re: Screen flickering in KDE with intel graphic card
« Reply #28 on: 14. January 2016, 01:43:18 »
Hi!

Everything went smooth with the upgrade of the KDE edition except 1 thing: terrible screen flickering occurs. My system uses bumblebee, but I assume that this problem might occur for anyone using Intel graphics.

So for everyone running into this issue: use DRI3, and the problem vanishes.

To enable DRI3 edit the file /etc/X11/mhwd.d/intel.conf,

in the 'Device' section, replace the line:
Option      "DRI"    "true"
by
Option      "DRI"    "3"

Smooth update!!! Only the same flickering issue solved as above...
Since nearly 2003 to today I never installed anyelse than GNU/Linux OS...

 My actual OS: Manjaro Linux 15.12 KDE (Capella) on Asus X551CA-SX024D

Italian IRC channel on Freenode: #manjaro-it

Offline scachemaille

  • Held Mitglied
  • *****
  • Posts: 528
  • I'm new. Be nice!
  • Branch: Unstable
  • Desktop: Plasma 5
  • GPU Card: nVidia GT 330M
  • GPU driver: Nouveau
  • Kernel: 4.8_x64
  • Skill: Intermediate
Qt5-base 5.5.1-8 problems
it seems a quick fix in qt5-base in arch repos for upcoming nvidia-361.16  broke things with intel and nouveau drivers
https://bbs.archlinux.org/viewtopic.php?id=207492
https://bugs.archlinux.org/task/47739
https://bbs.archlinux.org/viewtopic.php?id=207483

the workaround with DRI3 for intel seems to work,
but It doesn't work for nouveau drivers on my systems.  I didn't found any workaround beside downgrading. :(
« Last Edit: 14. January 2016, 02:29:45 by scachemaille »