Author Topic: Terminal misbehavin  (Read 2767 times)

0 Members and 1 Guest are viewing this topic.

Offline redart

  • Neuling
  • *
  • Posts: 45
  • I'm new. Be nice!
  • Branch: stable
  • Desktop: Xfce 15.12-rc2 Capella
  • GPU Card: Intel Mobile 4
  • GPU driver: free
  • Kernel: 4.1.15-1-MANJARO x86_64
  • Skill: Novice
Re: Terminal misbehavin
« Reply #15 on: 28. October 2015, 12:41:12 »
Tried mdm, lxdm, slim, startx,.......now got a new problem - Switch option doesn't work  :-[.  So I thought....."aahhhaa...there's no-one to switch to as I'm the only account!".  So added two new accounts.  Can log in and out of each, but the Switch option still wont work  >:(    What have I missed?

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: Terminal misbehavin
« Reply #16 on: 28. October 2015, 12:58:21 »
Oh. well... ;) Oblogout-manjaro at the moment assumes that we use Lightdm ::)
The switch-user command is to be found in /etc/oblogout.conf
At the moment it says
Code: [Select]
switch = dm-tool switch-to-greeterWe'll need to change that to the respective command for a different dm/greeter. For lxdm that would be
Code: [Select]
switch = lxdm -c USER_SWITCH
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline redart

  • Neuling
  • *
  • Posts: 45
  • I'm new. Be nice!
  • Branch: stable
  • Desktop: Xfce 15.12-rc2 Capella
  • GPU Card: Intel Mobile 4
  • GPU driver: free
  • Kernel: 4.1.15-1-MANJARO x86_64
  • Skill: Novice
Re: Terminal misbehavin
« Reply #17 on: 28. October 2015, 14:25:47 »
Well the bad news is that the answer seems to be "sometimes".  Using lxdm I can switch back and forth and usually the terminal window will place fine, but occasionally it still gets stuck at top right. Seems kinda random too so no real insight into what's happening  :-[   Sorry.

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: Terminal misbehavin
« Reply #18 on: 28. October 2015, 14:38:25 »
Ok. Thank you very much for your investigation! :)
Can you confirm though that restarting fluxbox with "fluxbox-remote restart" fixes it?
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline redart

  • Neuling
  • *
  • Posts: 45
  • I'm new. Be nice!
  • Branch: stable
  • Desktop: Xfce 15.12-rc2 Capella
  • GPU Card: Intel Mobile 4
  • GPU driver: free
  • Kernel: 4.1.15-1-MANJARO x86_64
  • Skill: Novice
Re: Terminal misbehavin
« Reply #19 on: 30. October 2015, 12:38:55 »
Sorry - more newbieisms - is "fluxbox-remote restart" a terminal command?  If so it didn't do anything. Using Restart from the Fluxbox Settings menu does the trick every time though.

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: Terminal misbehavin
« Reply #20 on: 30. October 2015, 13:51:06 »
is "fluxbox-remote restart" a terminal command?
Hm. Yes that was supposed to be a command to do the same as 'restart fluxbox' from the menu - obviously... not 8) ::)
So looks like unfortunately I don't know a way, yet to get a keybinding for that but at least it's good to know that restarting works :)
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline gychang

  • Vollwertiges Mitglied
  • ***
  • Posts: 217
  • Skill: Novice
Re: Terminal misbehavin
« Reply #21 on: 10. November 2015, 21:21:28 »
am having this problem on my X220 thinkpad, with latest 64bit fluxbox (15.12).  Terminal always stays on top, even with chromium just opened and it can not be moved.

tried reinstalling lxterminal, and guess there is no solution to this?

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: Terminal misbehavin
« Reply #22 on: 11. November 2015, 06:12:48 »
gychang, does "restart fluxbox" not help?
Does this happen every time for you?
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline gychang

  • Vollwertiges Mitglied
  • ***
  • Posts: 217
  • Skill: Novice
Re: Terminal misbehavin
« Reply #23 on: 11. November 2015, 15:21:49 »
gychang, does "restart fluxbox" not help?
Does this happen every time for you?

yes to both questions. 

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: Terminal misbehavin
« Reply #24 on: 12. November 2015, 15:31:29 »
What about switching to another kernel? 4.1 maybe, or even newer?
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline gychang

  • Vollwertiges Mitglied
  • ***
  • Posts: 217
  • Skill: Novice
Re: Terminal misbehavin
« Reply #25 on: 12. November 2015, 18:57:24 »
What about switching to another kernel? 4.1 maybe, or even newer?

tried 4.3.0.1 kernel, same problem remains.

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: Terminal misbehavin
« Reply #26 on: 12. November 2015, 19:03:56 »
 :P
Thank you anyway, gychang!
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline gohlip

  • Held Mitglied
  • *****
  • Posts: 1689
  • Desktop: OpenBox
  • GPU Card: nvidia
  • GPU driver: nonfree
  • Kernel: linux46 - x64
  • Skill: Intermediate
Re: Terminal misbehavin
« Reply #27 on: 12. November 2015, 19:22:14 »
gychang, can you try with another terminal?
BTW( by the way), what terminal are you using? ( I don't see a heading)

If there is a "layer..." tab for that therminal, set it to normal, not "top" or "above dock"

Life is a sexually transmitted disease with a 100% mortality rate.

Offline gychang

  • Vollwertiges Mitglied
  • ***
  • Posts: 217
  • Skill: Novice
Re: Terminal misbehavin
« Reply #28 on: 13. November 2015, 00:18:19 »
gychang, can you try with another terminal?
BTW( by the way), what terminal are you using? ( I don't see a heading)

If there is a "layer..." tab for that therminal, set it to normal, not "top" or "above dock"

tried xfce4-terminal, exactly same problem, opens on left upper corner and unable to move and when I open another program the terminal app it stays on top.  Originally same problem on the default lxterminal, I checked the layer option and it is in "normal"...., minor irritant.

Offline gohlip

  • Held Mitglied
  • *****
  • Posts: 1689
  • Desktop: OpenBox
  • GPU Card: nvidia
  • GPU driver: nonfree
  • Kernel: linux46 - x64
  • Skill: Intermediate
Re: Terminal misbehavin
« Reply #29 on: 13. November 2015, 01:19:59 »
Okay. I don't know how else then. Sorry.
But good luck.
Life is a sexually transmitted disease with a 100% mortality rate.