Author Topic: Terminal misbehavin  (Read 2766 times)

0 Members and 1 Guest are viewing this topic.

Offline redart

  • Neuling
  • *
  • Posts: 45
  • I'm new. Be nice!
  • Branch: stable
  • Desktop: Xfce 15.12-rc2 Capella
  • GPU Card: Intel Mobile 4
  • GPU driver: free
  • Kernel: 4.1.15-1-MANJARO x86_64
  • Skill: Novice
Terminal misbehavin
« on: 26. October 2015, 16:32:26 »
Hi All,
Been playing around with Fluxbox from live USB stick for a while and today decided to change out XFCE4 and give Fluxbox a full blown try. Initially everything was good, although I did notice the background image didn't load a couple of times.  Anyway, after letting the new updates do their thing the terminal window will now not move - not a bit.  It will only open in the top left corner and then wont move, and has also lost it's borders.  can't drag or resize. Did the main update after installing and it was fine. Then I got another update message with 3 (I think) files to update. After this the terminal window has gone bad.  So, question 1 - can I "undo" the last updates and if so how?, 2 - anyone else seeing this? Bug?.  Thanks.  p.s. Kernel: 4.1.11-1-MANJARO x86_64 (64 bit)  Desktop: Fluxbox 1.3.7 Distro: ManjaroLinux 15.09 Bellatrix

Offline tanaymkis

  • Jr. Mitglied
  • **
  • Posts: 72
  • I'm new. Be nice!
  • Branch: Stable
  • Desktop: i3
  • Kernel: 3.18.22-1-MANJARO i686
  • Skill: Novice
Re: Terminal misbehavin
« Reply #1 on: 26. October 2015, 17:05:50 »
Not much I can think of,but any way here is my go at it.
Using pamac(in fluxbox menu go to Tools->System->Add/Remove Software) install another teminal
I recommend Urxvt or Xterm.
Then from the new terminal run the following command
Code: [Select]
downgrade lxterminal
Then downgrade to a lower version.

PS - Sorry for bad English

Offline redart

  • Neuling
  • *
  • Posts: 45
  • I'm new. Be nice!
  • Branch: stable
  • Desktop: Xfce 15.12-rc2 Capella
  • GPU Card: Intel Mobile 4
  • GPU driver: free
  • Kernel: 4.1.15-1-MANJARO x86_64
  • Skill: Novice
Re: Terminal misbehavin
« Reply #2 on: 26. October 2015, 17:27:02 »
thanks for the suggestion.  Installed Xterm and downgraded Lxterminal but same thing.  Then removed lxterminal completely and re-installed - same again.  Guess I'll just use Xterm for the time being !

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: Terminal misbehavin
« Reply #3 on: 26. October 2015, 18:59:34 »
This strange bug has been reported before. A few people experience this behavior with several terminal programs - some only in connection with video recording apps running at the same time. So far I don't have a real answer, but you could try using gnome-terminal instead of lxterminal. Would that work for you?
« Last Edit: 26. October 2015, 19:10:15 by oberon »
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: Terminal misbehavin
« Reply #4 on: 26. October 2015, 19:14:16 »
Would you maybe have a choice of different video drivers? That would be interesting. My guess is that this is related to certain GPUs - because, as I said, the strange thing is that only some people get this problem...
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline redart

  • Neuling
  • *
  • Posts: 45
  • I'm new. Be nice!
  • Branch: stable
  • Desktop: Xfce 15.12-rc2 Capella
  • GPU Card: Intel Mobile 4
  • GPU driver: free
  • Kernel: 4.1.15-1-MANJARO x86_64
  • Skill: Novice
Re: Terminal misbehavin
« Reply #5 on: 26. October 2015, 19:30:21 »
thanks for the replies oberon.  I thought I'd solved the problem by downloading the latest 15.10 version of fluxbox from sourceforge. Initially evrything was great - LXTerminal working as intended, however after an hours use it's just now gone the same way  :(   Also, the dock is behaving strangely as well - think it could be related.....with position set to bottom is goes near the top of the screen but the text stays at the bottom; when set to top it's at the top; when set to right it goes near the left side but  text is on the right side; and when set to left it's all left.

Offline redart

  • Neuling
  • *
  • Posts: 45
  • I'm new. Be nice!
  • Branch: stable
  • Desktop: Xfce 15.12-rc2 Capella
  • GPU Card: Intel Mobile 4
  • GPU driver: free
  • Kernel: 4.1.15-1-MANJARO x86_64
  • Skill: Novice
Re: Terminal misbehavin
« Reply #6 on: 26. October 2015, 19:51:25 »
Not sure if this is related but could be useful - just installed a Conky (Gotham) - if i set the transparency to either "Transparent" or "Semi-Transparent" then it ignores the position setting and sits top left like the LXTerminal window.  If I set the transparency to "Psuedo-Transparent" or "Opaque" then it takes whatever position I set it to. Weird.

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: Terminal misbehavin
« Reply #7 on: 26. October 2015, 20:00:54 »
hmmm, interesting, indeed!! ???
something to do with the built in fluxbox pseudo transparency maybe??
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline redart

  • Neuling
  • *
  • Posts: 45
  • I'm new. Be nice!
  • Branch: stable
  • Desktop: Xfce 15.12-rc2 Capella
  • GPU Card: Intel Mobile 4
  • GPU driver: free
  • Kernel: 4.1.15-1-MANJARO x86_64
  • Skill: Novice
Re: Terminal misbehavin
« Reply #8 on: 26. October 2015, 21:07:46 »
Possibly.  Tried forcing pseudo-transparency option and playing around with the various alpha settings but no diff.  I'm afraid i'm too much of a noob to be of much help  :-[

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: Terminal misbehavin
« Reply #9 on: 27. October 2015, 00:11:42 »
My problem is that I don't have that issue to try and fix it ;) ;D
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline redart

  • Neuling
  • *
  • Posts: 45
  • I'm new. Be nice!
  • Branch: stable
  • Desktop: Xfce 15.12-rc2 Capella
  • GPU Card: Intel Mobile 4
  • GPU driver: free
  • Kernel: 4.1.15-1-MANJARO x86_64
  • Skill: Novice
Re: Terminal misbehavin
« Reply #10 on: 27. October 2015, 12:12:37 »
I envy you your problems !  ;)   OK, well I don't know if this will help but a few other observations:-  1. Tried a different laptop (although same manufacturer - Lenovo), Thinkpad T500 and T400s both display the same behaviour. 2. Tried a different video driver - the hardware detection tool in Manjaro Setting Manager lists video-intel (default) and video-vesa - video-vesa just gave a blank screen on reboot  :(.  3. the issue also happens when running Live environment from a USB  stick, and,  4.  it only happens AFTER either logging out and back in, or switching users !!.  Most peculiar.   ***** CORRECTION - only happens if I use the Switch option in Oblogout.  Logging out doesn't do it, but after using Switch, loggin out and back in fixes the problem.  Also, choosing Restart from the Fluxbox settings menu gets it back to normal too  :)

« Last Edit: 27. October 2015, 12:31:46 by redart »

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: Terminal misbehavin
« Reply #11 on: 27. October 2015, 14:48:13 »
OK, that is really interesting news. Thank you very much!
My guess is that this could be related to lightdm-gtk-greeter. Until recently I used to have the issue that switching user and back gave me a completely black screen...
But well, if that means that restarting fluxbox helps at least that sounds like something one can live with until the greeter bug is fixed.
I think this command should work to link to a keyboard-shortcut (not tested, yet)
Code: [Select]
fluxbox-remote restart
Or one could also think of using a different greeter... That would definitely be a way to prove if lightdm-gtk-greeter is the culprit  >:(
« Last Edit: 27. October 2015, 14:51:40 by oberon »
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline redart

  • Neuling
  • *
  • Posts: 45
  • I'm new. Be nice!
  • Branch: stable
  • Desktop: Xfce 15.12-rc2 Capella
  • GPU Card: Intel Mobile 4
  • GPU driver: free
  • Kernel: 4.1.15-1-MANJARO x86_64
  • Skill: Novice
Re: Terminal misbehavin
« Reply #12 on: 27. October 2015, 18:00:47 »
Tried lightdm-kde-greeter and same thing  :(    Fortunately I don't actually need to Switch accounts as it's just me, so I think I'll just avoid that icon  ;D   Thanks for all the help anyway  :)

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: Terminal misbehavin
« Reply #13 on: 27. October 2015, 20:15:31 »
Maybe you could try something not lightdm ... like lxdm for example?
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline simgin

  • Held Mitglied
  • *****
  • Posts: 774
  • Branch: All.
  • Desktop: XFCE+Alpine Linux, Mate+Fedora, Ubuntu Server + Mate and NoX+LinuxBBQ
  • GPU Card: GeForce 8600M & GT 555M 2GB
  • Skill: Intermediate
Re: Terminal misbehavin
« Reply #14 on: 28. October 2015, 03:00:34 »
^ Maybe good old startx ?  ::)