Author Topic: nvidia setting on reboot lost  (Read 638 times)

0 Members and 1 Guest are viewing this topic.

Offline gychang

  • Vollwertiges Mitglied
  • ***
  • Posts: 217
  • Skill: Novice
nvidia setting on reboot lost
« on: 17. October 2015, 20:08:08 »
Enjoying the latest fluxbox, very quick.  Able to install the nivida propriety driver.  I have a rotating screen, usually use it in portrait mode.  After I rotate on the nivida setting I apply and quit.  On next reboot however portrait mode is lost.

before I reboot I get this:
--
[apa@main2 ~]$ sudo xrandr -q
[sudo] password for apa:
Screen 0: minimum 8 x 8, current 1280 x 1024, maximum 8192 x 8192
DVI-I-0 disconnected primary (normal left inverted right x axis y axis)
VGA-0 disconnected (normal left inverted right x axis y axis)
DVI-I-1 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 376mm x 301mm
   1280x1024     60.02*+  76.00    75.02    72.00    70.00 
   1152x864      75.00 
   1024x768      75.03    70.07    60.00 
   800x600       75.00    72.19    60.32 
   640x480       75.00    72.81    59.94 
[apa@main2 ~]$
--

Do I need to modify xorg configuration somewhere?

Offline m0rl0ck

  • Neuling
  • *
  • Posts: 27
  • Branch: Manjaro 15.09 OpenRC, Debian 8.2, Slackware -current
  • Desktop: !gnome3
  • GPU Card: Geforce GT 630
  • GPU driver: NVIDIA 3.55
  • Kernel: 4.1.6 RYO
  • Skill: Novice
Re: nvidia setting on reboot lost
« Reply #1 on: 18. October 2015, 01:46:18 »
After you get it like you want it hit the save configuration button in nvidia-settings, its on the "nvidia-settings Configuration" page.  It will save settings to ~/.nvidia-settings-rc by default. Then run nvidia-settings on startup, you can place this in your .fluxbox/startup file for instance.
Code: [Select]
nvidia-settings&
See if that works.
"The mind sent outside is the origination of suffering.
The result of the mind sent outside is suffering.
The mind seeing the mind is the path.
The result of the mind seeing the mind is the cessation of suffering."
http://www.accesstoinsight.org/lib/thai/dune/giftsheleft.html

Offline gychang

  • Vollwertiges Mitglied
  • ***
  • Posts: 217
  • Skill: Novice
Re: nvidia setting on reboot lost
« Reply #2 on: 18. October 2015, 03:08:54 »
After you get it like you want it hit the save configuration button in nvidia-settings, its on the "nvidia-settings Configuration" page.  It will save settings to ~/.nvidia-settings-rc by default. Then run nvidia-settings on startup, you can place this in your .fluxbox/startup file for instance.
Code: [Select]
nvidia-settings&
See if that works.

I have ~/.nvidia-setting-rc and ~/.nvidia-settings.rc for some reason, which is the one that is saved?

if I just add the code nvidia-settings &, it does not work, just starts the program on reboot without rotating the screen.


Offline gychang

  • Vollwertiges Mitglied
  • ***
  • Posts: 217
  • Skill: Novice
Re: nvidia setting on reboot lost
« Reply #3 on: 18. October 2015, 18:18:06 »
After you get it like you want it hit the save configuration button in nvidia-settings, its on the "nvidia-settings Configuration" page.  It will save settings to ~/.nvidia-settings-rc by default. Then run nvidia-settings on startup, you can place this in your .fluxbox/startup file for instance.
Code: [Select]
nvidia-settings&
See if that works.

that only brings the configuration page again and I have to L rotate to get into portrait mode but does not save on reboot.
I also tried adding to ~/.xinitrc file.  I also tried to add "nvidia-settings --load-config-only &" to start and xinitrc which also does not work.

further help please.

Offline gychang

  • Vollwertiges Mitglied
  • ***
  • Posts: 217
  • Skill: Novice
Re: nvidia setting on reboot lost
« Reply #4 on: 18. October 2015, 18:56:34 »
bypassing the nvidia setting altogether on terminal if I type in:

xrandr --output HDMI-0 --rotate left, I get the properly rotated screen.

If I add "xrandr --output HDMI-0 --rotate left &" to either ~/.fluxbox/startup or ~/.xinitrc it does not work on reboot.  What am I doing wrong?