Author Topic: [Solved]Conky-Shadow on Desktop  (Read 1729 times)

0 Members and 1 Guest are viewing this topic.

Offline tanaymkis

  • Jr. Mitglied
  • **
  • Posts: 72
  • I'm new. Be nice!
  • Branch: Stable
  • Desktop: i3
  • Kernel: 3.18.22-1-MANJARO i686
  • Skill: Novice
[Solved]Conky-Shadow on Desktop
« on: 13. October 2015, 13:59:49 »
Hello !

I have recently tried Manjaro Fluxbox and I liked it. The edition is absolutely wonderful.
But there is a problem.
I have installed conky manager and whenever I select a theme I get an ugly looking shadow.
I have searched and found nothing to be useful.I have tried all suggestions from this thread:
https://forum.manjaro.org/index.php?topic=26334.0
I have attached an image of desktop.

Thanks for the help in advance.
« Last Edit: 14. October 2015, 12:34:00 by tanaymkis »

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: Conky-Shadow on Desktop
« Reply #1 on: 13. October 2015, 14:18:58 »
What I explain in this post definitely works for me, as you can see in my screenshot there 8)
If still in doubt please post the full conkyrc you'd like to use. Bear in mind that the syntax is different for Conky 0.9 and 0.10 and I don't know which version Conky-manger uses... But we'll see that from your config file anyway...
Maybe also post your compton.conf ...
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline tanaymkis

  • Jr. Mitglied
  • **
  • Posts: 72
  • I'm new. Be nice!
  • Branch: Stable
  • Desktop: i3
  • Kernel: 3.18.22-1-MANJARO i686
  • Skill: Novice
Re: Conky-Shadow on Desktop
« Reply #2 on: 13. October 2015, 17:08:33 »
Here is conky config as asked:
Code: [Select]
use_xft yes
xftfont 123:size=8
xftalpha 0.1
update_interval 1
total_run_times 0

own_window yes
own_window_type conky
own_window_transparent yes
own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager
own_window_colour 000000
own_window_argb_visual yes
own_window_argb_value 0

double_buffer yes
#minimum_size 250 5
#maximum_width 500
draw_shades no
draw_outline no
draw_borders no
draw_graph_borders no
default_color white
default_shade_color red
default_outline_color green
alignment top_left
gap_x 0
gap_y 20
no_buffers yes
uppercase no
cpu_avg_samples 2
net_avg_samples 1
override_utf8_locale yes
use_spacer yes


minimum_size 0 0
TEXT
${voffset 10}${color EAEAEA}${font GE Inspira:pixelsize=120}${time %I:%M}${font}${voffset -84}${offset 10}${color FFA300}${font GE Inspira:pixelsize=42}${time %d} ${voffset -15}${color EAEAEA}${font GE Inspira:pixelsize=22}${time  %B} ${time %Y}${font}${voffset 24}${font GE Inspira:pixelsize=58}${offset -148}${time %A}${font}
${voffset 1}${offset 12}${font Ubuntu:pixelsize=12}${color FFA300}HD ${offset 9}$color${fs_free /} / ${fs_size /}${offset 30}${color FFA300}RAM ${offset 9}$color$mem / $memmax${offset 30}${color FFA300}CPU ${offset 9}$color${cpu cpu0}%

and compton.conf
Code: [Select]
# Shadow
shadow = true; # Enabled client-side shadows on windows.
no-dock-shadow = true; # Avoid drawing shadows on dock/panel windows.
no-dnd-shadow = true; # Don't draw shadows on DND windows.
clear-shadow = true; # Zero the part of the shadow's mask behind the window (experimental).
detect-rounded-corners = true;
# shadow-radius = 7; # The blur radius for shadows. (default 12)
# shadow-offset-x = -7; # The left offset for shadows. (default -15)
# shadow-offset-y = -7; # The top offset for shadows. (default -15)
shadow-ignore-shaped = false;
shadow-exclude = [
"class_g = 'wbar'",
"class_g = 'Conky'"
];

# Fading
# fading = true; # Fade windows during opacity changes.
# fade-delta = 4; # The time between steps in a fade in milliseconds. (default 10).
# fade-in-step = 0.03; # Opacity change between steps while fading in. (default 0.028).
# fade-out-step = 0.03; # Opacity change between steps while fading out. (default 0.03).
# no-fading-openclose = true; # Fade windows in/out when opening/closing.





Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: Conky-Shadow on Desktop
« Reply #3 on: 13. October 2015, 21:00:59 »
I have just tried your files on my system and it works perfectly and without shadows on the conky.
Have you stopped and restarted Compton after editing the config - but well, I think you are using the original anyway, right?
So this is a little weird... ???
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline tanaymkis

  • Jr. Mitglied
  • **
  • Posts: 72
  • I'm new. Be nice!
  • Branch: Stable
  • Desktop: i3
  • Kernel: 3.18.22-1-MANJARO i686
  • Skill: Novice
Re: Conky-Shadow on Desktop
« Reply #4 on: 14. October 2015, 11:36:32 »
IS there I can use as an alternate to conky now.
Any ideas would be appreciated

Offline Dastious

  • Neuling
  • *
  • Posts: 40
  • Branch: testing
  • Desktop: Kde 5
  • GPU Card: nvidia 750Ti / 970
  • GPU driver: non-free
  • Kernel: 4.4
  • Skill: Novice
Re: Conky-Shadow on Desktop
« Reply #5 on: 14. October 2015, 12:00:27 »
I have this too. It's very simple, if you tell you compositor to draw shadow to every windows, it will draw shadow to conky too.

With compton you can tell him to ignore conky.
Code: [Select]
https://wiki.archlinux.org/index.php/Compton#Disable_conky_shadowing :

>disable shadows around conky windows - where used - first amend the conky configuration file ~/.conkyrc as follows:

own_window_class conky

>Then amend the compton configuration file as follows:

shadow-exclude = "class_g = 'conky'";

Offline tanaymkis

  • Jr. Mitglied
  • **
  • Posts: 72
  • I'm new. Be nice!
  • Branch: Stable
  • Desktop: i3
  • Kernel: 3.18.22-1-MANJARO i686
  • Skill: Novice
Re: Conky-Shadow on Desktop
« Reply #6 on: 14. October 2015, 12:22:11 »
I have already done the changes as you suggested with no effects.Shadows are still their.

EDIT
After restarting compton worked.
It wasn't working with a capital C for Conky,had to change to conky in compton.conf
 :) :D
« Last Edit: 14. October 2015, 12:28:03 by tanaymkis »