Author Topic: Manjaro-Fluxbox 15.10 stable release  (Read 11739 times)

0 Members and 1 Guest are viewing this topic.

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: Manjaro-Fluxbox 15.10 stable release
« Reply #30 on: 12. October 2015, 10:07:22 »
Ask yourself what exactly you would like to get from 15.10 ! :)
Run the live environment and then tell me if you need help.
For the theming just install numix-reborn-suite...  8)
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline cipricus

  • Jr. Mitglied
  • **
  • Posts: 58
  • Desktop: Fluxbox
  • Kernel: linux38-x64
  • Skill: Novice
Re: Manjaro-Fluxbox 15.10 stable release
« Reply #31 on: 12. October 2015, 10:26:56 »
Does the new 15.10 have an applet to switch keyboards?

Offline skazzi

  • Neuling
  • *
  • Posts: 2
  • I'm new. Be nice!
  • Desktop: Xfce, KDE
  • GPU Card: Nvidia
  • GPU driver: non-free
  • Kernel: 4.1.10-1-MANJARO
  • Skill: Intermediate
Re: Manjaro-Fluxbox 15.10 stable release
« Reply #32 on: 12. October 2015, 11:04:53 »
I was thinking of switching to the Arch family for some time now, but I didn't have a lot of free time to read all the documentation and spend a few days working on my PC. After that, I've heard of Manjaro and I really liked everything about it, and it definitely looked like it would shorten the process.

Yesterday, my PC was really working slow (I was on Elementary) and somehow I stumbled upon Manjaro fluxbox. I saw it was lightweight, looked epic with Numix theme (which I always use) and obviously it was form the Arch family.

Boom switched, and I really enjoy it!
Except that I have a ton of stuff already to learn, but no matter, it's fun.


I have a few things to point out, please take into consideration this is essentially my first post on this forum.

Using plank is a great option, it comes with Elementary OS and I've used it for quite a bit, not a single crash, problem or anything. Still there are 2 problems with Plank here - One is that adding new icons needs to be done from config file, and second is that when I go fullscreen, plank won't appear when I hover down with my mouse.

Yes I am aware that it's the arch way of editing config files directly over clicking around, but still, it's just a small detail that would really be cool.

I really like the terminal font!

And I'd really like to know where I can rebind the keyboard shortcuts for usual desktop use. For example, I'd like to rebind CTRL+1,2,3,4 for switching for workspaces 1,2,3,4.

Keep up the incredible work, and thanks a lot for my new OS!  8)
« Last Edit: 12. October 2015, 11:07:59 by skazzi »

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: Manjaro-Fluxbox 15.10 stable release
« Reply #33 on: 12. October 2015, 11:44:33 »
Hi, skazzi, welcome! :)
adding new icons needs to be done from config file,
There is actually a GUI for the plank settings, but it is a bit tricky to find it ;) You have to right-click somewhere inbetween the icons and the bar itself... ::)
Otherwise you can edit this config file: ~/.config/plank/dock1/settings
There first of all you should set:
Code: [Select]
"LockItems=false"(should have done right away ::) )

To add items to the dock now you can simply open whichever app you wish to add and then right-click on the now existing plank-icon and there you'll find "Keep in Dock"  8)
Quote
when I go fullscreen, plank won't appear when I hover down with my mouse.
well, theoretically the autohide / unhide does work. The problem in fluxbox here is the concept of layers.
I had to set plank to open in a low layer and the other windows above, because otherwise you run into the problem that you cannot click in a certain area around plank (plank's actual invisible window is bigger than what we see ... )
Now when another window is fullscreen and you move the mouse against plank it actually does unhide but it is covered by the other window in the higher layer ...  :P
Quote
And I'd really like to know where I can rebind the keyboard shortcuts for usual desktop use.
For example, I'd like to rebind CTRL+1,2,3,4 for switching for workspaces 1,2,3,4.
That you'll actually have to do in a text config, but really no big deal :)
Just open ~/.fluxbox/keys - it is really self-explanatory what you do there ;)
You just need to know that 'Mod1' stands for the <Alt>-key and 'Mod4' is the <Super>-key
Quote
Keep up the incredible work, and thanks a lot for my new OS!  8)
Thank you for your feedback! :)
And enjoy your new fluxbox! ;D
« Last Edit: 12. October 2015, 11:46:56 by oberon »
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: Manjaro-Fluxbox 15.10 stable release
« Reply #34 on: 12. October 2015, 11:59:29 »
Does the new 15.10 have an applet to switch keyboards?
Actually yes ... and no ;) :D
The little app sbxkb is preinstalled but not autostarted by default. You have to add it to your ~/.fluxbox/startup file.
I could not really preconfigure it because I would not know wich keyboard layouts people are going to use... ;D
More information you can find here: https://forum.manjaro.org/index.php?topic=26408.msg223738#msg223738
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline MrRoberts

  • Neuling
  • *
  • Posts: 42
  • Skill: Intermediate
Re: Manjaro-Fluxbox 15.10 stable release
« Reply #35 on: 12. October 2015, 13:36:29 »
Bloody hell!... this is faster than my Manjaro XFCE 64bit on SSD. I'm running this off my USB stick lol.

Seriously, how do I change the font in Fluxbox? If I can I'll switch over in a heart beat!

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: Manjaro-Fluxbox 15.10 stable release
« Reply #36 on: 12. October 2015, 14:11:53 »
Seriously, how do I change the font in Fluxbox? If I can I'll switch over in a heart beat!
Code: [Select]
gksu mousepad /usr/share/fluxbox/styles/manjaro-flux/theme.cfgAnd there under ## FONTS ## replace every entry of 'cantarell' with the name of your favourite font 8) (simplest way is to use <Ctrl>+r or Search > 'Find and Replace' ;) )
For the gtk-apps you also have to change that in ~/.gtkrc-2.0
To preview the fonts and to see which ones are installed you can simply open Abiword and check ... There is an app available for that, too, I just cannot find it right now ... ::)
Have fun! :)
« Last Edit: 12. October 2015, 14:32:31 by oberon »
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline MrRoberts

  • Neuling
  • *
  • Posts: 42
  • Skill: Intermediate
Re: Manjaro-Fluxbox 15.10 stable release
« Reply #37 on: 12. October 2015, 14:32:25 »
Thank you! Will have a go. :-)

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: Manjaro-Fluxbox 15.10 stable release
« Reply #38 on: 12. October 2015, 14:35:22 »
I also found this:
Quote
Since Fluxbox 0.9.15 there has been a new option called session.styleOverlay that allows user to override some or even all elements of style. This comes in very handy for keeping fonts the same for every style or some other things.

Add this line to your ~/.fluxbox/init

session.styleOverlay: ~/.fluxbox/overlay

Then edit the file ~/.fluxbox/overlay like you would edit any style. Add your custom fonts there for example:

Code: [Select]
menu.title.font: sans-10:bold
toolbar.clock.font: sans-10:bold
toolbar.workspace.font: sans-10:bold
*font: sans-8
This is maybe the cleaner way, because if one day fluxbox-theme-manjaro receives an update, your changes in the theme file would be overwritten >:D
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline Lend27

  • Jr. Mitglied
  • **
  • Posts: 89
  • I'm new. Be nice!
  • GPU Card: Nvidia GTX760
  • GPU driver: non-free
  • Skill: Intermediate
Re: Manjaro-Fluxbox 15.10 stable release
« Reply #39 on: 12. October 2015, 15:09:56 »
Hm. So this seems to be related to some terminal emulators... lxterminal, urxvt ? ...
My problem here is, I cannot reproduce this. For me everything works as it should - so difficult for me to be of any help right now.
If we know that xterm works that's already something and you can use that instead ;) I don't know about configuration, yet, to make that one look as good as lxterminal does, but we'll find out.... ;) Very interesting indeed that bug-report about cool-retro-term. But that one is quite old and seems like they did not solve it ... ???

Guys, when you launch lxterminal from another lxterminal window or another terminal, do you get any error messages when that happens?

I also tried to install Terminator and same thing happens.
With mine, the terminal opens normally until I start a  program like Guvcview, Kazam, Simplescreenrecorder.
Then the term window is stuck in top left. Stays that way until I reboot. Then it's ok again until I use one of the aforementioned programs.

Len

Len

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: Manjaro-Fluxbox 15.10 stable release
« Reply #40 on: 12. October 2015, 15:37:01 »
So that means basically: open any terminal emulator, then launch any screencast app and that produces the issue... :o
How weird is that? ???
Yet then, my dear friend, Linux Help Guy does not have that problem... So that means on top of that it appears to be also hardware related :P
Great! ;D
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline MrRoberts

  • Neuling
  • *
  • Posts: 42
  • Skill: Intermediate
Re: Manjaro-Fluxbox 15.10 stable release
« Reply #41 on: 12. October 2015, 16:30:01 »
Looks like I'm having problems after installed Manjaro Fluxbox OpenRC 64bit... after I logged on, cannot start anything?

I can right-click and clicked on an app... nothing. No responses at all.

What's up?

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: Manjaro-Fluxbox 15.10 stable release
« Reply #42 on: 12. October 2015, 16:41:31 »
Hm. Have you confirmed the checksum of your ISO-download? Has your /home partition been freshly formatted or is it maybe a recycled one with leftover config in it?
What happens when you try launching an app from the terminal? (You can open it with <Alt>+F1... ;) )
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline MrRoberts

  • Neuling
  • *
  • Posts: 42
  • Skill: Intermediate
Re: Manjaro-Fluxbox 15.10 stable release
« Reply #43 on: 12. October 2015, 16:54:02 »
Nothing... cannot launch any apps from the terminal.

What home partition? I always used /boot (ext2), /root (btrfs) and /linuxswap

Was working fine off USB stick and installed from it.

Software update popped up, but cannot open it to have a look.

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: Manjaro-Fluxbox 15.10 stable release
« Reply #44 on: 12. October 2015, 17:01:55 »
Ok. No separate /home partition then. But did you format the harddrive when you installed?
Check the download please and in any case reinstall - this sounds weird. There is certainly something very wrong ...  ???
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin