Author Topic: [Solved] Establishing connection to PulseAudio. Please wait ...  (Read 17921 times)

0 Members and 2 Guests are viewing this topic.

Offline Antre

  • Neuling
  • *
  • Posts: 8
  • I'm new. Be nice!
  • Branch: manjaro-xfce-openrc-15.09
  • Desktop: Xfce
  • GPU Card: Graphics: AMD Radeon HD 7640G integrated graphics
  • GPU driver: GPU: AMD/ATI Trinity [Radeon HD 7640G]
  • Skill: Novice
Hi,

I”m having a very rare problem with the audio system:

1-There is no audio, pavucontrol has this message:

Establishing connection to PulseAudio. Please wait ...

 2-Then i tried to run:

pulseaudio --check
pulseaudio -D

3-And audio is back!

4-But ... i re-started the system and ... audio is gone.

5- Then i installed gnome-alsamixer: no audio at all ... i removed alsamixer and run again pulseaudio -D and the audio is no coming back anymore.

6- I repeat the process and this is what happen now:

[andres@manjaro ~]$ pulseaudio --check
[andres@manjaro ~]$ pulseaudio -D
E: [pulseaudio] main.c: Falló el inicio del demonio.  * failed to start daemon
[andres@manjaro ~]$


*pulseaudio-alsa is  already installed in the system.

 Unsure what I'm doing wrong ...
« Last Edit: 08. October 2015, 00:34:13 by Antre »

Offline Antre

  • Neuling
  • *
  • Posts: 8
  • I'm new. Be nice!
  • Branch: manjaro-xfce-openrc-15.09
  • Desktop: Xfce
  • GPU Card: Graphics: AMD Radeon HD 7640G integrated graphics
  • GPU driver: GPU: AMD/ATI Trinity [Radeon HD 7640G]
  • Skill: Novice
Re: Establishing connection to PulseAudio. Please wait ...
« Reply #1 on: 07. October 2015, 02:21:06 »
After restart and turn off the computer for a long period of time the audio is back, but only IF i go to the terminal and write: pulseaudio -D

Offline glock172

  • Vollwertiges Mitglied
  • ***
  • Posts: 124
  • Branch: openrc, unstable
  • Desktop: MATE,Xfce
  • GPU Card: GT 210
  • GPU driver: free
  • Kernel: 4.4
  • Skill: Novice
Re: Establishing connection to PulseAudio. Please wait ...
« Reply #2 on: 07. October 2015, 21:08:02 »
This is my "solution" for this problem:
https://forum.manjaro.org/index.php?topic=26756.0
I don't know if this will work for you.
If it ain't broke, don't fix it

Offline beardedragon

  • Held Mitglied
  • *****
  • Posts: 500
  • Branch: Stable OpenRC & Testing Systemd
  • Desktop: Xfce 4.12.3 (Gtk 2.24.28)
  • GPU Card: NVIDIA GK208 [GeForce GT 720/PCIe/SSE2]
  • GPU driver: 4.5.0 NVIDIA 361.42(non-free)
  • Kernel: 4.4-6 & 4.6-rc5-MANJARO-x86_64
  • Skill: Advanced
Re: Establishing connection to PulseAudio. Please wait ...
« Reply #3 on: 07. October 2015, 23:31:46 »
Robert Collard Madison, WI
Lenova K450e  8GB RAM
ManjaroLinux 15.12 Capella

Offline Antre

  • Neuling
  • *
  • Posts: 8
  • I'm new. Be nice!
  • Branch: manjaro-xfce-openrc-15.09
  • Desktop: Xfce
  • GPU Card: Graphics: AMD Radeon HD 7640G integrated graphics
  • GPU driver: GPU: AMD/ATI Trinity [Radeon HD 7640G]
  • Skill: Novice
Re: Establishing connection to PulseAudio. Please wait ...
« Reply #4 on: 08. October 2015, 00:33:29 »
Thanks guys but what works for me was to remove pulseaudio 7 and to install pulseaudio60 ...

Offline obarun

  • Neuling
  • *
  • Posts: 10
    • Arch under runit without systemd
  • Skill: Novice
Re: [Solved] Establishing connection to PulseAudio. Please wait ...
« Reply #5 on: 11. October 2015, 07:29:35 »
try this : https://github.com/Obarun/obarun-pkgbuild/tree/master/pulseaudio-nosystemd

build it and be sure to have readme the warning file

enjoy it :)
Obarun : free to control your system