Author Topic: Problem using Conky on desktop  (Read 2618 times)

0 Members and 1 Guest are viewing this topic.

Offline Lend27

  • Jr. Mitglied
  • **
  • Posts: 89
  • I'm new. Be nice!
  • GPU Card: Nvidia GTX760
  • GPU driver: non-free
  • Skill: Intermediate
Problem using Conky on desktop
« on: 18. September 2015, 02:44:04 »
I installed Conky-Manager. I setp my conky which works fine in most Manjaro versions, but not in fluxbox.
The compositing manager has to be set properly to allow transparency.
I normally use compton but it's not working in fluxbox.
When I start compton in a terminal, it says a compositing manager is already running. I do see that compton is installed, but maybe not configured properly for conky transparency.

Anyone know how to get this working right?

Thanks!

Len

Offline Lend27

  • Jr. Mitglied
  • **
  • Posts: 89
  • I'm new. Be nice!
  • GPU Card: Nvidia GTX760
  • GPU driver: non-free
  • Skill: Intermediate
Re: Problem using Conky on desktop
« Reply #1 on: 19. September 2015, 03:19:27 »
I figured this out. In the fluxbox startup file I just removed the "-c" and add an sh startup command and that worked great.

Len

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: Problem using Conky on desktop
« Reply #2 on: 19. September 2015, 07:34:14 »
Oh, interesting!  :o
Could you show me what you have in your startup file now? ???
Since - as you know meanwhile, I guess - Compton was indeed already running, I would have guessed that either your conkyrc or .config/compton.conf would have needed adjustment...
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline Lend27

  • Jr. Mitglied
  • **
  • Posts: 89
  • I'm new. Be nice!
  • GPU Card: Nvidia GTX760
  • GPU driver: non-free
  • Skill: Intermediate
Re: Problem using Conky on desktop
« Reply #3 on: 20. September 2015, 02:17:23 »
Oh, interesting!  :o
Could you show me what you have in your startup file now? ???
Since - as you know meanwhile, I guess - Compton was indeed already running, I would have guessed that either your conkyrc or .config/compton.conf would have needed adjustment...


OK, here is my startup file:

#!/bin/sh
# fbsetbg -l # sets the last background set, very useful and recommended.

# In the below commands the ampersand symbol (&) is required on all applications that do not terminate immediately.
# Failure to provide them will cause Fluxbox not to start.
/usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1 &
sh "/home/len/.conky/conky-startup.sh" &
nitrogen --restore &
compton &
clipit &
nm-applet &
pa-applet &
cbatticon &
pamac-tray &
redshift-gtk &
synapse &
psensor &
caffeine &
xscreensaver &
synapse &
pcmanfm --desktop &
sleep 1s
pcmanfm --set-wallpaper=/home/user/images/wallpaper/nicepic.jpg

# exec is for starting Fluxbox itself, do not put an ampersand (&) after this or Fluxbox will exit immediately.
exec /usr/bin/fluxbox

# or if you want to keep a log, uncomment the below command and comment out the above command:
# exec /usr/bin/fluxbox -log ~/.fluxbox/log



And here is a screenshot of my current desktop:


Offline mandog

  • Held Mitglied
  • *****
  • Posts: 1921
  • Architect Forum And G+ Forum Owner With Daniel S
  • Branch: All
  • Desktop: Gnome, Mate, E19, Openbox,FLuxbox,Budgie, XFCE openRC,
  • GPU Card: nvidia
  • GPU driver: Non Free
  • Kernel: latest
  • Skill: Advanced
Re: Problem using Conky on desktop
« Reply #4 on: 20. September 2015, 02:53:02 »
set your transparency in conky manager highlight the conky press the 5 button click transparency choose which you want
A ENGLISHMAN IN PERU
I'm dyslexic Please do not complain about punctuation or spelling,
FANBOY,Taken from the urban dictionary
 A pathetic insult often used by fanboys themselves to try and put down people who don't like whatever it is they like.

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: Problem using Conky on desktop
« Reply #5 on: 20. September 2015, 08:59:04 »
Starting compton without the -c option will remove all your shadows, I'm afraid...
Conky is not dependent on Compton though. You should be able to get transparency without it.
The only thing is, if you're applying Compton shadows and Conky you will have to exclude shadows for Conky in your compton.conf like that
Code: [Select]
shadow-ignore-shaped = false;
shadow-exclude = [
"class_g = 'wbar'",
"class_g = 'Conky'",
"_GTK_FRAME_EXTENTS@:c" ];
I will be at my fluxbox machine only later and can then play around with that more.
BTW, Len, you have the Synapse entry twice, not sure if this could be a problem...  8)
« Last Edit: 20. September 2015, 20:17:37 by oberon »
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: Problem using Conky on desktop
« Reply #6 on: 20. September 2015, 20:17:02 »
Ok. So I have checked this now:
The shadow-exclude entry in compton.conf needs to be with a capital C, so:
Code: [Select]
"class_g = 'Conky'"And also you have to make sure that in your conkyrc you have this:
Code: [Select]
own_window_type conkyAt least this applies to fluxbox. In other environments you will sometimes need different settings... ::)
In .fluxbox/startup you can then use
Code: [Select]
compton -c &again and the shadows for all your other windows will be back :)

« Last Edit: 20. September 2015, 20:22:38 by oberon »
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline Lend27

  • Jr. Mitglied
  • **
  • Posts: 89
  • I'm new. Be nice!
  • GPU Card: Nvidia GTX760
  • GPU driver: non-free
  • Skill: Intermediate
Re: Problem using Conky on desktop
« Reply #7 on: 22. September 2015, 14:54:20 »
I made the changes you suggested and I get extreme shadows on the conky and synapse.

Here are the files:

conkyrc:

# Overwrite this file if you want to have a permanent setting

own_window_type conky



Fluxbox startup:

#!/bin/sh
# fbsetbg -l # sets the last background set, very useful and recommended.

# In the below commands the ampersand symbol (&) is required on all applications that do not terminate immediately.
# Failure to provide them will cause Fluxbox not to start.
/usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1 &
sh "/home/len/.conky/conky-startup.sh" &
nitrogen --restore &
compton -c &
clipit &
nm-applet &
pa-applet &
cbatticon &
pamac-tray &
redshift-gtk &
synapse &
psensor &
caffeine &
xscreensaver &
synapse &
plank &
pcmanfm --desktop &
sleep 1s
pcmanfm --set-wallpaper=/home/user/images/wallpaper/nicepic.jpg

# exec is for starting Fluxbox itself, do not put an ampersand (&) after this or Fluxbox will exit immediately.
exec /usr/bin/fluxbox

# or if you want to keep a log, uncomment the below command and comment out the above command:
# exec /usr/bin/fluxbox -log ~/.fluxbox/log



compton.conf:

shadow-ignore-shaped = false;
shadow-exclude = [
   "class_g = 'Conky'" ];


Thanks!
Len


Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: Problem using Conky on desktop
« Reply #8 on: 22. September 2015, 15:08:52 »
Hi Len!
Several ideas:
A screenshot would indeed be interesting to see.
Your synapse entry in the startup file is still present twice!
See what happens if you launch fluxbox without those two pcmanfm entries - maybe they interfere with desktop rendering since pcmanfm takes over...
Normally the default settings of compton are nice, but since in your case for some reason they don't seem to apply you should still be able to define shadows the way you want them in your compton.conf like here: https://github.com/chjj/compton/blob/master/compton.sample.conf
Maybe also this entry about gtk frames could be helpful (I doubt that it applies here, but I guess it will not hurt to have it in your config ;) ):
Code: [Select]
shadow-exclude = [
"class_g = 'wbar'",
"class_g = 'Conky'",
"_GTK_FRAME_EXTENTS@:c" ];
« Last Edit: 22. September 2015, 15:17:36 by oberon »
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline Lend27

  • Jr. Mitglied
  • **
  • Posts: 89
  • I'm new. Be nice!
  • GPU Card: Nvidia GTX760
  • GPU driver: non-free
  • Skill: Intermediate
Re: Problem using Conky on desktop
« Reply #9 on: 22. September 2015, 15:23:57 »
OK, I made one change at a time to see what the effects of each are.
I removed the second synapse.
The config that creates the funky shadows is the "-c" in the startup file.
I used your recommendations on all the files and all is well until I add the "-c" in compton back to the startup file.

It doesn't appear that I have any shadows at all now.

But at least for the most part it looks "normal".
Anything else you'd like me to try?

Len


Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: Problem using Conky on desktop
« Reply #10 on: 22. September 2015, 15:33:17 »
I used your recommendations on all the files and all is well until I add the "-c" in compton back to the startup file.
It doesn't appear that I have any shadows at all now.
Yes, that's to be expected, because by removing the -c you turn off the window shadows ;)
Like that you can practically get rid of Compton altogether because fake transparency is provided by fluxbox already...
If you want to have shadows then you should try to leave the -c option on and turn off everything that did not come by default, like pcmanfm desktop, synapse ... Then I would switch back on everything one by one and see when the funky shadows start.
I remember that in your first videos the shadows looked fine! So it must definitely have to do with the changes and additions that have happened since  8)
What I think is most concerning is the fact that you are not using the native desktop but substitute it with pcmanfm!
Also maybe check if the settings in compton.conf affect the shadows at all! It might be an incompatibility of compton with one of your other software components.
« Last Edit: 22. September 2015, 15:37:38 by oberon »
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline Lend27

  • Jr. Mitglied
  • **
  • Posts: 89
  • I'm new. Be nice!
  • GPU Card: Nvidia GTX760
  • GPU driver: non-free
  • Skill: Intermediate
Re: Problem using Conky on desktop
« Reply #11 on: 22. September 2015, 17:06:14 »
OK, I will try that.
Thanks again for your help!

Len