Author Topic: new i3- and Conky-Packages available  (Read 4304 times)

0 Members and 1 Guest are viewing this topic.

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
new i3- and Conky-Packages available
« on: 27. July 2015, 18:56:55 »
With the new i3-version 0.8.13.1 (on the way to Sourceforge currently :) ) some new packages have become available (not only for i3)
  • dmenu-manjaro - an advanced version of dmenu with recency/terminal-awareness, supporting xft-fonts, mouse-interaction (from version 4.5-6, currently in unstable) and more, customized with with matching font and manjaro-green  ^-^ To be called with
    <bindsym $mod+d exec dmenu_recency>
  • i3status-manjaro - The status bar of the latest i3-edition can now be installed and updated as a package, too. An existing ~/.i3status.config will not be overwritten. You can use the new config simply by renaming your old custom config.
  • i3exit - The new exit-script detects Systemd/OpenRC automatically and includes lockscreen with screen-blur-effect and user-switch via lightdm-gtk-greeter (can be used without that feature if you're not using a DM)
  • ttf-font-icons - Icon-Font from the AUR, ideal to be used with stuff like statusbar, Conky...
i3 0.8.13.1 comes with a new lighter Conky. But the fancy lua-clock-version of the older edition can now easily be installed in any environment as
  • lua-clock-i3 - including the shortcut-reminder, or:
  • lua-clock-manjaro - the lua-clock-conky with manjaro-logo on its own (Screenshot, right)
enjoy! :)
oberon
« Last Edit: 27. July 2015, 19:08:17 by oberon »
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline mxx

  • Sr. Mitglied
  • ****
  • Posts: 420
  • Branch: stable
  • Desktop: Openbox/i3wm
  • Kernel: linux4
  • Skill: Intermediate
Re: new i3- and Conky-Packages available
« Reply #1 on: 07. August 2015, 17:05:31 »
How can the new conky (not the clock, but the other one) be edited? How can the dmenu_recency be edited?

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: new i3- and Conky-Packages available
« Reply #2 on: 07. August 2015, 17:11:23 »
How can the new conky (not the clock, but the other one) be edited?
here: /usr/share/conky/
Quote
How can the dmenu_recency be edited?
That depends on want you would like to change! :)
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline mxx

  • Sr. Mitglied
  • ****
  • Posts: 420
  • Branch: stable
  • Desktop: Openbox/i3wm
  • Kernel: linux4
  • Skill: Intermediate
Re: new i3- and Conky-Packages available
« Reply #3 on: 07. August 2015, 17:30:16 »
That depends on want you would like to change! :)
Fonts and colours :)

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: new i3- and Conky-Packages available
« Reply #4 on: 07. August 2015, 17:59:14 »
Fonts and colours :)
:o :o
At the top of /usr/bin/dmenu_recency you will find
Code: [Select]
dmenu_cmd='dmenu -fn 'Cantarell-9' -nb '#000000' -nf '#FFFFFF' -sb '#2ECC71' -sf '#333333''
-fn = font (obviously ::) )
-nb = unselected background
-nf = unselected textcolour ;D ;D
-sb = selected background
-sf = selected textcolour
« Last Edit: 07. August 2015, 18:03:19 by oberon »
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline mxx

  • Sr. Mitglied
  • ****
  • Posts: 420
  • Branch: stable
  • Desktop: Openbox/i3wm
  • Kernel: linux4
  • Skill: Intermediate
Re: new i3- and Conky-Packages available
« Reply #5 on: 07. August 2015, 18:07:55 »
Actually, some time ago I learned a new command: type. This tells some info about every other command and script. I should use it more, so I don't have to ask about the place of scripts all the time.

Offline lightbeam

  • Sr. Mitglied
  • ****
  • Posts: 286
  • Branch: Stable as in: "Whoa, Nelly!"
  • Desktop: Wide Openbox
  • GPU Card: AMD Radeon Xpress 200 Series - Methuselah Edition
  • GPU driver: Free as in Lunch
  • Kernel: Linux44, i686
  • Skill: Intermediate
Re: new i3- and Conky-Packages available
« Reply #6 on: 07. August 2015, 18:11:08 »
With the new i3-version 0.8.13.1 (on the way to Sourceforge currently :) ) some new packages have become available (not only for i3)
  • dmenu-manjaro - an advanced version of dmenu with recency/terminal-awareness, supporting xft-fonts, mouse-interaction (from version 4.5-6, currently in unstable) and more, customized with with matching font and manjaro-green  ^-^ To be called with
    <bindsym $mod+d exec dmenu_recency>
  • i3status-manjaro - The status bar of the latest i3-edition can now be installed and updated as a package, too. An existing ~/.i3status.config will not be overwritten. You can use the new config simply by renaming your old custom config.
  • i3exit - The new exit-script detects Systemd/OpenRC automatically and includes lockscreen with screen-blur-effect and user-switch via lightdm-gtk-greeter (can be used without that feature if you're not using a DM)
  • ttf-font-icons - Icon-Font from the AUR, ideal to be used with stuff like statusbar, Conky...
i3 0.8.13.1 comes with a new lighter Conky. But the fancy lua-clock-version of the older edition can now easily be installed in any environment as
  • lua-clock-i3 - including the shortcut-reminder, or:
  • lua-clock-manjaro - the lua-clock-conky with manjaro-logo on its own (Screenshot, right)
enjoy! :)
oberon

These things can be installed in Openbox DE?  I could kill a weekend fiddling around with that stuff!  ;)
---------------------------------------------------
I make you look good. 8)

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: new i3- and Conky-Packages available
« Reply #7 on: 07. August 2015, 18:21:17 »
These things can be installed in Openbox DE?  I could kill a weekend fiddling around with that stuff!  ;)
The conkies for sure! Meanwhile there is also the new one: conky-i3 - just the shortcuts will not make too much sense for you. You could just adjust them to match yours or edit the launch script to only start the right widget.
About dmenu-manjaro I'm not so sure. You will have to ask the openboxers about that, or just try it. It conflicts with dmenu, but you can always revert that of course.
The icon-font of course, no question.
Statusbar ??? nope.
And i3exit will definitely only work in i3.
 8)
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline withjaro

  • Held Mitglied
  • *****
  • Posts: 772
  • 360
  • Branch: unstable
  • Desktop: openrc
  • GPU Card: geforce7150/ATIx2300
  • GPU driver: free
  • Kernel: linux4xxx-x64
  • Skill: Novice
Re: new i3- and Conky-Packages available
« Reply #8 on: 07. August 2015, 18:27:21 »
interested in the conky-lua :) .... which got me looking at http://unix.stackexchange.com/questions/168705/conky-block-padding-archlinux ... (yep,got my cut and paste mixed up there.. did you see that ;))
just wondered if there is any involvement with http://lua-users.org/wiki/PlutoLibrary ?
« Last Edit: 07. August 2015, 18:30:12 by withjaro »
< insert your own inspiring quotation - and smile :) >

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: new i3- and Conky-Packages available
« Reply #9 on: 07. August 2015, 19:07:42 »
interested in the conky-lua :) .... which got me looking at http://unix.stackexchange.com/questions/168705/conky-block-padding-archlinux ...
just wondered if there is any involvement with http://lua-users.org/wiki/PlutoLibrary ?
I'm not sure what you mean ???
What is it with the padding problem and the Plutolibrary?
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline withjaro

  • Held Mitglied
  • *****
  • Posts: 772
  • 360
  • Branch: unstable
  • Desktop: openrc
  • GPU Card: geforce7150/ATIx2300
  • GPU driver: free
  • Kernel: linux4xxx-x64
  • Skill: Novice
Re: new i3- and Conky-Packages available
« Reply #10 on: 07. August 2015, 19:19:15 »
sorry oberon  :-[ ... not relevant to any existing situation .. i was just projecting thoughts O:-)

just wondered also ... is there like a real-time code scroller window attachment for Conky ... like a text pictorial ticker tape (htop?)?
have to have a good look at Conky addons
« Last Edit: 07. August 2015, 19:47:55 by withjaro »
< insert your own inspiring quotation - and smile :) >

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: new i3- and Conky-Packages available
« Reply #11 on: 07. August 2015, 20:03:10 »
:)

 >:( We DON'T have a padding problem!!  ;D ;D
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline withjaro

  • Held Mitglied
  • *****
  • Posts: 772
  • 360
  • Branch: unstable
  • Desktop: openrc
  • GPU Card: geforce7150/ATIx2300
  • GPU driver: free
  • Kernel: linux4xxx-x64
  • Skill: Novice
Re: new i3- and Conky-Packages available
« Reply #12 on: 07. August 2015, 20:08:31 »
Pas de probleme ;)
< insert your own inspiring quotation - and smile :) >