Author Topic: Octopi doesn't recognize kdesu  (Read 2095 times)

0 Members and 1 Guest are viewing this topic.

Offline Spacesurfer

  • Jr. Mitglied
  • **
  • Posts: 54
  • Branch: Stable
  • Desktop: LXQt
  • GPU Card: AMD Radeon HD 7870
  • GPU driver: Non-Free
  • Kernel: linux41-x64
  • Skill: Novice
Octopi doesn't recognize kdesu
« on: 29. May 2015, 23:55:18 »
Just setup Manjaro with the net-install. Went ahead and add Octopi. Said I needed kdesu so I installed it. After a few reboots it still doesn't recognize that I have it. What am I missing?

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: Octopi doesn't recognize kdesu
« Reply #1 on: 29. May 2015, 23:58:05 »
Hi Spacesurfer!
Do you have gksu installed?
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline Spacesurfer

  • Jr. Mitglied
  • **
  • Posts: 54
  • Branch: Stable
  • Desktop: LXQt
  • GPU Card: AMD Radeon HD 7870
  • GPU driver: Non-Free
  • Kernel: linux41-x64
  • Skill: Novice
Re: Octopi doesn't recognize kdesu
« Reply #2 on: 30. May 2015, 00:00:26 »
No I'm running LXQt and wanted a Qt based su manager. Sorry I should have mentioned that before.

Offline Robin0800

  • Vollwertiges Mitglied
  • ***
  • Posts: 125
  • Branch: Stable
  • Desktop: Cinnamon as KDE Dolphin doesn't like my phone or tablet
  • GPU Card: Nvidia gt 520
  • GPU driver: non free
  • Skill: Intermediate
Re: Octopi doesn't recognize kdesu
« Reply #3 on: 30. May 2015, 12:13:47 »
You need kdesu4 not kdsu one is for kde4 and the other for plasma5 this is a recent change when kdesu was removed from the framework

Offline Spacesurfer

  • Jr. Mitglied
  • **
  • Posts: 54
  • Branch: Stable
  • Desktop: LXQt
  • GPU Card: AMD Radeon HD 7870
  • GPU driver: Non-Free
  • Kernel: linux41-x64
  • Skill: Novice
Re: Octopi doesn't recognize kdesu
« Reply #4 on: 01. June 2015, 05:51:46 »
Trying to download kdesu4 leads to downloading 102MB of stuff... Is there no other way for Qt?

Edit 1: I guess not right now. Thanks for your help oberon and Robin0800.

https://forum.manjaro.org/index.php?topic=22909.0
« Last Edit: 01. June 2015, 05:56:57 by Spacesurfer »

Offline wanderson

  • Neuling
  • *
  • Posts: 1
  • I'm new. Be nice!
  • Branch: 0.8.12 stable
  • Desktop: KDE
  • GPU Card: ATI Radeon
  • GPU driver: non-free
  • Kernel: 3.19
  • Skill: Intermediate
Re: Octopi doesn't recognize kdesu
« Reply #5 on: 20. June 2015, 21:25:35 »
Unble to update 0.8.12 for fist time, with error message:There are no means to get Administrator's credentials. You'll need to install a su frontend like gksu or kdesu"

Attempt to install kdesu (for KDE desktop) gave same error message.

Offline AJSlye

  • Maintainer
  • ***
  • Posts: 4298
  • Netrunner Rolling Edition moderator / maintainer
  • Branch: Stable / Testing / Unstable
  • Desktop: Netrunner Rolling
  • GPU Card: Intel
  • GPU driver: Intel
  • Kernel: 4.4.1-1-MANJARO x86_64 (64 bit)
  • Skill: Guru
Re: Octopi doesn't recognize kdesu
« Reply #6 on: 20. June 2015, 22:37:54 »
kdesu is for plasma 5, kdesu4 is for KDE SC 4, if your not running either of these than you will need to install gksu for Octopi.
« Last Edit: 21. June 2015, 00:17:31 by AJSlye »

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: Octopi doesn't recognize kdesu
« Reply #7 on: 20. June 2015, 23:00:07 »
@wanderson, Its a bit strange that gksu would not be pre-installed on your system... ???
In any case, since octopi will not (yet) be working for you, open a terminal a try
Code: [Select]
sudo pacman -S gksuHopefully octopi will be happier then - if you get an error, please post the output of the above mentioned command.
« Last Edit: 20. June 2015, 23:05:48 by oberon »
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline Kirek

  • Core Team
  • *****
  • Posts: 1209
  • Branch: unstable
  • Desktop: Plasma 5
  • GPU Card: Intel HD4000 + Nvidia 620M / Geforxe GTX 970
  • GPU driver: nonfree
  • Kernel: Latest
  • Skill: Intermediate
Re: Octopi doesn't recognize kdesu
« Reply #8 on: 20. June 2015, 23:03:59 »
For kdesu install kde-cli-tools (plasma5 version), or kdesu4 (kde4 version). Installing kdesu package will do nothing, its only libraries.

Offline AJSlye

  • Maintainer
  • ***
  • Posts: 4298
  • Netrunner Rolling Edition moderator / maintainer
  • Branch: Stable / Testing / Unstable
  • Desktop: Netrunner Rolling
  • GPU Card: Intel
  • GPU driver: Intel
  • Kernel: 4.4.1-1-MANJARO x86_64 (64 bit)
  • Skill: Guru
Re: Octopi doesn't recognize kdesu
« Reply #9 on: 21. June 2015, 00:19:39 »
For kdesu install kde-cli-tools (plasma5 version), or kdesu4 (kde4 version). Installing kdesu package will do nothing, its only libraries.

Oops I do apologize, I completely forgot all about the need for kde-cli-tools for kdesu to work.