Author Topic: The problem with updating  (Read 1374 times)

0 Members and 1 Guest are viewing this topic.

Offline tukvondo

  • Neuling
  • *
  • Posts: 11
The problem with updating
« on: 13. April 2013, 17:11:47 »
Help, Friends! When upgrading a Pamaс issued the following message:

libgl will be replaced by mesa-libgl
gummiboot-efi will be replaced by gummiboot
lib32-libgl will be replaced by lib32-mesa-libgl
lib32-libglapi will be replaced by lib32-Mesa


How to solve this problem? Thank you!

Offline tukvondo

  • Neuling
  • *
  • Posts: 11
Re: The problem with updating
« Reply #1 on: 13. April 2013, 17:14:01 »
Then this:

Init Error:
Traceback (most recent call last):
  File "/usr/lib/python3.3/site-packages/pamac/pamac-daemon.py", line 185, in Init
    t = config.handle.init_transaction(**options)
alpm.error: transaction could not be initialized, pm_errno 10 (unable to lock database)

Offline DiscipleOfDante

  • Sr. Mitglied
  • ****
  • Posts: 406
  • Branch: Unstable
  • Desktop: Plasma 5
  • GPU Card: Intel HD 4000
  • GPU driver: Free
  • Kernel: linux-ck-x64
  • Skill: Intermediate
Re: The problem with updating
« Reply #2 on: 13. April 2013, 17:37:29 »
That first one can be solved by doing an update from the command line and saying yes to all the prompts, don't know about that second one though

Offline philm

  • Core Team
  • *****
  • Posts: 10671
    • Manjaro Linux
  • Branch: Unstable
  • Desktop: XFCE
  • GPU Card: Geforce GTX 650
  • GPU driver: non-free
  • Kernel: Maintainer - so all ;)
  • Skill: Guru
Re: The problem with updating
« Reply #3 on: 13. April 2013, 17:48:00 »
You have to use pacman for this update as written in our blog:

Code: [Select]
sudo rm -v /var/lib/pacman/db.lck
sudo pacman -Syy
sudo pacman -Suu

... follow the instructions ...