Author Topic: [intel drivers] Solving the light-locker black screen problem.  (Read 984 times)

0 Members and 1 Guest are viewing this topic.

Offline Berneri

  • Vollwertiges Mitglied
  • ***
  • Posts: 103
  • Branch: Testing
  • Desktop: xfce
  • GPU Card: intel GMA 4500
  • GPU driver: free
  • Kernel: linux318
  • Skill: Novice
Hi all,

After researching a bit this problem, I found a solution on the Arch forums. Briefly, this is what we see in the
Code: [Select]
/etc/X11/mhwd.d/intel.conf.old
Code: [Select]
Section "Device"
Identifier  "Device0"
Driver      "intel"
BusID       "PCI:0:2:0"
Option      "AccelMethod" "sna"
Option      "DRI"    "true"
EndSection
Changing "sna" to "uxa" seems to fix the problem.
« Last Edit: 13. December 2015, 03:44:52 by oberon »

Offline chimy

  • Jr. Mitglied
  • **
  • Posts: 79
  • I'm new. Be nice!
  • Skill: Intermediate
Re: [intel drivers] Solving the light-locker black screen problem.
« Reply #1 on: 09. December 2015, 22:26:39 »
But only if you don't encounter problems with sna; see https://forum.manjaro.org/index.php?topic=15120.0 or https://wiki.archlinux.org/index.php/Intel_graphics:

Quote
SNA is the default acceleration method in xf86-video-intel. If you are experience issues with SNA (e.g. pixelated graphics, corrupt text, etc.), try using UXA instead, which can be done by adding the following line to your configuration file:

Code: [Select]
Option      "AccelMethod"  "uxa"

Otherwise you can just remove light-locker and install xscreensaver instead. See https://forum.manjaro.org/index.php?topic=28234.msg238566#msg238566

Offline daogiahieu

  • Vollwertiges Mitglied
  • ***
  • Posts: 143
  • I'm new. Be nice!
  • Branch: Stable
  • Desktop: KDE plasma 5.5.x
  • Kernel: Linux Manjaro kernel 4.1 LTS
  • Skill: Novice
Re: [intel drivers] Solving the light-locker black screen problem.
« Reply #2 on: 13. December 2015, 03:20:42 »
But only if you don't encounter problems with sna; see https://forum.manjaro.org/index.php?topic=15120.0 or https://wiki.archlinux.org/index.php/Intel_graphics:

Otherwise you can just remove light-locker and install xscreensaver instead. See https://forum.manjaro.org/index.php?topic=28234.msg238566#msg238566
I am using KDE and have this problem too.
I have change "sna" to "uxa", but it isn't work.
Can i remove light-locker and install xscreensaver ?
because chimy said he used XFCE and this worked with him, but i am using KDE ?

edit: i have sloved this problem through installing caffeine-ng :) thanks for manjaro IRC
« Last Edit: 13. December 2015, 06:07:01 by daogiahieu »

Offline chimy

  • Jr. Mitglied
  • **
  • Posts: 79
  • I'm new. Be nice!
  • Skill: Intermediate
Re: [intel drivers] Solving the light-locker black screen problem.
« Reply #3 on: 13. December 2015, 11:47:45 »
edit: i have sloved this problem through installing caffeine-ng :) thanks for manjaro IRC

Well, if you don't need to lock your screen and / or use the suspend / hibernate function... caffeine just prohibits your system to enable the screensaver or go to sleep.