Author Topic: Cant upgrade after fresh install  (Read 15045 times)

0 Members and 1 Guest are viewing this topic.

Offline t101

  • Vollwertiges Mitglied
  • ***
  • Posts: 208
  • Branch: Stable
  • Desktop: KDE
  • GPU Card: Nvidia GeForce GTX 650
  • GPU driver: Non Free 343.36
  • Kernel: 3.19.1-1-MANJARO
  • Skill: Novice
Cant upgrade after fresh install
« on: 12. April 2015, 11:32:23 »
Hi after installing from the latest xfce iso I cant upgrade.

Code: [Select]
$ sudo pacman -S archlinux-keyring manjaro-keyring
warning: downgrading package archlinux-keyring (20141218-1 => 20140908-1)
warning: downgrading package manjaro-keyring (20141220-1 => 20141014-1)
resolving dependencies...
looking for conflicting packages...

Packages (2) archlinux-keyring-20140908-1  manjaro-keyring-20141014-1

Total Installed Size:   0.64 MiB
Net Upgrade Size:      -0.04 MiB

:: Proceed with installation? [Y/n]
(2/2) checking keys in keyring                     [######################] 100%
(2/2) checking package integrity                   [######################] 100%
error: manjaro-keyring: signature from "Rob McCathie <korrode@gmail.com>" is unknown trust
:: File /var/cache/pacman/pkg/manjaro-keyring-20141014-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: failed to commit transaction (invalid or corrupted package (PGP signature))
Errors occurred, no packages were upgraded.


Code: [Select]
$ sudo pacman -Syu
[sudo] password for roll:
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
:: Starting full system upgrade...
warning: acpid: local (2.0.23-4) is newer than community (2.0.23-3)
warning: archlinux-keyring: local (20141218-1) is newer than core (20140908-1)
warning: bash: local (4.3.033-1) is newer than core (4.3.030-1)
warning: binutils: local (2.25-1) is newer than core (2.24-8)
warning: bluez: local (5.27-1) is newer than extra (5.25-2)
warning: bluez-libs: local (5.27-1) is newer than extra (5.25-2)
warning: btrfs-progs: local (3.17.3-1) is newer than core (3.17.2-1)
warning: ca-certificates: local (20140923-9) is newer than core (20140325-2)
warning: ca-certificates-cacert: local (20140824-2) is newer than core (20140824-1)
warning: ca-certificates-mozilla: local (3.17.3-2) is newer than extra (3.17.2-1)
warning: ca-certificates-utils: local (20140923-9) is newer than core (20140325-2)
warning: cantarell-fonts: local (0.0.16-2) is newer than extra (0.0.16-1)
warning: cifs-utils: local (6.4-1) is newer than extra (6.3-2)
warning: colord: local (1.2.7-2) is newer than extra (1.2.5-1)
warning: cpupower: local (3.18-1) is newer than community (3.17-1)
warning: cups-filters: local (1.0.62-1) is newer than extra (1.0.61-3)
warning: curl: local (7.40.0-1) is newer than core (7.39.0-1)
warning: dbus: local (1.8.14-1) is newer than core (1.8.10-1)
warning: device-mapper: local (2.02.114-1) is newer than core (2.02.112-1)
warning: dhcpcd: local (6.6.7-1) is newer than core (6.6.4-1)
warning: dosfstools: local (3.0.27-1) is newer than core (3.0.26-1)
warning: elfutils: local (0.161-2) is newer than extra (0.160-1)
warning: ethtool: local (1:3.18-1) is newer than extra (1:3.16-1)
warning: exfat-utils: local (1.1.1-1) is newer than community (1.1.0-1)
warning: ffmpeg: local (1:2.5.3-1) is newer than extra (1:2.4.3-1)
warning: file: local (5.22-1) is newer than core (5.20-2)
warning: firefox: local (35.0-1) is newer than extra (33.1.1-1)
warning: flashplugin: local (11.2.202.440-1) is newer than extra (11.2.202.424-1)
warning: foomatic-db: local (3:20141229-1) is newer than extra (3:20141011-1)
warning: foomatic-db-engine: local (3:20141229-1) is newer than extra (3:20141011-1)
warning: foomatic-db-nonfree: local (3:20141229-1) is newer than extra (3:20141011-1)
warning: freetype2: local (2.5.5-1) is newer than extra (2.5.3-2)
warning: gcc: local (4.9.2-2) is newer than core (4.9.2-1)
warning: gcc-libs: local (4.9.2-2) is newer than core (4.9.2-1)
warning: glibc: local (2.20-6) is newer than core (2.20-4)
warning: gnome-themes-standard: local (3.14.2.3-1) is newer than extra (3.14.2-1)
warning: gnupg: local (2.1.1-1) is newer than core (2.1.0-6)
warning: gnutls: local (3.3.12-1) is newer than extra (3.3.10-1)
warning: gperftools: local (2.4-1) is newer than extra (2.2.1-1)
warning: gpgme: local (1.5.3-1) is newer than core (1.5.1-1)
warning: grub: local (2.02.beta2-8.2) is newer than core (2.02.beta2-6)
warning: gst-libav: local (1.4.5-1) is newer than extra (1.4.4-1)
warning: gst-plugins-bad: local (1.4.5-1) is newer than extra (1.4.4-1)
warning: gst-plugins-base: local (1.4.5-1) is newer than extra (1.4.4-1)
warning: gst-plugins-base-libs: local (1.4.5-1) is newer than extra (1.4.4-1)
warning: gst-plugins-good: local (1.4.5-1) is newer than extra (1.4.4-1)
warning: gst-plugins-ugly: local (1.4.5-1) is newer than extra (1.4.4-2)
warning: gstreamer: local (1.4.5-1) is newer than extra (1.4.4-1)
warning: gtk3: local (3.14.7-1) is newer than extra (3.14.5-1)
warning: gtksourceview3: local (3.14.3-1) is newer than extra (3.14.2-1)
warning: gufw: local (15.04.0-1) is newer than community (14.10.1-1)
warning: gvfs: local (1.22.3-1) is newer than extra (1.22.2-3)
warning: gvfs-afc: local (1.22.3-1) is newer than extra (1.22.2-3)
warning: gvfs-afp: local (1.22.3-1) is newer than extra (1.22.2-3)
warning: gvfs-gphoto2: local (1.22.3-1) is newer than extra (1.22.2-3)
warning: gvfs-mtp: local (1.22.3-1) is newer than extra (1.22.2-3)
warning: gvfs-smb: local (1.22.3-1) is newer than extra (1.22.2-3)
warning: harfbuzz: local (0.9.37-1) is newer than extra (0.9.36-1)
warning: harfbuzz-icu: local (0.9.37-1) is newer than extra (0.9.36-1)
warning: haveged: local (1.9.1-2) is newer than extra (1.9.1-1)
warning: hwids: local (20141214-1) is newer than core (20141030-1)
warning: hwinfo: local (21.10.1.1-1) is newer than community (21.8.1.1-1)
warning: imagemagick: local (6.9.0.4-1) is newer than extra (6.9.0.0-1)
warning: inxi: local (2.2.17-1) is newer than community (2.2.16-1)
warning: iso-codes: local (3.57-1) is newer than extra (3.52-1)
warning: jasper: local (1.900.1-12.10) is newer than extra (1.900.1-10)
warning: jre7-openjdk: local (7.u75_2.5.4-1) is newer than extra (7.u71_2.5.3-1)
warning: jre7-openjdk-headless: local (7.u75_2.5.4-1) is newer than extra (7.u71_2.5.3-1)
warning: kitemmodels: local (5.6.0-1) is newer than extra (5.4.0-1)
warning: ldb: local (1.1.19-1) is newer than extra (1.1.17-1)
warning: less: local (471-1) is newer than core (470-1)
warning: libass: local (0.12.1-1) is newer than extra (0.12.0-1)
warning: libcap: local (2.24-2) is newer than core (2.24-1)
warning: libdbus: local (1.8.14-1) is newer than core (1.8.10-1)
warning: libdrm: local (2.4.59-1) is newer than extra (2.4.58-1)
warning: libdvdnav: local (5.0.2-1) is newer than extra (5.0.1-1)
warning: libdvdread: local (5.0.1-1) is newer than extra (5.0.0-1)
warning: libebml: local (1.3.1-1) is newer than extra (1.3.0-2)
warning: libevdev: local (1.3.2-1) is newer than extra (1.3.1-1)
warning: libevent: local (2.0.22-1) is newer than core (2.0.21-3)
warning: libffi: local (3.2.1-1) is newer than core (3.1-3)
warning: libgadu: local (1.12.1-1) is newer than extra (1.12.0-2)
warning: libgdiplus: local (3.12-1) is newer than extra (3.8-1)
warning: libgphoto2: local (2.5.6-1) is newer than extra (2.5.5.1-1)
warning: libjpeg-turbo: local (1.4.0-1) is newer than extra (1.3.1-3)
warning: libldap: local (2.4.40-2) is newer than core (2.4.40-1)
warning: libmatroska: local (1.4.2-1) is newer than extra (1.4.1-1)
warning: libmbim: local (1.12.0-1) is newer than extra (1.10.0-1)
warning: libpng: local (1.6.16-1) is newer than extra (1.6.15-1)
warning: libpulse: local (5.0-1.1) is newer than extra (5.0-1)
warning: libqmi: local (1.12.0-1) is newer than extra (1.10.4-1)
warning: libreoffice-still-calc: local (4.2.8-2) is newer than extra (4.2.7-2)
warning: libreoffice-still-common: local (4.2.8-2) is newer than extra (4.2.7-2)
warning: libreoffice-still-en-US: local (4.2.8-2) is newer than extra (4.2.7-2)
warning: libreoffice-still-gnome: local (4.2.8-2) is newer than extra (4.2.7-2)
warning: libreoffice-still-impress: local (4.2.8-2) is newer than extra (4.2.7-2)
warning: libreoffice-still-math: local (4.2.8-2) is newer than extra (4.2.7-2)
warning: libreoffice-still-writer: local (4.2.8-2) is newer than extra (4.2.7-2)
warning: librsvg: local (1:2.40.6-1) is newer than extra (1:2.40.5-1)
warning: libsoup: local (2.48.1-1) is newer than extra (2.48.0-1)
warning: libsystemd: local (218-1) is newer than core (217-8)
warning: libteam: local (1.14-1) is newer than extra (1.11-1)
warning: libtool: local (2.4.4-2) is newer than core (2.4.2-15)
warning: libva: local (1.5.0-1) is newer than extra (1.4.1-1)
warning: libvdpau: local (0.9-1) is newer than extra (0.8-1)
warning: libwbclient: local (4.1.16-1) is newer than extra (4.1.13-1)
warning: libxshmfence: local (1.2-1) is newer than extra (1.1-1)
warning: linux-api-headers: local (3.18.1-1) is newer than core (3.16.2-1)
warning: linux-firmware: local (20141201.38e5405-1) is newer than core (20141009.0e5f637-1)
warning: linux316: local (3.16.7.4-1) is newer than core (3.16.7.1-1)
warning: linux316-ndiswrapper: local (1.59-6) is newer than extra (1.59-4)
warning: linux316-nvidia: local (343.36-3) is newer than extra (343.22-3)
warning: llvm-libs: local (3.5.1-1) is newer than extra (3.5.0-2)
warning: lvm2: local (2.02.114-1) is newer than core (2.02.112-1)
warning: lxsession: local (1:0.5.2-1.1) is newer than community (1:0.5.1-1.1)
warning: lz4: local (127-1) is newer than core (124-1)
warning: man-pages: local (3.77-1) is newer than core (3.75-1)
warning: manjaro-documentation: local (0.8.12-1) is newer than extra (0.8.11-1)
warning: manjaro-keyring: local (20141220-1) is newer than core (20141014-1)
warning: manjaro-release: local (0.8.12-1) is newer than core (0.8.11-1)
warning: manjaro-settings-manager: local (0.4.6-1) is newer than extra (0.4.3-1)
warning: manjaro-system: local (20150118-1) is newer than core (20141120-1)
warning: manjaro-welcome: local (0.8.12-1) is newer than extra (0.8.11-2)
warning: mdadm: local (3.3.2-1) is newer than core (3.3.1-2)
warning: menda-circle-icon-theme: local (20141219-1) is newer than extra (20141128-1)
warning: menda-square-icon-theme: local (20141219-1) is newer than extra (20141128-1)
warning: menda-themes: local (20150103-1) is newer than extra (20141123-1)
warning: menulibre: local (1:2.0.6-1) is newer than community (1:2.0-2)
warning: mesa: local (10.4.2-1) is newer than extra (10.3.4-1)
warning: mhwd: local (0.5.1-1) is newer than core (0.5.0-1)
warning: mhwd-catalyst: local (14.501-0) is newer than core (14.201-1)
warning: mhwd-db: local (0.5.1-1) is newer than core (0.5.0-1)
warning: mhwd-nvidia: local (343.36-1) is newer than core (343.22-2)
warning: mhwd-nvidia-304xx: local (304.125-1) is newer than core (304.123-1)
warning: mhwd-nvidia-340xx: local (340.65-1) is newer than core (340.58-1)
warning: mlocate: local (0.26-5) is newer than core (0.26-3)
warning: mono: local (3.12.0-1) is newer than extra (3.10.0-1)
warning: mpfr: local (3.1.2.p11-1) is newer than core (3.1.2.p10-1)
warning: mutagen: local (1.27-1) is newer than extra (1.26-1)
warning: ncurses: local (5.9-7) is newer than core (5.9-6)
warning: netctl: local (1.10-1) is newer than core (1.9-1)
warning: networkmanager-openconnect: local (0.9.10.0-2) is newer than extra (0.9.10.0-1)
warning: nss: local (3.17.3-2) is newer than extra (3.17.2-1)
warning: ntp: local (4.2.8-1) is newer than extra (4.2.7.p465-2)
warning: nvidia-utils: local (343.36-1) is newer than extra (343.22-1)
warning: openconnect: local (1:7.02-1) is newer than extra (1:6.00-3)
warning: openssl: local (1.0.1.l-1) is newer than core (1.0.1.j-1)
warning: openvpn: local (2.3.6-1) is newer than core (2.3.5-1)
warning: orc: local (0.4.23-1) is newer than extra (0.4.22-1)
warning: os-prober: local (1.65-0.1) is newer than community (1.64-1)
warning: p11-kit: local (0.22.1-3) is newer than extra (0.22.1-1)
warning: package-query: local (1.5-1) is newer than extra (1.4-1)
warning: pacman: local (4.2.0-6.4) is newer than core (4.1.2-8)
warning: pacman-mirrorlist: local (20150105-1) is newer than core (20140831-1)
warning: pamac: local (2.1.1-1) is newer than extra (2.0-1)
warning: pciutils: local (3.3.0-1) is newer than core (3.2.1-1)
warning: perl-dbi: local (1.633-1) is newer than extra (1.632-1)
warning: perl-xml-libxml: local (2.0117-1) is newer than community (2.0116-2)
warning: poppler: local (0.29.0-1) is newer than extra (0.28.1-1)
warning: poppler-glib: local (0.29.0-1) is newer than extra (0.28.1-1)
warning: poppler-qt5: local (0.29.0-1) is newer than extra (0.28.1-1)
warning: pulseaudio: local (5.0-1.1) is newer than extra (5.0-1)
warning: python: local (3.4.2-2) is newer than extra (3.4.2-1)
warning: python-configobj: local (5.0.6-1) is newer than community (5.0.5-1)
warning: python-psutil: local (2.2.0-1) is newer than community (2.1.3-1)
warning: python-pycups: local (1.9.70-1) is newer than extra (1.9.68-1)
warning: python-pycurl: local (7.19.5.1-1) is newer than extra (7.19.5-1)
warning: python-sip: local (4.16.5-1) is newer than extra (4.16.4-1)
warning: python-six: local (1.9.0-1) is newer than community (1.8.0-1)
warning: python2: local (2.7.9-1) is newer than extra (2.7.8-2)
warning: python2-sip: local (4.16.5-1) is newer than extra (4.16.4-1)
warning: qpdfview: local (0.4.13-1.2) is newer than community (0.4.13-1)
warning: qt4: local (4.8.6-4) is newer than extra (4.8.6-3)
warning: qt5-base: local (5.4.0-3) is newer than extra (5.3.2-2)
warning: qt5-declarative: local (5.4.0-3) is newer than extra (5.3.2-2)
warning: qt5-location: local (5.4.0-3) is newer than extra (5.3.2-2)
warning: qt5-sensors: local (5.4.0-3) is newer than extra (5.3.2-2)
warning: qt5-svg: local (5.4.0-3) is newer than extra (5.3.2-2)
warning: qt5-webkit: local (5.4.0-3) is newer than extra (5.3.2-2)
warning: qt5-xmlpatterns: local (5.4.0-3) is newer than extra (5.3.2-2)
warning: qtchooser: local (48-1) is newer than extra (41-1)
warning: s-nail: local (14.7.11-1) is newer than core (14.7.8-1)
warning: sdparm: local (1.09-1) is newer than core (1.08-1)
warning: shadow: local (4.2.1-2) is newer than core (4.2.1-1)
warning: sip: local (4.16.5-1) is newer than extra (4.16.4-1)
warning: smbclient: local (4.1.16-1) is newer than extra (4.1.13-1)
warning: spandsp: local (0.0.6-1) is newer than extra (0.0.6pre21-2)
warning: sqlite: local (3.8.8-1) is newer than extra (3.8.7.2-1)
warning: steam-native: local (1.0.0.49-7.1) is newer than community (1.0.0.49-6.1)
warning: subversion: local (1.8.11-2) is newer than extra (1.8.10-1)
warning: system-config-printer: local (1.5.4-2) is newer than extra (1.5.4-1)
warning: systemd: local (218-1) is newer than core (217-8)
warning: systemd-sysvcompat: local (218-1) is newer than core (217-8)
warning: tdb: local (1.3.4-1) is newer than extra (1.3.1-1)
warning: thunar: local (1.6.4-2) is newer than extra (1.6.3-6)
warning: thunderbird: local (31.4.0-1) is newer than extra (31.2.0-1)
warning: ttf-droid: local (20121017-4) is newer than community (20121017-3)
warning: ttf-inconsolata: local (20090215-5) is newer than community (20090215-4)
warning: ttf-indic-otf: local (0.2-8) is newer than extra (0.2-7)
warning: ttf-khmer: local (5.0-5) is newer than extra (5.0-4)
warning: ttf-liberation: local (2.00.1-5) is newer than community (2.00.1-4)
warning: ttf-tlwg: local (0.6.1-2) is newer than extra (0.6.1-1)
warning: unrar: local (1:5.2.3-2) is newer than extra (1:5.2.2-1)
warning: unzip: local (6.0-9) is newer than extra (6.0-7)
warning: upower: local (0.99.2-1) is newer than extra (0.99.1-3)
warning: vte-common: local (0.38.3-1) is newer than extra (0.38.2-1)
warning: vte3: local (0.38.3-1) is newer than extra (0.38.2-1)
warning: webkitgtk: local (2.4.8-1) is newer than extra (2.4.7-1)
warning: webkitgtk2: local (2.4.8-1) is newer than extra (2.4.7-1)
warning: wget: local (1.16.1-1) is newer than extra (1.16-2)
warning: xfce4-cpufreq-plugin: local (1.1.1-1) is newer than extra (1.1.0-1)
warning: xfce4-panel: local (4.11.2-1) is newer than extra (4.11.1-4)
warning: xfce4-power-manager: local (1.4.2-1) is newer than extra (1.4.1-3)
warning: xfce4-session: local (4.11.1-2) is newer than extra (4.11.0-8)
warning: xfce4-settings: local (4.11.3-3) is newer than extra (4.11.3-2)
warning: xfce4-taskmanager: local (1.1.0-1) is newer than extra (1.0.1-1)
warning: xfce4-weather-plugin: local (0.8.5-1) is newer than extra (0.8.4-1)
warning: xfce4-whiskermenu-plugin: local (1.4.2-1) is newer than community (1.4.0-3)
warning: xfdesktop: local (4.11.8-6) is newer than extra (4.11.8-5)
warning: xfsprogs: local (3.2.2-1) is newer than core (3.2.1-1)
warning: xfwm4: local (4.11.2-4) is newer than extra (4.11.2-1)
warning: xorg-bdftopcf: local (1.0.5-1) is newer than extra (1.0.4-2)
warning: xorg-fonts-misc: local (1.0.3-2) is newer than extra (1.0.1-3)
warning: xorg-iceauth: local (1.0.7-1) is newer than extra (1.0.6-1)
warning: xorg-mkfontscale: local (1.1.2-1) is newer than extra (1.1.1-1)
warning: xorg-server: local (1.16.3-2) is newer than extra (1.16.2-1)
warning: xorg-server-common: local (1.16.3-2) is newer than extra (1.16.2-1)
warning: xorg-sessreg: local (1.1.0-1) is newer than extra (1.0.8-2)
warning: xproto: local (7.0.27-1) is newer than extra (7.0.26-1)
warning: xz: local (5.2.0-1) is newer than core (5.0.7-1)
warning: yaourt: local (1.5-1.3) is newer than extra (1.5-1.1)
warning: zip: local (3.0-6) is newer than extra (3.0-4)
warning: zita-alsa-pcmi: local (0.2.0-2) is newer than extra (0.2.0-1)
warning: zita-resampler: local (1.3.0-3) is newer than extra (1.3.0-2)
warning: zvbi: local (0.2.35-1) is newer than extra (0.2.33-6)
 there is nothing to do
The loneliest people are the kindest. The saddest people smile the brightest. The most damaged people are the wisest.

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: Cant upgrade after fresh install
« Reply #1 on: 12. April 2015, 12:32:20 »
You will find all your answers bei doing a forum search with keywords "Rob McCathie" for example :) ;)
Good luck!
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline Kirkx

  • Neuling
  • *
  • Posts: 11
  • Branch: Stable
  • Desktop: Xfce
  • GPU Card: Nvidia GF 8500 GT
  • GPU driver: video-nouveau
  • Kernel: 312_x64
  • Skill: Novice
Re: Cant upgrade after fresh install
« Reply #2 on: 12. April 2015, 12:35:34 »
It's a known issue. Have a look at post #2 (reply #1) here:

https://forum.manjaro.org/index.php?topic=21925.0

Keep in mind that the command below will initialize pacman keyring. You need to generate entropy (move the mouse around and hit keys at random), otherwise it may take hours to complete:

sudo pacman-key --init
« Last Edit: 12. April 2015, 12:38:31 by Kirkx »

Offline oberon

  • Core Team
  • *****
  • Posts: 3858
  • I'm nice. Be new!
  • Branch: unstable
  • Desktop: i3, Deepin, Cinnamon
  • GPU Card: Intel ValleyView Gen7
  • GPU driver: Intel
  • Kernel: 4.1 / 4.4
  • Skill: Intermediate
Re: Cant upgrade after fresh install
« Reply #3 on: 12. April 2015, 12:42:15 »
You need to generate entropy (move the mouse around and hit keys at random

 :o ??? :D
manjaro is addictive ::)
* manjaro-i3  * manjaro-cinnamon  * manjaro-deepin

Offline t101

  • Vollwertiges Mitglied
  • ***
  • Posts: 208
  • Branch: Stable
  • Desktop: KDE
  • GPU Card: Nvidia GeForce GTX 650
  • GPU driver: Non Free 343.36
  • Kernel: 3.19.1-1-MANJARO
  • Skill: Novice
Re: Cant upgrade after fresh install
« Reply #4 on: 12. April 2015, 13:09:13 »
This is the result

Code: [Select]
$ sudo pacman -Scc
error: failed to init transaction (unable to lock database)
error: could not lock database: File exists
  if you're sure a package manager is not already
  running, you can remove /var/lib/pacman/db.lck
[roll@roll ~]$ sudo rm  /var/lib/pacman/db.lck
[roll@roll ~]$ sudo pacman -Scc

Cache directory: /var/cache/pacman/pkg/
:: Do you want to remove ALL files from cache? [y/N] y
removing all files from cache...

Database directory: /var/lib/pacman/
:: Do you want to remove unused repositories? [Y/n] y
removing unused sync repositories...
[roll@roll ~]$ sudo pacman -S manjaro-keyring archlinux-keyring
warning: downgrading package manjaro-keyring (20141220-1 => 20141014-1)
warning: downgrading package archlinux-keyring (20141218-1 => 20140908-1)
resolving dependencies...
looking for conflicting packages...

Packages (2) archlinux-keyring-20140908-1  manjaro-keyring-20141014-1

Total Download Size:    0.45 MiB
Total Installed Size:   0.64 MiB
Net Upgrade Size:      -0.04 MiB

:: Proceed with installation? [Y/n]
:: Retrieving packages ...
 manjaro-keyring-201...    14.9 KiB  15.8K/s 00:01 [####################] 100%
 archlinux-keyring-2...   444.8 KiB  17.5K/s 00:25 [####################] 100%
(2/2) checking keys in keyring                     [####################] 100%
(2/2) checking package integrity                   [####################] 100%
error: manjaro-keyring: signature from "Rob McCathie <korrode@gmail.com>" is unknown trust
:: File /var/cache/pacman/pkg/manjaro-keyring-20141014-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.
[roll@roll ~]$ sudo pacman-key --init
gpg: key 7890AD0D was created 11154 seconds in the future (time warp or clock problem)
[roll@roll ~]$ sudo pacman -S manjaro-keyring archlinux-keyring
warning: downgrading package manjaro-keyring (20141220-1 => 20141014-1)
warning: downgrading package archlinux-keyring (20141218-1 => 20140908-1)
resolving dependencies...
looking for conflicting packages...

Packages (2) archlinux-keyring-20140908-1  manjaro-keyring-20141014-1

Total Download Size:    0.01 MiB
Total Installed Size:   0.64 MiB
Net Upgrade Size:      -0.04 MiB

:: Proceed with installation? [Y/n]
:: Retrieving packages ...
 manjaro-keyring-201...    14.9 KiB  7.46K/s 00:02 [####################] 100%
(2/2) checking keys in keyring                     [####################] 100%
(2/2) checking package integrity                   [####################] 100%
error: manjaro-keyring: signature from "Rob McCathie <korrode@gmail.com>" is unknown trust
:: File /var/cache/pacman/pkg/manjaro-keyring-20141014-1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.
[roll@roll ~]$ sudo pacman-key --populate archlinux manjaro
==> Appending keys from archlinux.gpg...
==> Appending keys from manjaro.gpg...
==> Locally signing trusted keys in keyring...
  -> Locally signing key 7C89F4D439B2BFACF425107B62443D89B35859F8...
==> ERROR: 7C89F4D439B2BFACF425107B62443D89B35859F8 could not be locally signed.
  -> Locally signing key 0E8B644079F599DFC1DDC3973348882F6AC6A4C2...
==> ERROR: 0E8B644079F599DFC1DDC3973348882F6AC6A4C2 could not be locally signed.
  -> Locally signing key 5A97ED6B72418199F0C22B23137C934B5DCB998E...
==> ERROR: 5A97ED6B72418199F0C22B23137C934B5DCB998E could not be locally signed.
  -> Locally signing key FAA6840E8C3FC7F89BEE0DC8AC7AB10BCB6CDD17...
==> ERROR: FAA6840E8C3FC7F89BEE0DC8AC7AB10BCB6CDD17 could not be locally signed.
  -> Locally signing key B4663188A692DB1E45A98EE95BD96CC4247B52CC...
==> ERROR: B4663188A692DB1E45A98EE95BD96CC4247B52CC could not be locally signed.
  -> Locally signing key 684148BB25B49E986A4944C55184252D824B18E8...
==> ERROR: 684148BB25B49E986A4944C55184252D824B18E8 could not be locally signed.
  -> Locally signing key 540DE7083B89314CF70EA6F0C1B1AD0DA80EBF3E...
==> ERROR: 540DE7083B89314CF70EA6F0C1B1AD0DA80EBF3E could not be locally signed.
  -> Locally signing key 35B4FF23EA9477582C2A0AF12B80869C5C0102A6...
==> ERROR: 35B4FF23EA9477582C2A0AF12B80869C5C0102A6 could not be locally signed.
  -> Locally signing key 1E7908935AAB9A00D6B47503363DFFFD59152F77...
==> ERROR: 1E7908935AAB9A00D6B47503363DFFFD59152F77 could not be locally signed.
  -> Locally signing key 44D4A033AC140143927397D47EFD567D4C7EA887...
==> ERROR: 44D4A033AC140143927397D47EFD567D4C7EA887 could not be locally signed.
  -> Locally signing key 77DC01C9971AC3C39A0626F72C089F09AC97B894...
==> ERROR: 77DC01C9971AC3C39A0626F72C089F09AC97B894 could not be locally signed.
  -> Locally signing key 74C2F2CC05A0AB7D859839938934292D604F8BA2...
==> ERROR: 74C2F2CC05A0AB7D859839938934292D604F8BA2 could not be locally signed.
  -> Locally signing key 27FFC4769E19F096D41D9265A04F9397CDFD6BB0...
==> ERROR: 27FFC4769E19F096D41D9265A04F9397CDFD6BB0 could not be locally signed.
  -> Locally signing key E4CDFE50A2DA85D58C8A8C70CAA6A59611C7F07E...
==> ERROR: E4CDFE50A2DA85D58C8A8C70CAA6A59611C7F07E could not be locally signed.
  -> Locally signing key AB19265E5D7D20687D303246BA1DFB64FFF979E7...
==> ERROR: AB19265E5D7D20687D303246BA1DFB64FFF979E7 could not be locally signed.
[roll@roll ~]$ sudo pacman-key --refresh-keys
gpg: key 7890AD0D was created 11115 seconds in the future (time warp or clock problem)
gpg: refreshing 88 keys from hkp://pool.sks-keyservers.net
gpg: connecting dirmngr at '/root/.gnupg/S.dirmngr' failed: IPC connect call failed
gpg: keyserver refresh failed: No dirmngr
==> ERROR: A specified local key could not be updated from a keyserver.
[roll@roll ~]$ sudo pacman -Sc
Packages to keep:
  All locally installed packages

Cache directory: /var/cache/pacman/pkg/
:: Do you want to remove all other packages from cache? [Y/n]
removing old packages from cache...

Database directory: /var/lib/pacman/
:: Do you want to remove unused repositories? [Y/n]
removing unused sync repositories...
The loneliest people are the kindest. The saddest people smile the brightest. The most damaged people are the wisest.

Offline JayGuevara

  • Vollwertiges Mitglied
  • ***
  • Posts: 113
  • I wonder what happens if I do this...
  • Branch: Stable
  • Desktop: Cinnamon
  • GPU Card: GTX650
  • GPU driver: non-free
  • Kernel: 4.4
  • Skill: Novice
Re: Cant upgrade after fresh install
« Reply #5 on: 12. April 2015, 14:54:43 »
Looks like it might be an out of date mirror.
Code: [Select]
sudo pacman-mirrors -g && sudo pacman -SyyAlso
Code: [Select]
sudo pacman-optimize && syncmight be an idea.

Offline t101

  • Vollwertiges Mitglied
  • ***
  • Posts: 208
  • Branch: Stable
  • Desktop: KDE
  • GPU Card: Nvidia GeForce GTX 650
  • GPU driver: Non Free 343.36
  • Kernel: 3.19.1-1-MANJARO
  • Skill: Novice
Re: Cant upgrade after fresh install
« Reply #6 on: 12. April 2015, 15:10:43 »
Looks like it might be an out of date mirror.
Code: [Select]
sudo pacman-mirrors -g && sudo pacman -SyyAlso
Code: [Select]
sudo pacman-optimize && syncmight be an idea.

Did both now
Code: [Select]
$ sudo pacman -S manjaro-keyring archlinux-keyring
warning: manjaro-keyring-20150204-1 is up to date -- reinstalling
warning: archlinux-keyring-20150212-1 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Packages (2) archlinux-keyring-20150212-1  manjaro-keyring-20150204-1

Total Installed Size:  0.70 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n]
(2/2) checking keys in keyring                     [######################] 100%
(2/2) checking package integrity                   [######################] 100%
(2/2) loading package files                        [######################] 100%
(2/2) checking for file conflicts                  [######################] 100%
(2/2) checking available disk space                [######################] 100%
(1/2) reinstalling manjaro-keyring                 [######################] 100%
==> Appending keys from manjaro.gpg...
==> Locally signing trusted keys in keyring...
  -> Locally signing key 7C89F4D439B2BFACF425107B62443D89B35859F8...
==> ERROR: 7C89F4D439B2BFACF425107B62443D89B35859F8 could not be locally signed.
  -> Locally signing key 5A97ED6B72418199F0C22B23137C934B5DCB998E...
==> ERROR: 5A97ED6B72418199F0C22B23137C934B5DCB998E could not be locally signed.
  -> Locally signing key FAA6840E8C3FC7F89BEE0DC8AC7AB10BCB6CDD17...
==> ERROR: FAA6840E8C3FC7F89BEE0DC8AC7AB10BCB6CDD17 could not be locally signed.
  -> Locally signing key B4663188A692DB1E45A98EE95BD96CC4247B52CC...
==> ERROR: B4663188A692DB1E45A98EE95BD96CC4247B52CC could not be locally signed.
  -> Locally signing key 540DE7083B89314CF70EA6F0C1B1AD0DA80EBF3E...
==> ERROR: 540DE7083B89314CF70EA6F0C1B1AD0DA80EBF3E could not be locally signed.
  -> Locally signing key 35B4FF23EA9477582C2A0AF12B80869C5C0102A6...
==> ERROR: 35B4FF23EA9477582C2A0AF12B80869C5C0102A6 could not be locally signed.
  -> Locally signing key 1E7908935AAB9A00D6B47503363DFFFD59152F77...
==> ERROR: 1E7908935AAB9A00D6B47503363DFFFD59152F77 could not be locally signed.
  -> Locally signing key 77DC01C9971AC3C39A0626F72C089F09AC97B894...
==> ERROR: 77DC01C9971AC3C39A0626F72C089F09AC97B894 could not be locally signed.
  -> Locally signing key 74C2F2CC05A0AB7D859839938934292D604F8BA2...
==> ERROR: 74C2F2CC05A0AB7D859839938934292D604F8BA2 could not be locally signed.
  -> Locally signing key E4CDFE50A2DA85D58C8A8C70CAA6A59611C7F07E...
==> ERROR: E4CDFE50A2DA85D58C8A8C70CAA6A59611C7F07E could not be locally signed.
error: command failed to execute correctly
(2/2) reinstalling archlinux-keyring               [######################] 100%
==> Appending keys from archlinux.gpg...
==> Locally signing trusted keys in keyring...
  -> Locally signing key 0E8B644079F599DFC1DDC3973348882F6AC6A4C2...
==> ERROR: 0E8B644079F599DFC1DDC3973348882F6AC6A4C2 could not be locally signed.
  -> Locally signing key 684148BB25B49E986A4944C55184252D824B18E8...
==> ERROR: 684148BB25B49E986A4944C55184252D824B18E8 could not be locally signed.
  -> Locally signing key 44D4A033AC140143927397D47EFD567D4C7EA887...
==> ERROR: 44D4A033AC140143927397D47EFD567D4C7EA887 could not be locally signed.
  -> Locally signing key 27FFC4769E19F096D41D9265A04F9397CDFD6BB0...
==> ERROR: 27FFC4769E19F096D41D9265A04F9397CDFD6BB0 could not be locally signed.
  -> Locally signing key AB19265E5D7D20687D303246BA1DFB64FFF979E7...
==> ERROR: AB19265E5D7D20687D303246BA1DFB64FFF979E7 could not be locally signed.
The loneliest people are the kindest. The saddest people smile the brightest. The most damaged people are the wisest.

Offline PingoDindo

  • Sr. Mitglied
  • ****
  • Posts: 405
  • Branch: Arch-Stable
  • Desktop: XFCE
  • GPU Card: nVidia GT218 (340xx)
  • GPU driver: Non-free
  • Kernel: 3.19x (Arch-x86_64)
  • Skill: Intermediate
Re: Cant upgrade after fresh install
« Reply #7 on: 12. April 2015, 16:11:25 »
You have run "-Syy" many times without completing updates (i.e. "-Su") this breaks updates. You said it's a fresh install, how old is your installation media?
Do mark thread solved if done by editing your original post and prepending [Solved] in subject.

My Arch XFCE desktop:
http://pastebin.com/Zbn2xRZj

Offline t101

  • Vollwertiges Mitglied
  • ***
  • Posts: 208
  • Branch: Stable
  • Desktop: KDE
  • GPU Card: Nvidia GeForce GTX 650
  • GPU driver: Non Free 343.36
  • Kernel: 3.19.1-1-MANJARO
  • Skill: Novice
Re: Cant upgrade after fresh install
« Reply #8 on: 12. April 2015, 17:11:21 »
You have run "-Syy" many times without completing updates (i.e. "-Su") this breaks updates. You said it's a fresh install, how old is your installation media?

I installed using manjaro-xfce-0.8.12-i686.iso. I have moved to Debian temporarily. I will try future releases of Manjaro to see if they work for me.

Bye for now.
The loneliest people are the kindest. The saddest people smile the brightest. The most damaged people are the wisest.

Offline Kirkx

  • Neuling
  • *
  • Posts: 11
  • Branch: Stable
  • Desktop: Xfce
  • GPU Card: Nvidia GF 8500 GT
  • GPU driver: video-nouveau
  • Kernel: 312_x64
  • Skill: Novice
Re: Cant upgrade after fresh install
« Reply #9 on: 13. April 2015, 01:56:44 »
If you decide to do a fresh install and give it a try again here is what worked for me when I got "PGP Signature" errors myself when installing Manjaro for the first time a few weeks ago. I compiled the procedure listed below based on a few Arch Linux threads.

Code: [Select]
# update mirrors list
    sudo pacman-mirrors -g
# refresh all pkg lists after mirror lst update
    sudo pacman -Syy
# update packages
    sudo pacman -Syu
# in case of PGP signature errors first try re-installing the keyrings:
    sudo pacman -S archlinux-keyring
    manjaro-keyring
    sudo pacman -Syyu
# if errors continue proceed as follows:
# initialize pacman keyring
    sudo pacman-key --init
    # to generate entropy move the mouse around and press random keys
# load signature keys
    sudo pacman-key --populate archlinux
    manjaro
# refresh signature keys
    sudo pacman-key --refresh-keys
# if errors continue re-install keyrings
    sudo pacman -S archlinux-keyring
    manjaro-keyring
   # if errors continue run
    dirmngr </dev/null
    # refresh signature keys
    # if errors continue create empty file
    ~/.gnupg/dirmngr_ldapservers.conf
    # refresh signature keys
    # repeat /dev/null + refresh a few times
# if update was aborted clear pacman cache
    # sudo pacman -Sc
# update packages
    sudo pacman -Syyu
« Last Edit: 13. April 2015, 06:13:09 by Kirkx »

Offline fredhoud

  • Sr. Mitglied
  • ****
  • Posts: 388
  • King of Liunx!
  • Branch: Stable
  • Desktop: KDE Plasma Version 5.6.3
  • GPU Card: Intel Quad Core i7-4790K - NVIDIA GeForce GTX 745
  • GPU driver: non-free
  • Kernel: 4.4.9-1 Manjaro
  • Skill: Novice
Re: Cant upgrade after fresh install
« Reply #10 on: 13. April 2015, 02:09:18 »
I just installed a fresh copy of Manjaro 0.8.12 x86, and updated without any problem.
Here's what I did to update.
sudo pacman -S archlinux-keyring manjaro-keyring
sudo pacman -Syyu

Hope this helps.

Offline Kirkx

  • Neuling
  • *
  • Posts: 11
  • Branch: Stable
  • Desktop: Xfce
  • GPU Card: Nvidia GF 8500 GT
  • GPU driver: video-nouveau
  • Kernel: 312_x64
  • Skill: Novice
Re: Cant upgrade after fresh install
« Reply #11 on: 13. April 2015, 06:19:44 »
I think there should be a sticky placed in the Installation section about how to deal with PGP Signature errors. They seem to be quite common during the fresh install and they are quite confusing even for intermediate Linux users coming over from other distros. I have never seen this problem in any Debian based dsitro I have tried.

Offline Lukimya

  • Held Mitglied
  • *****
  • Posts: 884
  • Branch: Unstable
  • Desktop: Gnome 3.20x
  • GPU Card: Intel HD4400
  • GPU driver: free
  • Kernel: 4.4.5-1-ARCH
  • Skill: Intermediate
Re: Cant upgrade after fresh install
« Reply #12 on: 13. April 2015, 07:08:28 »
I think there should be a sticky placed in the Installation section about how to deal with PGP Signature errors. They seem to be quite common during the fresh install and they are quite confusing even for intermediate Linux users coming over from other distros. I have never seen this problem in any Debian based dsitro I have tried.

+1. We get a ton of topics that are explained in detail already a 100 times here and in the wiki. There must be a better way than to explain the same stuff another 100 times.

Offline PingoDindo

  • Sr. Mitglied
  • ****
  • Posts: 405
  • Branch: Arch-Stable
  • Desktop: XFCE
  • GPU Card: nVidia GT218 (340xx)
  • GPU driver: Non-free
  • Kernel: 3.19x (Arch-x86_64)
  • Skill: Intermediate
Re: Cant upgrade after fresh install
« Reply #13 on: 13. April 2015, 16:14:57 »
+1. We get a ton of topics that are explained in detail already a 100 times here and in the wiki. There must be a better way than to explain the same stuff another 100 times.

Probably if you have time, why not ask for Manjaro Wiki account and create a FAQ section? Issue also comes from users, they don't bother to use search on forum or Google.
Do mark thread solved if done by editing your original post and prepending [Solved] in subject.

My Arch XFCE desktop:
http://pastebin.com/Zbn2xRZj

Offline aaditya

  • OpenRC Team
  • ****
  • Posts: 2844
    • My Website
  • Branch: Testing
  • Desktop: Xfce, Openbox
  • GPU Card: Intel HD 4000
  • Kernel: Linux 4.4 x86_64
  • Skill: Intermediate
Re: Cant upgrade after fresh install
« Reply #14 on: 13. April 2015, 16:22:12 »
The OP had a different problem originally I think (his mirror being out of date), but I will just sticky this thread and see what comes of it.