Author Topic: [to test] ISO's Lxqt 0.9 pre4 32 (CDS) and 64 available (without Gtk3 :-)  (Read 7253 times)

0 Members and 1 Guest are viewing this topic.

Offline Esclapion

  • Support Team
  • ****
  • Posts: 5523
    • manjaro
  • Branch: stable
  • Desktop: Lxqt
  • GPU Card: GTX 970
  • GPU driver: nonfree
  • Kernel: 4.4.6
  • Skill: Advanced
Hi all,  :)

In the last ISO's we removed Qt4. In those, Gtk3. So, they are faster and lighter (only 120MB of Ram used for the 32 in VBox) than never. They are based on the stable repos, including today's update.


Highlights
  • Calamares 1.0 installer
  • based on Manjaro 0.9 "Bellatrix" stable and lxqt 0.9
  • kernel 3.18.9
  • lightdm : session manager
  • openbox : windows manager
  • all lxqt tools
  • dark theme, menda, azenis green icon theme
  • infinality font smoothing and ttf-droid-ib font
  • connman and cmst, modem manager,  rfkill
  • firefox 36
  • hexchat : IRC client
  • transmisson-qt : bitTorrent client
  • manjaro-alsa
  • [64 bits only] manjaro-pulse
  • mpv : basic multimedia player, recommended
  • [64 bits only] bomi : multimedia player (successor of cmplayer)
  • cantata : mpd-based, very advanced music manager and player
  • pcmanfm-qt : file manager
  • urxvt : ultra-fast terminal, fully configured
  • leafpad : text editor
  • octopi : pacman frontend
  • gparted : partition manager
  • lxtask : task manager
  • lximage : simple image viewer
  • sumopaint : online image editor
  • xarchiver : light archive manipulator
  • speedcrunch (Qt5 version) : simple but powerful calculator
  • [64 bits only] pinta : advanced image editor, paint.net-like
  • [64 bits only] libreoffice installer
  • [64 bits only] non-free drivers



Technical details
  • journal size limit installed
  • services man-db and updatedb masked
  • service ModemManager disabled (must be enabled by user if necessary)
  • manjaro-printer (heavy) not installed
  • gnome-keyring not installed (gtk3, and not necessary (?) for a normal use)
  • back to names ethX and wlanY for the links
  • buttons restart and shutdown added to the taskbar
  • commands Edit as root and Set as wallpaper added to the pcmanfm-qt right-click
  • administrator terminal



Download link



Screenshot

« Last Edit: 14. March 2015, 16:32:16 by Esclapion »
Venez nous rejoindre sur l'IRC francophone
Patrice - Violence is the last refuge of the incompetent (Asimov)

Offline darso

  • Held Mitglied
  • *****
  • Posts: 543
  • Keep 'er between the hedges!
  • Branch: OpenRC-Stable
  • Desktop: OpenBox+XFCE
  • GPU Card: nVidia GT610
  • GPU driver: non-free
  • Kernel: linux43-x64
  • Skill: Novice
Hi Esclapion, I just tried both the 32bit & 64bit ISO' in a Virtualbox setup.  On both occasions it let me get to the point where the actual install starts and the VM closes down and gives an "aborted" sign on the icon of the VM in VBox.  I tried it with "MBR" and "GUID" and also the "Partition Automatically" options.

I have the 0.8.1.2 version running on an old Viglen pc and I must say mate, bl**dy well done  ;) I am really looking forward to getting this version running on it with the promises of lightness and speeeeeeeeeeeed weeeeeeeee.

Thanks for all the work you have put in here, it's a real cracker  8)

Cheers,
darso.

EDIT: I will burn the 32bit to CD and try it on this old machine I have, back shortly with an update.

EDIT2: I burnt the CD and the Viglen wouldn't read it at all, may be down to a bad burn or a bad disk.  Just burnt it to USB and gonna reboot and see if it will boot in my own pc, unfortunately I can't get the old box to boot from USB  :(   I will report back shortly.
« Last Edit: 14. March 2015, 18:24:39 by darso »
It must be difficult... for those who have taken authority as the truth, rather than truth as the authority.
-G. Massey, Egyptologist.

Linux Counter Reg Number #578558

Offline excalibur1234

  • Global Moderator
  • *****
  • Posts: 2508
  • Branch: unstable
  • Desktop: net-minimal + LXQt
  • GPU driver: video-nouveau
  • Kernel: 4.6
  • Skill: Intermediate
i can confirm darso's finding:
virtualbox crashes the moment calamares starts the installation.
Need more information? Search here:   Manjaro Forum   |   Manjaro Wiki   |   Arch Wiki

Offline darso

  • Held Mitglied
  • *****
  • Posts: 543
  • Keep 'er between the hedges!
  • Branch: OpenRC-Stable
  • Desktop: OpenBox+XFCE
  • GPU Card: nVidia GT610
  • GPU driver: non-free
  • Kernel: linux43-x64
  • Skill: Novice
Hi guys, thanks for that confirmation excalibur, you're a gent  ;)


My new findings are however a little more serious.  As I mentioned earlier I burnt the ISO to USB and was to reboot my own pc to see if it would boot.  I went a little further and changed my HDD for a spare I had here and started the install process.  The process finished ok but an error message box has just popped up and reads as such:


Installation Failed


Failed to unpack image /bootmnt/manjaro/x86_64/lxqt-image.sqfs


rsync failed with error code 23.


Hope this helps ya get the bugger Esclapion :) I will reboot and see what she says.


EDIT: There's nothing there mate, just a blank screen, no Grub, nothing. :(


Cheers,
darso.
« Last Edit: 14. March 2015, 18:52:50 by darso »
It must be difficult... for those who have taken authority as the truth, rather than truth as the authority.
-G. Massey, Egyptologist.

Linux Counter Reg Number #578558

Offline Esclapion

  • Support Team
  • ****
  • Posts: 5523
    • manjaro
  • Branch: stable
  • Desktop: Lxqt
  • GPU Card: GTX 970
  • GPU driver: nonfree
  • Kernel: 4.4.6
  • Skill: Advanced
Nope, works for me. I never had such a problem.  :o

(edit)

I will download my own ISO and try again.  ;)
« Last Edit: 14. March 2015, 19:03:25 by Esclapion »
Venez nous rejoindre sur l'IRC francophone
Patrice - Violence is the last refuge of the incompetent (Asimov)

Offline darso

  • Held Mitglied
  • *****
  • Posts: 543
  • Keep 'er between the hedges!
  • Branch: OpenRC-Stable
  • Desktop: OpenBox+XFCE
  • GPU Card: nVidia GT610
  • GPU driver: non-free
  • Kernel: linux43-x64
  • Skill: Novice
Ok, I'll try downloading the 64bit again and burning it again, going by the live environment it's looking pretty sweet mate ;)   I downloaded it using DownThemAll earlier but I'll just grab it through FFox this time.


Cheers,
darso.
It must be difficult... for those who have taken authority as the truth, rather than truth as the authority.
-G. Massey, Egyptologist.

Linux Counter Reg Number #578558

Offline urbanomad64

  • Vollwertiges Mitglied
  • ***
  • Posts: 126
  • Branch: testing
  • Desktop: LXQt + OpenRC + eudev
  • GPU Card: nVidia GTX 750 Ti
  • GPU driver: non-free
  • Kernel: Linux45-x64
  • Skill: Intermediate
No problem installing in VM. Looks nice and smooth.

Offline Esclapion

  • Support Team
  • ****
  • Posts: 5523
    • manjaro
  • Branch: stable
  • Desktop: Lxqt
  • GPU Card: GTX 970
  • GPU driver: nonfree
  • Kernel: 4.4.6
  • Skill: Advanced
I re-downloaded and re-tried both ISOs, they work.

I must push the RAM of the VBox over 1GB, because Calamares will that (too much, I think), but it's all.

So, for Darso, it works, if I understand well.

For Excalibur : do you use the VBox default settings ? 1 CPU, no accelerated graphic, and so on ?

Venez nous rejoindre sur l'IRC francophone
Patrice - Violence is the last refuge of the incompetent (Asimov)

Offline darso

  • Held Mitglied
  • *****
  • Posts: 543
  • Keep 'er between the hedges!
  • Branch: OpenRC-Stable
  • Desktop: OpenBox+XFCE
  • GPU Card: nVidia GT610
  • GPU driver: non-free
  • Kernel: linux43-x64
  • Skill: Novice
Hi Esclapion, No mate it's not working for me, I re-downloaded the ISO but I am still getting the same message, I have been triying to use GPT for partitioning so I will now try MBR format,  I will let you know what happens.


Cheers,
darso.
It must be difficult... for those who have taken authority as the truth, rather than truth as the authority.
-G. Massey, Egyptologist.

Linux Counter Reg Number #578558

Offline Esclapion

  • Support Team
  • ****
  • Posts: 5523
    • manjaro
  • Branch: stable
  • Desktop: Lxqt
  • GPU Card: GTX 970
  • GPU driver: nonfree
  • Kernel: 4.4.6
  • Skill: Advanced
I use MBR, but...  :o

I don't burn a CD, I install in VBox from the ISO or on my real disk with an USB key.

(edit)

Can you also try the CLI ?

« Last Edit: 14. March 2015, 19:45:39 by Esclapion »
Venez nous rejoindre sur l'IRC francophone
Patrice - Violence is the last refuge of the incompetent (Asimov)

Offline darso

  • Held Mitglied
  • *****
  • Posts: 543
  • Keep 'er between the hedges!
  • Branch: OpenRC-Stable
  • Desktop: OpenBox+XFCE
  • GPU Card: nVidia GT610
  • GPU driver: non-free
  • Kernel: linux43-x64
  • Skill: Novice
No probs, will do, report back shortly.

EDIT: Ok here's what happened.  The install through CLI went seamlessly and all looked well, until I rebooted that is, see below image for what happened next :( something about "Kernel Panic" the images is quite large so I thought a link would be better.

Image Here.


Cheers,
darso.
« Last Edit: 14. March 2015, 20:21:33 by darso »
It must be difficult... for those who have taken authority as the truth, rather than truth as the authority.
-G. Massey, Egyptologist.

Linux Counter Reg Number #578558

Offline excalibur1234

  • Global Moderator
  • *****
  • Posts: 2508
  • Branch: unstable
  • Desktop: net-minimal + LXQt
  • GPU driver: video-nouveau
  • Kernel: 4.6
  • Skill: Intermediate
i did some testing:

i can install the ISO without problems in virtualbox IF i have 3D acceleration disabled.
in fact, i have problems with manjaro lxqt and 3d acceleration in virtualbox for a long time, e.g. the panel always crashes in the 64bit version (it used to be invisible, too).
this means the ISO (also the 64bit version) will probably install without any problems on real hardware.


p.s.: i have only tested the 64bit ISO image.
Need more information? Search here:   Manjaro Forum   |   Manjaro Wiki   |   Arch Wiki

Offline darso

  • Held Mitglied
  • *****
  • Posts: 543
  • Keep 'er between the hedges!
  • Branch: OpenRC-Stable
  • Desktop: OpenBox+XFCE
  • GPU Card: nVidia GT610
  • GPU driver: non-free
  • Kernel: linux43-x64
  • Skill: Novice
I can confirm what Excalibur says, works fine with 3d acceleration switched of in a VM, looks great Esclapion, very nice indeed, welll done that man!

Is there any other information I can give to help iron this out mate?  Just let me know.

Cheers,
darso.
It must be difficult... for those who have taken authority as the truth, rather than truth as the authority.
-G. Massey, Egyptologist.

Linux Counter Reg Number #578558

Offline Esclapion

  • Support Team
  • ****
  • Posts: 5523
    • manjaro
  • Branch: stable
  • Desktop: Lxqt
  • GPU Card: GTX 970
  • GPU driver: nonfree
  • Kernel: 4.4.6
  • Skill: Advanced
Happy it works, and thanks for your tries.  :)
Venez nous rejoindre sur l'IRC francophone
Patrice - Violence is the last refuge of the incompetent (Asimov)

Offline Xeto

  • Jr. Mitglied
  • **
  • Posts: 64
  • Skill: Novice
Installation works fine at my Dell V131 notebook, but after boot no login shown. I use two external monitors. Disconnect hdmi and vga monitor & ctrl + alt + backspace and I get a login.
Mirrored displays is ok, but can't use the two external only / well configured.