Author Topic: New buildiso script ?  (Read 2137 times)

0 Members and 1 Guest are viewing this topic.

Offline fassil

  • Support Team
  • ****
  • Posts: 709
  • Branch: stable/unstable
  • Desktop: E19/E20
  • GPU driver: free
  • Kernel: Linux314 & 318
  • Skill: Intermediate
New buildiso script ?
« on: 29. January 2015, 18:03:28 »
HeLLo,

With last update of manjaroiso, my current E profile didn't build anymore (with 8.12), stopped just before sqfs on something like following:
Code: [Select]
umount: /home/work/manjaroiso/configs/enlightenment/work-x86_64/enlightenment-image/dev: target is busyI retake the old modified one (noefi) buildiso script & it works again...
So, first effect of manjaro-tools dev ?  :o
"Are you enlightened ?"

Offline Ste74

  • Support Team
  • ****
  • Posts: 1256
  • sudo pacman -Rs windows && sudo pacman -S manjaro
  • Branch: unstable
  • Desktop: Budgie / Gnome / Pantheon (testing)
  • GPU Card: ATI/Intel mobility radeon hd 5400
  • GPU driver: free
  • Kernel: linux4.x -x86_64 series
  • Skill: Advanced
Re: New buildiso script ?
« Reply #1 on: 31. January 2015, 21:28:34 »
I fassil i have installed the patch and the manjaroiso development branch but nothing works , only the 0.8.11 series work i have downgraded with pacman only manjaroiso .
i am happy pkg from aur works in my iso .
Pantheon Community Edition & Budgie Desktop Edition
www.forum.manjaro-it.org
Canale IRC italiano
#manjaro-it

Offline agnotek

  • Jr. Mitglied
  • **
  • Posts: 68
  • Branch: stable
  • Desktop: Cinnamon
  • GPU Card: Geforce 840M
  • GPU driver: free
  • Kernel: linux40
  • Skill: Advanced
Re: New buildiso script ?
« Reply #2 on: 01. February 2015, 01:07:42 »
Hi, I had the same problems.
I replaced every
Code: [Select]
umount -R with
Code: [Select]
umount -R -l in
/usr/bin/buildiso

Offline artoo

  • OpenRC Team
  • ****
  • Posts: 2373
  • Branch: Unstable
  • Desktop: LXQT/Plasma5, openrc & eudev
  • Kernel: x86_64
  • Skill: Advanced
Re: New buildiso script ?
« Reply #3 on: 01. February 2015, 19:54:44 »
Hi, I had the same problems.
I replaced every
Code: [Select]
umount -R with
Code: [Select]
umount -R -l in
/usr/bin/buildiso

This works temporarily, but lazy unmounting can lead to problems with still mounted stuff.

The issue is caused by systemd 218 and the reason unmounting fails, is that for some strange reason, a dbus process gets started in chroot, but not properly terminated. It is in fact a package issue.


So, first effect of manjaro-tools dev ?  :o

Nope, manjaro-tools use entirely new iso profiles which are incompatible with manjaroiso profiles.
« Last Edit: 01. February 2015, 19:58:16 by artoo »

Offline Ste74

  • Support Team
  • ****
  • Posts: 1256
  • sudo pacman -Rs windows && sudo pacman -S manjaro
  • Branch: unstable
  • Desktop: Budgie / Gnome / Pantheon (testing)
  • GPU Card: ATI/Intel mobility radeon hd 5400
  • GPU driver: free
  • Kernel: linux4.x -x86_64 series
  • Skill: Advanced
Re: New buildiso script ?
« Reply #4 on: 02. February 2015, 21:34:20 »
Hi, I had the same problems.
I replaced every
Code: [Select]
umount -R with
Code: [Select]
umount -R -l in
/usr/bin/buildiso

Hi , i have replaced umount -R with umount -R -l
the iso was created but in the virtualbox whit my preference in
Code: [Select]
work/manjaroiso/configs/cinnamon/cinnamon-overlay/etc/skel

What is that ?

Thank you

i get this error

Pantheon Community Edition & Budgie Desktop Edition
www.forum.manjaro-it.org
Canale IRC italiano
#manjaro-it

Offline fassil

  • Support Team
  • ****
  • Posts: 709
  • Branch: stable/unstable
  • Desktop: E19/E20
  • GPU driver: free
  • Kernel: Linux314 & 318
  • Skill: Intermediate
Re: New buildiso script ?
« Reply #5 on: 03. February 2015, 15:44:19 »
HeLLo,

Maybe, it sounds like a permission problem with your permission prefs into skel (inside /manjaroiso/configs/bla...)
"Are you enlightened ?"

Offline Ste74

  • Support Team
  • ****
  • Posts: 1256
  • sudo pacman -Rs windows && sudo pacman -S manjaro
  • Branch: unstable
  • Desktop: Budgie / Gnome / Pantheon (testing)
  • GPU Card: ATI/Intel mobility radeon hd 5400
  • GPU driver: free
  • Kernel: linux4.x -x86_64 series
  • Skill: Advanced
Re: New buildiso script ?
« Reply #6 on: 03. February 2015, 20:55:41 »
I have Just created a cinnamon iso 3 monts later And works fine With My preference.
Now i build a iso with My configuration And whit program Fromm aur ( teamviewer, timeshift And other)
In The cinnamon overlay skel folder i have copied all files in My home (cinnamon in Vbox machine) .
It is  wrong?  I not remember.  :-[ :-[
Pantheon Community Edition & Budgie Desktop Edition
www.forum.manjaro-it.org
Canale IRC italiano
#manjaro-it

Offline philm

  • Core Team
  • *****
  • Posts: 10671
    • Manjaro Linux
  • Branch: Unstable
  • Desktop: XFCE
  • GPU Card: Geforce GTX 650
  • GPU driver: non-free
  • Kernel: Maintainer - so all ;)
  • Skill: Guru
Re: New buildiso script ?
« Reply #7 on: 03. February 2015, 21:02:00 »
@Ste74: might be an issue we won't fix. Please tryout manjaro-tools as manjaroiso we will depreciate. It uses Calamares as installer.

Offline Ste74

  • Support Team
  • ****
  • Posts: 1256
  • sudo pacman -Rs windows && sudo pacman -S manjaro
  • Branch: unstable
  • Desktop: Budgie / Gnome / Pantheon (testing)
  • GPU Card: ATI/Intel mobility radeon hd 5400
  • GPU driver: free
  • Kernel: linux4.x -x86_64 series
  • Skill: Advanced
Re: New buildiso script ?
« Reply #8 on: 03. February 2015, 21:17:05 »
@philm : tank you for Your reply.  Ok i attend manjaro-tools in stable realese. 
Manjaro is great i have removed Seven OS in My laptop  ;D And sorry for My bad english  :P
Pantheon Community Edition & Budgie Desktop Edition
www.forum.manjaro-it.org
Canale IRC italiano
#manjaro-it

Offline Strit

  • Maintainer
  • ***
  • Posts: 746
  • Manjaro Torrent Maintainer
    • Strits.dk
  • Branch: Stable
  • Desktop: XFCE
  • GPU Card: GTX 760 OC
  • GPU driver: Non-free nvidia 361
  • Kernel: 4.4.8-1-MANJARO
  • Skill: Intermediate
Re: New buildiso script ?
« Reply #9 on: 21. March 2015, 20:31:50 »
HeLLo,

With last update of manjaroiso, my current E profile didn't build anymore (with 8.12), stopped just before sqfs on something like following:
Code: [Select]
umount: /home/work/manjaroiso/configs/enlightenment/work-x86_64/enlightenment-image/dev: target is busyI retake the old modified one (noefi) buildiso script & it works again...
So, first effect of manjaro-tools dev ?  :o

I am also hit, by this "bug". Just with the xfce profile, so I asume it's like that with all the configs. This is using the latest manjaro-tools from repo's.
Is there any way to fix this?
Desktop PC: Manjaro XFCE 15.12 (stable, kernel 4.4)
Private Laptop: Manjaro Strit 16.03 (unstable, kernel 4.6)
Work Laptop: Manjaro Strit 16.03 (stable, kernel 4.4)
Netbook: Arch Linux XFCE/LXqt (i686, kernel 4.0)