Author Topic: (SOLVED) Xserver broken after last actualisation...  (Read 1811 times)

0 Members and 1 Guest are viewing this topic.

Offline baron

  • Neuling
  • *
  • Posts: 17
(SOLVED) Xserver broken after last actualisation...
« on: 30. January 2013, 11:19:14 »
Hello everybody, yesterday I did open my laptop with Manjaro first time after a month. I get system message with huge actualisation. Pacman had problems to finish that actualisation, because was one aplication in unused with system now folder "lib64". I did find by google an instruction how to solve the problem. I did make an actualisation for this aplication which has his files in folder "lib64".
After that pacman did make an actualisation as normally as always.  I was very suprised when after reebot I had only chance to console login... It's second similar accident with Manjaro. First incident was on my desktop computer, on which I can't login to console after my attempts with instalations nvidia, xorg, kernels etc now and I'm waiting for new versions Manjaro, bacause I want to install it once more. Second broken system on my laptop still works, but xserver has problems. I did try to reinstall nvidia and I did run in console command : nvidia-xconfig without succes...  :-[
Both systems uses unstable repositories, maybe that was a bad choice...

Has anybody any idea to repair my favorite last time system?

Thx and greatings,

Adam
« Last Edit: 31. January 2013, 19:10:38 by baron »

Offline ringo

  • Held Mitglied
  • *****
  • Posts: 9684
  • www.manjaro-nl.org
    • Manjaro Belgium + forum
  • Branch: unsourced
  • Desktop: xfce
  • GPU Card: Nvidia Geforce 8600 GT (acer 23inch)
  • GPU driver: Free*
  • Kernel: linux kernel
  • Skill: Novice
Re: Xserver broken after last actualisation...
« Reply #1 on: 30. January 2013, 11:39:29 »
And on which kernel do you work?

mayby you can install with free drivers of nvidia? with mhwd..

and wait for this weekend? when testing comes together with stable..

you could try other kernels ...

 like in other kernels...

when it doesnt does in linux37 completely and it works under linux34

then should i send the /etc/mkinitcpio.conf
i had it last time, i couldnt go in linux37 dont know if it the same :)

mayby send us more info mayby is it something else ..
Dutch go the dutch site :)

Offline baron

  • Neuling
  • *
  • Posts: 17
Re: Xserver broken after last actualisation...
« Reply #2 on: 30. January 2013, 14:07:33 »
Both systems had linux37 kernels. Oldest had 3.7.0.3, broken yesterday 3.7.0.4. Nvidia nonfree, works better on both computers, so I had default nvidia installed from Manjaro repositories. Ringo, both of systems works with unstable repositories as I did write before.

Offline baron

  • Neuling
  • *
  • Posts: 17
Re: Xserver broken after last actualisation...
« Reply #3 on: 30. January 2013, 20:24:58 »
Dear users,

nobody knows how to repair xserver after actualisation? One computer needs reinstall and I'll install new Manjaro with stable repo. Second I hope has a chance to repair, but I really don't know how to do that... When I log into console i try to run xserver with command: startx - I can read only that is xserver problem.

Offline ringo

  • Held Mitglied
  • *****
  • Posts: 9684
  • www.manjaro-nl.org
    • Manjaro Belgium + forum
  • Branch: unsourced
  • Desktop: xfce
  • GPU Card: Nvidia Geforce 8600 GT (acer 23inch)
  • GPU driver: Free*
  • Kernel: linux kernel
  • Skill: Novice
Re: Xserver broken after last actualisation...
« Reply #4 on: 30. January 2013, 23:57:31 »
how could you have unstable when you have 3.704? testing is on 3.7.5 now?? thats the reason why i dont push on unstable :)if i have a second pc mayby i do on unstable...only i know is the bug of update from today its fixed, kernel modules for linux37 was broken..if it broken you can try to to downgrade... is then a proper solution , thats more the risc for an unstable you dont know what it gets ;) on testing thinks could break also , but i believe is better to fix then on unstable..

you can try doing reinstall it or point on testing now try do a new upgrade reinstall the kernel and nonfree driver on it..
Dutch go the dutch site :)

Offline mandog

  • Held Mitglied
  • *****
  • Posts: 1921
  • Architect Forum And G+ Forum Owner With Daniel S
  • Branch: All
  • Desktop: Gnome, Mate, E19, Openbox,FLuxbox,Budgie, XFCE openRC,
  • GPU Card: nvidia
  • GPU driver: Non Free
  • Kernel: latest
  • Skill: Advanced
Re: Xserver broken after last actualisation...
« Reply #5 on: 31. January 2013, 00:53:16 »
You don't need to reinstall manjaro you need to read the arch wiki and downgrade xorg its in /var/cache /pacman/packages. The wiki is the best way as trying to explain is ver time consuming looking stuf up then copying then you reading its easyer for you to look up your self its all copy paste.You should never use unstable thats for the devs and testers not users with very little knowledge i'm sorry this sounds hard but its true. You could go on the irc channel and Mayby one of the devs will help you. you need logs etc 1st as to help you need to give lots more info.
A ENGLISHMAN IN PERU
I'm dyslexic Please do not complain about punctuation or spelling,
FANBOY,Taken from the urban dictionary
 A pathetic insult often used by fanboys themselves to try and put down people who don't like whatever it is they like.

Offline baron

  • Neuling
  • *
  • Posts: 17
Re: Xserver broken after last actualisation...
« Reply #6 on: 31. January 2013, 11:01:51 »
You are right Mandog, I suppose...   :(  I'm a debian user from years, and I did always use unstable (sid) with experimental. Belive me please, it was'nt dangerous and I use once installed debian from years without any changes and reinstalls. I thought with Manjaro will be similarly. I see is not... I will try to repair system on my laptop (if arch wiki and helpful people from this Forum help me), because there is only usable Windows7 now, but for me to use it is like a punishment. In my desktop computer I'll install new version of Manjaro with stable (grrrr) repo, I could wait for it longer because there is 2 runnings debians sids beyond Windows7.

Many Thx and greatings

Offline ringo

  • Held Mitglied
  • *****
  • Posts: 9684
  • www.manjaro-nl.org
    • Manjaro Belgium + forum
  • Branch: unsourced
  • Desktop: xfce
  • GPU Card: Nvidia Geforce 8600 GT (acer 23inch)
  • GPU driver: Free*
  • Kernel: linux kernel
  • Skill: Novice
Re: Xserver broken after last actualisation...
« Reply #7 on: 31. January 2013, 11:43:53 »
problem with debian in times is unstable/sid just Stable  or bit more stable then arch.. only switch over to an newer version of debian could have make troubles :) but that is mayby ones on 2years?
Dutch go the dutch site :)

Offline philm

  • Core Team
  • *****
  • Posts: 10671
    • Manjaro Linux
  • Branch: Unstable
  • Desktop: XFCE
  • GPU Card: Geforce GTX 650
  • GPU driver: non-free
  • Kernel: Maintainer - so all ;)
  • Skill: Guru
Re: Xserver broken after last actualisation...
« Reply #8 on: 31. January 2013, 11:47:31 »
First of all. I assume you have testing-repos installed. There all extramodules for linux37-series was broken. This is already solved by another update. Start your PC and login to your console. Type sudo pacman -Syu and reboot. More infos here.

Offline baron

  • Neuling
  • *
  • Posts: 17
Re: Xserver broken after last actualisation...
« Reply #9 on: 31. January 2013, 12:19:49 »
philm thanks for a really good news. I'm in work already and I'm very impatient. I try repair system in the evening. If the operation will have a good finish, have I change repositories to stable or testing  or keep the unstable? How do You think?

Greetings
« Last Edit: 31. January 2013, 18:42:22 by baron »

Offline baron

  • Neuling
  • *
  • Posts: 17
Re: Xserver broken after last actualisation...
« Reply #10 on: 31. January 2013, 19:03:22 »
First of all. I assume you have testing-repos installed. There all extramodules for linux37-series was broken. This is already solved by another update. Start your PC and login to your console. Type sudo pacman -Syu and reboot. More infos here.

Dear Philm, I got all unstable repositories in /etc/pacman.conf 
I did checked the file... Well, You were right. I did typing sudo pacman -Syyu and after that sudo pacman -Scc
After reebot my lovely xfce desktop comes back to me. It's lesson for me - first seek for help in wiki & forum and just until that repair the system. My impatience kills Manjaro in my desktop computer...

Thx for the help, problem is Solved  :)

Offline baron

  • Neuling
  • *
  • Posts: 17
Re: Xserver broken after last actualisation...
« Reply #11 on: 31. January 2013, 19:09:52 »
how could you have unstable when you have 3.704? testing is on 3.7.5 now??

You're almost right, now I've got a 3.7.5.1 Manjaro kernel. 3.7.0.4 I had on desktop computer when I did kill the system...

Thx for help.

Offline philm

  • Core Team
  • *****
  • Posts: 10671
    • Manjaro Linux
  • Branch: Unstable
  • Desktop: XFCE
  • GPU Card: Geforce GTX 650
  • GPU driver: non-free
  • Kernel: Maintainer - so all ;)
  • Skill: Guru
Re: (SOLVED) Xserver broken after last actualisation...
« Reply #12 on: 31. January 2013, 19:37:03 »
Thx, I'll mark this as solved now and move it to unstable repo-support.