Author Topic: LXQt with kwin  (Read 7679 times)

0 Members and 1 Guest are viewing this topic.

Offline excalibur1234

  • Global Moderator
  • *****
  • Posts: 2508
  • Branch: unstable
  • Desktop: net-minimal + LXQt
  • GPU driver: video-nouveau
  • Kernel: 4.6
  • Skill: Intermediate
LXQt with kwin
« on: 05. November 2014, 01:52:38 »
i just tried to install lxqt with kwin:


1. i downloaded and installed the 64bit version from here in virtualbox: https://forum.manjaro.org/index.php?topic=17220.msg159844#msg159844

2. i updated:
Code: [Select]
sudo pacman -Syyuu && sudo pacman -Syyuu

3. i installed kwin with the default options:
Code: [Select]
sudo pacman -S kwin

4. i opened lxqt session settings and changed "openbox" to "kwin_x11"

5. i rebooted the system

i tried this with the latest git builds of kwin and the unstable repository, too. but both ways, i get a system without any title bars or window borders (this means kwin is not working correctly).

my questions:
1. do you have any idea what i did wrong? or is kwin and kwin-git buggy at the moment?
2. how can i install a "kwin settings manager" or change settings for kwin (with the least amount of kde dependencies)?
Need more information? Search here:   Manjaro Forum   |   Manjaro Wiki   |   Arch Wiki

Offline samigina

  • Jr. Mitglied
  • **
  • Posts: 99
  • Branch: Stable
  • Desktop: LXQT and Gnome
  • GPU Card: AMD Apu A4
  • GPU driver: Non-free
  • Kernel: The latest one!
  • Skill: Intermediate
Re: LXQt with kwin
« Reply #1 on: 05. November 2014, 01:57:16 »
Is not your fault.

I f you run "kwin_11 --replace" you will see Kwin complaining about no Oxygen decoration found.

More info here: https://bbs.archlinux.org/viewtopic.php?pid=1456754


Offline excalibur1234

  • Global Moderator
  • *****
  • Posts: 2508
  • Branch: unstable
  • Desktop: net-minimal + LXQt
  • GPU driver: video-nouveau
  • Kernel: 4.6
  • Skill: Intermediate
Re: LXQt with kwin
« Reply #2 on: 05. November 2014, 15:46:00 »
thanks for the link!

i did some tests and found out that installing
Code: [Select]
sudo pacman -S kdebase-workspace
is enough to get kwin with all it's dependencies and a settings menu. this package is 140mb to download and it needs 500mb on a hard drive. it is part of kde 4.11.
this means i have to install a big part of (old) kde 4 just to get kwin (with a settings menu).
i think this is not acceptable.
Need more information? Search here:   Manjaro Forum   |   Manjaro Wiki   |   Arch Wiki

Offline Esclapion

  • Support Team
  • ****
  • Posts: 5523
    • manjaro
  • Branch: stable
  • Desktop: Lxqt
  • GPU Card: GTX 970
  • GPU driver: nonfree
  • Kernel: 4.4.6
  • Skill: Advanced
Re: LXQt with kwin
« Reply #3 on: 05. November 2014, 15:48:49 »
Same opinion. We must wait until kwin is really stand-alone.
Venez nous rejoindre sur l'IRC francophone
Patrice - Violence is the last refuge of the incompetent (Asimov)

Offline artoo

  • OpenRC Team
  • ****
  • Posts: 2373
  • Branch: Unstable
  • Desktop: LXQT/Plasma5, openrc & eudev
  • Kernel: x86_64
  • Skill: Advanced
Re: LXQt with kwin
« Reply #4 on: 05. November 2014, 15:50:32 »

is enough to get kwin with all it's dependencies and a settings menu. this package is 140mb to download and it needs 500mb on a hard drive. it is part of kde 4.11.
this means i have to install a big part of (old) kde 4 just to get kwin (with a settings menu).
i think this is not acceptable.

It's why kf5 was made much more modular, so you can pull kwin without big kdelibs.

If you use kwin5, you'd need to tell lxqt to use kwin_x11.

Concewrning your question, It may be the case, that kwin5 in repos is buggy.

It runs fine from git head master and with lxqt.

You could try to use kwin-git from AUR.
« Last Edit: 05. November 2014, 15:53:36 by artoo »

Offline excalibur1234

  • Global Moderator
  • *****
  • Posts: 2508
  • Branch: unstable
  • Desktop: net-minimal + LXQt
  • GPU driver: video-nouveau
  • Kernel: 4.6
  • Skill: Intermediate
Re: LXQt with kwin
« Reply #5 on: 05. November 2014, 16:15:10 »
i did some more testing and installed
Code: [Select]
sudo pacman -S oxygen
it brings kwin5 as dependency, is about 35mb to download and need 135mb on your hard disk.
after choosing kwin_x11 as compositor and rebooting, kwin works well.
but i have no settings window.
Need more information? Search here:   Manjaro Forum   |   Manjaro Wiki   |   Arch Wiki

Offline artoo

  • OpenRC Team
  • ****
  • Posts: 2373
  • Branch: Unstable
  • Desktop: LXQT/Plasma5, openrc & eudev
  • Kernel: x86_64
  • Skill: Advanced
Re: LXQt with kwin
« Reply #6 on: 05. November 2014, 16:16:42 »
i did some more testing and installed
Code: [Select]
sudo pacman -S oxygen
it brings kwin5 as dependency, is about 35mb to download and need 135mb on your hard disk.
after choosing kwin_x11 as compositor and rebooting, kwin works well.
but i have no settings window.

I think you'd need to install systemsettings5

Offline excalibur1234

  • Global Moderator
  • *****
  • Posts: 2508
  • Branch: unstable
  • Desktop: net-minimal + LXQt
  • GPU driver: video-nouveau
  • Kernel: 4.6
  • Skill: Intermediate
Re: LXQt with kwin
« Reply #7 on: 05. November 2014, 16:27:00 »
I think you'd need to install systemsettings5
thanks for the tip! i will try this, too.
this sounds like a good answer on my initial question.

you are answering faster on my posts than i can test this stuff.
Need more information? Search here:   Manjaro Forum   |   Manjaro Wiki   |   Arch Wiki

Offline excalibur1234

  • Global Moderator
  • *****
  • Posts: 2508
  • Branch: unstable
  • Desktop: net-minimal + LXQt
  • GPU driver: video-nouveau
  • Kernel: 4.6
  • Skill: Intermediate
Re: LXQt with kwin
« Reply #8 on: 05. November 2014, 16:45:15 »
this is the easiest method i have found:
Code: [Select]
sudo pacman -S oxygen systemsettings
sudo pacman -R openbox obconf-qt-git
then, go to "lxqt session settings" and choose "kwin_x11" instead of "openbox" as window manager.
reboot.

kwin5 works and some "kde system settings" are available. new themes can be downloaded and applied. vsync settings and animation speed settings are available, too.



after doing some tests, i found out: the following packages in AUR have a build error at the moment and do not work:
Code: [Select]
yaourt -S systemsettings-git
Code: [Select]
yaourt -S kwin-git
Code: [Select]
yaourt -S oxygen-git
« Last Edit: 14. November 2014, 17:19:01 by excalibur1234 »
Need more information? Search here:   Manjaro Forum   |   Manjaro Wiki   |   Arch Wiki

Offline Noitatsidem

  • Neuling
  • *
  • Posts: 13
  • Branch: arch
  • Desktop: GNOME
  • GPU Card: Radeon HD 6520G
  • GPU driver: Free
  • Kernel: linux
  • Skill: Advanced
Re: LXQt with kwin
« Reply #9 on: 06. November 2014, 15:43:21 »
It's really nice to see a thread dedicated to this, I already posted this in the KDE forums, but I figured I'd post it here too just in case other people were having rendering problems with kwin compositing.
Quote
In the KDE system settings, there's an entry for the acceleration method in the Display and Monitor section, for me by default this was "GLX" switching it to "EGL" seems to have solved all of my problems.
After doing that I've had no issues whatsoever, I'm personally really excited to see how LXQT and Plasma 5 evolve from here on, I've traditionally only used GTK desktops (and Enlightenment on occasion) simply because their QT counterparts just didn't feel right, that's not the case anymore, and I'm thrilled with the performance.
I'm not sure if you also need oxygen, but I've been using the breeze theme, it's wonderful with LXQT's plasma next theme, but I have both oxygen and breeze installed so I can't really comment on what you "need" to be able to run kwin.

Offline excalibur1234

  • Global Moderator
  • *****
  • Posts: 2508
  • Branch: unstable
  • Desktop: net-minimal + LXQt
  • GPU driver: video-nouveau
  • Kernel: 4.6
  • Skill: Intermediate
Re: LXQt with kwin
« Reply #10 on: 06. November 2014, 16:19:08 »
thanks a lot Noitatsidem for answering!
i tried to follow your tips, but i was not successful:
i installed
Code: [Select]
sudo pacman -S kwin systemsettings
which needed about 30mb to download and 165mb on my hard drive.
i set kwin_x11 and rebooted.
i did not see any window borders or title bars (like the last times i tried this). even after choosing "OpenGL" and "GLX" or "EGL" and activating the compositor or not (and rebooting every time), i never saw window title bars and window borders.


in the end, i tried to install
Code: [Select]
sudo pacman -S oxygen systemsettings breeze
i activated the breeze theme and window borders and title bars disappeared. obviously, the breeze theme (version 5.1) is not ready for light systems.


i was using manjaro lxqt with kernel 3.17 and the unstable repositories.
« Last Edit: 12. November 2014, 18:42:05 by excalibur1234 »
Need more information? Search here:   Manjaro Forum   |   Manjaro Wiki   |   Arch Wiki

Offline Noitatsidem

  • Neuling
  • *
  • Posts: 13
  • Branch: arch
  • Desktop: GNOME
  • GPU Card: Radeon HD 6520G
  • GPU driver: Free
  • Kernel: linux
  • Skill: Advanced
Re: LXQt with kwin
« Reply #11 on: 06. November 2014, 17:09:18 »
I was wondering, is manjaro properly handling all of breeze's dependencies? Maybe you're missing something that I have from installing Plasma 5 that's required to use Breeze. Just a thought.

Offline excalibur1234

  • Global Moderator
  • *****
  • Posts: 2508
  • Branch: unstable
  • Desktop: net-minimal + LXQt
  • GPU driver: video-nouveau
  • Kernel: 4.6
  • Skill: Intermediate
Re: LXQt with kwin
« Reply #12 on: 12. November 2014, 18:33:51 »
i found the leanest / smallest-sized way to use lxqt with kwin5. it does not require to install "oxygen" (as the "easiest method - look above), but it requires a little more work:

1.
Code: [Select]
sudo pacman -S kwin systemsettings

2.
go to "lxqt session settings" and choose "kwin_x11" instead of "openbox" as window manager.
reboot.

3.
you will not see any window decoration (neither title bars, borders nor shadows). open the new "kde system settings" window, choose "appearance" and there, you have only one theme "plastik" to choose from. the "apply" button is grey and unclickable, just change something which makes the "apply" button clickable and click it, e.g.: rearrange the buttons of the "plastik" theme or download a completely new kde theme.
reboot.



if you want, you can remove openbox:
Code: [Select]
sudo pacman -Rsnc openbox
and the openbox settings window:
Code: [Select]
sudo pacman -R obconf-qt-git


if you need more window decoration options (e.g. changing the color of "color glow" of active windows), you should install the default oxygen theme and set these options in the "oxygen" theme:
Code: [Select]
sudo pacman -S oxygen




edit: a wiki page with my findings is available here: https://wiki.manjaro.org/index.php?title=LXQt_with_kwin
« Last Edit: 21. November 2014, 01:23:07 by excalibur1234 »
Need more information? Search here:   Manjaro Forum   |   Manjaro Wiki   |   Arch Wiki

Offline Spacesurfer

  • Jr. Mitglied
  • **
  • Posts: 54
  • Branch: Stable
  • Desktop: LXQt
  • GPU Card: AMD Radeon HD 7870
  • GPU driver: Non-Free
  • Kernel: linux41-x64
  • Skill: Novice
Re: LXQt with kwin
« Reply #13 on: 12. December 2014, 06:34:22 »
Is there or will there be a Menda theme that can be used with LXQt and kwin? Frickin' loving the theme on LXQt w/ Openbox.

Offline AJSlye

  • Maintainer
  • ***
  • Posts: 4298
  • Netrunner Rolling Edition moderator / maintainer
  • Branch: Stable / Testing / Unstable
  • Desktop: Netrunner Rolling
  • GPU Card: Intel
  • GPU driver: Intel
  • Kernel: 4.4.1-1-MANJARO x86_64 (64 bit)
  • Skill: Guru
Re: LXQt with kwin
« Reply #14 on: 12. December 2014, 08:41:09 »
There is already a Menda theme made for plasma5, it should work for just Kwin5, but you may need to install it with the nodeps option.

« Last Edit: 12. December 2014, 08:48:07 by AJSlye »