Author Topic: slim 1.3.6 not working in manjaro fluxbox  (Read 1879 times)

0 Members and 1 Guest are viewing this topic.

Offline fixed

  • Neuling
  • *
  • Posts: 6
  • Skill: Novice
slim 1.3.6 not working in manjaro fluxbox
« on: 04. November 2014, 16:39:36 »
After updating manjora fluxbox SLiM stopped working.

I read up on the wiki and went through the process described there. But still no luck. Sometimes it does come up (slim) but it is one in a million now...

The wiki is for slim 1.6.2 but as far as i can tell 1.3.6 is the latest version? (http://en.wikipedia.org/wiki/SLiM) It made me a little confused and maybe I am totally lost here?

here is my /etc/slim.conf

Code: [Select]
# Path, X server and arguments (if needed)
# Note: -xauth $authfile is automatically appended
default_path        /bin:/usr/bin:/usr/local/bin
default_xserver     /usr/bin/X
xserver_arguments -nolisten tcp vt07

# Commands for halt, login, etc.
halt_cmd            /sbin/shutdown -h now
reboot_cmd          /sbin/shutdown -r now
console_cmd         /usr/bin/xterm -C -fg white -bg black +sb -T "Console login" -e /bin/sh -c "/bin/cat /etc/issue; exec /bin/login"
#suspend_cmd        /usr/sbin/suspend

# Full path to the xauth binary
xauth_path         /usr/bin/xauth

# Xauth file for server
authfile           /var/run/slim.auth


# Activate numlock when slim starts. Valid values: on|off
# numlock             on

# Hide the mouse cursor (note: does not work with some WMs).
# Valid values: true|false
# hidecursor          false

# This command is executed after a succesful login.
# you can place the %session and %theme variables
# to handle launching of specific commands in .xinitrc
# depending of chosen session and slim theme
#
# NOTE: if your system does not have bash you need
# to adjust the command according to your preferred shell,
# i.e. for freebsd use:
# login_cmd           exec /bin/sh - ~/.xinitrc %session
login_cmd           exec /bin/bash -login ~/.xinitrc %session

# Commands executed when starting and exiting a session.
# They can be used for registering a X11 session with
# sessreg. You can use the %user variable
#
# sessionstart_cmd some command
# sessionstop_cmd some command

# Start in daemon mode. Valid values: yes | no
# Note that this can be overriden by the command line
# options "-d" and "-nodaemon"
# daemon yes

# Available sessions are auto-detected. leave hashed if only wishing to
# use a single desktop environment. Otherwise, ~/.xinirc must also be
# edited to enable multiple desktop environments.
sessiondir /usr/share/xsessions/

# Executed when pressing F11 (requires imagemagick)
#screenshot_cmd      import -window root /slim.png

# welcome message. Available variables: %host, %domain
welcome_msg         Welcome to ManjaroBox

# Session message. Prepended to the session name when pressing F1
# session_msg         Session:

# shutdown / reboot messages
shutdown_msg       The system is halting...
reboot_msg         The system is rebooting...

# default user, leave blank or remove this line
# for avoid pre-loading the username.
#default_user        simone

# Focus the password field on start when default_user is set
# Set to "yes" to enable this feature
#focus_password      no

# Automatically login the default user (without entering
# the password. Set to "yes" to enable this feature
#auto_login          no


# current theme, use comma separated list to specify a set to
# randomly choose from
current_theme       default

# Lock file
lockfile            /var/lock/slim.lock

# Log file
logfile             /var/log/slim.log


and here is my .xinitrc

Code: [Select]
#!/bin/sh
#zenbook
syndaemon -t -k -i 2 &
#
# ~/.xinitrc
#
# Executed by startx (run your window manager from here)
#
# Written by Phil Muller and Carl Duff


## Ensure that the D-Bus Communication System is running properly to fix
## File management, authentication, and other essential system processes

if which dbus-launch >/dev/null && test -z "$DBUS_SESSION_BUS_ADDRESS"; then
    eval "$(dbus-launch --sh-syntax --exit-with-session)"
fi


## Ensure that GTK themes are applied uniformly in the Desktop Environment

export GTK2_RC_FILES="$HOME/.gtkrc-2.0"


## Where the default Home folders have not already been created, generate them

if [ -x /usr/bin/xdg-user-dirs-update ]; then
   /usr/bin/xdg-user-dirs-update
fi

## Apps at startup

/usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1 &
nitrogen --restore &
compton -c --shadow-exclude 'class_g = "wbar"' &
nm-applet &
volumeicon &
cbatticon &
pamac-tray &
(sleep 8s && wbar) &

## Enable SLiM to enable selection of multiple desktop environments, or
## set a single session. Only one or the other must be unhashed! In either
## instance, /etc/slim.conf must also be amended accordingly.

## Enable multiple desktop environments
#exec $1

## Set a single desktop environment
#exec openbox-session
#exec xfce4-session
#exec gnome-session
#exec startkde
#exec cinnamon-session
#exec razor-session
#exec lxsession
#exec mate-session
#exec startfluxbox

exec $1

I have tryed to make different variations of this file and uncommenting exec $1 and then including it ... but it is random at best... and i only made it work one time where after a reboot with no changes it still didnt work.

Can anyone help me and tell me what I am doing wrong?

best regards

J
« Last Edit: 04. November 2014, 20:05:07 by fixed »

Offline gohlip

  • Held Mitglied
  • *****
  • Posts: 1689
  • Desktop: OpenBox
  • GPU Card: nvidia
  • GPU driver: nonfree
  • Kernel: linux46 - x64
  • Skill: Intermediate
Re: slim 1.3.6 not working in manjora fluxbox
« Reply #1 on: 04. November 2014, 16:57:33 »
It is difficult to pinpoint exactly in cases like this.
But just to eliminate some issues, please do these

o in your .xinitrc, there should be
Code: [Select]
.
.
.

#exec cinnamon-session
#exec razor-session
#exec lxsession
#exec mate-session
exec startfluxbox
not
Code: [Select]
exec $1

o start without 'splash' and 'quiet' in the linux line of grub menu
see if you have no problem or lag booting up.
[at grub menu, press 'e', arrow down to linux line and remove quiet and splash and F10 to boot]

o what are the output of
Code: [Select]
systemctl status display-manager
Life is a sexually transmitted disease with a 100% mortality rate.

Offline d7rk

  • Held Mitglied
  • *****
  • Posts: 617
  • Branch: testing
  • Desktop: Gnome // Openbox
  • GPU Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller and NVIDIA GF119M [GeForce 610M]
  • GPU driver: nvidia
  • Kernel: 4.4.8-1-MANJARO x86_64 (64 bit)
  • Skill: Novice
Re: slim 1.3.6 not working in manjora fluxbox
« Reply #2 on: 04. November 2014, 18:26:31 »
It is difficult to pinpoint exactly in cases like this.
But just to eliminate some issues, please do these

o in your .xinitrc, there should be
Code: [Select]
.
.
.

#exec cinnamon-session
#exec razor-session
#exec lxsession
#exec mate-session
exec startfluxbox
not
Code: [Select]
exec $1

I don't know. According to https://wiki.archlinux.org/index.php/Slim it's exec $1 now.
That's what I use, but I'm on openbox.

[EDIT]
After comparing our files, my slim.conf is significantly the same.
.xinitrc is quite different. Maybe try commenting all non essential lines (startup programs...).
Cheers,
Cheers,
« Last Edit: 04. November 2014, 18:32:47 by d7rk »

Offline mips

  • Held Mitglied
  • *****
  • Posts: 2892
  • Valkyrja
  • Branch: Testing
  • Desktop: XFCE
  • GPU Card: GTX 960
  • GPU driver: video-nvidia
  • Kernel: 3.16
  • Skill: Intermediate
Re: slim 1.3.6 not working in manjora fluxbox
« Reply #3 on: 04. November 2014, 20:02:14 »
I don't know. According to https://wiki.archlinux.org/index.php/Slim it's exec $1 now.
That's what I use, but I'm on openbox.

I use the same in PekWm.

~/.xinitrc
Code: [Select]
#!/bin/sh

# ~/.xinitrc
#
# Executed by startx (run your window manager from here)
#
# Written by Phil Muller

## Ensure that the D-Bus Communication System is running properly to fix
## File management, authentication, and other essential system processes

if which dbus-launch >/dev/null && test -z "$DBUS_SESSION_BUS_ADDRESS"; then
    eval "$(dbus-launch --sh-syntax --exit-with-session)"
fi

## Ensure that GTK themes are applied uniformly in the Desktop Environment

export GTK2_RC_FILES="$HOME/.gtkrc-2.0"

## Where the default Home folders have not already been created, generate them

if [ -x /usr/bin/xdg-user-dirs-update ]; then
   /usr/bin/xdg-user-dirs-update
fi

## Window Manager

#exec pekwm
exec $1


/etc/slim.conf
Code: [Select]
# Path, X server and arguments (if needed)
# Note: -xauth $authfile is automatically appended
default_path        /bin:/usr/bin:/usr/local/bin
default_xserver     /usr/bin/X
xserver_arguments -nolisten tcp vt07

# Commands for halt, login, etc.
halt_cmd            /sbin/shutdown -h now
reboot_cmd          /sbin/shutdown -r now
console_cmd         /usr/bin/xterm -C -fg white -bg black +sb -T "Console login" -e /bin/sh -c "/bin/cat /etc/issue; exec /bin/login"
#suspend_cmd        /usr/sbin/suspend

# Full path to the xauth binary
xauth_path         /usr/bin/xauth

# Xauth file for server
authfile           /var/run/slim.auth


# Activate numlock when slim starts. Valid values: on|off
# numlock             on

# Hide the mouse cursor (note: does not work with some WMs).
# Valid values: true|false
# hidecursor          false

# This command is executed after a succesful login.
# you can place the %session and %theme variables
# to handle launching of specific commands in .xinitrc
# depending of chosen session and slim theme
#
# NOTE: if your system does not have bash you need
# to adjust the command according to your preferred shell,
# i.e. for freebsd use:
# login_cmd           exec /bin/sh - ~/.xinitrc %session
login_cmd           exec /bin/bash -login ~/.xinitrc %session

# Commands executed when starting and exiting a session.
# They can be used for registering a X11 session with
# sessreg. You can use the %user variable
#
# sessionstart_cmd some command
# sessionstop_cmd some command

# Start in daemon mode. Valid values: yes | no
# Note that this can be overriden by the command line
# options "-d" and "-nodaemon"
# daemon yes

# Available sessions are auto-detected. leave hashed if only wishing to
# use a single desktop environment. Otherwise, ~/.xinirc must also be
# edited to enable multiple desktop environments.
sessiondir /usr/share/xsessions/

# Executed when pressing F11 (requires imagemagick)
#screenshot_cmd      import -window root /slim.png

# welcome message. Available variables: %host, %domain
welcome_msg         Welcome to ManjaroPek

# Session message. Prepended to the session name when pressing F1
# session_msg         Session:

# shutdown / reboot messages
shutdown_msg       The system is halting...
reboot_msg         The system is rebooting...

# default user, leave blank or remove this line
# for avoid pre-loading the username.
#default_user        simone

# Focus the password field on start when default_user is set
# Set to "yes" to enable this feature
#focus_password      no

# Automatically login the default user (without entering
# the password. Set to "yes" to enable this feature
#auto_login          no


# current theme, use comma separated list to specify a set to
# randomly choose from
current_theme       SlimMinimalManjaro

# Lock file
lockfile            /var/lock/slim.lock

# Log file
logfile             /var/log/slim.log


Offline fixed

  • Neuling
  • *
  • Posts: 6
  • Skill: Novice
Re: slim 1.3.6 not working in manjora fluxbox
« Reply #4 on: 04. November 2014, 20:16:18 »
It is difficult to pinpoint exactly in cases like this.
But just to eliminate some issues, please do these

o in your .xinitrc, there should be
Code: [Select]
.
.
.

#exec cinnamon-session
#exec razor-session
#exec lxsession
#exec mate-session
exec startfluxbox
not
Code: [Select]
exec $1

o start without 'splash' and 'quiet' in the linux line of grub menu
see if you have no problem or lag booting up.
[at grub menu, press 'e', arrow down to linux line and remove quiet and splash and F10 to boot]

o what are the output of
Code: [Select]
systemctl status display-manager

Thanks for all the answers!

I also think that the wiki explicitly says to use exec $1
so i left it in. but i then removed guiet and splas and used f10 to boot... and then SLiM does come up!?

But does it make any change to remove guiet and splash? isnt that just for debugging purpose?

however it does act a little strange... e.g. fluxbox sets SLiM default theme as back ground...  i will fix that...

Am i wrong when i say the wiki refers to a wrong version number of SLim?

I will try and reboot my machine and slowly add startup programs in xinitrc again and see how it acts.

thanks again so far :)

EDIT: wow... Now I have tryed alot of different combinations and it seems to be something with the splash!? when i remove splash in grub SLiM comes up just fine? How can that be? and can I maybe somehow debug that more?

EDIT 2: HEre is the output of:

Code: [Select]
$ systemctl status display-manager
● slim.service - SLiM Simple Login Manager
   Loaded: loaded (/usr/lib/systemd/system/slim.service; enabled)
   Active: active (running) since Tue 2014-11-04 20:02:21 CET; 3min 50s ago
 Main PID: 1512 (slim)
   CGroup: /system.slice/slim.service
           ├─1512 /usr/bin/slim -nodaemon
           └─1558 /usr/bin/Xorg.bin -nolisten tcp vt07 -auth /var/run/slim.auth


« Last Edit: 04. November 2014, 20:31:44 by fixed »

Offline fixed

  • Neuling
  • *
  • Posts: 6
  • Skill: Novice
Re: slim 1.3.6 not working in manjora fluxbox
« Reply #5 on: 04. November 2014, 20:30:23 »
EDIT: ups. I messed up and posted twice

Offline mips

  • Held Mitglied
  • *****
  • Posts: 2892
  • Valkyrja
  • Branch: Testing
  • Desktop: XFCE
  • GPU Card: GTX 960
  • GPU driver: video-nvidia
  • Kernel: 3.16
  • Skill: Intermediate
Re: slim 1.3.6 not working in manjora fluxbox
« Reply #6 on: 04. November 2014, 20:38:47 »
But does it make any change to remove guiet and splash? isnt that just for debugging purpose?

If you get rid of splash (I'm assuming plymouth?) your boot time will decrease.
Removing quiet will stop most of the text output at boot but doing so adds a very slight increase to boot time as the text has to be displayed.

I'm no fan of plymouth and if a distro has it I will remove it. If there are problems during boot it's easy to remove the 'quiet' parameter on the grub screen to help diagnose problems.

Offline fixed

  • Neuling
  • *
  • Posts: 6
  • Skill: Novice
Re: slim 1.3.6 not working in manjora fluxbox
« Reply #7 on: 04. November 2014, 20:46:12 »
If you get rid of splash (I'm assuming plymouth?) your boot time will decrease.
Removing quiet will stop most of the text output at boot but doing so adds a very slight increase to boot time as the text has to be displayed.

I'm no fan of plymouth and if a distro has it I will remove it. If there are problems during boot it's easy to remove the 'quiet' parameter on the grub screen to help diagnose problems.

Thanks for your advice :)

yeah i have plymouth i assume :)

Code: [Select]
$ pacman -Q | grep ply
plymouth 0.8.8-9
plymouth-theme-manjaro 1.0-2
plymouth-theme-manjaro-elegant 1.0.1-1

are you suggesting just to :
pacman -Rsc plymouth?
« Last Edit: 04. November 2014, 20:51:41 by fixed »

Offline mips

  • Held Mitglied
  • *****
  • Posts: 2892
  • Valkyrja
  • Branch: Testing
  • Desktop: XFCE
  • GPU Card: GTX 960
  • GPU driver: video-nvidia
  • Kernel: 3.16
  • Skill: Intermediate
Re: slim 1.3.6 not working in manjora fluxbox
« Reply #8 on: 04. November 2014, 21:00:12 »
are you suggesting just to :
pacman -Rsc plymouth?

Only do that after https://forum.manjaro.org/index.php?topic=14654.msg132847#msg132847 Not all this applies to Slim but it's a starting point.

Offline PingoDindo

  • Sr. Mitglied
  • ****
  • Posts: 405
  • Branch: Arch-Stable
  • Desktop: XFCE
  • GPU Card: nVidia GT218 (340xx)
  • GPU driver: Non-free
  • Kernel: 3.19x (Arch-x86_64)
  • Skill: Intermediate
Re: slim 1.3.6 not working in manjaro fluxbox
« Reply #9 on: 04. November 2014, 21:08:26 »
SLiM project has been discontinued, better switch to another DM. See this notification on Arch Wiki.
Do mark thread solved if done by editing your original post and prepending [Solved] in subject.

My Arch XFCE desktop:
http://pastebin.com/Zbn2xRZj

Offline fixed

  • Neuling
  • *
  • Posts: 6
  • Skill: Novice
Re: slim 1.3.6 not working in manjaro fluxbox
« Reply #10 on: 04. November 2014, 21:20:41 »
@ mips : Wow :) thanks alot! SLiM actually works again now!  For some reason plymouth must have conflicted with it... thanks for your help

@ PingoDindo : Thanks for the link. Well now SLiM does work. But if I get into trouble with it again I will very likely try out LXDM :)

i guess we can mark this solved now :)

thanks for helping me

Offline mips

  • Held Mitglied
  • *****
  • Posts: 2892
  • Valkyrja
  • Branch: Testing
  • Desktop: XFCE
  • GPU Card: GTX 960
  • GPU driver: video-nvidia
  • Kernel: 3.16
  • Skill: Intermediate
Re: slim 1.3.6 not working in manjaro fluxbox
« Reply #11 on: 04. November 2014, 21:26:10 »
SLiM project has been discontinued, better switch to another DM. See this notification on Arch Wiki.
Slim still does the job just fine for me, push comes to shove I'll just let xinitrc handle things...

Offline gohlip

  • Held Mitglied
  • *****
  • Posts: 1689
  • Desktop: OpenBox
  • GPU Card: nvidia
  • GPU driver: nonfree
  • Kernel: linux46 - x64
  • Skill: Intermediate
Re: slim 1.3.6 not working in manjaro fluxbox
« Reply #12 on: 05. November 2014, 03:28:32 »
Good to hear you've got it fixed.

o removing 'splash' and 'quiet' does more than just reducing boot time (and it's minimal)
 - it helps to see where some issues are.
 -  plymouth - it boots up whenever there's issues  with plymouth (and other things)

o slim - there's nothing wrong with slim.
It is, IMO, still a great simple (and complete) DM.

Having splash and grub themes(*) add to 'polished' distro and helps burnish its image, and it takes negligible resources.
Of course, for 'steak and potato (and beer)' guys like us   ;)  , it's just appearances, like in japanese food presentations.
Anyway, to each his own.  Cheers.

(*) -grub theme - Manjaro comes installed with starfield theme, it's a simple matter to add theme to grub, change theme background to some Manjaro picture that you like.

[edit] - oh, our slim version is also 1.3.6-5.



« Last Edit: 05. November 2014, 04:22:35 by gohlip »
Life is a sexually transmitted disease with a 100% mortality rate.