Author Topic: Awesome WM freezes after suspend or log out  (Read 1254 times)

0 Members and 1 Guest are viewing this topic.

Offline J2112O

  • Neuling
  • *
  • Posts: 3
  • Branch: Stable
  • Desktop: Awesome WM Respin
  • GPU Card: Nvidia Geforce 750
  • GPU driver: Free
  • Kernel: 3.15-x86
  • Skill: Novice
Awesome WM freezes after suspend or log out
« on: 30. July 2014, 18:11:21 »
Using the Awesome WM spin of Manjaro and having trouble with GUI and log in screen after suspend or log out. The mouse and keyboard do not work and the screen is frozen and unresponsive. Have to do a power off hard kill to get out of it. Any ideas or suggestion to fix this?

Offline Dreyeth

  • Vollwertiges Mitglied
  • ***
  • Posts: 222
  • High fat, low carb, no grains, carnivore.
  • Branch: Stable
  • Desktop: Manjaro Minimal Net Edition [OpenRC] (Awesome-LuaJIT) [Xinit] on a dedicated BtrFS without a partition table, ALSA, Fish Shell, Dvorak Keyboard
  • GPU Card: AMD Trinity APU A10 5800k
  • GPU driver: Free
  • Kernel: Linux317-X64
  • Skill: Novice
Re: Awesome WM freezes after suspend or log out
« Reply #1 on: 31. October 2014, 01:09:25 »
Heres some things to try to narrow down the issue, does resuming from suspend work
in a different desktop evironment then awesome?, or better yet with X not running?

Is reboot your computer and before you login switch to a terminal and issue a spend command,
with just your login manager running and see if it is a general X issue or specific to your desktop.
ctrl+alt+f2, login and try and using systemctl suspend, and see if it resumes without awesome running.
if it does then its not a awesome issue but a general suspend or a suspend while Xorg is running issue.

Then systemctl disable "name of your display manger" reboot
and try and systemctl suspend and see if it comes back up when x isn't running,
after doing the test systemctl enable "display manager" to set it back.
If this works but the above failed then its a graphics issue with suspend.

If this fails then its a general issue with suspend not working at all, how much ram do you have
and how big is your swap file?
And do you know which version of suspend, hibernate, or hybrid sleep awesome is supsending you to?
Which of the awesome-oblogout buttons are you clicking for suspend?
https://wiki.archlinux.org/index.php/Power_management#Power_management_with_systemd
regular suspend should just work, but if your clicking hibernate that is likely not to without configuration,
and I don't know about hybrid-sleep.

Code: [Select]
systemctl supsend
systemctl hibernate
systemctl hybrid-sleep

This is the three different commands for the three different types of sleep, the third one I wouldn't even
bother testing oblogout doesn't offer it as a option.

If you disable the graphics system so its not a variable and then just try all three before
turning it back on you'll know which work and witch don't (maybe all of them don't work, maybe
your just having trouble with hibernate)

Also you said you were having trouble just logging out of awesome as well, are you logging
out to a display manager like lxdm, lightdm, or slim?
If that is the case then you could try installing a new display manager like one of the other above three
and then doing systemctl disable "olddisplaymanagername" and then systemctl enable "new display manager".

Depending on what kind of issue you have that is some of your options to narrow down exactly what kind
of problem your having and where it is coming from, if this post isn't clear on how to try some of those
just reply about them.

Code: [Select]
systemctl disable "name of your display manager you want to turn off"
systemctl enable "name of the new display manager you want to turn on"

Careful your responsible for your own system, if you disable something remember to turn it back on
when your done testing, and make sure you've read how to do that before.

More to going on whould make this alot easier.
« Last Edit: 31. October 2014, 01:26:10 by Dreyeth »