Author Topic: Compiz 0.9 series package available  (Read 37952 times)

0 Members and 1 Guest are viewing this topic.

Offline Jeannie

  • Held Mitglied
  • *****
  • Posts: 1546
  • Skill: Novice
Re: Compiz 0.9.11 series package available
« Reply #30 on: 30. July 2014, 15:31:30 »
I changed the pkgbuild as you said, still emerald-git tries to remove compiz-manjaro.
Using emerald0.9 from aur worked though.
The reason why I wanted to give  compiz 0.9 a try was that I hoped to get rid of the problems with compiz 0.8 and  window refreshing under Nvidia >= 334 with my gpu's power not set to maximum in nvidia-settings.
The flickering I mentioned for ccsm with Compiz 0.9 only goes away when setting my gpu's power to max performance in nvidia-settings, so the problems with Compiz and Nvidia  non-free seem to be present in compiz 0.9 too.
Is there a website to report compiz 0.9 bugs?
J.
Hitten by the door in the back when I left Manjaro.

Offline Rob

  • Core Team
  • *****
  • Posts: 5390
  • Alias: Korrode
  • Branch: Unstable
  • Desktop: Xfce+Compiz
  • GPU Card: nVidia GTX560Ti
  • GPU driver: non-free
  • Kernel: linux314 x64
  • Skill: Advanced
Re: Compiz 0.9.11 series package available
« Reply #31 on: 30. July 2014, 15:35:28 »
Is there a website to report compiz 0.9 bugs?

https://bugs.launchpad.net/compiz


I changed the pkgbuild as you said, still emerald-git tries to remove compiz-manjaro.
Well something went wrong or you typo'd or whatever, because the adjustments to the PKGBUILD i listed enable you to build and install Emerald so long as you have the current compiz-manjaro package installed, which is compiz-manjaro 0.9.11.2-4
« Last Edit: 30. July 2014, 15:38:10 by Rob »

Offline Kat

  • Sr. Mitglied
  • ****
  • Posts: 296
  • Don't Believe What You Cannot See
  • Branch: unstable
  • Desktop: KDE 0.8.11-pre1 Gnome 0.8.10 RC1
  • GPU Card: Ati 6870
  • GPU driver: non-free
  • Kernel: linux312-x64
  • Skill: Intermediate
Re: Compiz 0.9.11 series package available
« Reply #32 on: 30. July 2014, 15:37:22 »


Log out/in after entering 'emerald' there is there's any issue.
Hmm, thumbnail plugin crashed X when i enabled it (which certainly isn't great), though when i killed X and re-logged in, it has since been working fine.


You did as i advised here?
Because i am running emerald-git with Compiz 0.9 right now and it's working fine for me.
I don't understand the confusion with Emerald.There are 0 conflicts.  I installed this last night,install went perfect, compiz was running.Had emerald and emerald themes installed as well. ONLY thing I could not install was fusion-icon. I needed that to run it at startup.. I could have made a launcher for it to start at boot,  BUT, I would have rather used Icon.  BUT, could not install so reverted back. Done!!
It is better to keep your mouth shut and be thought a fool than to open it and remove all doubt. (Mark Twain)

Offline Jeannie

  • Held Mitglied
  • *****
  • Posts: 1546
  • Skill: Novice
Re: Compiz 0.9.11 series package available
« Reply #33 on: 30. July 2014, 15:39:18 »
Seems there is a known fix/patch for compiz0.9 whch has not been included due to nVidia/canonical licensing problems, see here:
https://bbs.archlinux.org/viewtopic.php?pid=1428789#p1428789
J,


Hitten by the door in the back when I left Manjaro.

Offline Rob

  • Core Team
  • *****
  • Posts: 5390
  • Alias: Korrode
  • Branch: Unstable
  • Desktop: Xfce+Compiz
  • GPU Card: nVidia GTX560Ti
  • GPU driver: non-free
  • Kernel: linux314 x64
  • Skill: Advanced
Re: Compiz 0.9.11 series package available
« Reply #34 on: 30. July 2014, 15:41:52 »
I don't understand the confusion with Emerald.

The modifications i mentioned are for the emerald-git package, maybe the emerald package works fine. I thought i heard emerald-git was needed for compiz0.9, maybe that is incorrect.

Certainly compiz-manjaro meets the package dependencies for "emerald":
Code: [Select]
depends=('compiz-core' 'libwnck' 'gtk2' 'libxres' 'shared-mime-info' 'xdg-utils' \
         'desktop-file-utils' 'hicolor-icon-theme')
compiz-manjaro provides 'compiz-core', so building emerald would not fail due to package deps.

Try the normal emerald package as Kat suggests, Jeannie.



Seems there is a known fix/patch for compiz0.9 whch has not been included due to nVidia/canonical licensing problems, see here:
https://bbs.archlinux.org/viewtopic.php?pid=1428789#p1428789
J,

I'll investigate.

Offline Kat

  • Sr. Mitglied
  • ****
  • Posts: 296
  • Don't Believe What You Cannot See
  • Branch: unstable
  • Desktop: KDE 0.8.11-pre1 Gnome 0.8.10 RC1
  • GPU Card: Ati 6870
  • GPU driver: non-free
  • Kernel: linux312-x64
  • Skill: Intermediate
Re: Compiz 0.9.11 series package available
« Reply #35 on: 30. July 2014, 15:44:16 »
The modifications i mentioned are for the emerald-git package, maybe the emerald package works fine. I thought i heard emerald-git was needed for compiz0.9, maybe that is incorrect.

Certainly compiz-manjaro meets the package dependencies for "emerald":
Code: [Select]
depends=('compiz-core' 'libwnck' 'gtk2' 'libxres' 'shared-mime-info' 'xdg-utils' \
         'desktop-file-utils' 'hicolor-icon-theme')
compiz-manjaro provides 'compiz-core', so building emerald would not fail due to package deps.

Try the normal emerald package as Kat suggests, Jeannie.



I'll investigate.
No Rob, NO modifications needed what so ever. I just entered
Code: [Select]
yaourt -S emerald emerald-themes DONE!!


The wiki is our friend!!  ;)

https://wiki.manjaro.org/index.php/Compiz_and_Emerald
@jeannie. One question. Did you completely uninstall the older compiz  one first? I did.
« Last Edit: 30. July 2014, 15:53:43 by Kat »
It is better to keep your mouth shut and be thought a fool than to open it and remove all doubt. (Mark Twain)

Offline Jeannie

  • Held Mitglied
  • *****
  • Posts: 1546
  • Skill: Novice
Re: Compiz 0.9.11 series package available
« Reply #36 on: 30. July 2014, 15:54:22 »
No Rob, NO modifications needed what so ever. I just entered
Code: [Select]
yaourt -S emerald emerald-themes DONE!!


The wiki is our friend!!  ;)

https://wiki.manjaro.org/index.php/Compiz_and_Emerald
yaourt -S emerald will install emerald compatible for compiz 0.8, yaourt -S emerald0.9 will install emerald compatible for compiz 0.9
J.
P.S. The arch wiki only deals with compiz 0.8, so it's kind of outdated in regards of compiz.
Hitten by the door in the back when I left Manjaro.

Offline Kat

  • Sr. Mitglied
  • ****
  • Posts: 296
  • Don't Believe What You Cannot See
  • Branch: unstable
  • Desktop: KDE 0.8.11-pre1 Gnome 0.8.10 RC1
  • GPU Card: Ati 6870
  • GPU driver: non-free
  • Kernel: linux312-x64
  • Skill: Intermediate
Re: Compiz 0.9.11 series package available
« Reply #37 on: 30. July 2014, 15:59:02 »
yaourt -S emerald will install emerald compatible for compiz 0.8, yaourt -S emerald0.9 will install emerald compatible for compiz 0.9
J.
P.S. The arch wiki only deals with compiz 0.8, so it's kind of outdated in regards of compiz.
I had 0 problems with it
Edit: OH. Just got an update with 53 updates!! for kde . Good luck with this
« Last Edit: 30. July 2014, 16:01:28 by Kat »
It is better to keep your mouth shut and be thought a fool than to open it and remove all doubt. (Mark Twain)

Offline Rob

  • Core Team
  • *****
  • Posts: 5390
  • Alias: Korrode
  • Branch: Unstable
  • Desktop: Xfce+Compiz
  • GPU Card: nVidia GTX560Ti
  • GPU driver: non-free
  • Kernel: linux314 x64
  • Skill: Advanced
Re: Compiz 0.9.11 series package available
« Reply #38 on: 30. July 2014, 16:01:20 »
i checked out fusion-icon and it is simply incompatible with compiz 0.9

Offline Kat

  • Sr. Mitglied
  • ****
  • Posts: 296
  • Don't Believe What You Cannot See
  • Branch: unstable
  • Desktop: KDE 0.8.11-pre1 Gnome 0.8.10 RC1
  • GPU Card: Ati 6870
  • GPU driver: non-free
  • Kernel: linux312-x64
  • Skill: Intermediate
Re: Compiz 0.9.11 series package available
« Reply #39 on: 30. July 2014, 16:02:21 »
i checked out fusion-icon and it is simply incompatible with compiz 0.9
cool Rob.. if there was only a way we could make it compatible would be perfect!! Thank you
It is better to keep your mouth shut and be thought a fool than to open it and remove all doubt. (Mark Twain)

Offline Rob

  • Core Team
  • *****
  • Posts: 5390
  • Alias: Korrode
  • Branch: Unstable
  • Desktop: Xfce+Compiz
  • GPU Card: nVidia GTX560Ti
  • GPU driver: non-free
  • Kernel: linux314 x64
  • Skill: Advanced
Re: Compiz 0.9.11 series package available
« Reply #40 on: 30. July 2014, 16:06:05 »
cool Rob.. if there was only a way we could make it compatible would be perfect!! Thank you

Well it could be done of course.



normal emerald package didn't work for me with Compiz0.9, but emerald-git was fine.

Offline Kat

  • Sr. Mitglied
  • ****
  • Posts: 296
  • Don't Believe What You Cannot See
  • Branch: unstable
  • Desktop: KDE 0.8.11-pre1 Gnome 0.8.10 RC1
  • GPU Card: Ati 6870
  • GPU driver: non-free
  • Kernel: linux312-x64
  • Skill: Intermediate
Re: Compiz 0.9.11 series package available
« Reply #41 on: 30. July 2014, 16:07:23 »
Well it could be done of course.



normal emerald package didn't work for me with Compiz0.9, but emerald-git was fine.
YEP. Thats what I;m hoping  ;) Pretty PLEASE!!!  ;D Back to the drawing board!! Rob!!
« Last Edit: 30. July 2014, 16:10:45 by Kat »
It is better to keep your mouth shut and be thought a fool than to open it and remove all doubt. (Mark Twain)

Offline Kat

  • Sr. Mitglied
  • ****
  • Posts: 296
  • Don't Believe What You Cannot See
  • Branch: unstable
  • Desktop: KDE 0.8.11-pre1 Gnome 0.8.10 RC1
  • GPU Card: Ati 6870
  • GPU driver: non-free
  • Kernel: linux312-x64
  • Skill: Intermediate
Re: Compiz 0.9.11 series package available
« Reply #42 on: 30. July 2014, 16:08:30 »
Well it could be done of course.



normal emerald package didn't work for me with Compiz0.9, but emerald-git was fine.

 wow weird, normal worked for me!!
« Last Edit: 30. July 2014, 16:23:53 by Kat »
It is better to keep your mouth shut and be thought a fool than to open it and remove all doubt. (Mark Twain)

Offline coolthingy450

  • Vollwertiges Mitglied
  • ***
  • Posts: 119
  • Using GNU/Linux since 2013. Started at 2010
  • Branch: Arch/CentOS/Kaos
  • Desktop: Xfce/KDE5
  • GPU Card: GeForce GTX 965M
  • GPU driver: Non-free driver
  • Kernel: Linux Natsuko 4.4.5-1-ARCH
  • Skill: Intermediate
Re: Compiz 0.9.11 series package available
« Reply #43 on: 31. July 2014, 04:44:39 »
Thank you for the notice. I was prepared to just use Xfwm4 for normal use, or kwin (I don't like to use KDE dependencies) If I wanted to have special effects. But I do use the workspaces a lot.

Offline Rob

  • Core Team
  • *****
  • Posts: 5390
  • Alias: Korrode
  • Branch: Unstable
  • Desktop: Xfce+Compiz
  • GPU Card: nVidia GTX560Ti
  • GPU driver: non-free
  • Kernel: linux314 x64
  • Skill: Advanced
Re: Compiz 0.9.11 series package available
« Reply #44 on: 31. July 2014, 20:42:11 »
wow weird, normal worked for me!!

Kat is would be helpful to me if you could really triple-check and confirm that you are definitely running "compiz-manjaro" (not still accidentally somehow running "compiz-gtk-standalone" or something else) and that you are definitely running the package called "emerald" (not "emerald-git" or anything else) and that Emerald is definitely working (i.e. install "emerald-themes", open that Emerald Theme Selector config app and make sure you can in fact swap to different themes) and that it all continues to work after a reboot.

It can have implications not just for this package and myself, but for all AUR compiz packages and their maintainers (who i am in contact and coordinate with) regarding how we set up our provides arrays.