Author Topic: Compiz 0.9 series package available  (Read 46102 times)

0 Members and 2 Guests are viewing this topic.

Offline trzalica

  • Sr. Mitglied
  • ****
  • Posts: 285
  • Branch: stable
  • Desktop: Xfce
  • GPU Card: nVidia Geforce 8800 GT
  • GPU driver: Non-free
  • Kernel: Linux 4.1 x64
  • Skill: Intermediate

Offline Rob

  • Core Team
  • *****
  • Posts: 5390
  • Alias: Korrode
  • Branch: Unstable
  • Desktop: Xfce+Compiz
  • GPU Card: nVidia GTX560Ti
  • GPU driver: non-free
  • Kernel: linux314 x64
  • Skill: Advanced
Re: Compiz 0.9 series package available
« Reply #166 on: 19. December 2014, 13:18:54 »
The issue is resolved now in our package, details are on the Launchpad bug report.

Offline Jeannie

  • Held Mitglied
  • *****
  • Posts: 1546
  • Skill: Novice
Re: Compiz 0.9 series package available
« Reply #167 on: 19. December 2014, 13:31:43 »
So I can chose between Compiz 0.8 with the screen refresh bug or Unity optimised Compiz 0.9 which is not working for two panel 2x2 virtual workspace  grid setups.
That's great news....
J.
Hitten by the door in the back when I left Manjaro.

Offline Ayceman

  • Core Team
  • *****
  • Posts: 2113
  • Security Chief :P
  • Branch: stable, unstable
  • Desktop: Xfce
  • GPU Card: GTX780/HD3000/AMD8400
  • GPU driver: Nvidia/Intel/Catalyst
  • Kernel: latest stable+lts (64)
  • Skill: Advanced
Re: Compiz 0.9 series package available
« Reply #168 on: 24. December 2014, 14:47:31 »
Currently shading animations don't seem to work (tested on Intel and nVidia cards). I had it set to none do avoid the animation delay before returning to xfwm4 because compiz wouldn't bring an Alt+Tabbed War Thunder window to the foreground.

Offline DarN

  • Neuling
  • *
  • Posts: 11
  • Branch: stable
  • Desktop: Cinnamon
  • GPU Card: Radeon HD 6990
  • GPU driver: non-free
  • Kernel: latest_stable-x64
  • Skill: Advanced
Re: Compiz 0.9 series package available
« Reply #169 on: 24. December 2014, 21:50:58 »
I get a black screen with compiz 0.9. compiz 0.8 works fine. Tried in XFCE and LXQT. I have a mouse pointer, and the desktop exists somewhere under it, but it's all black. I can click and select stuff - it's just not visible. I'd really like to try 0.9, as I seem to recall it had some aero snap features.

Latest Manjaro/Catalyst.

edit:
Funnily enough, compiz performs better than openbox/compton - color me surprised.
« Last Edit: 25. December 2014, 05:44:54 by DarN »

Offline Rob

  • Core Team
  • *****
  • Posts: 5390
  • Alias: Korrode
  • Branch: Unstable
  • Desktop: Xfce+Compiz
  • GPU Card: nVidia GTX560Ti
  • GPU driver: non-free
  • Kernel: linux314 x64
  • Skill: Advanced
Re: Compiz 0.9 series package available
« Reply #170 on: 25. December 2014, 02:05:48 »
Catalyst.

*shrugs*

I don't really expect anything to work with Catalyst.

Offline DarN

  • Neuling
  • *
  • Posts: 11
  • Branch: stable
  • Desktop: Cinnamon
  • GPU Card: Radeon HD 6990
  • GPU driver: non-free
  • Kernel: latest_stable-x64
  • Skill: Advanced
Re: Compiz 0.9 series package available
« Reply #171 on: 25. December 2014, 08:02:27 »
Well, I had another go. Added fusion icon this time - now it works...

Offline bardo

  • Vollwertiges Mitglied
  • ***
  • Posts: 226
  • Branch: stable
  • GPU Card: Card: NVIDIA GF108 [GeForce GT 430]
  • GPU driver: non free
  • Kernel: 319
  • Skill: Novice
Re: Compiz 0.9 series package available
« Reply #172 on: 03. January 2015, 16:57:30 »
[bardo@bardo ~]$ sudo pacman -S compiz-manjaro
[sudo] password for bardo:
a resolver dependências...
a procurar por conflitos internos...
:: compiz-manjaro e compiz08-gtk-standalone estão em conflito (compiz-core). Substituir compiz08-gtk-standalone? [s/N] s
:: metacity e metacity2 estão em conflito. Substituir metacity2? [s/N] s
erro: falhou ao preparar a transação (não foi possível cumprir as dependências)
:: emerald08: exige compiz08-core

Offline Rob

  • Core Team
  • *****
  • Posts: 5390
  • Alias: Korrode
  • Branch: Unstable
  • Desktop: Xfce+Compiz
  • GPU Card: nVidia GTX560Ti
  • GPU driver: non-free
  • Kernel: linux314 x64
  • Skill: Advanced
Re: Compiz 0.9 series package available
« Reply #173 on: 03. January 2015, 17:09:30 »
[bardo@bardo ~]$ sudo pacman -S compiz-manjaro
[sudo] password for bardo:
a resolver dependências...
a procurar por conflitos internos...
:: compiz-manjaro e compiz08-gtk-standalone estão em conflito (compiz-core). Substituir compiz08-gtk-standalone? [s/N] s
:: metacity e metacity2 estão em conflito. Substituir metacity2? [s/N] s
erro: falhou ao preparar a transação (não foi possível cumprir as dependências)
:: emerald08: exige compiz08-core

If you're an emerald user you need to swap to the newer version:
Code: [Select]
sudo pacman -S compiz-manjaro emerald0.9
...or if you don't actually use Emerald, just remove it.

Offline CyberWolf2k14

  • Held Mitglied
  • *****
  • Posts: 1184
  • Computers make very fast, very accurate mistakes.
  • Branch: Stable-sysd229-LightDM
  • Desktop: MATE/Cinnamon/GNOME
  • GPU Card: nVidia GeForce GT740
  • GPU driver: nVidia-NF-364.19
  • Kernel: 4.4.9x64 / 4.2.8.9x64 / 4.1.23x64
  • Skill: Intermediate
Re: Compiz 0.9 series package available
« Reply #174 on: 04. January 2015, 14:16:44 »
Uncertain if this is an "appropriate" place for this question, but figure cannot hurt:

Considering my current equipment and I am using the free nouveau/MESA hybrid drivers, is it possible to use Compiz? On both my Xfce and my LXDE desktops? ???

Currently have only Compton I believe (at least what is referenced in the LXDE side of things).

Oh, and BTW, according to the utils in Manajro, the vid drivers in use og=ffer apparently only maybe OpenGL v1.5.

Thanks.
PowerSpec Quad core Intel Core i5-4690K w/ 16GB RAM
Dual Boot = Win 7 Ult x64 and Manjaro 15.12 x64
===================================================
"A computer lets you make more mistakes faster than any invention in human history...
with the possible exceptions of handguns and tequila".

Offline Jeannie

  • Held Mitglied
  • *****
  • Posts: 1546
  • Skill: Novice
Re: Compiz 0.9 series package available
« Reply #175 on: 04. January 2015, 14:58:57 »
Uncertain if this is an "appropriate" place for this question, but figure cannot hurt:

Considering my current equipment and I am using the free nouveau/MESA hybrid drivers, is it possible to use Compiz? On both my Xfce and my LXDE desktops? ???

Currently have only Compton I believe (at least what is referenced in the LXDE side of things).

Oh, and BTW, according to the utils in Manajro, the vid drivers in use og=ffer apparently only maybe OpenGL v1.5.

Thanks.
Yay, the benfits of nouveau, 80% less gpu power.
Hitten by the door in the back when I left Manjaro.

Offline CyberWolf2k14

  • Held Mitglied
  • *****
  • Posts: 1184
  • Computers make very fast, very accurate mistakes.
  • Branch: Stable-sysd229-LightDM
  • Desktop: MATE/Cinnamon/GNOME
  • GPU Card: nVidia GeForce GT740
  • GPU driver: nVidia-NF-364.19
  • Kernel: 4.4.9x64 / 4.2.8.9x64 / 4.1.23x64
  • Skill: Intermediate
Re: Compiz 0.9 series package available
« Reply #176 on: 04. January 2015, 20:23:03 »
Yay, the benfits of nouveau, 80% less gpu power.

OK, I get the sarcasm.  ::)  BUT, still begs my original question:
Can I run Compiz on my machine? Would really like to be able to make desktop a wee bit prettier, ya
know? ??? ^-^
PowerSpec Quad core Intel Core i5-4690K w/ 16GB RAM
Dual Boot = Win 7 Ult x64 and Manjaro 15.12 x64
===================================================
"A computer lets you make more mistakes faster than any invention in human history...
with the possible exceptions of handguns and tequila".

Offline Rob

  • Core Team
  • *****
  • Posts: 5390
  • Alias: Korrode
  • Branch: Unstable
  • Desktop: Xfce+Compiz
  • GPU Card: nVidia GTX560Ti
  • GPU driver: non-free
  • Kernel: linux314 x64
  • Skill: Advanced
Re: Compiz 0.9 series package available
« Reply #177 on: 06. January 2015, 05:04:09 »
Quote from: ANNOUNCE: xfce4-panel 4.11.2 released
- Action buttons: only save session when requested (bug #7930)

This bugfix for Xfce4-panel will hopefully help with the issues some users encounter after uninstallation. :)

Offline CyberWolf2k14

  • Held Mitglied
  • *****
  • Posts: 1184
  • Computers make very fast, very accurate mistakes.
  • Branch: Stable-sysd229-LightDM
  • Desktop: MATE/Cinnamon/GNOME
  • GPU Card: nVidia GeForce GT740
  • GPU driver: nVidia-NF-364.19
  • Kernel: 4.4.9x64 / 4.2.8.9x64 / 4.1.23x64
  • Skill: Intermediate
Re: Compiz 0.9 series package available
« Reply #178 on: 07. January 2015, 14:31:16 »
Please ignore above
https://forum.manjaro.org/index.php?topic=12618.msg175438#msg175438
As I have just recently turned off all compositing in Xfce and will soon be doing the same in LXDE.
SOMETHING from the most recent update (STABLE)) is causing graphics issues. Is either MESA or something.
PowerSpec Quad core Intel Core i5-4690K w/ 16GB RAM
Dual Boot = Win 7 Ult x64 and Manjaro 15.12 x64
===================================================
"A computer lets you make more mistakes faster than any invention in human history...
with the possible exceptions of handguns and tequila".

Offline Jeannie

  • Held Mitglied
  • *****
  • Posts: 1546
  • Skill: Novice
Re: Compiz 0.9 series package available
« Reply #179 on: 07. January 2015, 15:14:25 »
Please ignore above
https://forum.manjaro.org/index.php?topic=12618.msg175438#msg175438
As I have just recently turned off all compositing in Xfce and will soon be doing the same in LXDE.
SOMETHING from the most recent update (STABLE)) is causing graphics issues. Is either MESA or something.
Running twelve year old graphics card can  lead to problems with up to date librairies.
Sometimes, it's time to  get more up to date hardware, especially when running a cutting edge rolling linux distro.
J.
Hitten by the door in the back when I left Manjaro.