Author Topic: "unexpected error" When downloading language packs.  (Read 1336 times)

0 Members and 1 Guest are viewing this topic.

Offline Greg541

  • Neuling
  • *
  • Posts: 9
  • I'm new. Be nice!
  • Desktop: Cinnamon
  • GPU Card: Nvidia GTX 640
  • GPU driver: non-free
  • Kernel: linux38-x64VTNXHN
  • Skill: Novice
"unexpected error" When downloading language packs.
« on: 28. February 2016, 06:17:35 »

Hi all;

:: Synchronizing package databases...
error: failed to update core (unable to lock database)
error: failed to update extra (unable to lock database)
error: failed to update community (unable to lock database)
error: failed to update multilib (unable to lock database)
error: failed to synchronize any databases
error: failed to init transaction (unable to lock database)
error: could not lock database: File exists
  if you're sure a package manager is not already
  running, you can remove /var/lib/pacman/db.lck

-> Process failed!

This error messages above occured while trying to download and install language packs in Cinnamon Manjaro/Language Packages.
Cannot restart program the download process cannot be restarted. It just gives me the option to close.

Tryed to install same language packs throu the package manager, but got the message that there was errors in the databases. They would not install. Is there a way to purge or reset? Or is the system ow broken?

Any help would be appreciated.

Greg541

Offline withjaro

  • Held Mitglied
  • *****
  • Posts: 772
  • 360
  • Branch: unstable
  • Desktop: openrc
  • GPU Card: geforce7150/ATIx2300
  • GPU driver: free
  • Kernel: linux4xxx-x64
  • Skill: Novice
Re: "unexpected error" When downloading language packs.
« Reply #1 on: 28. February 2016, 06:56:34 »
dont
 think it will be a problem with the language packs .. or any other
package.
just takes a while for Pacman to 'settle down' for some reason,i had
messages like this at the beginning of Manjaro,now they dont occur at
all :)

just simply take note of the error message   'running, you can remove
/var/lib/pacman/db.lck'
delete the offending file (sudo rm /var/lib/pacman/db.lck)
... then reupdate .. the file will be replaced
 and you should be good to go :)
« Last Edit: 28. February 2016, 07:00:37 by withjaro »
< insert your own inspiring quotation - and smile :) >

Offline Greg541

  • Neuling
  • *
  • Posts: 9
  • I'm new. Be nice!
  • Desktop: Cinnamon
  • GPU Card: Nvidia GTX 640
  • GPU driver: non-free
  • Kernel: linux38-x64VTNXHN
  • Skill: Novice
Re: "unexpected error" When downloading language packs.[solved]
« Reply #2 on: 28. February 2016, 19:39:37 »
you were right on!
thanks

Offline p-value

  • Neuling
  • *
  • Posts: 9
  • Branch: stable (16.06pre3)
  • Desktop: Xfce 4.12.3
  • GPU Card: Intel HD 3000
  • Kernel: 4.4.9-1-MANJARO (64bit)
  • Skill: Novice
Re: "unexpected error" When downloading language packs.
« Reply #3 on: 06. May 2016, 16:40:21 »
Thank you. This simple solution has fixed my out-of-the-box update problem within 16.06pre3 (wasn't able to update any package).
It is also stickied in the newbie section: https://forum.manjaro.org/index.php?topic=12383.0
« Last Edit: 06. May 2016, 17:07:12 by p-value »