Author Topic: [sec] flashplugin, lib32-flashplugin: arbitrary code execution  (Read 1152 times)

0 Members and 1 Guest are viewing this topic.

Offline Kirek

  • Core Team
  • *****
  • Posts: 1209
  • Branch: unstable
  • Desktop: Plasma 5
  • GPU Card: Intel HD4000 + Nvidia 620M / Geforxe GTX 970
  • GPU driver: nonfree
  • Kernel: Latest
  • Skill: Intermediate
The updated version in Manjaro stable branch is "11.2.202.491-0.1" till the next stable update.

Quote
Arch Linux Security Advisory ASA-201507-13
==========================================

Severity: Critical
Date    : 2015-07-16
CVE-ID  : CVE-2015-5122 CVE-2015-5123
Package : flashplugin
Type    : arbitrary code execution
Remote  : Yes
Link    : https://wiki.archlinux.org/index.php/CVE

Summary
=======

The package flashplugin before version 11.2.202.491-1 is vulnerable to
arbitrary code execution.

Resolution
==========

Upgrade to 11.2.202.491-1.

# pacman -Syu "flashplugin>=11.2.202.491-1"

The problems have been fixed upstream in version 11.2.202.491.

Workaround
==========

None.

Description
===========

- CVE-2015-5122 (arbitrary code execution)

Use-after-free vulnerability in the DisplayObject class in the
ActionScript 3 (AS3) implementation allows remote attackers to execute
arbitrary code or cause a denial of service (memory corruption) via
crafted Flash content that leverages improper handling of the
opaqueBackground property.

- CVE-2015-5123 (arbitrary code execution)

Use-after-free vulnerability in the BitmapData class in the ActionScript
3 (AS3) implementation allows remote attackers to execute arbitrary code
or cause a denial of service (memory corruption) via crafted Flash
content that overrides a valueOf function.

Impact
======

A remote attacker is able to use a specially crafted flash application
to execute arbitrary code.

References
==========

https://helpx.adobe.com/security/products/flash-player/apsb15-18.html
https://access.redhat.com/security/cve/CVE-2015-5122
https://access.redhat.com/security/cve/CVE-2015-5123

Quote
Arch Linux Security Advisory ASA-201507-14
==========================================

Severity: Critical
Date    : 2015-07-16
CVE-ID  : CVE-2015-5122 CVE-2015-5123
Package : lib32-flashplugin
Type    : arbitrary code execution
Remote  : Yes
Link    : https://wiki.archlinux.org/index.php/CVE

Summary
=======

The package lib32-flashplugin before version 11.2.202.491-1 is
vulnerable to arbitrary code execution.

Resolution
==========

Upgrade to 11.2.202.491-1.

# pacman -Syu "lib32-flashplugin>=11.2.202.491-1"

The problems have been fixed upstream in version 11.2.202.491.

Workaround
==========

None.

Description
===========

- CVE-2015-5122 (arbitrary code execution)

Use-after-free vulnerability in the DisplayObject class in the
ActionScript 3 (AS3) implementation allows remote attackers to execute
arbitrary code or cause a denial of service (memory corruption) via
crafted Flash content that leverages improper handling of the
opaqueBackground property.

- CVE-2015-5123 (arbitrary code execution)

Use-after-free vulnerability in the BitmapData class in the ActionScript
3 (AS3) implementation allows remote attackers to execute arbitrary code
or cause a denial of service (memory corruption) via crafted Flash
content that overrides a valueOf function.

Impact
======

A remote attacker is able to use a specially crafted flash application
to execute arbitrary code.

References
==========

https://helpx.adobe.com/security/products/flash-player/apsb15-18.html
https://access.redhat.com/security/cve/CVE-2015-5122
https://access.redhat.com/security/cve/CVE-2015-5123