Manjaro Linux Forum

Technical Issues and Assistance => Kernel & Hardware => Topic started by: Bienenmann on 01. April 2018, 12:41:31

Title: external Harddrive eSATA doe not spin up
Post by: Bienenmann on 01. April 2018, 12:41:31

I encounter the following problem:
I attached an eSata harddrive to my PC. The eSATA connector is just a slot braket with eSATA-connectors, no additional controller. Internally, the cables are connected to the normal Sata board connectors.
If I turn the external drive on and start the PC, the disc spins up and is recognized by Manjaro.
If I start the PC and manjaro and THEN swith the drive on, it won't even spin up. If I disconnect the SATA-cable from the disc, it spins up.

Several months ago (about 12-18 Months ;) ) it worked fine. Then I made a complete reinstall of manjaro (changed from HDD to an SSD) and now I cant't get it working again. I did not change any Hardware and I tested several board SATA-connectors.
SATA is set to AHCI in the bios.

Does anyone have an idea?

OS: Linux bienenmann-pc 4.15.13-1-MANJARO #1 SMP PREEMPT Sun Mar 25 19:51:07 UTC 2018 x86_64 GNU/Linux
        [bienenmann@bienenmann-pc ~]$ cat /etc/lsb-release
        DISTRIB_DESCRIPTION="Manjaro Linux"
Window manager Cinnamon

Mainboard: ga-ep43-ds3l

# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>                            <mount point>                    <type>  <options>               <dump>  <pass>
UUID=fc87e95b-8706-4c6f-82b4-91522abe6ead swap                              swap    defaults,noatime            0       0
UUID=e0d717f2-544d-478d-92d0-3e7f5355ae9c /                                 ext4    defaults,noatime,discard    0       1
UUID=d7a74844-30c0-4802-b174-f678af043a66 /home                             ext4    defaults,noatime            0       2
tmpfs                                     /tmp                              tmpfs   defaults,noatime,mode=1777  0       0     
UUID=069AF3471CAC69DB                     /run/media/bienenmann/Musiklager  ntfs-3g rw,noauto,users,exec,nls=utf8,umask=000,gid=bienenmann       0      0
UUID=72e294d1-6ba1-43a0-8c7e-1c46d8ad6b2e /run/media/bienenmann/BackupDrive ext4    defaults,noauto,users   0   0

Master of the Bees
Title: Re: external Harddrive eSATA doe not spin up
Post by: throwaway675 on 13. May 2018, 04:27:12

did you figure it out eventually? I have a very similar problem with my external (esata/usb) enclosure that has worked fine before. When esata is connected the drive wont spin up. USB works fine. I have tested several HDDs, two different cables and two different hosts. I am using Ubuntu but two very different kernels so it shouldn't matter that much anyway.

Title: Re: external Harddrive eSATA doe not spin up
Post by: throwaway675 on 13. May 2018, 13:43:55
My setup started to work again after getting some sleep... without any evident changes made. And I tried a lot... no idea what happened. I'd guess some loose connection or so? :/