Manjaro Linux Forum

Support for Community Editions => LXQt => Topic started by: urbanomad64 on 23. December 2014, 11:39:45

Title: Thunderbird not passing html links to Firefox when clicked
Post by: urbanomad64 on 23. December 2014, 11:39:45
I am posting this enquiry here as I didn't have this problem when on KDE. I am new to LXQt and have Firefox set to my default browser everywhere I can think of or found. When I click on a link in Thunderbird, Firefox opens to the default page (Manjaro main site in this case) but it doesn't pass the clicked on link to Firefox. I have Firefox installed in my ~/.bin directory.

Any thoughts/comments?
Title: Re: Thunderbird not passing html links to Firefox when clicked
Post by: notargets on 23. December 2014, 12:49:57
I'm not familiar with LXQt, but my guess it that Thunderbird wants to run the default web browser, but Firefox is not set correctly as the default one. However, if it works fine with other applications, then it may be specific to Thunderbird.

Here's something worth a try but it only affects Thunderbird: http://kb.mozillazine.org/Changing_the_web_browser_invoked_by_Thunderbird
Title: Re: Thunderbird not passing html links to Firefox when clicked
Post by: megapop on 23. December 2014, 13:02:24
I'm having the same problem (also having firefox in ~/.bin/), and editing prefs.js didn't work; neither did creating a symbolic link in /usr/bin/. :-\
Title: Re: Thunderbird not passing html links to Firefox when clicked
Post by: urbanomad64 on 23. December 2014, 14:03:40
I'm having the same problem (also having firefox in ~/.bin/), and editing prefs.js didn't work; neither did creating a symbolic link in /usr/bin/. :-\

I just checked Preferences -> Preferred Applications again and saw that Thunderbird didn't have an application icon and Firefox did. I pulled down the list and there was a Firefox without an application icon and selected it. Thunderbird is now working as expected... I suppose I hadn't checked this before I copied over firefox.desktop...
Title: Re: Thunderbird not passing html links to Firefox when clicked
Post by: megapop on 23. December 2014, 14:13:48
Hm, I already had set the correct firefox and thunderbird as preferred applications... great that you could solve the problem though! :)