Author Topic: ATi Catalyst Control Center & aticonfig  (Read 2954 times)

0 Members and 1 Guest are viewing this topic.

Offline SpaceAviator

  • Neuling
  • *
  • Posts: 26
ATi Catalyst Control Center & aticonfig
« on: 22. August 2012, 17:17:53 »
The control center never launches from the menu. Also aticonfig --pplib-cmd "get fanspeed 0" gives me the following error :

o layout section was found in the file: '/etc/X11/xorg.conf'.
Please run 'aticonfig --initial' first or modify your configuration file manually and run aticonfig again.
aticonfig: parsing the command-line failed.


I have a feeling this has something to do with how manjaro deals with the drivers so I didn't want to run aticonfig --initial before I got some feedback here!

Offline philm

  • Core Team
  • *****
  • Posts: 10671
    • Manjaro Linux
  • Branch: Unstable
  • Desktop: XFCE
  • GPU Card: Geforce GTX 650
  • GPU driver: non-free
  • Kernel: Maintainer - so all ;)
  • Skill: Guru
Re: ATi Catalyst Control Center & aticonfig
« Reply #1 on: 22. August 2012, 20:25:45 »
Our ATI-Configs get created with followed cmd:

Code: [Select]
aticonfig -o "/etc/X11/mhwd.d/catalyst.conf" --initial --nobackup
This might help to get it running:

Code: [Select]
sudo ln -sfv /etc/X11/mhwd.d/catalyst.conf /etc/X11/xorg.conf

Offline eskaini

  • Security Team
  • *****
  • Posts: 10842
  • I eat deleted accounts
  • Skill: Novice
Re: ATi Catalyst Control Center & aticonfig
« Reply #2 on: 22. August 2012, 20:54:13 »
I can catalyst control center without any issues.

Offline philm

  • Core Team
  • *****
  • Posts: 10671
    • Manjaro Linux
  • Branch: Unstable
  • Desktop: XFCE
  • GPU Card: Geforce GTX 650
  • GPU driver: non-free
  • Kernel: Maintainer - so all ;)
  • Skill: Guru
Re: ATi Catalyst Control Center & aticonfig
« Reply #3 on: 22. August 2012, 21:01:13 »
You run catalyst. Maybe he runs catalyst-legacy which is a different driver ...

Offline eskaini

  • Security Team
  • *****
  • Posts: 10842
  • I eat deleted accounts
  • Skill: Novice
Re: ATi Catalyst Control Center & aticonfig
« Reply #4 on: 22. August 2012, 21:06:01 »
Hmm, that's true. Sorry for that. ;)

Offline JSM

  • Neuling
  • *
  • Posts: 3
    • Lavandas ICT
Re: ATi Catalyst Control Center & aticonfig
« Reply #5 on: 22. August 2012, 21:13:43 »
The qt libraries are missing on the XFCE and GNOME standard install, which are needed by the Catalyst control center.
A simple "pacman -S qt" will fix this. Maybe the qt package can be added to the next release ?

Offline philm

  • Core Team
  • *****
  • Posts: 10671
    • Manjaro Linux
  • Branch: Unstable
  • Desktop: XFCE
  • GPU Card: Geforce GTX 650
  • GPU driver: non-free
  • Kernel: Maintainer - so all ;)
  • Skill: Guru
Re: ATi Catalyst Control Center & aticonfig
« Reply #6 on: 23. August 2012, 19:46:03 »
qt will be readded to our next release. I missed that one ... Sorry.