Author Topic: deluge not working  (Read 2374 times)

0 Members and 1 Guest are viewing this topic.

Offline Riley88

  • Jr. Mitglied
  • **
  • Posts: 68
  • Branch: testing
  • Desktop: Awesome WM
  • GPU Card: Intel HD 3000
  • GPU driver: OpenSource
  • Kernel: 3.9.11-1
  • Skill: Guru
deluge not working
« on: 18. September 2012, 00:26:35 »
hey i just installed deluge and it installed fine and it shows up in my menu but it dosnt do anything when i launch it im not sure if its a broken package or its just me i did install ktorrent and that works fine.

Offline philm

  • Core Team
  • *****
  • Posts: 10671
    • Manjaro Linux
  • Branch: Unstable
  • Desktop: XFCE
  • GPU Card: Geforce GTX 650
  • GPU driver: non-free
  • Kernel: Maintainer - so all ;)
  • Skill: Guru
Re: deluge not working
« Reply #1 on: 18. September 2012, 18:43:38 »
Works just fine here on x64. Post me your output for deluge in a console ...

Offline Riley88

  • Jr. Mitglied
  • **
  • Posts: 68
  • Branch: testing
  • Desktop: Awesome WM
  • GPU Card: Intel HD 3000
  • GPU driver: OpenSource
  • Kernel: 3.9.11-1
  • Skill: Guru
Re: deluge not working
« Reply #2 on: 18. September 2012, 19:47:28 »
[riley@archlinux ~]$ deluge
[ERROR   ] 13:46:19 ui:168 No module named gobject
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/deluge/ui/ui.py", line 149, in __init__
    from deluge.ui.gtkui.gtkui import GtkUI
  File "/usr/lib/python2.7/site-packages/deluge/ui/gtkui/__init__.py", line 1, in <module>
    from gtkui import start
  File "/usr/lib/python2.7/site-packages/deluge/ui/gtkui/gtkui.py", line 37, in <module>
    import gobject
ImportError: No module named gobject
[ERROR   ] 13:46:19 ui:169 There was an error whilst launching the request UI: gtk
[ERROR   ] 13:46:19 ui:170 Look at the traceback above for more information.
[riley@archlinux ~]$


Offline eskaini

  • Security Team
  • *****
  • Posts: 10842
  • I eat deleted accounts
  • Skill: Novice
Re: deluge not working
« Reply #3 on: 18. September 2012, 22:24:08 »
Are you on KDE ? If im right you´re missing GTK-dependencies. I recommend using Qtorrent in that case instead of pulling all those dependencies.

Offline James T

  • Sr. Mitglied
  • ****
  • Posts: 289
Re: deluge not working
« Reply #4 on: 18. September 2012, 22:31:12 »
Are you on KDE ? If im right you´re missing GTK-dependencies. I recommend using Qtorrent in that case instead of pulling all those dependencies.

Nonetheless, the package should be considered broken. Required dependencies should be specified in the PKGBUILD file. In this case at least python-gtk.

Offline philm

  • Core Team
  • *****
  • Posts: 10671
    • Manjaro Linux
  • Branch: Unstable
  • Desktop: XFCE
  • GPU Card: Geforce GTX 650
  • GPU driver: non-free
  • Kernel: Maintainer - so all ;)
  • Skill: Guru
Re: deluge not working
« Reply #5 on: 18. September 2012, 22:47:00 »
Arch has it optional ...

Code: [Select]
optdepends=('python-notify: libnotify notifications'
            'pygtk: needed for gtk ui'
            'librsvg: needed for gtk ui'
            'python2-mako: needed for web ui')

Offline Riley88

  • Jr. Mitglied
  • **
  • Posts: 68
  • Branch: testing
  • Desktop: Awesome WM
  • GPU Card: Intel HD 3000
  • GPU driver: OpenSource
  • Kernel: 3.9.11-1
  • Skill: Guru
Re: deluge not working
« Reply #6 on: 19. September 2012, 01:05:06 »
no im on xfce64bit version

Offline eskaini

  • Security Team
  • *****
  • Posts: 10842
  • I eat deleted accounts
  • Skill: Novice
Re: deluge not working
« Reply #7 on: 19. September 2012, 07:50:27 »
Right, the dependency should be resolved nonetheless. You could install transmission though and wait untill the problem with deluge is sorted out.

Offline shrinivas

  • Neuling
  • *
  • Posts: 15
Re: deluge not working
« Reply #8 on: 19. September 2012, 08:49:31 »
I too am running xfce64, deluge works fine here.
Just for info.
Regards