Author Topic: Updates through chroot.  (Read 1554 times)

0 Members and 1 Guest are viewing this topic.

Offline viking

  • Sr. Mitglied
  • ****
  • Posts: 346
  • Branch: Unstable
  • Desktop: XFCE
  • GPU Card: Intel HD3000
  • GPU driver: Free
  • Kernel: Whichever is the latest
  • Skill: Intermediate
Updates through chroot.
« on: 13. September 2012, 18:30:03 »
As I run several distros, I frequently update them using chroot. It has always worked before, but with Manjaro it doesn't, I get the error:

Code: [Select]
GPGME error: Inappropriate ioctl for device
I've googled it of course, and although there are many results, they seem to be divided into two categories, one is a problem with the Arch Linux installer and therefore of no relevance to Manjaro, the other seems to suggest that binding /dev/ (or /dev/pts) from the host OS to the chroot target fixes the problem. Well it doesn't for me, I have also tried binding /proc and /sys both separately and at the same time as /dev, but it still doesn't work.

Does anyone have a solution for this?

Two points to note, firstly the chroot environment functions perfectly in all other respects, it is only when attempting to read package signing keys that it fails. Secondly my pacman keys are fully updated, both for Arch and Manjaro, when I boot Manjaro and update from within the distro I get no errors.
Fujitsu Lifebook AH532 laptop. Intel i5 processor, 16Gb ram, Intel HD3000 graphics, Intel Audio/wifi, Mint17, Ubuntu1404, Manjaro, all Xfce4.